Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
8266 tcp Reserved
espeasy-p2p 8266 udp ESPeasy peer-2-peer communication ESPeasy Gijs Noorlander 2018-11-28
8267-8269 Unassigned
ms-mcc 8276 tcp Microsoft Connected Cache Microsoft Corporation Narkis Engler 2008-02-27 2022-05-03
ms-mcc 8276 udp Microsoft Connected Cache Microsoft Corporation Narkis Engler 2008-02-27 2022-05-03
cruise-enum 8376 tcp Cruise ENUM Steve Husak Steve Husak
cruise-enum 8376 udp Cruise ENUM Steve Husak Steve Husak
8406-8414 Unassigned
espeech 8416 tcp eSpeech Session Protocol Scott Tarone Scott Tarone 2002-11
espeech 8416 udp eSpeech Session Protocol Scott Tarone Scott Tarone 2002-11
8446-8447 Unassigned
8451-8456 Unassigned
8458-8469 Unassigned
pim-port 8471 tcp PIM over Reliable Transport IESG IETF Chair 2008-08-21 RFC 6559
pim-port 8471 sctp PIM over Reliable Transport IESG IETF Chair 2008-08-21 RFC 6559
lsp-self-ping 8503 udp MPLS LSP Self-Ping IESG IETF Chair 2015-06-11 2016-02-01 RFC 7746
8556-8566 Unassigned
dof-tunnel 8567 tcp DOF Tunneling Protocol OpenDOF Bryant Eastham 2005-08 2015-04-23
dof-tunnel 8567 udp DOF Tunneling Protocol OpenDOF Bryant Eastham 2005-08 2015-04-23
8568-8599 Unassigned
asterix 8600 tcp Surveillance Data Eivan Cerasi Eivan Cerasi 2005-11
asterix 8600 udp Surveillance Data Eivan Cerasi Eivan Cerasi 2005-11
8601-8608 Unassigned
8609 tcp Reserved
canon-cpp-disc 8609 udp Canon Compact Printer Protocol Discovery Canon Inc. Ryusuke Okuhara 2012-06-08 2012-06-15
canon-mfnp 8610 tcp Canon MFNP Service Ritsuto Sako Ritsuto Sako 2009-05-04
canon-mfnp 8610 udp Canon MFNP Service Ritsuto Sako Ritsuto Sako 2009-05-04
canon-bjnp1 8611 tcp Canon BJNP Port 1 Atsushi Nakamura Atsushi Nakamura 2003-11
canon-bjnp1 8611 udp Canon BJNP Port 1 Atsushi Nakamura Atsushi Nakamura 2003-11
canon-bjnp2 8612 tcp Canon BJNP Port 2 Atsushi Nakamura Atsushi Nakamura 2003-11
canon-bjnp2 8612 udp Canon BJNP Port 2 Atsushi Nakamura Atsushi Nakamura 2003-11
canon-bjnp3 8613 tcp Canon BJNP Port 3 Atsushi Nakamura Atsushi Nakamura 2003-11
canon-bjnp3 8613 udp Canon BJNP Port 3 Atsushi Nakamura Atsushi Nakamura 2003-11
canon-bjnp4 8614 tcp Canon BJNP Port 4 Atsushi Nakamura Atsushi Nakamura 2003-11
canon-bjnp4 8614 udp Canon BJNP Port 4 Atsushi Nakamura Atsushi Nakamura 2003-11
imink 8615 tcp Imink Service Control Canon Inc. Ken'ichi FUJII 2011-10-10
8615 udp Reserved
8616-8664 Unassigned Unauthorized Use Known on ports 8616 and 8617
monetra 8665 tcp Monetra Main Street Softworks Inc Brad House 2013-04-02
8665 udp Reserved
monetra-admin 8666 tcp Monetra Administrative Access Main Street Softworks Inc Brad House 2013-04-02
8666 udp Reserved
8667 Unassigned
spartan 8668 tcp Spartan management Tenebris Technologies Inc. Eric Jacksch 2023-10-26
8668 udp Reserved
8669-8674 Unassigned
msi-cps-rm 8675 tcp Motorola Solutions Customer Programming Software for Radio Management Motorola Solutions, Inc. Jenish Amin 2012-03-14
msi-cps-rm-disc 8675 udp Motorola Solutions Customer Programming Software for Radio Management Discovery Motorola Solutions, Inc. Jenish Amin 2012-03-14
8676-8685 Unassigned
sun-as-jmxrmi 8686 tcp Sun App Server - JMX/RMI Abhijit Kumar Abhijit Kumar 2005-11
sun-as-jmxrmi 8686 udp Sun App Server - JMX/RMI Abhijit Kumar Abhijit Kumar 2005-11
8687 Unassigned
openremote-ctrl 8688 tcp OpenRemote Controller HTTP/REST OpenRemote, Inc. Juha Lindfors 2012-12-18
8688 udp Reserved
8689-8698 Unassigned
vnyx 8699 tcp VNYX Primary Port Gregg Green Gregg Green 2004-11
8699 udp Reserved 2004-11 2013-05-24 This entry is being removed on 2013-05-24.
8751-8762 Unassigned
mc-appserver 8763 tcp MC-APPSERVER Romeo Kasanwidjojo Romeo Kasanwidjojo
mc-appserver 8763 udp MC-APPSERVER Romeo Kasanwidjojo Romeo Kasanwidjojo
openqueue 8764 tcp OPENQUEUE Matt Jensen Matt Jensen
openqueue 8764 udp OPENQUEUE Matt Jensen Matt Jensen
ultraseek-http 8765 tcp Ultraseek HTTP Walter Underwood Walter Underwood
ultraseek-http 8765 udp Ultraseek HTTP Walter Underwood Walter Underwood
amcs 8766 tcp Agilent Connectivity Service Keysight Technologies, Inc. Tom Fay 2013-01-16 2016-09-12
amcs 8766 udp Agilent Connectivity Service Keysight Technologies, Inc. Tom Fay 2013-01-16 2016-09-12
core-of-source 8767 tcp Online mobile multiplayer game Alt Solve Sdn Bhd Almaz Hong 2019-07-24
8767 udp Reserved
sandpolis 8768 tcp Sandpolis Server Tyler Cook Tyler Cook 2019-11-22
8768 udp Reserved
oktaauthenticat 8769 tcp Okta MultiPlatform Access Mgmt for Cloud Svcs Okta Inc Tom Belote 2019-12-19
8769 udp Reserved
msgclnt 8786 tcp Message Client Michael O'Brien Michael O'Brien 2003-03
msgclnt 8786 udp Message Client Michael O'Brien Michael O'Brien 2003-03
8806 Unassigned
ddi-tcp-6 8893 tcp Desktop Data TCP 5: NewsEDGE/Web application Fred Yao Fred Yao
ddi-udp-6 8893 udp Desktop Data UDP 5: NewsEDGE/Web application Fred Yao Fred Yao
ddi-tcp-7 8894 tcp Desktop Data TCP 6: COAL application Fred Yao Fred Yao
ddi-udp-7 8894 udp Desktop Data UDP 6: COAL application Fred Yao Fred Yao
8914-8936 Unassigned
8992-8996 Unassigned
oracle-ms-ens 8997 tcp Oracle Messaging Server Event Notification Service Oracle Corp. Hubert Vijay Arokiasamy 2014-10-28
9006 De-Commissioned Port 2000-02-24
swa-4 9026 tcp Secure Web Access - 4 Tim McGranaghan Tim McGranaghan
swa-4 9026 udp Secure Web Access - 4 Tim McGranaghan Tim McGranaghan
CardWeb-IO 9060 tcp CardWeb request-response I/O exchange CardWare, Inc David Wyatt 2016-10-07 2025-07-17
CardWeb-RT 9060 udp CardWeb realtime device data CardWare, Inc David Wyatt 2016-10-07 2025-07-17
9061-9079 Unassigned
net2display 9086 tcp Vesa Net2Display Kenneth B. Ocheltree Kenneth B. Ocheltree 2008-01-07
net2display 9086 udp Vesa Net2Display Kenneth B. Ocheltree Kenneth B. Ocheltree 2008-01-07
astergate 9106 tcp Astergate Control Service Ariën Huisken Ariën Huisken 2010-01-04
astergate-disc 9106 udp Astergate Discovery Service Ariën Huisken Ariën Huisken 2010-01-04
apani1 9160 tcp apani1 Neal Taylor Neal Taylor
apani1 9160 udp apani1 Neal Taylor Neal Taylor
apani2 9161 tcp apani2 Neal Taylor Neal Taylor
apani2 9161 udp apani2 Neal Taylor Neal Taylor
apani3 9162 tcp apani3 Neal Taylor Neal Taylor
apani3 9162 udp apani3 Neal Taylor Neal Taylor
apani4 9163 tcp apani4 Neal Taylor Neal Taylor
apani4 9163 udp apani4 Neal Taylor Neal Taylor
apani5 9164 tcp apani5 Neal Taylor Neal Taylor

Contact Information

Name Organization Contact URI Last Updated
Abhijit Kumar as-iana-ports&sun.com 2005-11
Almaz Hong almaz.hong&altsolve.com 2019-07-24
Alt Solve Sdn Bhd support&altsolve.com 2019-07-24
Ariën Huisken astergate&huisken-systems.nl 2010-01-04
Atsushi Nakamura nakamura.atsushi318&canon.co.jp 2003-11
Brad House Main Street Softworks Inc brad&mainstreetsoftworks.com 2013-04-02
Bryant Eastham OenDOF protocol&opendof.org 2015-04-23
Canon Inc. fujii.ken-ichi149&canon.co.jp 2011-10-10
CardWare, Inc dwyatt&cardware.com 2025-07-17
David Wyatt dwyatt&cardware.com 2025-07-17
Eivan Cerasi eivan.cerasi&eurocontrol.int 2022-08-08
Eric Jacksch eric&tenebris.com 2023-10-26
ESPeasy gijs.noorlander&gmail.com 2018-11-28
Fred Yao Fred_Yao&ddigate2.desktopdata.com
Gijs Noorlander gijs.noorlander&gmail.com 2018-11-28
Gregg Green legal&vnyx.net 2004-11
Hubert Vijay Arokiasamy Oracle Corp. hubert.vijay.arokiasamy&oracle.com 2014-10-28
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jenish Amin Motorola Solutions, Inc. jenish&motorolasolutions.com 2012-03-14
Juha Lindfors OpenRemote, Inc. juha&openremote.org 2012-12-18
Ken'ichi FUJII Canon Inc. fujii.ken-ichi149&canon.co.jp 2011-10-10
Kenneth B. Ocheltree kennetho&us.ibm.com 2008-01-07
Keysight Technologies, Inc. iana.contact&keysight.com 2016-09-12
Main Street Softworks Inc info&mainstreetsoftworks.com 2013-04-02
Matt Jensen mattj&newsblip.com
Michael O'Brien mobrien03&gmail.com 2020-05-11
Microsoft Corporation naengler&microsoft.com 2022-05-03
Motorola Solutions, Inc. jenish&motorolasolutions.com 2012-03-14
Narkis Engler Microsoft Corporation naengler&microsoft.com 2022-05-03
Neal Taylor ianareg&apani.com
Okta Inc tbelote&okta.com 2019-12-19
OpenDOF protocol&opendof.org 2015-04-23
OpenRemote, Inc. juha&openremote.org 2012-12-18
Oracle Corp. hubert.vijay.arokiasamy&oracle.com 2014-10-28
Ritsuto Sako sakou.ritsuto&canon.co.jp 2009-05-04
Romeo Kasanwidjojo romeo&microcomgroup.com
Ryusuke Okuhara Canon Inc. okuhara.ryuusuke&canon.co.jp 2012-06-08
Scott Tarone starone&proactivethought.com 2003-04
Steve Husak portmaster&cruisetech.com
Tenebris Technologies Inc. info&tenebris.com 2023-10-26
Tim McGranaghan tim_mcgranaghan&mech.disa.mil
Tom Belote tbelote&okta.com 2019-12-19
Tom Fay iana.contact&keysight.com 2016-09-12
Tyler Cook tcc&sandpolis.com 2019-11-22
Walter Underwood wunder&infoseek.com