Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
iqrm 10117 tcp NetIQ IQCResource Managament Svc Michael Sharpe Michael Sharpe 2010-09-14
iqrm 10117 udp NetIQ IQCResource Managament Svc Michael Sharpe Michael Sharpe 2010-09-14
10126-10127 Unassigned
10262-10287 Unassigned
hip-nat-t 10500 udp HIP NAT-Traversal IESG IETF Chair 2020-08-12 RFC 5770; RFC 9028
10545-10547 Unassigned
10632-10799 Unassigned
10861-10879 Unassigned
11107 Unassigned
11166-11170 Unassigned
11171 tcp Reserved
snss 11171 udp Surgical Notes Security Service Discovery (SNSS) David Lethe David Lethe 2010-12-24
oemcacao-jmxmp 11172 tcp OEM cacao JMX-remoting access point David Sechrest David Sechrest 2010-09-22
11172 udp Reserved
t5-straton 11173 tcp Straton Runtime Programing COPALP Jerome FOLLUT 2012-03-01
11173 udp Reserved
oemcacao-rmi 11174 tcp OEM cacao rmi registry access point David Sechrest David Sechrest 2010-09-22
11174 udp Reserved
oemcacao-websvc 11175 tcp OEM cacao web service access point David Sechrest David Sechrest 2010-09-22
11175 udp Reserved
11176-11200 Unassigned
11203-11207 Unassigned
atm-uhas 11367 tcp ATM UHAS Todd Barker Todd Barker
atm-uhas 11367 udp ATM UHAS Todd Barker Todd Barker
11368-11370 Unassigned
hkp 11371 tcp OpenPGP HTTP Keyserver David Shaw David Shaw 2003-05
hkp 11371 udp OpenPGP HTTP Keyserver David Shaw David Shaw 2003-05
11372-11429 Unassigned
11624-11719 Unassigned Unauthorized Use Known on port 11711
h323callsigalt 11720 tcp H.323 Call Control Signalling Alternate ITU-T ITU-T TSB 2013-01-31
h323callsigalt 11720 udp H.323 Call Control Signalling Alternate ITU-T ITU-T TSB 2013-01-31
11721-11722 Unassigned
emc-xsw-dcache 11723 tcp EMC XtremSW distributed cache EMC David Erel 2013-09-18
emc-xsw-dcache 11723 udp EMC XtremSW distributed cache EMC David Erel 2013-09-18
11724-11750 Unassigned
intrepid-ssl 11751 tcp Intrepid SSL Robert Eden Robert Eden 2003-03
intrepid-ssl 11751 udp Intrepid SSL Robert Eden Robert Eden 2003-03
11752-11795 Unassigned
lanschool 11796 tcp LanSchool Stoneware Inc. Dana Doggett 2012-05-18
lanschool-mpt 11796 udp Lanschool Multipoint Stoneware Inc. Dana Doggett 2012-05-18
11797-11875 Unassigned
xoraya 11876 tcp X2E Xoraya Multichannel protocol Hannes K√§lber Hannes K√§lber 2010-09-13
xoraya 11876 udp X2E Xoraya Multichannel protocol Hannes K√§lber Hannes K√§lber 2010-09-13
11877 tcp Reserved
x2e-disc 11877 udp X2E service discovery protocol Hannes K√§lber Hannes K√§lber 2010-09-13
11878-11966 Unassigned
sysinfo-sp 11967 tcp SysInfo Service Protocol Mike Cooper Mike Cooper 2003-03
sysinfo-sp 11967 udp SysInfo Service Protocol Mike Cooper Mike Cooper 2003-03
11968-11970 Unassigned
tibsd 11971 tcp TiBS Service Teradactyl LLC Kristen Webb 2019-05-17
11971 udp Reserved
11972-11996 Unassigned
wmereceiving 11997 sctp WorldMailExpress Greg Foutz Greg Foutz 2006-03
accuracer 12007 tcp Accuracer Database System Server Alexander V. Ivanov Alexander V. Ivanov 2004-12
accuracer 12007 udp Accuracer Database System Server Alexander V. Ivanov Alexander V. Ivanov 2004-12
12122-12167 Unassigned
12169-12171 Unassigned
hivep 12172 tcp HiveP Dick Augustsson Dick Augustsson
hivep 12172 udp HiveP Dick Augustsson Dick Augustsson
12173-12299 Unassigned
12547-12752 Unassigned
tsaf 12753 tcp tsaf port Andreas Fehr Andreas Fehr
tsaf 12753 udp tsaf port Andreas Fehr Andreas Fehr
12754-12864 Unassigned
rs-pias 13217 tcp R&S Proxy Installation Assistant Service Guido Kiener Guido Kiener 2008-12-04
rs-pias 13217 udp R&S Proxy Installation Assistant Service Guido Kiener Guido Kiener 2008-12-04
13401-13719 Unassigned
bprd 13720 tcp BPRD Protocol (VERITAS NetBackup) Jeff Holmbeck Jeff Holmbeck
bprd 13720 udp BPRD Protocol (VERITAS NetBackup) Jeff Holmbeck Jeff Holmbeck
bpdbm 13721 tcp BPDBM Protocol (VERITAS NetBackup) Jeff Holmbeck Jeff Holmbeck
bpdbm 13721 udp BPDBM Protocol (VERITAS NetBackup) Jeff Holmbeck Jeff Holmbeck
bpjava-msvc 13722 tcp BP Java MSVC Protocol Tim Schmidt Tim Schmidt
bpjava-msvc 13722 udp BP Java MSVC Protocol Tim Schmidt Tim Schmidt
13723 Unassigned
vnetd 13724 tcp Veritas Network Utility Jeff Holmbeck Jeff Holmbeck
vnetd 13724 udp Veritas Network Utility Jeff Holmbeck Jeff Holmbeck
13725-13781 Unassigned
bpcd 13782 tcp VERITAS NetBackup Jeff Holmbeck Jeff Holmbeck
bpcd 13782 udp VERITAS NetBackup Jeff Holmbeck Jeff Holmbeck
vopied 13783 tcp VOPIED Protocol Jeff Holmbeck Jeff Holmbeck
vopied 13783 udp VOPIED Protocol Jeff Holmbeck Jeff Holmbeck
13784 Unassigned
nbdb 13785 tcp NetBackup Database Pat Tovo Pat Tovo 2004-12
nbdb 13785 udp NetBackup Database Pat Tovo Pat Tovo 2004-12
nomdb 13786 tcp Veritas-nomdb Clayton Haapala Clayton Haapala 2005-08
nomdb 13786 udp Veritas-nomdb Clayton Haapala Clayton Haapala 2005-08
13787-13817 Unassigned
hde-lcesrvr-2 14937 tcp hde-lcesrvr-2 Horizon Digital Enterprise Inc. Horizon Digital Enterprise Inc.
hde-lcesrvr-2 14937 udp hde-lcesrvr-2 Horizon Digital Enterprise Inc. Horizon Digital Enterprise Inc.
15003-15117 Unassigned
15661-15739 Unassigned
ptp 15740 tcp Picture Transfer Protocol Petronel Bigioi Petronel Bigioi 2004-11 Defined TXT keys: guid=<Device guid>
ptp 15740 udp Picture Transfer Protocol Petronel Bigioi Petronel Bigioi 2004-11 Defined TXT keys: guid=<Device guid>
15741-15997 Unassigned
netserialext3 16367 tcp Network Serial Extension Ports Three Michael J Hoy Michael J Hoy
netserialext3 16367 udp Network Serial Extension Ports Three Michael J Hoy Michael J Hoy
rdgs 16385 tcp Reliable Datagram Sockets Oracle Corp Sowmini Varadhan 2015-04-30
16667-16788 Unassigned
cadsisvr 16789 tcp This server provides callable services to mainframe External Security Managers from any TCP/IP platform Broadcom Thomas Sakowski 2015-06-02 2023-03-29
16789 udp Reserved
16790-16899 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Alexander V. Ivanov support&aidaim.com 2004-12
Andreas Fehr andreas&mrs.ch
Broadcom thomas.sakowski&broadcom.com 2023-03-29
Clayton Haapala clay.haapala&veritas.com 2005-08
COPALP jf&copalp.com 2012-03-01
Dana Doggett Stoneware Inc. dana.doggett&stone-ware.com 2012-05-18
David Erel EMC david.erel&emc.com 2013-09-18
David Lethe david&santools.com 2010-12-24
David Sechrest david.sechrest&oracle.com 2010-09-22
David Shaw dshaw&jabberwocky.com 2003-05
Dick Augustsson dick&skenbe.net
EMC david.erel&emc.com 2013-09-18
Greg Foutz gregf&adminovation.com 2006-03
Guido Kiener Guido.Kiener&rohde-schwarz.com 2008-12-04
Hannes K√§lber hannes.kaelber&x2e.de 2010-09-13
Horizon Digital Enterprise Inc. info&hde.co.jp
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
ITU-T tsbsg16&itu.int 2013-01-31
ITU-T TSB ITU-T tsbsg16&itu.int 2013-01-31
Jeff Holmbeck Jeff.Holmbeck&veritas.com
Jerome FOLLUT COPALP jf&copalp.com 2012-03-01
Kristen Webb kwebb&teradactyl.com 2019-05-17
Michael J Hoy mhoy&canberra-abq.com
Michael Sharpe iana-ports&netiq.com 2010-09-14
Mike Cooper mcooper&magnicomp.com 2003-03
Oracle Corp sowmini.varadhan&oracle.com 2015-04-30
Pat Tovo pat.tovo&veritas.com 2004-12
Petronel Bigioi petronel&fotonation.com 2004-11
Robert Eden reden&sieglertech.com 2003-03
Sowmini Varadhan Oracle Corp sowmini.varadhan&oracle.com 2015-04-30
Stoneware Inc. coby.gurr&stone-ware.com 2012-05-18
Teradactyl LLC vendors&teradactyl.com 2019-05-17
Thomas Sakowski Broadcom thomas.sakowski&broadcom.com 2023-03-29
Tim Schmidt Tim.Schmidt&veritas.com
Todd Barker toddba&attachmate.com