Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 20811-20998 | Unassigned | ||||||||||
| athand-mmp | 20999 | tcp | At Hand MMP | Stepan Riha | Stepan Riha | ||||||
| athand-mmp | 20999 | udp | AT Hand MMP | Stepan Riha | Stepan Riha | ||||||
| 21001-21009 | Unassigned | ||||||||||
| 21555-21589 | Unassigned | ||||||||||
| vofr-gateway | 21590 | tcp | VoFR Gateway | Marty Borden | Marty Borden | ||||||
| vofr-gateway | 21590 | udp | VoFR Gateway | Marty Borden | Marty Borden | ||||||
| 21591-21799 | Unassigned | ||||||||||
| netspeak-cps | 21849 | tcp | NetSpeak Corp. Credit Processing System | Toby Hosterman | Toby Hosterman | ||||||
| netspeak-cps | 21849 | udp | NetSpeak Corp. Credit Processing System | Toby Hosterman | Toby Hosterman | ||||||
| 21850-21999 | Unassigned | ||||||||||
| 22129-22221 | Unassigned | ||||||||||
| 22348-22349 | Unassigned | ||||||||||
| 22764-22799 | Unassigned | ||||||||||
| 22801-22950 | Unassigned | ||||||||||
| brf-gw | 22951 | tcp | Telerate Information Platform WAN | Timo Sivonen | Timo Sivonen | ||||||
| brf-gw | 22951 | udp | Telerate Information Platform WAN | Timo Sivonen | Timo Sivonen | ||||||
| 22952-22999 | Unassigned | ||||||||||
| 23273-23293 | Unassigned | ||||||||||
| 5afe-dir | 23294 | tcp | 5AFE SDN Directory | Ayoda GmbH | Laurenz Eschwey | 2016-04-01 | |||||
| 5afe-disc | 23294 | udp | 5AFE SDN Directory discovery | Ayoda GmbH | Laurenz Eschwey | 2016-04-01 | |||||
| 23295-23332 | Unassigned | ||||||||||
| 23334-23399 | Unassigned | ||||||||||
| 23547-23999 | Unassigned | ||||||||||
| vista-4gl | 24249 | tcp | Vista 4GL | Ingenta plc | Mark Itzcovitz | 2020-01-06 | |||||
| vista-4gl | 24249 | udp | Vista 4GL | Ingenta plc | Mark Itzcovitz | 2020-01-06 | |||||
| udpstp | 24601 | udp | UDP-based IP-Layer Capacity and Performance Measurement protocol | IESG | IETF Chair | 2025-09-26 | RFC 9946 | ||||
| 24679 | Unassigned | ||||||||||
| 24755-24849 | Unassigned | ||||||||||
| 24851-24921 | Unassigned | ||||||||||
| find | 24922 | tcp | Find Identification of Network Devices | Jean-Paul Moreaux | Jean-Paul Moreaux | ||||||
| find | 24922 | udp | Find Identification of Network Devices | Jean-Paul Moreaux | Jean-Paul Moreaux | ||||||
| 24923-24999 | Unassigned | ||||||||||
| icl-twobase9 | 25008 | tcp | icl-twobase9 | J. A. (Tony) Sever | J. A. (Tony) Sever | ||||||
| icl-twobase9 | 25008 | udp | icl-twobase9 | J. A. (Tony) Sever | J. A. (Tony) Sever | ||||||
| icl-twobase10 | 25009 | tcp | icl-twobase10 | J. A. (Tony) Sever | J. A. (Tony) Sever | ||||||
| icl-twobase10 | 25009 | udp | icl-twobase10 | J. A. (Tony) Sever | J. A. (Tony) Sever | ||||||
| 25010-25099 | Unassigned | ||||||||||
| 25605-25792 | Unassigned | ||||||||||
| vocaltec-hos | 25793 | tcp | Vocaltec Address Server | Scott Petrack | Scott Petrack | ||||||
| vocaltec-hos | 25793 | udp | Vocaltec Address Server | Scott Petrack | Scott Petrack | ||||||
| 25794-25899 | Unassigned | ||||||||||
| tasp-net | 25900 | tcp | TASP Network Comm | Martin Ellis | Martin Ellis | 2004-11 | |||||
| tasp-net | 25900 | udp | TASP Network Comm | Martin Ellis | Martin Ellis | 2004-11 | |||||
| niobserver | 25901 | tcp | NIObserver | Roman Oliynyk | Roman Oliynyk | ||||||
| niobserver | 25901 | udp | NIObserver | Roman Oliynyk | Roman Oliynyk | ||||||
| nilinkanalyst | 25902 | tcp | NILinkAnalyst | Roman Oliynyk | Roman Oliynyk | 2007-08-30 | |||||
| nilinkanalyst | 25902 | udp | NILinkAnalyst | Roman Oliynyk | Roman Oliynyk | 2007-08-30 | |||||
| niprobe | 25903 | tcp | NIProbe | Roman Oliynyk | Roman Oliynyk | ||||||
| niprobe | 25903 | udp | NIProbe | Roman Oliynyk | Roman Oliynyk | ||||||
| 25904-25953 | Unassigned | ||||||||||
| bf-game | 25954 | udp | Bitfighter game server | Christopher Eykamp | Christopher Eykamp | 2012-08-16 | |||||
| 25954 | tcp | Reserved | |||||||||
| bf-master | 25955 | udp | Bitfighter master server | Christopher Eykamp | Christopher Eykamp | 2012-08-16 | |||||
| 25955 | tcp | Reserved | |||||||||
| 25956-25999 | Unassigned | ||||||||||
| 26209-26256 | Unassigned | ||||||||||
| 26258-26259 | Unassigned | ||||||||||
| exonet | 26489 | tcp | EXOnet | Urban Fosseus | Urban Fosseus | 2008-12-24 | |||||
| exonet | 26489 | udp | EXOnet | Urban Fosseus | Urban Fosseus | 2008-12-24 | |||||
| 26490-26999 | Unassigned | ||||||||||
| flex-lm | 27000-27009 | FLEX LM (1-10) | Flexera Software | Paul Bland | 2018-02-15 | ||||||
| 27018-27344 | Unassigned | Unauthorized Use Known on ports 27018 and 27019 | |||||||||
| 27877-27998 | Unassigned | ||||||||||
| tw-auth-key | 27999 | tcp | TW Authentication/Key Distribution and | Alex Duncan | Alex Duncan | ||||||
| tw-auth-key | 27999 | udp | Attribute Certificate Services | Alex Duncan | Alex Duncan | ||||||
| 28002-28009 | Unassigned | ||||||||||
| 28011-28079 | Unassigned | Unauthorized Use Known on ports 28017, 28018 and 28019 | |||||||||
| 28119 | tcp | Reserved | |||||||||
| a27-ran-ran | 28119 | udp | A27 cdma2000 RAN Management | 3GPP2 | Zhiming Li | 2012-04-13 | |||||
| 28120-28199 | Unassigned | ||||||||||
| 28201-28239 | Unassigned | ||||||||||
| bosswave | 28589 | tcp | Building operating system services wide area verified exchange | University of California, Berkeley | Michael Andersen | 2016-06-13 | |||||
| 28589 | udp | Reserved | |||||||||
| 28590-28999 | Unassigned | ||||||||||
| saltd-licensing | 29000 | tcp | Siemens Licensing Server | Siemens Digital Industries Software | Tony Greatorex | 2020-06-08 | |||||
| 29000 | udp | Reserved | |||||||||
| 29001-29117 | Unassigned | ||||||||||
| 29118 | tcp | Reserved | |||||||||
| 29118 | udp | Reserved | |||||||||
| sgsap | 29118 | sctp | SGsAP in 3GPP | Dongwook Kim | Dongwook Kim | 2009-06-11 | |||||
| 29119-29166 | Unassigned | ||||||||||
| otmp | 29167 | tcp | ObTools Message Protocol | Paul Clark | Paul Clark | 2006-02 | |||||
| otmp | 29167 | udp | ObTools Message Protocol | Paul Clark | Paul Clark | 2006-02 | |||||
| 29168 | tcp | Reserved | |||||||||
| 29168 | udp | Reserved | |||||||||
| sbcap | 29168 | sctp | SBcAP in 3GPP | Dongwook Kim | Dongwook Kim | 2009-06-11 | |||||
| iuhsctpassoc | 29169 | sctp | HNBAP and RUA Common Association | Dongwook Kim | Dongwook Kim | 2009-09-08 | 2026-01-23 | ||||
| 29170-29998 | Unassigned | ||||||||||
| bingbang | 29999 | tcp | data exchange protocol for IEC61850 in wind power plants | DEIF A/S | Armin Solies | 2012-10-15 | |||||
| 29999 | udp | Reserved | |||||||||
| 30005-30099 | Unassigned | ||||||||||
| 30101-30259 | Unassigned | ||||||||||
| 30261-30399 | Unassigned | ||||||||||
| 30833-30938 | Unassigned | ||||||||||
| dilithium3 | 30939 | tcp | Persistent peer-to-peer connections for block propagation, transaction relay, and BFT consensus message exchange. | Juan Jose Todoli de Torres | Juan Jose Todoli de Torres | 2026-05-28 | |||||
| dilithium3 | 30939 | udp | Kademlia DHT peer discovery and routing table maintenance. | Juan Jose Todoli de Torres | Juan Jose Todoli de Torres | 2026-05-28 | |||||
| 30940-30998 | Unassigned | ||||||||||
| ovobs | 30999 | tcp | OpenView Service Desk Client | Service Desk Product Manager | Service Desk Product Manager | 2006-05 | |||||
| ovobs | 30999 | udp | OpenView Service Desk Client | Service Desk Product Manager | Service Desk Product Manager | 2006-05 | |||||
| 31017-31019 | Unassigned |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| 3GPP2 | lizhiming&huawei.com | 2012-01-11 | |
| Alex Duncan | Alex.Duncan&sse.ie | ||
| Armin Solies | DEIF A/S | aes&deif.com | 2012-10-15 |
| Ayoda GmbH | info&ayoda.net | 2016-04-01 | |
| Christopher Eykamp | chris&eykamp.com | 2012-08-16 | |
| DEIF A/S | aes&deif.com | 2012-10-15 | |
| Dongwook Kim | 3GPP | dongwook.kim&etsi.org | 2026-01-23 |
| Flexera Software | security&flexerasoftware.com | 2016-07-19 | |
| Dongwook Kim | 3GPP Specifications Manager | dongwook.kim&etsi.org | 2026-01-23 |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Ingenta plc | mark.itzcovitz&ingenta.com | 2020-01-06 | |
| J. A. (Tony) Sever | J.A.Sever&bra0119.wins.icl.co.uk | ||
| Jean-Paul Moreaux | jean-paul.moreaux&airbus.com | ||
| Juan Jose Todoli de Torres | admin&dilithium3.com | 2026-05-28 | |
| Laurenz Eschwey | laurenz.eschwey&ayoda.net | 2016-04-01 | |
| Mark Itzcovitz | mark.itzcovitz&ingenta.com | 2020-01-06 | |
| Martin Ellis | martin&clanleagues.net | 2004-11 | |
| Marty Borden | mborden&tollbridgetech.com | ||
| Michael Andersen | michael&steelcode.com | 2016-06-13 | |
| Paul Bland | pbland&flexera.com | 2018-08-22 | |
| Paul Clark | paul&xmill.com | 2006-02 | |
| Roman Oliynyk | romano&netinst.com | ||
| Roman Oliynyk | roman&netinst.com | 2007-08-30 | |
| Scott Petrack | Scott_Petrack&vocaltec.com | ||
| Service Desk Product Manager | info&hp.com | 2006-05 | |
| Siemens Digital Industries Software | tony.greatorex&siemens.com | 2020-06-08 | |
| Stepan Riha | stepan.riha&hand.com | ||
| Timo Sivonen | timo.sivonen&ccmail.dowjones.com | ||
| Toby Hosterman | root&netspeak.com | ||
| Tony Greatorex | tony.greatorex&siemens.com | 2020-06-08 | |
| University of California, Berkeley | m.andersen&cs.berkeley.edu | 2016-06-13 | |
| Urban Fosseus | urban.fosseus®in.se | 2008-12-24 | |
| Zhiming Li | 3GPP2 | lizhiming&huawei.com | 2012-01-11 |