Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| vmsvc-2 | 7025 | udp | Vormetric Service II | Tom Boyle | Tom Boyle | 2005-06 | |||||
| jdp-disc | 7095 | udp | Java Discovery Protocol | OpenJDK | Florian Weimer | 2013-03-12 | |||||
| 7095 | tcp | Reserved | |||||||||
| snif | 7123 | tcp | SNIF End-to-End TLS Relay Control Connection | VESvault Corp | Jim Zubov | 2021-12-24 | 2026-07-22 | draft-zubov-snif-05, Section 4.3 | |||
| snif | 7123 | udp | SNIF End-to-End TLS Relay over QUIC | VESvault Corp | Jim Zubov | 2026-07-22 | 2026-07-22 | draft-zubov-snif-05, Section 4.4 | |||
| doc-server | 7165 | tcp | Document WCF Server | Micha Ben-Efraim | Micha Ben-Efraim | 2008-01-07 | |||||
| doc-server | 7165 | udp | Document WCF Server | Micha Ben-Efraim | Micha Ben-Efraim | 2008-01-07 | |||||
| 7175-7180 | Unassigned | ||||||||||
| pon-ictp | 7202 | tcp | Inter-Channel Termination Protocol (ICTP) for multi-wavelength PON (Passive Optical Network) systems | Broadband Forum | Broadband Forum | 2017-02-22 | 2019-12-16 | TR-352; Inter-Channel-Termination protocol (ICTP) is a peer-to-peer protocol with a binary message format that is used by a set of optical line terminal (OLT) channel terminations (CT) comprising a 40-Gigabit-capable next-generation passive optical network (NG-PON2) system to exchange channel profile configuration and status information and to coordinate the operation of tunable optical network units (ONUs) in a multi-wavelength channel environment. | |||
| PS-Server | 7215 | tcp | Communication ports for PaperStream Server services | PFU Systems Inc. | Hari Asuri | 2016-02-26 | |||||
| 7215 | udp | Reserved | |||||||||
| aspcoordination | 7235 | udp | ASP Coordination Protocol | Wi-Fi Alliance | Mick Conley | 2013-12-31 | |||||
| 7235 | tcp | Reserved | |||||||||
| 7245-7261 | Unassigned | ||||||||||
| oma-ulp | 7275 | tcp | OMA UserPlane Location | Larry A. Young | Larry A. Young | 2006-02 | |||||
| oma-ulp | 7275 | udp | OMA UserPlane Location | Larry A. Young | Larry A. Young | 2006-02 | |||||
| swx | 7300-7359 | The Swiss Exchange | Edgar Blum | Edgar Blum | |||||||
| lcm-server | 7365 | tcp | LifeKeeper Communications | James Bottomley | James Bottomley | 2006-02 | |||||
| lcm-server | 7365 | udp | LifeKeeper Communications | James Bottomley | James Bottomley | 2006-02 | |||||
| winqedit | 7395 | tcp | winqedit | David Greer | David Greer | ||||||
| winqedit | 7395 | udp | winqedit | David Greer | David Greer | ||||||
| 7422-7425 | Unassigned | ||||||||||
| 7475-7477 | Unassigned | ||||||||||
| silhouette | 7500 | tcp | Silhouette User | Anthony Payne | Anthony Payne | 2004-02 | |||||
| silhouette | 7500 | udp | Silhouette User | Anthony Payne | Anthony Payne | 2004-02 | |||||
| ovbus | 7501 | tcp | HP OpenView Bus Daemon | David M. Rhodes | David M. Rhodes | Known Unauthorized Use on port 7501 | |||||
| ovbus | 7501 | udp | HP OpenView Bus Daemon | David M. Rhodes | David M. Rhodes | Known Unauthorized Use on port 7501 | |||||
| 7502-7507 | Unassigned | ||||||||||
| adcp | 7508 | tcp | Automation Device Configuration Protocol | Festo AG & Co. KG | Joerg Ullmann | 2011-05-27 | 2012-07-26 | ||||
| 7508 | udp | Reserved | |||||||||
| acplt | 7509 | tcp | ACPLT - process automation service | The Chair for Process Control Engineering | Ulrich Epple | 2010-12-07 | 2012-08-07 | ||||
| 7509 | udp | Reserved | |||||||||
| ovhpas | 7510 | tcp | HP OpenView Application Server | Jeff Conrad | Jeff Conrad | ||||||
| ovhpas | 7510 | udp | HP OpenView Application Server | Jeff Conrad | Jeff Conrad | ||||||
| pafec-lm | 7511 | tcp | pafec-lm | Billy Dhillon | Billy Dhillon | ||||||
| pafec-lm | 7511 | udp | pafec-lm | Billy Dhillon | Billy Dhillon | ||||||
| 7512-7541 | Unassigned | ||||||||||
| saratoga | 7542 | tcp | Saratoga Transfer Protocol | Lloyd Wood | Lloyd Wood | 2007-05 | |||||
| saratoga | 7542 | udp | Saratoga Transfer Protocol | Lloyd Wood | Lloyd Wood | 2007-05 | |||||
| atul | 7543 | tcp | atul server | Mark Stapp | Mark Stapp | 2006-01 | |||||
| atul | 7543 | udp | atul server | Mark Stapp | Mark Stapp | 2006-01 | |||||
| nta-ds | 7544 | tcp | FlowAnalyzer DisplayServer | Fred Messinger | Fred Messinger | ||||||
| nta-ds | 7544 | udp | FlowAnalyzer DisplayServer | Fred Messinger | Fred Messinger | ||||||
| nta-us | 7545 | tcp | FlowAnalyzer UtilityServer | Fred Messinger | Fred Messinger | ||||||
| nta-us | 7545 | udp | FlowAnalyzer UtilityServer | Fred Messinger | Fred Messinger | ||||||
| cfs | 7546 | tcp | Cisco Fabric service | Rituparna Agrawal | Rituparna Agrawal | 2005-09 | |||||
| cfs | 7546 | udp | Cisco Fabric service | Rituparna Agrawal | Rituparna Agrawal | 2005-09 | |||||
| cwmp | 7547 | tcp | Broadband Forum CWMP | Broadband Forum | Broadband Forum | 2006-01 | 2019-12-13 | ||||
| cwmp | 7547 | udp | Broadband Forum CWMP | Broadband Forum | Broadband Forum | 2006-01 | 2019-12-13 | ||||
| tidp | 7548 | tcp | Threat Information Distribution Protocol | Chui-Tin Yen | Chui-Tin Yen | 2006-02 | |||||
| tidp | 7548 | udp | Threat Information Distribution Protocol | Chui-Tin Yen | Chui-Tin Yen | 2006-02 | |||||
| nls-tl | 7549 | tcp | Network Layer Signaling Transport Layer | Melinda Shore | Melinda Shore | 2006-05 | |||||
| nls-tl | 7549 | udp | Network Layer Signaling Transport Layer | Melinda Shore | Melinda Shore | 2006-05 | |||||
| 7550 | tcp | Reserved | |||||||||
| cloudsignaling | 7550 | udp | Cloud Signaling Service | Scott Dawson | Scott Dawson | 2011-07-01 | |||||
| controlone-con | 7551 | tcp | ControlONE Console signaling | BYNE | Andre Nazario | 2014-11-07 | 2017-06-13 | ||||
| 7551 | udp | Reserved | |||||||||
| 7552-7559 | Unassigned | ||||||||||
| sncp | 7560 | tcp | Sniffer Command Protocol | Dominick Cafarelli | Dominick Cafarelli | 2005-08 | |||||
| sncp | 7560 | udp | Sniffer Command Protocol | Dominick Cafarelli | Dominick Cafarelli | 2005-08 | |||||
| 7561-7562 | Unassigned | ||||||||||
| cfw | 7563 | tcp | Control Framework | RFC 6230 | |||||||
| 7563 | udp | Reserved | |||||||||
| 7564-7565 | Unassigned | ||||||||||
| vsi-omega | 7566 | tcp | VSI Omega | Curtis Smith | Curtis Smith | ||||||
| vsi-omega | 7566 | udp | VSI Omega | Curtis Smith | Curtis Smith | ||||||
| 7567-7568 | Unassigned | ||||||||||
| dell-eql-asm | 7569 | tcp | Dell EqualLogic Host Group Management | James E. King, III | James E. King, III | ||||||
| 7569 | udp | Reserved | |||||||||
| aries-kfinder | 7570 | tcp | Aries Kfinder | James King III | James King III | ||||||
| aries-kfinder | 7570 | udp | Aries Kfinder | James King III | James King III | ||||||
| 7571-7573 | Unassigned | ||||||||||
| coherence | 7574 | tcp | Oracle Coherence Cluster Service | Oracle | Mark Falco | 2014-07-09 | |||||
| coherence-disc | 7574 | udp | Oracle Coherence Cluster discovery service | Oracle | Mark Falco | 2014-07-09 | |||||
| wtmi-panel | 7575 | tcp | Main access port for WTMI Panel | WTMI LLC | Jay Dubinsky | 2024-08-13 | |||||
| 7575 | udp | Reserved | |||||||||
| 7576-7587 | Unassigned | ||||||||||
| sun-lm | 7588 | tcp | Sun License Manager | Sophie Deng | Sophie Deng | ||||||
| sun-lm | 7588 | udp | Sun License Manager | Sophie Deng | Sophie Deng | ||||||
| 7589-7605 | Unassigned | ||||||||||
| 7625 | Unassigned | ||||||||||
| simco | 7626 | tcp | SImple Middlebox COnfiguration (SIMCO) Server | RFC 4540 | |||||||
| imqtunnel | 7675 | tcp | iMQ Tunnel | Shailesh S. Bavadekar | Shailesh S. Bavadekar | 2002-04 | |||||
| imqtunnel | 7675 | udp | iMQ Tunnel | Shailesh S. Bavadekar | Shailesh S. Bavadekar | 2002-04 | |||||
| nitrogen | 7725 | tcp | Nitrogen Service | Randy Lomnes | Randy Lomnes | 2004-11 | |||||
| nitrogen | 7725 | udp | Nitrogen Service | Randy Lomnes | Randy Lomnes | 2004-11 | |||||
| 7735-7737 | Unassigned | ||||||||||
| 7745-7746 | Unassigned | ||||||||||
| inetfs | 7775 | tcp | A File System using TLS over a wide area network | Roger Allan | Roger Allan | 2016-01-28 | |||||
| 7775 | udp | Reserved | |||||||||
| 7785 | Unassigned | Known Unauthorized Use on port 7785 | |||||||||
| 7795-7796 | Unassigned | ||||||||||
| apc-7845 | 7845 | tcp | APC 7845 | American Power Conversion | American Power Conversion | ||||||
| apc-7845 | 7845 | udp | APC 7845 | American Power Conversion | American Power Conversion | ||||||
| mxi | 8005 | tcp | MXI Generation II for z/OS | Rob Scott | Rob Scott | 2007-05 | |||||
| mxi | 8005 | udp | MXI Generation II for z/OS | Rob Scott | Rob Scott | 2007-05 | |||||
| cfg-cloud | 8015 | tcp | Configuration Cloud Service | admin_at_cfg_cloud | Goksel Darcan | 2019-01-09 | |||||
| 8015 | udp | Reserved | |||||||||
| ca-audit-da | 8025 | tcp | CA Audit Distribution Agent | Henning Smith | Henning Smith | 2006-07 | |||||
| ca-audit-da | 8025 | udp | CA Audit Distribution Agent | Henning Smith | Henning Smith | 2006-07 | |||||
| 8035-8039 | Unassigned |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| admin_at_cfg_cloud | gdarcan&gmail.com | 2019-01-09 | |
| American Power Conversion | ports&apcc.com | 2002-02 | |
| Andre Nazario | andre.nazario&byne.com.br | 2017-06-13 | |
| Anthony Payne | opayne&pacbell.net | 2004-02 | |
| Billy Dhillon | bdsos&pafec.co.uk | ||
| Broadband Forum | help&broadband-forum.org | 2020-03-17 | |
| BYNE | devel&byne.com.br | 2017-06-13 | |
| The Chair for Process Control Engineering | ks&plt.rwth-aachen.de | 2012-08-07 | |
| Chui-Tin Yen | tin&cisco.com | 2006-02 | |
| Curtis Smith | curtis.smith&vsin.com | ||
| David Greer | david_greer&robelle.com | ||
| David M. Rhodes | davidrho&cnd.hp.com | ||
| Dominick Cafarelli | dominick.cafarelli&networkgeneral.com | 2005-08 | |
| Edgar Blum | edgar.blum&swx.ch | ||
| Festo AG & Co. KG | Software-Support&de.festo.com | 2012-07-26 | |
| Florian Weimer | fweimer&redhat.com | 2013-03-12 | |
| Fred Messinger | fredm&cisco.com | ||
| Goksel Darcan | gdarcan&gmail.com | 2019-01-09 | |
| Hari Asuri | hasuri.pfu&us.fujitsu.com | 2016-02-26 | |
| Henning Smith | henning.smith&ca.com | 2006-07 | |
| James Bottomley | James.Bottomley&steeleye.com | 2006-02 | |
| James E. King, III | James_E_K&dell.com | 2010-06-24 | |
| James King III | jking&ariessys.com | ||
| Jay Dubinsky | WTMI LLC | jay&wtmi.com | 2024-08-13 |
| Jeff Conrad | jeff_conrad&hp.com | ||
| Jim Zubov | VESvault Corp | jz&vesvault.com | 2021-12-29 |
| Joerg Ullmann | Festo AG & Co. KG | jgu&de.festo.com | 2012-07-26 |
| Larry A. Young | Larry.A.Young&sprint.com | 2006-02 | |
| Lloyd Wood | lwood&cisco.com | 2007-05 | |
| Mark Falco | Oracle | mark.falco&oracle.com | 2014-07-09 |
| Mark Stapp | mjs&cisco.com | 2006-01 | |
| Melinda Shore | mshore&cisco.com | 2006-05 | |
| Micha Ben-Efraim | benmi07&ca.com | 2008-01-07 | |
| Mick Conley | Wi-Fi Alliance | mconley&wi-fi.org | 2013-12-31 |
| OpenJDK | discuss&openjdk.java.net | 2013-03-12 | |
| Oracle | mark.falco&oracle.com | 2014-07-09 | |
| PFU Systems Inc. | hasuri.pfu&us.fujitsu.com | 2016-02-26 | |
| Randy Lomnes | rlomnes&faronics.com | 2004-11 | |
| Rituparna Agrawal | riagrawa&cisco.com | 2005-09 | |
| Rob Scott | rscott&rs.com | 2007-05 | |
| Roger Allan | rallan&inetfs.org | 2016-01-28 | |
| Scott Dawson | sdawson&arbor.net | 2011-07-01 | |
| Shailesh S. Bavadekar | shailesh.bavadekar&sun.com | 2002-04 | |
| Sophie Deng | Sophie.Deng&eng.sun.com | ||
| Tom Boyle | tboyle&vormetric.com | 2005-06 | |
| Ulrich Epple | ks&plt.rwth-aachen.de | 2012-08-07 | |
| VESvault Corp | info&vesvault.com | 2021-12-29 | |
| Wi-Fi Alliance | mconley&wi-fi.org | 2013-12-31 | |
| WTMI LLC | engineering&wtmi.com | 2024-08-13 |