Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
apani5 9164 tcp apani5 Neal Taylor Neal Taylor
apani5 9164 udp apani5 Neal Taylor Neal Taylor
9165-9182 Unassigned
wap-vcard-s 9206 tcp WAP vCard Secure WAP Forum WAP Forum
wap-vcard-s 9206 udp WAP vCard Secure WAP Forum WAP Forum
acme 9216 tcp Aionex Communication Management Engine Mark Sapp Mark Sapp 2006-04
acme 9216 udp Aionex Communication Management Engine Mark Sapp Mark Sapp 2006-04
9256-9276 Unassigned
9286 tcp Reserved
n2receive 9286 udp n2 monitoring receiver Peter van Dijk Peter van Dijk 2011-01-10
9296-9299 Unassigned
sphinxql 9306 tcp Sphinx search server (MySQL listener) Andrew Aksyonoff Andrew Aksyonoff 2009-10-20
9306 udp Reserved
ctechlicensing 9346 tcp C Tech Licensing Reed Copsey Jr. Reed Copsey Jr.
ctechlicensing 9346 udp C Tech Licensing Reed Copsey Jr. Reed Copsey Jr.
9381-9386 Unassigned
fjinvmgr 9396 tcp fjinvmgr Yutaka Ono Yutaka Ono
fjinvmgr 9396 udp fjinvmgr Yutaka Ono Yutaka Ono
9446-9449 Unassigned
laes-bf 9536 tcp Surveillance buffering function Glen Myers Glen Myers 2007-05
laes-bf 9536 udp Surveillance buffering function Glen Myers Glen Myers 2007-05
9556-9558 Unassigned
9560-9591 Unassigned
mercury-disc 9596 tcp Mercury Discovery Paul Mclachlan Paul Mclachlan 2005-11
mercury-disc 9596 udp Mercury Discovery Paul Mclachlan Paul Mclachlan 2005-11
micromuse-ncpw 9600 tcp MICROMUSE-NCPW Hing Wing To Hing Wing To
micromuse-ncpw 9600 udp MICROMUSE-NCPW Hing Wing To Hing Wing To
9601-9611 Unassigned
streamcomm-ds 9612 tcp StreamComm User Directory Brian C. Wiles Brian C. Wiles
streamcomm-ds 9612 udp StreamComm User Directory Brian C. Wiles Brian C. Wiles
9613 Unassigned
iadt-tls 9614 tcp iADT Protocol over TLS Paul A. Suhler Paul A. Suhler 2009-02-05
9614 udp Reserved
9615 Unassigned
erunbook-agent 9616 tcp eRunbook Agent

IANA assigned this well-formed service name as a replacement for "erunbook_agent".
Gerhard Wagner Gerhard Wagner 2009-03-10
erunbook_agent 9616 tcp eRunbook Agent Gerhard Wagner Gerhard Wagner 2009-03-10 This entry is an alias to "erunbook-agent". This entry is now historic, not usable for use with many common service discovery mechanisms.
9616 udp Reserved
erunbook-server 9617 tcp eRunbook Server

IANA assigned this well-formed service name as a replacement for "erunbook_server".
Gerhard Wagner Gerhard Wagner 2009-03-10
erunbook_server 9617 tcp eRunbook Server Gerhard Wagner Gerhard Wagner 2009-03-10 This entry is an alias to "erunbook-server". This entry is now historic, not usable for use with many common service discovery mechanisms.
9617 udp Reserved
condor 9618 tcp Condor Collector Service Todd Tannenbaum Todd Tannenbaum 2008-04-03
condor 9618 udp Condor Collector Service Todd Tannenbaum Todd Tannenbaum 2008-04-03
9619-9627 Unassigned
odbcpathway 9628 tcp ODBC Pathway Service Adrian Hungate Adrian Hungate 2007-05
odbcpathway 9628 udp ODBC Pathway Service Adrian Hungate Adrian Hungate 2007-05
uniport 9629 tcp UniPort SSO Controller Adrian Hungate Adrian Hungate 2007-09-05
uniport 9629 udp UniPort SSO Controller Adrian Hungate Adrian Hungate 2007-09-05
peoctlr 9630 tcp Peovica Controller Adrian Hungate Adrian Hungate 2009-09-14
9630 udp Reserved
peocoll 9631 tcp Peovica Collector Adrian Hungate Adrian Hungate 2009-09-14
9631 udp Reserved
9632 tcp Reserved
mc-comm 9632 udp Mobile-C Communications David Ko David Ko 2009-09-14
9633-9639 Unassigned
pqsflows 9640 tcp ProQueSys Flows Service Sarene Caiazza Sarene Caiazza 2010-04-27
9640 udp Reserved
9641-9665 Unassigned
zoomcp 9666 tcp Zoom Control Panel Game Server Management Zoom Control Panel Joshua Pedroza 2014-02-26
9666 udp Reserved
xmms2 9667 tcp Cross-platform Music Multiplexing System Juho Vähä-Herttua Juho Vähä-Herttua 2009-04-14
xmms2 9667 udp Cross-platform Music Multiplexing System Juho Vähä-Herttua Juho Vähä-Herttua
tec5-sdctp 9668 tcp tec5 Spectral Device Control Protocol Michael Muth Michael Muth 2009-05-11
tec5-sdctp 9668 udp tec5 Spectral Device Control Protocol Michael Muth Michael Muth 2009-05-11
9669-9693 Unassigned
client-wakeup 9694 tcp T-Mobile Client Wakeup Message Michael Schönborn Michael Schönborn 2009-09-11
client-wakeup 9694 udp T-Mobile Client Wakeup Message Michael Schönborn Michael Schönborn 2009-09-11
ccnx 9695 tcp Content Centric Networking Van Jacobson; Simon Barber Van Jacobson; Simon Barber 2009-09-29
ccnx 9695 udp Content Centric Networking Van Jacobson; Simon Barber Van Jacobson; Simon Barber 2009-09-29
9696-9699 Unassigned
9701-9746 Unassigned
9754-9761 Unassigned
tungsten-http 9762 tcp WSO2 Tungsten HTTP Afkham Azeez Afkham Azeez 2006-06
tungsten-http 9762 udp WSO2 Tungsten HTTP Afkham Azeez Afkham Azeez 2006-06
9763-9799 Unassigned
sd 9876 tcp Session Director Van Jacobson Van Jacobson
kca-service 9878 udp The KX509 Kerberized Certificate Issuance Protocol in Use in 2012 IESG IETF Chair 2012-07-12 RFC 6717 Historically, this service has been referred to as "kca_service", but this service name does not meet the registry requirements.
sctp-tunneling 9899 udp SCTP TUNNELING IESG IETF Chair 2013-04-10 RFC 6951
multicast-ping 9903 udp Multicast Ping Protocol 2011-12-09 RFC 6450
9926-9949 Unassigned
9956 tcp Reserved
alljoyn 9956 udp Alljoyn Name Service Qualcomm Innovation Center, Inc. Craig Dowell 2011-12-21
9957-9965 Unassigned
odnsp 9966 tcp OKI Data Network Setting Protocol Masato Sato Masato Sato 2006-05
odnsp 9966 udp OKI Data Network Setting Protocol Masato Sato Masato Sato 2006-05
9967-9977 Unassigned
kaostransport 9986 tcp KAOS secure message transport protocol for safety-critical environments KAOS Management Group, LLC Philip Duvalsaint 2025-10-30
9986 udp Reserved
palace-5 9996 tcp Palace-5 Douglas Crockford Douglas Crockford
palace-5 9996 udp Palace-5 Douglas Crockford Douglas Crockford
palace-6 9997 tcp Palace-6 Douglas Crockford Douglas Crockford
palace-6 9997 udp Palace-6 Douglas Crockford Douglas Crockford
netapp-sync 10006 tcp Sync replication protocol among different NetApp platforms NetApp Paul Mu 2014-08-07
10006 udp Reserved
10056-10079 Unassigned
10105-10106 Unassigned
netiq-voipa 10116 tcp NetIQ VoIP Assessor Gary Weichinger Gary Weichinger
netiq-voipa 10116 udp NetIQ VoIP Assessor Gary Weichinger Gary Weichinger
10126-10127 Unassigned
qb-db-server 10160 tcp QB Database Server Wei Wang Wei Wang 2005-11
qb-db-server 10160 udp QB Database Server Wei Wang Wei Wang 2005-11
snmptls 10161 tcp SNMP-TLS RFC 6353

Contact Information

Name Organization Contact URI Last Updated
Adrian Hungate adrian&tlspu.com 2014-07-11
Afkham Azeez azeez&wso2.com 2006-06
Andrew Aksyonoff shodan&sphinxsearch.com 2009-10-20
Brian C. Wiles brian&streamcomm.com
Craig Dowell Qualcomm Innovation Center, Inc. cdowell&quicinc.com 2011-12-21
David Ko david.dk.ko&gmail.com 2009-09-14
Douglas Crockford douglas&crockford.com
Gary Weichinger gary.weichinger&netiq.com
Gerhard Wagner gw&nova-ratio.de 2009-03-10
Glen Myers glen.myers&ipfabrics.com 2007-05
Hing Wing To wing.to&micromuse.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Joshua Pedroza Zoom Control Panel info&zoomcp.com 2014-02-26
Juho Vähä-Herttua juhovh&iki.fi 2009-04-14
KAOS Management Group, LLC phil&GotKAOS.com 2025-10-30
Mark Sapp mark.sapp&aionex.com 2006-04
Masato Sato satou203&oki.com 2006-05
Michael Muth m.muth&tec5.com 2009-05-11
Michael Schönborn T-Mobile International AG michael.schoenborn&t-mobile.net 2009-09-11
Neal Taylor ianareg&apani.com
NetApp pmu&netapp.com. 2014-08-12
Paul A. Suhler paul.suhler&quantum.com 2009-02-06
Paul Mclachlan pmclachlan&mercury.com 2005-11
Paul Mu NetApp pmu&netapp.com 2014-08-07
Peter van Dijk peter&xlshosting.nl 2011-01-10
Philip Duvalsaint phil&GotKAOS.com 2025-10-30
Qualcomm Innovation Center, Inc. cdowell&quicinc.com 2011-12-21
Reed Copsey Jr. reedc&ctech.com
Sarene Caiazza scaiazza&proquesys.com 2010-04-27
Simon Barber simon.barber&parc.com 2009-09-29
Todd Tannenbaum tannenba&cs.wisc.edu 2008-04-03
Van Jacobson van&ee.lbl.gov
Van Jacobson van&parc.com 2009-09-29
WAP Forum wap-feedback&mail.wapforum.org
pg&uplanet.com
Wei Wang Wei_Wang&intuit.com 2005-11
Yutaka Ono ono&saint.nm.fujitsu.co.jp
Zoom Control Panel ianaport&zoomcp.com 2014-02-26