Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
16790-16899 Unassigned
16996-17006 Unassigned
isode-dua 17007 tcp
isode-dua 17007 udp
17008-17009 Unassigned
ncpu 17010 tcp Plan 9 cpu port Ronald G. Minnich Ronald G. Minnich 2022-05-13 Defined TXT keys: u=username; k=keypattern; f=fstabFILE; n=namespace; h=hostkey; r=root
17010 udp Reserved
17011-17183 Unassigned
vestasdlp 17184 tcp Vestas Data Layer Protocol Vestas Wind Systems Teunis de Wit 2013-10-30
17184 udp Reserved
soundsvirtual 17185 tcp Sounds Virtual Richard Snider Richard Snider
soundsvirtual 17185 udp Sounds Virtual Richard Snider Richard Snider
17186-17218 Unassigned
chipper 17219 tcp Chipper Ronald Jimmink Ronald Jimmink
chipper 17219 udp Chipper Ronald Jimmink Ronald Jimmink
avtp 17220 tcp IEEE 1722 Transport Protocol for Time Sensitive Applications Transport Protocol for Time-Sensitive Networking TG Ashley Butterworth 2014-03-07
avtp 17220 udp IEEE 1722 Transport Protocol for Time Sensitive Applications Transport Protocol for Time-Sensitive Networking TG Ashley Butterworth 2014-03-07
avdecc 17221 tcp IEEE 1722.1 AVB Discovery, Enumeration, Connection management, and Control IEEE-1722.1 Jeffrey Daniel Koftinoff 2011-11-01
avdecc 17221 udp IEEE 1722.1 AVB Discovery, Enumeration, Connection management, and Control IEEE-1722.1 Jeffrey Daniel Koftinoff 2011-11-01
17222 tcp Reserved
cpsp 17222 udp Control Plane Synchronization Protocol (SPSP) Randall Stewart Randall Stewart 2011-11-10
isa100-gci 17223 tcp ISA100 GCI is a service utilizing a common interface between an ISA100 Wireless gateway and a client application ISA100 Wireless Compliance Institute Jay Werb 2015-07-24
17223 udp Reserved
trdp-pd 17224 udp Train Realtime Data Protocol (TRDP) Process Data IEC Central Office Gianosvaldo Fadin 2015-07-24
17224 tcp Reserved
trdp-md 17225 tcp Train Realtime Data Protocol (TRDP) Message Data IEC Central Office Gianosvaldo Fadin 2015-07-24
trdp-md 17225 udp Train Realtime Data Protocol (TRDP) Message Data IEC Central Office Gianosvaldo Fadin 2015-07-24
17226-17233 Unassigned
integrius-stp 17234 tcp Integrius Secure Tunnel Protocol Christian Klemetsson Christian Klemetsson 2010-03-04
integrius-stp 17234 udp Integrius Secure Tunnel Protocol Christian Klemetsson Christian Klemetsson 2010-03-04
ssh-mgmt 17235 tcp SSH Tectia Manager Ville Laurikari Ville Laurikari 2005-08
ssh-mgmt 17235 udp SSH Tectia Manager Ville Laurikari Ville Laurikari 2005-08
17236-17499 Unassigned
db-lsp 17500 tcp Dropbox LanSync Protocol Paul Bohm Paul Bohm 2010-01-21
db-lsp-disc 17500 udp Dropbox LanSync Discovery Paul Bohm Paul Bohm 2010-01-21
17501-17554 Unassigned
ailith 17555 tcp Ailith management of routers Thomas Boje Thomas Boje 2014-03-27
17555 udp Reserved
17556-17728 Unassigned
ea 17729 tcp Eclipse Aviation William Schmidt William Schmidt 2006-03
ea 17729 udp Eclipse Aviation William Schmidt William Schmidt 2006-03
17730-17753 Unassigned
zep 17754 tcp Encap. ZigBee Packets Fred Fierling Fred Fierling 2006-02
zep 17754 udp Encap. ZigBee Packets Fred Fierling Fred Fierling 2006-02
zigbee-ip 17755 tcp ZigBee IP Transport Service Chris Herzog Chris Herzog 2006-05
zigbee-ip 17755 udp ZigBee IP Transport Service Chris Herzog Chris Herzog 2006-05
zigbee-ips 17756 tcp ZigBee IP Transport Secure Service Chris Herzog Chris Herzog 2006-05
zigbee-ips 17756 udp ZigBee IP Transport Secure Service Chris Herzog Chris Herzog 2006-05
17757-17776 Unassigned
sw-orion 17777 tcp SolarWinds Orion Joel Dolisy Joel Dolisy 2008-09-10
17777 udp Reserved
17778-17999 Unassigned
18137-18180 Unassigned
opsec-ela 18187 tcp OPSEC ELA Alon Kantor Alon Kantor
opsec-ela 18187 udp OPSEC ELA Alon Kantor Alon Kantor
18517-18633 Unassigned
18636-18667 Unassigned
18669-18768 Unassigned
ique 18769 tcp IQue Protocol Avi Drissman Avi Drissman 2002-07
ique 18769 udp IQue Protocol Avi Drissman Avi Drissman 2002-07
18770-18880 Unassigned
18882-18887 Unassigned
scintilla 19007 tcp Scintilla protocol for device services Veejansh Inc Chirag Patel 2014-03-04
scintilla 19007 udp Scintilla protocol for device services Veejansh Inc Chirag Patel 2014-03-04
19316-19397 Unassigned
19542-19787 Unassigned
mle 19788 udp Mesh Link Establishment IESG IETF Chair 2012-12-18
19788 tcp Reserved
19789 Unassigned
faircom-db 19790 tcp FairCom Database FairCom Corporation Michael Bowers 2020-12-04
19790 udp Reserved
19791-19997 Unassigned
iec-104-sec 19998 tcp IEC 60870-5-104 process control - secure Grant Gilchrist Grant Gilchrist 2010-10-18
tmophl7mts 20046 tcp TMOP HL7 Message Transfer Service Tim Riley Tim Riley 2009-07-31
tmophl7mts 20046 udp TMOP HL7 Message Transfer Service Tim Riley Tim Riley 2009-07-31
20047-20047 Unassigned
nfsrdma 20049 tcp Network File System (NFS) over RDMA 2017-09-05 RFC 8267
nfsrdma 20049 udp Network File System (NFS) over RDMA 2017-09-05 RFC 8267
nfsrdma 20049 sctp Network File System (NFS) over RDMA 2017-09-05 RFC 8267
avesterra 20057 tcp AvesTerra Hypergraph Transfer Protocol (HGTP) Georgetown University J.C. Smart 2016-06-06
20057 udp Reserved
tolfab 20167 tcp TOLfab Data Change Pierre Couderc Pierre Couderc 2006-03
tolfab 20167 udp TOLfab Data Change Pierre Couderc Pierre Couderc 2006-03
20223-20479 Unassigned
track 20670 tcp Track Michael Sweet Michael Sweet
track 20670 udp Track Michael Sweet Michael Sweet
20671-20809 Unassigned
xahaud 21337 tcp Xahau P2P network protocol INFTF MTU Bharath Chari 2025-10-16 https://xahau.network
21337 udp Reserved
21591-21799 Unassigned
netspeak-cs 21847 tcp NetSpeak Corp. Connection Services Toby Hosterman Toby Hosterman
netspeak-cs 21847 udp NetSpeak Corp. Connection Services Toby Hosterman Toby Hosterman
22126-22127 Unassigned
22223-22272 Unassigned
wnn6 22273 tcp wnn6 Yasunari Gon Yamasita Yasunari Gon Yamasita
wnn6 22273 udp wnn6 Yasunari Gon Yamasita Yasunari Gon Yamasita
22274-22304 Unassigned
wibukey 22347 tcp WibuKey Standard WkLan Wolfgang Voelker Wolfgang Voelker 2007-06
wibukey 22347 udp WibuKey Standard WkLan Wolfgang Voelker Wolfgang Voelker 2007-06
caldsoft-backup 22537 tcp CaldSoft Backup server file transfer CaldSoft Mark Caldwell 2011-08-12
22537 udp Reserved

Contact Information

Name Organization Contact URI Last Updated
Alon Kantor alonk&checkpoint.com
Ashley Butterworth abutterworth&apple.com 2014-03-07
Avi Drissman ique-protocol&harrisbaseview.com 2002-07
Bharath Chari bharath&inftf.org 2025-10-16
CaldSoft development&caldsoft.co.uk 2011-08-12
Chirag Patel Veejansh Inc cpatel&veejansh.com 2014-03-04
Chris Herzog zog&stg.com 2006-05
Christian Klemetsson Integrius AB christian.klemetsson&integrius.se 2010-03-04
FairCom Corporation alysha.brown&faircom.com 2020-12-04
Fred Fierling fff&exegin.com 2006-02
Georgetown University smart&georgetown.edu 2016-06-06
Gianosvaldo Fadin IEC Central Office gianosvaldo.fadin&anie.it 2015-07-24
Grant Gilchrist grant&enernex.com 2010-10-18
IEEE-1722.1 jeff.koftinoff&ieee.com 2011-11-01
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
INFTF MTU bharath&inftf.org 2025-10-16
IEC Central Office cj&iec.ch 2015-07-24
ISA100 Wireless Compliance Institute jay&jwerb.com 2015-07-24
J.C. Smart smart&georgetown.edu 2016-06-06
Jay Werb ISA100 Wireless Compliance Institute jay&jwerb.com 2015-07-24
Jeffrey Daniel Koftinoff IEEE-1722.1 jeff.koftinoff&ieee.com 2011-11-01
Joel Dolisy joel.dolisy&solarwinds.com 2008-09-10
Mark Caldwell development&caldsoft.co.uk 2011-08-12
Michael Bowers FairCom Corporation mike.bowers&faircom.com 2020-12-04
Michael Sweet msweet&ctr.nawcad.navy.mil
Paul Bohm paul&dropbox.com 2010-01-21
Pierre Couderc pcouderc&tol.fr 2006-03
Randall Stewart rrs&lakerest.net 2011-10-24
Richard Snider rsnider&sounds.com
Ronald G. Minnich rminnich&gmail.com 2022-05-13
Ronald Jimmink Ronald.Jimmink&chipper.nl
Teunis de Wit Vestas Wind Systems tdwi&vestas.com 2013-10-30
Thomas Boje thomas.boje&gmx.de 2014-03-27
Tim Riley rileyt&saic.com 2009-07-31
Toby Hosterman root&netspeak.com
Transport Protocol for Time-Sensitive Networking TG AVBTP&ieee.org 2014-03-07
Veejansh Inc admin&veejansh.com 2014-03-04
Vestas Wind Systems tdwi&vestas.com 2013-10-30
Ville Laurikari vlaurika&ssh.com 2005-08
William Schmidt info&eclipseaviation.com 2006-03
Wolfgang Voelker wolfgang.voelker&wibu.com 2007-06
Yasunari Gon Yamasita yamasita&omronsoft.co.jp