Service Name and Transport Protocol Port Number Registry

Last Updated
2026-10-09
Expert(s)
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell,
and Michael Scharf
SCTP: Michael Tuexen
DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
[RFC 6335]
Note
Service names and port numbers are used to distinguish between different
services that run over transport protocols such as TCP, UDP, DCCP, and
SCTP.

Service names are assigned on a first-come, first-served process, as
documented in [RFC 6335].

Port numbers are assigned in various ways, based on three ranges: System
Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private
Ports (49152-65535); the different uses of these ranges are described in
[RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are 
assigned by the "IETF Review" or "IESG Approval" procedures described in 
[RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, 
the "IESG Approval" process, or the "Expert Review" process, as per 
[RFC 6335]. Dynamic Ports are not assigned.

The registration procedures for service names and port numbers are
described in [RFC 6335].

Assigned ports both System and User ports SHOULD NOT be used without
or prior to IANA registration.

************************************************************************
* PLEASE NOTE THE FOLLOWING:                                           *
*                                                                      *
* ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN             *
* ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK  *
* TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT   *
* IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE     *
* ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD          *
* CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF    *
* THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER          *
* REGISTERED OR NOT.                                                   *
************************************************************************

Request an Assignment
  [https://www.iana.org/protocols/apply]

Available Formats

CSV

XML

HTML

TXT
Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
servicetags 6481 udp Service Tags [Peter_Schow] [Peter_Schow] 2007-01
ldoms-mgmt 6482 tcp Logical Domains Management Interface [Eric_Sharakan] [Eric_Sharakan] 2008-02-14
ldoms-mgmt 6482 udp Logical Domains Management Interface [Eric_Sharakan] [Eric_Sharakan] 2008-02-14
SunVTS-RMI 6483 tcp SunVTS RMI [Sumit_Arora] [Sumit_Arora] 2007-06
SunVTS-RMI 6483 udp SunVTS RMI [Sumit_Arora] [Sumit_Arora] 2007-06
sun-sr-jms 6484 tcp Service Registry Default JMS Domain [Paul_Sterk] [Paul_Sterk] 2006-03
sun-sr-jms 6484 udp Service Registry Default JMS Domain [Paul_Sterk] [Paul_Sterk] 2006-03
sun-sr-iiop 6485 tcp Service Registry Default IIOP Domain [Paul_Sterk] [Paul_Sterk] 2006-03
sun-sr-iiop 6485 udp Service Registry Default IIOP Domain [Paul_Sterk] [Paul_Sterk] 2006-03
sun-sr-iiops 6486 tcp Service Registry Default IIOPS Domain [Paul_Sterk] [Paul_Sterk] 2006-03
sun-sr-iiops 6486 udp Service Registry Default IIOPS Domain [Paul_Sterk] [Paul_Sterk] 2006-03
sun-sr-iiop-aut 6487 tcp Service Registry Default IIOPAuth Domain [Paul_Sterk] [Paul_Sterk] 2006-03
sun-sr-iiop-aut 6487 udp Service Registry Default IIOPAuth Domain [Paul_Sterk] [Paul_Sterk] 2006-03
sun-sr-jmx 6488 tcp Service Registry Default JMX Domain [Paul_Sterk] [Paul_Sterk] 2006-03
sun-sr-jmx 6488 udp Service Registry Default JMX Domain [Paul_Sterk] [Paul_Sterk] 2006-03
sun-sr-admin 6489 tcp Service Registry Default Admin Domain [Paul_Sterk] [Paul_Sterk] 2006-03
sun-sr-admin 6489 udp Service Registry Default Admin Domain [Paul_Sterk] [Paul_Sterk] 2006-03
6490-6499 Unassigned
6504 Unassigned
syslog-tls 6514 tcp Syslog over TLS [RFC 5425]
syslog-tls 6514 udp syslog over DTLS [RFC 6012]
syslog-tls 6514 dccp syslog over DTLS [RFC 6012]
6516-6542 Unassigned
lds-distrib 6543 tcp lds_distrib [Jack_Baker] [Jack_Baker] 2003-06
lds-distrib 6543 udp lds_distrib [Jack_Baker] [Jack_Baker] 2003-06
lds-dump 6544 tcp LDS Dump Service [Jack_Baker] [Jack_Baker] 2006-02
lds-dump 6544 udp LDS Dump Service [Jack_Baker] [Jack_Baker] 2006-02
6545-6546 Unassigned
apc-6547 6547 tcp APC 6547 [American_Power_Conve] [American_Power_Conve]
apc-6547 6547 udp APC 6547 [American_Power_Conve] [American_Power_Conve]
apc-6548 6548 tcp APC 6548 [American_Power_Conve] [American_Power_Conve]
apc-6548 6548 udp APC 6548 [American_Power_Conve] [American_Power_Conve]
apc-6549 6549 tcp APC 6549 [American_Power_Conve] [American_Power_Conve]
apc-6549 6549 udp APC 6549 [American_Power_Conve] [American_Power_Conve]
6584-6587 Unassigned
odette-ftps 6619 tcp ODETTE-FTP over TLS/SSL [Ieuan_Friend] [Ieuan_Friend] 2006-03 [RFC 5024]
odette-ftps 6619 udp ODETTE-FTP over TLS/SSL [Ieuan_Friend] [Ieuan_Friend] 2006-03 [RFC 5024]
datascaler-db 6624 tcp DataScaler database [Vasu_Murthy] [Vasu_Murthy] 2010-02-08
6624 udp Reserved
mpls-pm 6634 udp MPLS Performance Measurement out-of-band response [Cisco_Systems_2] [Sagar_Soni] 2014-02-20
6634 tcp Reserved
ovsdb 6640 tcp Open vSwitch Database protocol [Bruce_Davie_2] [Bruce_Davie_2] 2013-07-31 [RFC 7047]
6640 udp Reserved
6641-6652 Unassigned
6654 Unassigned
6658-6664 Unassigned Unauthorized Use Known on Port 6659
p4p-portal 6671 tcp P4P Portal Service [Chris_Griffiths] [Chris_Griffiths] 2008-07-28
p4p-portal 6671 udp P4P Portal Service [Chris_Griffiths] [Chris_Griffiths] 2008-07-28
6674-6677 Unassigned
ircs-u 6697 tcp Internet Relay Chat via TLS/SSL 2014-02-11 [RFC 7194]
6704 udp Reserved
6704 tcp Reserved
frc-hp 6704 sctp ForCES HP (High Priority) channel [RFC 5811]
ibprotocol 6714 tcp Internet Backplane Protocol [Alessandro_Bassi] [Alessandro_Bassi]
ibprotocol 6714 udp Internet Backplane Protocol [Alessandro_Bassi] [Alessandro_Bassi]
6784 tcp Reserved
bfd-lag 6784 udp Bidirectional Forwarding Detection (BFD) on Link Aggregation Group (LAG) Interfaces [IESG] [BFD_Chairs] 2012-11-08 2014-01-09 [RFC 7130]
6832-6840 Unassigned
netmo-default 6841 tcp Netmo Default [Urs_Bertschinger] [Urs_Bertschinger]
netmo-default 6841 udp Netmo Default [Urs_Bertschinger] [Urs_Bertschinger]
netmo-http 6842 tcp Netmo HTTP [Urs_Bertschinger] [Urs_Bertschinger]
netmo-http 6842 udp Netmo HTTP [Urs_Bertschinger] [Urs_Bertschinger]
6843-6849 Unassigned
split-ping 6924 tcp Ping with RX/TX latency/loss split [Ben_Cartwright_Cox] [Ben_Cartwright_Cox] 2020-02-12
split-ping 6924 udp Ping with RX/TX latency/loss split [Ben_Cartwright_Cox] [Ben_Cartwright_Cox] 2020-02-12
6925-6934 Unassigned
6937-6945 Unassigned
bioserver 6946 tcp Biometrics Server [ISHII_AKIO] [ISHII_AKIO] 2006-01
bioserver 6946 udp Biometrics Server [ISHII_AKIO] [ISHII_AKIO] 2006-01
6947-6950 Unassigned
swismgr2 6964 tcp swismgr2 [Yutaka_Ono] [Yutaka_Ono]
swismgr2 6964 udp swismgr2 [Yutaka_Ono] [Yutaka_Ono]
afs3-kaserver 7004 tcp AFS/Kerberos authentication service
afs3-kaserver 7004 udp AFS/Kerberos authentication service
microtalon-com 7014 tcp Microtalon Communications [Jim_Thompson] [Jim_Thompson]
microtalon-com 7014 udp Microtalon Communications [Jim_Thompson] [Jim_Thompson]
vmsvc 7024 tcp Vormetric service [Tom_Boyle] [Tom_Boyle] 2005-06
vmsvc 7024 udp Vormetric service [Tom_Boyle] [Tom_Boyle] 2005-06
7040 tcp Reserved
quest-disc 7040 udp Quest application level network service discovery [Quest_Software] [Henrik_Johnson] 2012-04-09
7041-7069 Unassigned
7074-7079 Unassigned
7089-7094 Unassigned
snif 7123 tcp SNIF End-to-End TLS Relay Control Connection [VESvault_Corp] [Jim_Zubov] 2021-12-24 2026-07-22 [draft-zubov-snif-05, Section 4.3]
snif 7123 udp SNIF End-to-End TLS Relay over QUIC [VESvault_Corp] [Jim_Zubov] 2026-07-22 2026-07-22 [draft-zubov-snif-05, Section 4.4]
7124-7127 Unassigned
fsr 7164 tcp File System Repository Agent [Micha_Ben_Efraim] [Micha_Ben_Efraim] 2007-07-19
fsr 7164 udp File System Repository Agent [Micha_Ben_Efraim] [Micha_Ben_Efraim] 2007-07-19
metalbend 7172 tcp Port used for MetalBend programmable interface [Micha_Ben_Efraim_4] [Micha_Ben_Efraim_4] 2012-11-27
clutild 7174 tcp Clutild [Cheryl_Stoutenburg] [Cheryl_Stoutenburg]
clutild 7174 udp Clutild [Cheryl_Stoutenburg] [Cheryl_Stoutenburg]
pon-ictp 7202 tcp Inter-Channel Termination Protocol (ICTP) for multi-wavelength PON (Passive Optical Network) systems [Broadband_Forum] [Broadband_Forum] 2017-02-22 2019-12-16 [TR-352][Inter-Channel-Termination protocol (ICTP) is a peer-to-peer protocol with a binary message format that is used by a set of optical line terminal (OLT) channel terminations (CT) comprising a 40-Gigabit-capable next-generation passive optical network (NG-PON2) system to exchange channel profile configuration and status information and to coordinate the operation of tunable optical network units (ONUs) in a multi-wavelength channel environment.]
7203-7214 Unassigned
asa-gateways 7234 tcp Traffic forwarding for Okta cloud infra [Okta_Inc_2] [Sam_Hu] 2020-07-07
7234 udp Reserved
7238-7243 Unassigned
frc-hicp 7244 tcp FrontRow Calypso Human Interface Control Protocol [Frontrow_Calypso_LLC] [Scott_Halberg] 2016-04-19
frc-hicp-disc 7244 udp FrontRow Calypso Human Interface Control Protocol [Frontrow_Calypso_LLC] [Scott_Halberg] 2016-04-19
7245-7261 Unassigned
oma-rlp-s 7274 tcp OMA Roaming Location SEC [Larry_A_Young] [Larry_A_Young] 2005-08
oma-rlp-s 7274 udp OMA Roaming Location SEC [Larry_A_Young] [Larry_A_Young] 2005-08

Contact Information

ID Name Organization Contact URI Last Updated
[Alessandro_Bassi] Alessandro Bassi mailto:abassi&cs.utk.edu
[American_Power_Conve] American Power Conversion mailto:ports&apcc.com 2002-02
[Ben_Cartwright_Cox] Ben Cartwright-Cox mailto:ben&benjojo.co.uk 2020-02-12
[BFD_Chairs] IETF BFD Working Group Chairs mailto:bfd-chairs&tools.ietf.org 2014-01-09
[Broadband_Forum] Broadband Forum mailto:help&broadband-forum.org 2020-03-17
[Bruce_Davie_2] Bruce Davie mailto:bdavie&vmware.com 2013-07-31
[Cheryl_Stoutenburg] Cheryl Stoutenburg mailto:cstoutenburg&vnet.ibm.com
[Chris_Griffiths] Chris Griffiths mailto:chris_griffiths&cable.comcast.com 2008-07-28
[Cisco_Systems_2] Cisco Systems mailto:sagsoni&cisco.com 2014-02-20
[Eric_Sharakan] Eric Sharakan mailto:ldoms-iana-ports&sun.com 2008-02-14
[Frontrow_Calypso_LLC] Frontrow Calypso, LLC mailto:eng&gofrontrow.com 2016-04-13
[Henrik_Johnson] Henrik Johnson Quest Software mailto:henrik.johnson&quest.com 2012-04-09
[IESG] IESG mailto:iesg&ietf.org
[ISHII_AKIO] ISHII AKIO mailto:ishii.akio&jp.fujitsu.com 2006-01
[Ieuan_Friend] Ieuan Friend mailto:ieuan.friend&dip.co.uk 2006-03
[Jack_Baker] Jack Baker mailto:Jack.Baker&l-3com.com 2006-02
[Jim_Thompson] Jim Thompson mailto:jim.thompson&powerware.com
[Jim_Zubov] Jim Zubov VESvault Corp mailto:jz&vesvault.com 2021-12-29
[Larry_A_Young] Larry A. Young mailto:Larry.A.Young&mail.sprint.com 2005-08
[Micha_Ben_Efraim] Micha Ben-Efraim mailto:benmi07&ca.com 2008-01-07
[Micha_Ben_Efraim_4] Micha Ben-Efraim mailto:micha&metalix.net 2012-11-27
[Okta_Inc_2] Okta Inc mailto:asa-tech&okta.com 2020-07-07
[Paul_Sterk] Paul Sterk mailto:paul.sterk&sun.com 2006-03
[Peter_Schow] Peter Schow mailto:Peter.Schow&sun.com 2007-01
[Quest_Software] Quest Software mailto:iana.quest-disc&quest.com 2012-04-09
[Sam_Hu] Sam Hu Okta Inc mailto:sam.hu&okta.com 2020-07-07
[Sagar_Soni] Sagar Soni Cisco Systems mailto:sagsoni&cisco.com 2014-02-20
[Scott_Halberg] Scott Halberg mailto:slh&gofrontrow.com 2016-04-13
[Sumit_Arora] Sumit Arora mailto:sumit.arora&sun.com 2007-06
[Tom_Boyle] Tom Boyle mailto:tboyle&vormetric.com 2005-06
[Urs_Bertschinger] Urs Bertschinger mailto:urs&netmosphere.com
[Vasu_Murthy] Vasu Murthy mailto:vmurthy&datascaler.com 2010-02-08
[VESvault_Corp] VESvault Corp mailto:info&vesvault.com 2021-12-29
[Yutaka_Ono] Yutaka Ono mailto:ono&saint.nm.fujitsu.co.jp