Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 8035-8039 | Unassigned | ||||||||||
| 8045-8050 | Unassigned | ||||||||||
| rocrail | 8051 | tcp | Rocrail Client Service | Rob Versluis | Rob Versluis | 2011-05-23 | |||||
| 8051 | udp | Reserved | |||||||||
| senomix01 | 8052 | tcp | Senomix Timesheets Server | Charles O'Dale | Charles O'Dale | 2006-07 | |||||
| senomix01 | 8052 | udp | Senomix Timesheets Server | Charles O'Dale | Charles O'Dale | 2006-07 | |||||
| senomix02 | 8053 | tcp | Senomix Timesheets Client [1 year assignment] | Charles O'Dale | Charles O'Dale | 2006-07 | |||||
| senomix02 | 8053 | udp | Senomix Timesheets Client [1 year assignment] | Charles O'Dale | Charles O'Dale | 2006-07 | |||||
| senomix03 | 8054 | tcp | Senomix Timesheets Server [1 year assignment] | Charles O'Dale | Charles O'Dale | 2006-07 | |||||
| senomix03 | 8054 | udp | Senomix Timesheets Server [1 year assignment] | Charles O'Dale | Charles O'Dale | 2006-07 | |||||
| senomix04 | 8055 | tcp | Senomix Timesheets Server [1 year assignment] | Charles O'Dale | Charles O'Dale | 2006-07 | |||||
| senomix04 | 8055 | udp | Senomix Timesheets Server [1 year assignment] | Charles O'Dale | Charles O'Dale | 2006-07 | |||||
| senomix05 | 8056 | tcp | Senomix Timesheets Server [1 year assignment] | Charles O'Dale | Charles O'Dale | 2006-07 | |||||
| senomix05 | 8056 | udp | Senomix Timesheets Server [1 year assignment] | Charles O'Dale | Charles O'Dale | 2006-07 | |||||
| senomix06 | 8057 | tcp | Senomix Timesheets Client [1 year assignment] | Charles O'Dale | Charles O'Dale | 2006-07 | |||||
| senomix06 | 8057 | udp | Senomix Timesheets Client [1 year assignment] | Charles O'Dale | Charles O'Dale | 2006-07 | |||||
| senomix07 | 8058 | tcp | Senomix Timesheets Client [1 year assignment] | Charles O'Dale | Charles O'Dale | 2006-07 | |||||
| senomix07 | 8058 | udp | Senomix Timesheets Client [1 year assignment] | Charles O'Dale | Charles O'Dale | 2006-07 | |||||
| senomix08 | 8059 | tcp | Senomix Timesheets Client [1 year assignment] | Charles O'Dale | Charles O'Dale | 2006-07 | |||||
| senomix08 | 8059 | udp | Senomix Timesheets Client [1 year assignment] | Charles O'Dale | Charles O'Dale | 2006-07 | |||||
| 8062-8065 | Unassigned | ||||||||||
| 8075-8076 | Unassigned | ||||||||||
| 8077 | tcp | Reserved | 2024-01-05 | De-Assigned on 2024-01-05. | |||||||
| 8085 | Unassigned | ||||||||||
| mtl8000-matrix | 8115 | tcp | MTL8000 Matrix | David Pinch | David Pinch | 2002-04 | |||||
| mtl8000-matrix | 8115 | udp | MTL8000 Matrix | David Pinch | David Pinch | 2002-04 | |||||
| 8150-8152 | Unassigned | ||||||||||
| quantastor | 8153 | tcp | QuantaStor Management Interface | OS NEXUS, Inc. | Steven Umbehocker | 2012-09-21 | |||||
| 8153 | udp | Reserved | |||||||||
| 8154-8159 | Unassigned | ||||||||||
| 8185-8189 | Unassigned | ||||||||||
| blp2 | 8195 | tcp | Bloomberg feed | Albert Hou | Albert Hou | 2006-05 | |||||
| blp2 | 8195 | udp | Bloomberg feed | Albert Hou | Albert Hou | 2006-05 | |||||
| lm-instmgr | 8205 | tcp | LM Instmgr | Chris Flynn | Chris Flynn | ||||||
| lm-instmgr | 8205 | udp | LM Instmgr | Chris Flynn | Chris Flynn | ||||||
| 8244-8265 | Unassigned | ||||||||||
| 8271-8275 | Unassigned | ||||||||||
| 8295-8299 | Unassigned | ||||||||||
| 8323-8350 | Unassigned | ||||||||||
| server-find | 8351 | tcp | Server Find | Chris Brown | Chris Brown | ||||||
| server-find | 8351 | udp | Server Find | Chris Brown | Chris Brown | ||||||
| 8352-8375 | Unassigned | ||||||||||
| 8385-8399 | Unassigned | ||||||||||
| svbackup | 8405 | tcp | SuperVault Backup | Nine Technology, LLC | Alex Stoev | 2009-09-14 | 2011-08-01 | ||||
| 8405 | udp | Reserved | |||||||||
| dlpx-sp | 8415 | tcp | Delphix Session Protocol | Delphix Corp | Peng Dai | 2012-11-01 | |||||
| 8415 | udp | Reserved | |||||||||
| copy | 8445 | tcp | Port for copy peer sync feature | Copy | Jason Dictos | 2012-09-19 | |||||
| copy-disc | 8445 | udp | Port for copy discovery | Copy | Jason Dictos | 2012-09-19 | |||||
| npmp | 8450 | tcp | npmp | Ian Chard | Ian Chard | ||||||
| npmp | 8450 | udp | npmp | Ian Chard | Ian Chard | ||||||
| 8451-8456 | Unassigned | ||||||||||
| nexentamv | 8457 | tcp | Nexenta Management GUI | John S. Howard | Andrew Galloway | 2012-12-07 | |||||
| 8457 | udp | Reserved | |||||||||
| 8458-8469 | Unassigned | ||||||||||
| pim-port | 8471 | tcp | PIM over Reliable Transport | IESG | IETF Chair | 2008-08-21 | RFC 6559 | ||||
| pim-port | 8471 | sctp | PIM over Reliable Transport | IESG | IETF Chair | 2008-08-21 | RFC 6559 | ||||
| 8475-8499 | Unassigned | ||||||||||
| fmtp | 8500 | tcp | Flight Message Transfer Protocol | Eivan Cerasi | Eivan Cerasi | 2003-12 | |||||
| fmtp | 8500 | udp | Flight Message Transfer Protocol | Eivan Cerasi | Eivan Cerasi | 2003-12 | |||||
| cmtp-mgt | 8501 | tcp | CYTEL Message Transfer Management | ||||||||
| cmtp-av | 8501 | udp | CYTEL Message Transfer Audio and Video | Frank Jäkel | Frank Jäkel | 2011-04-29 | |||||
| ftnmtp | 8502 | tcp | FTN Message Transfer Protocol | Yuri Myakotin | Yuri Myakotin | 2014-01-07 | |||||
| 8502 | udp | Reserved | |||||||||
| lsp-self-ping | 8503 | udp | MPLS LSP Self-Ping | IESG | IETF Chair | 2015-06-11 | 2016-02-01 | RFC 7746 | |||
| 8503 | tcp | Reserved | |||||||||
| 8504-8553 | Unassigned | ||||||||||
| rtsp-alt | 8554 | tcp | RTSP Alternate (see port 554) | Stephen Casner | Stephen Casner | ||||||
| rtsp-alt | 8554 | udp | RTSP Alternate (see port 554) | Stephen Casner | Stephen Casner | ||||||
| d-fence | 8555 | tcp | SYMAX D-FENCE | Thomas Geisel | Thomas Geisel | 2003-01 | |||||
| d-fence | 8555 | udp | SYMAX D-FENCE | Thomas Geisel | Thomas Geisel | 2003-01 | |||||
| 8556-8566 | Unassigned | ||||||||||
| dof-tunnel | 8567 | tcp | DOF Tunneling Protocol | OpenDOF | Bryant Eastham | 2005-08 | 2015-04-23 | ||||
| dof-tunnel | 8567 | udp | DOF Tunneling Protocol | OpenDOF | Bryant Eastham | 2005-08 | 2015-04-23 | ||||
| 8568-8599 | Unassigned | ||||||||||
| imink | 8615 | tcp | Imink Service Control | Canon Inc. | Ken'ichi FUJII | 2011-10-10 | |||||
| 8615 | udp | Reserved | |||||||||
| monetra | 8665 | tcp | Monetra | Main Street Softworks Inc | Brad House | 2013-04-02 | |||||
| 8665 | udp | Reserved | |||||||||
| msi-cps-rm | 8675 | tcp | Motorola Solutions Customer Programming Software for Radio Management | Motorola Solutions, Inc. | Jenish Amin | 2012-03-14 | |||||
| msi-cps-rm-disc | 8675 | udp | Motorola Solutions Customer Programming Software for Radio Management Discovery | Motorola Solutions, Inc. | Jenish Amin | 2012-03-14 | |||||
| 8676-8685 | Unassigned | ||||||||||
| 8699 | udp | Reserved | 2004-11 | 2013-05-24 | This entry is being removed on 2013-05-24. | ||||||
| dey-keyneg | 8750 | tcp | DEY Storage Key Negotiation | DEY Storage Systems, Inc. | Garrett D'Amore | 2013-03-01 | |||||
| 8750 | udp | Reserved | |||||||||
| 8751-8762 | Unassigned | ||||||||||
| ultraseek-http | 8765 | tcp | Ultraseek HTTP | Walter Underwood | Walter Underwood | ||||||
| ultraseek-http | 8765 | udp | Ultraseek HTTP | Walter Underwood | Walter Underwood | ||||||
| 8779-8785 | Unassigned | ||||||||||
| 8805 | tcp | Reserved | |||||||||
| pfcp | 8805 | udp | Destination Port number for PFCP | Kimmo Kymalainen | Kimmo Kymalainen | 2017-05-08 | |||||
| 3gpp-monp | 8809 | udp | MCPTT Off-Network Protocol (MONP) | 3GPP | Dongwook Kim | 2019-04-15 | 2026-01-23 | 3GPP TS 24.379 v13.5.0s | |||
| ddi-tcp-5 | 8892 | tcp | Desktop Data TCP 4: FARM product | Fred Yao | Fred Yao | ||||||
| ddi-udp-5 | 8892 | udp | Desktop Data UDP 4: FARM product | Fred Yao | Fred Yao | ||||||
| ddi-tcp-6 | 8893 | tcp | Desktop Data TCP 5: NewsEDGE/Web application | Fred Yao | Fred Yao | ||||||
| ddi-udp-6 | 8893 | udp | Desktop Data UDP 5: NewsEDGE/Web application | Fred Yao | Fred Yao | ||||||
| 8895-8898 | Unassigned | ||||||||||
| 8938-8952 | Unassigned | ||||||||||
| ub-dns-control | 8953 | tcp | unbound dns nameserver control | NLnet Labs Support | NLnet Labs Support | 2011-05-10 | 2011-07-11 | ||||
| 8953 | udp | Reserved | |||||||||
| cumulus-admin | 8954 | tcp | Cumulus Admin Port | Thomas Schleu | Thomas Schleu |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| 3GPP | dongwook.kim&etsi.org | 2026-01-23 | |
| Albert Hou | ahou1&bloomberg.com | 2006-05 | |
| Alex Stoev | Nine Technology, LLC | astoev&ninetechnology.com | 2011-08-01 |
| Andrew Galloway | Nexenta | andrew.galloway&nexenta.com | 2012-12-07 |
| Brad House | Main Street Softworks Inc | brad&mainstreetsoftworks.com | 2013-04-02 |
| Bryant Eastham | OenDOF | protocol&opendof.org | 2015-04-23 |
| Canon Inc. | fujii.ken-ichi149&canon.co.jp | 2011-10-10 | |
| Charles O'Dale | codale&hfx.andara.com | 2006-07 | |
| Chris Brown | chrisb&chancery.com | ||
| Chris Flynn | cflynn&landmark.com | ||
| Copy | team©.com | 2012-09-19 | |
| David Pinch | dpinch&mtl-inst.com | 2002-04 | |
| Delphix Corp | peng.dai&delphix.com | 2012-11-01 | |
| DEY Storage Systems, Inc. | garrett&dey-sys.com | 2013-03-01 | |
| Dongwook Kim | 3GPP | dongwook.kim&etsi.org | 2026-01-23 |
| Eivan Cerasi | eivan.cerasi&eurocontrol.int | 2022-08-08 | |
| Frank Jäkel | Frank.Jaekel&cytel.de | 2011-04-29 | |
| Fred Yao | Fred_Yao&ddigate2.desktopdata.com | ||
| Garrett D'Amore | DEY Storage Systems, Inc. | garrett&dey-sys.com | 2013-03-01 |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Ian Chard | ian&tanagra.demon.co.uk | ||
| Jason Dictos | jdictos&barracuda.com | 2012-09-19 | |
| Jenish Amin | Motorola Solutions, Inc. | jenish&motorolasolutions.com | 2012-03-14 |
| Ken'ichi FUJII | Canon Inc. | fujii.ken-ichi149&canon.co.jp | 2011-10-10 |
| Kimmo Kymalainen | kimmo.kymalainen&etsi.org | 2017-05-08 | |
| Main Street Softworks Inc | info&mainstreetsoftworks.com | 2013-04-02 | |
| Motorola Solutions, Inc. | jenish&motorolasolutions.com | 2012-03-14 | |
| NLnet Labs Support | NLnet Labs | support&nlnetlabs.nl | 2011-07-11 |
| John S. Howard | Nexenta | jsh&nexenta.com | 2012-12-07 |
| Nine Technology, LLC | astoev&ninetechnology.com | 2011-08-01 | |
| OpenDOF | protocol&opendof.org | 2015-04-23 | |
| OS NEXUS, Inc. | info&osnexus.com | 2012-09-21 | |
| Peng Dai | Delphix Corp | peng.dai&delphix.com | 2012-11-01 |
| Rob Versluis | r.j.versluis&rocrail.net | 2011-05-23 | |
| Stephen Casner | casner&precept.com | ||
| Steven Umbehocker | OS NEXUS, Inc. | steven.umbehocker&osnexus.com | 2012-09-21 |
| Thomas Geisel | tgeisel&symax.de | 2003-01 | |
| Thomas Schleu | tschleu&canto.de | ||
| Walter Underwood | wunder&infoseek.com | ||
| Yuri Myakotin | yuri&ym-com.net | 2014-01-07 |