Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
snmptls 10161 tcp SNMP-TLS RFC 6353
snmpdtls 10161 udp SNMP-DTLS RFC 6353
snmptls-trap 10162 tcp SNMP-Trap-TLS RFC 6353
snmpdtls-trap 10162 udp SNMP-Trap-DTLS RFC 6353
10163-10199 Unassigned
axis-wimp-port 10260 tcp Axis WIMP Port Stefan Eriksson Stefan Eriksson
axis-wimp-port 10260 udp Axis WIMP Port Stefan Eriksson Stefan Eriksson
tile-ml 10261 tcp Tile remote machine learning 1026 Labs Rob Earhart 2016-09-27
10261 udp Reserved
10262-10287 Unassigned
10549-10630 Unassigned
printopia 10631 tcp Printopia Serve Decisive Tactics, Inc. Chris Kent 2011-10-24 2015-04-09
10631 udp Reserved
10632-10799 Unassigned
10806-10808 Unassigned
helix 10860 tcp Helix Client/Server Matthew Strange; Larry Atkin Matthew Strange; Larry Atkin 2009-03-06
helix 10860 udp Helix Client/Server Matthew Strange; Larry Atkin Matthew Strange; Larry Atkin 2009-03-06
10861-10879 Unassigned
11096-11102 Unassigned
sgi-lk 11106 tcp SGI LK Licensing service Michel Bourget Michel Bourget 2009-01-06
sgi-lk 11106 udp SGI LK Licensing service Michel Bourget Michel Bourget 2009-01-06
11113-11160 Unassigned
suncacao-snmp 11161 tcp sun cacao snmp access point Nick Stephen Nick Stephen 2005-08
suncacao-snmp 11161 udp sun cacao snmp access point Nick Stephen Nick Stephen 2005-08
suncacao-jmxmp 11162 tcp sun cacao JMX-remoting access point Nick Stephen Nick Stephen 2005-08
suncacao-jmxmp 11162 udp sun cacao JMX-remoting access point Nick Stephen Nick Stephen 2005-08
suncacao-rmi 11163 tcp sun cacao rmi registry access point Nick Stephen Nick Stephen 2005-08
suncacao-rmi 11163 udp sun cacao rmi registry access point Nick Stephen Nick Stephen 2005-08
suncacao-csa 11164 tcp sun cacao command-streaming access point Nick Stephen Nick Stephen 2005-08
suncacao-csa 11164 udp sun cacao command-streaming access point Nick Stephen Nick Stephen 2005-08
suncacao-websvc 11165 tcp sun cacao web service access point Nick Stephen Nick Stephen 2005-08
suncacao-websvc 11165 udp sun cacao web service access point Nick Stephen Nick Stephen 2005-08
11166-11170 Unassigned
11176-11200 Unassigned
11236-11318 Unassigned
11322-11366 Unassigned
atm-uhas 11367 tcp ATM UHAS Todd Barker Todd Barker
atm-uhas 11367 udp ATM UHAS Todd Barker Todd Barker
11368-11370 Unassigned
tempest-port 11600 tcp Tempest Protocol Port Francis Cianfrocca Francis Cianfrocca
tempest-port 11600 udp Tempest Protocol Port Francis Cianfrocca Francis Cianfrocca
11601-11622 Unassigned
emc-xsw-dconfig 11623 tcp EMC XtremSW distributed config EMC David Erel 2013-09-18
11623 udp Reserved
11624-11719 Unassigned Unauthorized Use Known on port 11711
lanschool 11796 tcp LanSchool Stoneware Inc. Dana Doggett 2012-05-18
lanschool-mpt 11796 udp Lanschool Multipoint Stoneware Inc. Dana Doggett 2012-05-18
xoraya 11876 tcp X2E Xoraya Multichannel protocol Hannes K√§lber Hannes K√§lber 2010-09-13
xoraya 11876 udp X2E Xoraya Multichannel protocol Hannes K√§lber Hannes K√§lber 2010-09-13
11878-11966 Unassigned
sysinfo-sp 11967 tcp SysInfo Service Protocol Mike Cooper Mike Cooper 2003-03
sysinfo-sp 11967 udp SysInfo Service Protocol Mike Cooper Mike Cooper 2003-03
11968-11970 Unassigned
11972-11996 Unassigned
dbisamserver2 12006 tcp DBISAM Database Server - Admin Tim Young Tim Young 2002-05
dbisamserver2 12006 udp DBISAM Database Server - Admin Tim Young Tim Young 2002-05
12122-12167 Unassigned
cawas 12168 tcp CA Web Access Service Jon Press Jon Press 2005-08
cawas 12168 udp CA Web Access Service Jon Press Jon Press 2005-08
12169-12171 Unassigned
12346-12545 Unassigned
carb-repl-ctrl 12546 tcp Carbonite Server Replication Control Open Text Corporation Tony Ponzo 2022-10-07
12546 udp Reserved
12754-12864 Unassigned
netperf 12865 tcp control port for the netperf benchmark netperf.org Rick Jones 2013-04-05
12865 udp Reserved
12866-13159 Unassigned
i-zipqd 13160 tcp I-ZIPQD Chuck Runquist Chuck Runquist
i-zipqd 13160 udp I-ZIPQD Chuck Runquist Chuck Runquist
13161-13215 Unassigned
bcslogc 13216 tcp Black Crow Software application logging Ramindur Singh Ramindur Singh 2008-12-04
bcslogc 13216 udp Black Crow Software application logging Ramindur Singh Ramindur Singh 2008-12-04
nomdb 13786 tcp Veritas-nomdb Clayton Haapala Clayton Haapala 2005-08
nomdb 13786 udp Veritas-nomdb Clayton Haapala Clayton Haapala 2005-08
dsmcc-config 13818 tcp DSMCC Config Tim Addington Tim Addington ISO/IEC 13818-6 MPEG-2 DSM-CC
dsmcc-config 13818 udp DSMCC Config Tim Addington Tim Addington ISO/IEC 13818-6 MPEG-2 DSM-CC
dsmcc-session 13819 tcp DSMCC Session Messages Tim Addington Tim Addington ISO/IEC 13818-6 MPEG-2 DSM-CC
dsmcc-session 13819 udp DSMCC Session Messages Tim Addington Tim Addington ISO/IEC 13818-6 MPEG-2 DSM-CC
dsmcc-passthru 13820 tcp DSMCC Pass-Thru Messages Tim Addington Tim Addington ISO/IEC 13818-6 MPEG-2 DSM-CC
dsmcc-passthru 13820 udp DSMCC Pass-Thru Messages Tim Addington Tim Addington ISO/IEC 13818-6 MPEG-2 DSM-CC
dsmcc-download 13821 tcp DSMCC Download Protocol Tim Addington Tim Addington ISO/IEC 13818-6 MPEG-2 DSM-CC
dsmcc-download 13821 udp DSMCC Download Protocol Tim Addington Tim Addington ISO/IEC 13818-6 MPEG-2 DSM-CC
dsmcc-ccp 13822 tcp DSMCC Channel Change Protocol Tim Addington Tim Addington ISO/IEC 13818-6 MPEG-2 DSM-CC
dsmcc-ccp 13822 udp DSMCC Channel Change Protocol Tim Addington Tim Addington ISO/IEC 13818-6 MPEG-2 DSM-CC
14146-14148 Unassigned
hde-lcesrvr-1 14936 tcp hde-lcesrvr-1 Horizon Digital Enterprise Inc. Horizon Digital Enterprise Inc.
hde-lcesrvr-1 14936 udp hde-lcesrvr-1 Horizon Digital Enterprise Inc. Horizon Digital Enterprise Inc.
15346-15362 Unassigned
3link 15363 tcp 3Link Negotiation Brant Thomsen Brant Thomsen 2003-01
3link 15363 udp 3Link Negotiation Brant Thomsen Brant Thomsen 2003-01
15364-15554 Unassigned
15556-15659 Unassigned
bex-xr 15660 tcp Backup Express Restore Server Catalogic Software, Inc. Chi Shih Chang 2008-03-19 2015-02-04
bex-xr 15660 udp Backup Express Restore Server Catalogic Software, Inc. Chi Shih Chang 2008-03-19 2015-02-04
15661-15739 Unassigned
fmsas 16000 tcp Administration Server Access Mark Davidson Mark Davidson 2010-10-06 Known Unauthorized Use on port 16000
16000 udp Reserved Known Unauthorized Use on port 16000
fmsascon 16001 tcp Administration Server Connector Mark Davidson Mark Davidson 2010-10-06
16001 udp Reserved
gsms 16002 tcp GoodSync Mediation Service Vadim Maslov Vadim Maslov 2010-10-06
16002 udp Reserved

Contact Information

Name Organization Contact URI Last Updated
1026 Labs contact&1026labs.com 2016-09-27
Brant Thomsen brant_thomsen&3com.com 2003-01
Catalogic Software, Inc. cchang&catalogicsoftware.com 2015-02-04
Chi Shih Chang Catalogic Software, Inc. cchang&catalogicsoftware.com 2015-02-04
Chris Kent Decisive Tactics, Inc. ckent&decisivetactics.com 2015-04-09
Chuck Runquist crunquist&quarterdeck.com
Clayton Haapala clay.haapala&veritas.com 2005-08
Dana Doggett Stoneware Inc. dana.doggett&stone-ware.com 2012-05-18
David Erel EMC david.erel&emc.com 2013-09-18
Decisive Tactics, Inc. ckent&decisivetactics.com 2015-04-09
EMC david.erel&emc.com 2013-09-18
Francis Cianfrocca francis&tempest.com
Hannes K√§lber hannes.kaelber&x2e.de 2010-09-13
Horizon Digital Enterprise Inc. info&hde.co.jp
Jon Press IANA.Registions&ca.com 2005-09
Larry Atkin shasta&qsatoolworks.com
Mark Davidson mark_davidson&filemaker.com 2010-10-06
Matthew Strange matt&qsatoolworks.com 2009-03-06
Michel Bourget michel&sgi.com 2009-01-06
Mike Cooper mcooper&magnicomp.com 2003-03
netperf.org netperf-feedback&netperf.org 2013-04-05
Nick Stephen nick.stephen&sun.com 2005-08
Open Text Corporation tponzo&opentext.com 2022-10-07
Ramindur Singh Ramindur.Singh&blackcrowsoftware.com 2008-12-04
Rick Jones perfgeek&mac.com 2013-04-05
Rob Earhart rob&1026labs.com 2016-09-27
Stefan Eriksson contact-iana&axis.com
Stoneware Inc. coby.gurr&stone-ware.com 2012-05-18
Tim Addington Tim.Addington&sciatl.com
Tim Young timyoung&elevatesoft.com 2009-05-06
Todd Barker toddba&attachmate.com
Tony Ponzo Open Text Corporation tponzo&opentext.com 2022-10-07
Vadim Maslov vm&siber.com 2010-10-06