Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| presonus-ucnet | 47809 | udp | PreSonus Universal Control Network Protocol | PreSonus Audio Electronics, Inc | Matthias Juwan | 2013-07-12 | |||||
| 47809 | tcp | Reserved | |||||||||
| 47810-47999 | Unassigned | ||||||||||
| 3gpp-cbsp | 48049 | tcp | 3GPP Cell Broadcast Service Protocol | Gert Thomasen | Gert Thomasen | 2009-12-07 | |||||
| 48049 | udp | Reserved | |||||||||
| blp5 | 48129 | tcp | Bloomberg locator | Albert Hou | Albert Hou | 2006-05 | |||||
| blp5 | 48129 | udp | Bloomberg locator | Albert Hou | Albert Hou | 2006-05 | |||||
| iqobject | 48619 | tcp | iqobject | Bjorn de Bonnenfant | Bjorn de Bonnenfant | 2003-11 | |||||
| iqobject | 48619 | udp | iqobject | Bjorn de Bonnenfant | Bjorn de Bonnenfant | 2003-11 | |||||
| 48654-48999 | Unassigned | ||||||||||
| matahari | 49000 | tcp | Matahari Broker | Matahari Project | Zane Bitter | 2011-08-31 | |||||
| 49000 | udp | Reserved | |||||||||
| nusrp | 49001 | tcp | Nuance Unity Service Request Protocol | Nuance Communications, Inc. | Andrew Andrews | 2017-04-20 | |||||
| nusdp-disc | 49001 | udp | Nuance Unity Service Discovery Protocol | Nuance Communications, Inc. | Andrew Andrews | 2017-04-20 | |||||
| 49002-49149 | Unassigned | ||||||||||
| inspider | 49150 | tcp | InSpider System | AnRobot | Zhang Xinnan | 2017-11-06 | |||||
| 49150 | udp | Reserved | |||||||||
| 49151 | Reserved | 2024-12-20 | RFC 6335 | ||||||||
| mihcs | MIH Command Services | RFC 5679 | |||||||||
| mihes | MIH Event Services | RFC 5679 | |||||||||
| mihis | MIH Information Services | RFC 5679 | |||||||||
| netconf-beep | NETCONF over BEEP | RFC 4744; RFC 9900 | |||||||||
| netconfsoapbeep | NETCONF for SOAP over BEEP | RFC 4743; RFC 9900 | |||||||||
| netconfsoaphttp | NETCONF for SOAP over HTTPS | RFC 4743; RFC 9900 | |||||||||
| brski-proxy | tcp | The Bootstrapping Remote Secure Key Infrastructure Proxy | IESG | IETF Chair | 2020-04-29 | RFC 8995 | Defined TXT keys: None | ||||
| brski-reg-cmp | tcp | Bootstrapping Remote Secure Key Infrastructure registrar with CMP capabilities according to the Lightweight CMP Profile (LCMPP) RFC 9483 | IESG | IETF Chair | 2024-09-23 | RFC 9733 | Defined TXT keys: None | ||||
| brski-registrar | tcp | The Bootstrapping Remote Secure Key Infrastructure Registrar | IESG | IETF Chair | 2020-04-29 | RFC 8995 | Defined TXT keys: None | ||||
| certificates | tcp | Server for S/MIME and PGP certificates | IESG | John Levine | 2016-07-26 | draft-bhjl-x509-srv-01 | Defined TXT keys: None | ||||
| core-rd | tcp | Resource Directory accessed using CoAP over TCP | IESG | IETF Chair | 2021-03-16 | RFC 9176 | Defined TXT keys: None | ||||
| core-rd | udp | Resource Directory accessed using CoAP | IESG | IETF Chair | 2021-03-16 | RFC 9176 | Defined TXT keys: None | ||||
| core-rd-tls | tcp | Resource Directory accessed using CoAP over TLS | IESG | IETF Chair | 2021-03-16 | 2022-04-14 | RFC 9176 | Defined TXT keys: None | |||
| core-rd-dtls | udp | Resource Directory accessed using CoAP over DTLS | IESG | IETF Chair | 2021-03-16 | RFC 9176 | Defined TXT keys: None | ||||
| dccp-ping | dccp | ping/traceroute using DCCP | Samuel Jero | Samuel Jero | 2012-11-14 | 1885957735 | Defined TXT keys: None | ||||
| dnssd-srp | tcp | DNS-Based Service Discovery | IESG | IETF Chair | 2024-04-12 | 2024-09-05 | RFC 9665 | Defined TXT keys: None | |||
| dnssd-srp-tls | tcp | DNS-Based Service Discovery (TLS) | IESG | IETF Chair | 2024-04-12 | 2024-09-05 | RFC 9665 | Defined TXT keys: None | |||
| dots-call-home | tcp | DOTS Signal Channel Call Home Protocol. The service name is used to construct the SRV service names "_dots-call-home._udp" and "_dots-call-home._tcp" for discovering Call Home DOTS clients used to establish DOTS signal channel call home. | IESG | IETF Chair | 2020-11-19 | RFC 8973 | Defined TXT keys: None | ||||
| dots-call-home | udp | DOTS Signal Channel Call Home Protocol. The service name is used to construct the SRV service names "_dots-call-home._udp" and "_dots-call-home._tcp" for discovering Call Home DOTS clients used to establish DOTS signal channel call home. | IESG | IETF Chair | 2020-11-19 | RFC 8973 | Defined TXT keys: None | ||||
| dots-data | tcp | DOTS Data Channel Protocol. The service name is used to construct the SRV service name "_dots-data._tcp" for discovering DOTS servers used to establish DOTS data channel. | IESG | IETF Chair | 2020-11-19 | RFC 8973 | Defined TXT keys: None | ||||
| est-coaps | udp | EST over secure CoAP (EST-coaps) | Toerless Eckert | Toerless Eckert | 2022-05-03 | 2022-05-04 | RFC 9148. Defined TXT keys: None | ||||
| jnx-kcsync | tcp | jollys keychain cloud sync protocol | Patrick Stein | Patrick Stein | 2011-10-24 | Defined TXT keys: hash=<40hex characters> salt=<40hex characters> uuid=<40hex characters> Example: hash=5e7580598c0d7064d4fc79faaeb42585e1a675f8 salt=f0164cb3a0c3d7efe75abea8fda86d2d56c8dda9 uuid=db61dc092922252e45bbb264f59147138c7fd5fa | |||||
| lobby | Gobby | 0x539 dev group | 0x539 dev group | Defined TXT keys: None | |||||||
| msrps | tcp | MSRP protocol over TLS | 2014-04-25 | RFC 4976 | Defined TXT keys: | ||||||
| robustirc | tcp | Like ircu (RFC 1459), but failure tolerant due to strong consistency among n>=3 servers | Michael Stapelberg | Michael Stapelberg | 2015-01-07 | Defined TXT keys: None | |||||
| smimeca | tcp | Domain signing certificate for S/MIME keys | IESG | John Levine | 2016-07-26 | draft-bhjl-x509-srv-01 | Defined TXT keys: None | ||||
| wot | tcp | W3C WoT Thing Description or Directory | W3C Web of Things Working Group | Kazuyuki Ashimura | 2022-11-22 | 2022-12-15 | Defined TXT keys: td: Absolute pathname of the Thing Description of the Thing or Thing Description of the Thing Description Directory. type: Type of the Thing Description, i.e. "Thing" or "Directory". If omitted, the type is assumed to be Thing. scheme: Scheme part of URL. One of the following values can be specified, with the standard registered URI interpretations RFC 7595: http (HTTP over TCP),https (HTTP over TLS/TCP), coap+tcp (CoAP over TCP), or coaps+tcp (CoAP over TLS/TCP). If omitted, the scheme is assumed to be http. |
||||
| wot | udp | W3C WoT Thing Description or Directory | W3C Web of Things Working Group | Kazuyuki Ashimura | 2022-11-22 | 2022-12-15 | Defined TXT keys: td: Absolute pathname of the Thing Description of the Thing or Thing Description of the Thing Description Directory. type: Type of the Thing Description, i.e. "Thing" or "Directory". If omitted, the type is assumed to be Thing. scheme: Scheme part of URL. One of the following values can be specified, with the standard registered URI interpretations RFC 7595: coap (CoAP over UDP), coaps CoAP over DTLS/UDP. If omitted, the scheme is assumed to be coap. |
||||
| x-plane9 | udp | x-plane9 | Austin Meyer | Austin Meyer | Defined TXT keys: None |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Albert Hou | ahou1&bloomberg.com | 2006-05 | |
| Andrew Andrews | Andrew.Andrews&Nuance.com | 2017-04-26 | |
| AnRobot | webmaster&anrobot.org | 2017-11-06 | |
| Austin Meyer | austin&x-plane.com | ||
| Bjorn de Bonnenfant | bdeb&iqobject.com | 2003-11 | |
| Gert Thomasen | gert.thomasen&etsi.org | 2009-12-07 | |
| 0x539 dev group | http://darcs.0x539.de/trac/obby/cgi-bin/trac.cgi | ||
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| John Levine | standards&taugh.com | 2016-07-26 | |
| Kazuyuki Ashimura | ashimura&w3.org | 2022-11-22 | |
| Matahari Project | matahari&lists.fedorahosted.org | 2011-08-31 | |
| Matthias Juwan | PreSonus Audio Electronics, Inc | mjuwan&presonus.com | 2013-07-12 |
| Michael Stapelberg | michael+iana&stapelberg.ch | 2015-01-07 | |
| Nuance Communications, Inc. | Andrew.Andrews&Nuance.com | 2017-04-20 | |
| Patrick Stein | Patrick.Stein&jinx.eu | 2011-10-24 | |
| PreSonus Audio Electronics, Inc | mjuwan&presonus.com | 2013-07-12 | |
| Samuel Jero | sj323707&ohio.edu | 2012-11-14 | |
| Toerless Eckert | tte&cs.fau.de | 2022-05-03 | |
| W3C Web of Things Working Group | team-wot&w3.org | 2022-11-22 | |
| Zane Bitter | zbitter&redhat.com | 2011-08-31 | |
| Zhang Xinnan | 70331471&qq.com | 2017-11-06 |