Service Name and Transport Protocol Port Number Registry
- Last Updated
- 2026-10-09
- Expert(s)
-
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf SCTP: Michael Tuexen DCCP: Eddie Kohler and Yoshifumi Nishida
- Reference
- [RFC 6335]
- Note
-
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP. Service names are assigned on a first-come, first-served process, as documented in [RFC 6335]. Port numbers are assigned in various ways, based on three ranges: System Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private Ports (49152-65535); the different uses of these ranges are described in [RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are assigned by the "IETF Review" or "IESG Approval" procedures described in [RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, the "IESG Approval" process, or the "Expert Review" process, as per [RFC 6335]. Dynamic Ports are not assigned. The registration procedures for service names and port numbers are described in [RFC 6335]. Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration. ************************************************************************ * PLEASE NOTE THE FOLLOWING: * * * * ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN * * ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK * * TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT * * IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE * * ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD * * CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF * * THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER * * REGISTERED OR NOT. * ************************************************************************
- Request an Assignment
-
[https://www.iana.org/protocols/apply]
- Available Formats
-

CSV
XML
HTML
TXT
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| mobileip-agent | 434 | tcp | MobileIP-Agent | ||||||||
| mobileip-agent | 434 | udp | MobileIP-Agent | ||||||||
| mobilip-mn | 435 | tcp | MobilIP-MN | [Kannan_Alagappan_2] | [Kannan_Alagappan_2] | ||||||
| mobilip-mn | 435 | udp | MobilIP-MN | [Kannan_Alagappan_2] | [Kannan_Alagappan_2] | ||||||
| dna-cml | 436 | tcp | DNA-CML | [Dan_Flowers] | [Dan_Flowers] | ||||||
| dna-cml | 436 | udp | DNA-CML | [Dan_Flowers] | [Dan_Flowers] | ||||||
| decvms-sysmgt | 441 | tcp | decvms-sysmgt | [Lee_Barton] | [Lee_Barton] | ||||||
| decvms-sysmgt | 441 | udp | decvms-sysmgt | [Lee_Barton] | [Lee_Barton] | ||||||
| cvc-hostd | 442 | tcp | cvc_hostd IANA assigned this well-formed service name as a replacement for "cvc_hostd". |
[Bill_Davidson] | [Bill_Davidson] | ||||||
| cvc_hostd | 442 | tcp | cvc_hostd | [Bill_Davidson] | [Bill_Davidson] | This entry is an alias to "cvc-hostd". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| cvc-hostd | 442 | udp | cvc_hostd IANA assigned this well-formed service name as a replacement for "cvc_hostd". |
[Bill_Davidson] | [Bill_Davidson] | ||||||
| cvc_hostd | 442 | udp | cvc_hostd | [Bill_Davidson] | [Bill_Davidson] | This entry is an alias to "cvc-hostd". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| microsoft-ds | 445 | tcp | Microsoft-DS | [Pradeep_Bahl] | [Pradeep_Bahl] | ||||||
| microsoft-ds | 445 | udp | Microsoft-DS | [Pradeep_Bahl] | [Pradeep_Bahl] | ||||||
| ddm-rdb | 446 | tcp | DDM-Remote Relational Database Access | ||||||||
| ddm-rdb | 446 | udp | DDM-Remote Relational Database Access | ||||||||
| ddm-dfm | 447 | tcp | DDM-Distributed File Management | [Steven_Ritland] | [Steven_Ritland] | ||||||
| ddm-dfm | 447 | udp | DDM-Distributed File Management | [Steven_Ritland] | [Steven_Ritland] | ||||||
| ddm-ssl | 448 | tcp | DDM-Remote DB Access Using Secure Sockets | [Steven_Ritland] | [Steven_Ritland] | ||||||
| ddm-ssl | 448 | udp | DDM-Remote DB Access Using Secure Sockets | [Steven_Ritland] | [Steven_Ritland] | ||||||
| as-servermap | 449 | tcp | AS Server Mapper | [Barbara_Foss] | [Barbara_Foss] | ||||||
| as-servermap | 449 | udp | AS Server Mapper | [Barbara_Foss] | [Barbara_Foss] | ||||||
| sfs-smp-net | 451 | tcp | Cray Network Semaphore server | ||||||||
| sfs-smp-net | 451 | udp | Cray Network Semaphore server | ||||||||
| sfs-config | 452 | tcp | Cray SFS config server | [Walter_Poxon] | [Walter_Poxon] | ||||||
| sfs-config | 452 | udp | Cray SFS config server | [Walter_Poxon] | [Walter_Poxon] | ||||||
| macon-tcp | 456 | tcp | macon-tcp | [Yoshinobu_Inoue] | [Yoshinobu_Inoue] | ||||||
| macon-udp | 456 | udp | macon-udp | [Yoshinobu_Inoue] | [Yoshinobu_Inoue] | ||||||
| ampr-rcmd | 459 | tcp | ampr-rcmd | [Rob_Janssen] | [Rob_Janssen] | ||||||
| ampr-rcmd | 459 | udp | ampr-rcmd | [Rob_Janssen] | [Rob_Janssen] | ||||||
| digital-vrc | 466 | tcp | digital-vrc | [Peter_Higginson] | [Peter_Higginson] | ||||||
| digital-vrc | 466 | udp | digital-vrc | [Peter_Higginson] | [Peter_Higginson] | ||||||
| mylex-mapd | 467 | tcp | mylex-mapd | [Gary_Lewis] | [Gary_Lewis] | ||||||
| mylex-mapd | 467 | udp | mylex-mapd | [Gary_Lewis] | [Gary_Lewis] | ||||||
| scx-proxy | 470 | tcp | scx-proxy | [Scott_Narveson] | [Scott_Narveson] | ||||||
| scx-proxy | 470 | udp | scx-proxy | [Scott_Narveson] | [Scott_Narveson] | ||||||
| ljk-login | 472 | tcp | ljk-login | [LJK] | [LJK] | ||||||
| ljk-login | 472 | udp | ljk-login | [LJK] | [LJK] | ||||||
| hybrid-pop | 473 | tcp | hybrid-pop | [Rami_Rubin] | [Rami_Rubin] | ||||||
| hybrid-pop | 473 | udp | hybrid-pop | [Rami_Rubin] | [Rami_Rubin] | ||||||
| tn-tl-w1 | 474 | tcp | tn-tl-w1 | ||||||||
| tn-tl-w2 | 474 | udp | tn-tl-w2 | [Ed_Kress] | [Ed_Kress] | ||||||
| tn-tl-fd1 | 476 | tcp | tn-tl-fd1 | [Ed_Kress] | [Ed_Kress] | ||||||
| tn-tl-fd1 | 476 | udp | tn-tl-fd1 | [Ed_Kress] | [Ed_Kress] | ||||||
| bgs-nsi | 482 | tcp | bgs-nsi | [Jon_Saperia] | [Jon_Saperia] | ||||||
| bgs-nsi | 482 | udp | bgs-nsi | [Jon_Saperia] | [Jon_Saperia] | ||||||
| integra-sme | 484 | tcp | Integra Software Management Environment | [Randall_Dow] | [Randall_Dow] | ||||||
| integra-sme | 484 | udp | Integra Software Management Environment | [Randall_Dow] | [Randall_Dow] | ||||||
| gss-http | 488 | tcp | gss-http | [Doug_Rosenthal] | [Doug_Rosenthal] | ||||||
| gss-http | 488 | udp | gss-http | [Doug_Rosenthal] | [Doug_Rosenthal] | ||||||
| nest-protocol | 489 | tcp | nest-protocol | [Gilles_Gameiro] | [Gilles_Gameiro] | ||||||
| nest-protocol | 489 | udp | nest-protocol | [Gilles_Gameiro] | [Gilles_Gameiro] | ||||||
| micom-pfs | 490 | tcp | micom-pfs | [David_Misunas] | [David_Misunas] | ||||||
| micom-pfs | 490 | udp | micom-pfs | [David_Misunas] | [David_Misunas] | ||||||
| go-login | 491 | tcp | go-login | [Troy_Morrison] | [Troy_Morrison] | ||||||
| go-login | 491 | udp | go-login | [Troy_Morrison] | [Troy_Morrison] | ||||||
| ticf-1 | 492 | tcp | Transport Independent Convergence for FNA | ||||||||
| ticf-1 | 492 | udp | Transport Independent Convergence for FNA | ||||||||
| ticf-2 | 493 | tcp | Transport Independent Convergence for FNA | [Mamoru_Ito] | [Mamoru_Ito] | ||||||
| ticf-2 | 493 | udp | Transport Independent Convergence for FNA | [Mamoru_Ito] | [Mamoru_Ito] | ||||||
| pov-ray | 494 | tcp | POV-Ray | [POV_Team_Co_ordinato] | [POV_Team_Co_ordinato] | ||||||
| pov-ray | 494 | udp | POV-Ray | [POV_Team_Co_ordinato] | [POV_Team_Co_ordinato] | ||||||
| pim-rp-disc | 496 | tcp | PIM-RP-DISC | [Dino_Farinacci] | [Dino_Farinacci] | ||||||
| pim-rp-disc | 496 | udp | PIM-RP-DISC | [Dino_Farinacci] | [Dino_Farinacci] | ||||||
| iso-ill | 499 | tcp | ISO ILL Protocol | [Mark_H_Needleman] | [Mark_H_Needleman] | ||||||
| iso-ill | 499 | udp | ISO ILL Protocol | [Mark_H_Needleman] | [Mark_H_Needleman] | ||||||
| mailbox-lm | 505 | tcp | mailbox-lm | [Beverly_Moody] | [Beverly_Moody] | ||||||
| mailbox-lm | 505 | udp | mailbox-lm | [Beverly_Moody] | [Beverly_Moody] | ||||||
| talk | 517 | tcp | like tenex link, but across machine - unfortunately, doesn't use link protocol (this is actually just a rendezvous port from which a tcp connection is established) | ||||||||
| talk | 517 | udp | like tenex link, but across machine - unfortunately, doesn't use link protocol (this is actually just a rendezvous port from which a tcp connection is established) | ||||||||
| router | 520 | udp | local routing process (on site); uses variant of Xerox NS routing information protocol - RIP | ||||||||
| ibm-db2 | 523 | tcp | IBM-DB2 | [Juliana_Hsu] | [Juliana_Hsu] | ||||||
| ibm-db2 | 523 | udp | IBM-DB2 | [Juliana_Hsu] | [Juliana_Hsu] | ||||||
| irc-serv | 529 | tcp | IRC-SERV | [Brian_Tackett] | [Brian_Tackett] | ||||||
| irc-serv | 529 | udp | IRC-SERV | [Brian_Tackett] | [Brian_Tackett] | ||||||
| opalis-rdv | 536 | tcp | opalis-rdv | [Laurent_Domenech] | [Laurent_Domenech] | ||||||
| opalis-rdv | 536 | udp | opalis-rdv | [Laurent_Domenech] | [Laurent_Domenech] | ||||||
| apertus-ldp | 539 | tcp | Apertus Technologies Load Determination | ||||||||
| apertus-ldp | 539 | udp | Apertus Technologies Load Determination | ||||||||
| uucp-rlogin | 541 | tcp | uucp-rlogin | [Stuart_Lynne] | [Stuart_Lynne] | ||||||
| uucp-rlogin | 541 | udp | uucp-rlogin | [Stuart_Lynne] | [Stuart_Lynne] | ||||||
| dhcpv6-client | 546 | tcp | DHCPv6 Client | ||||||||
| dhcpv6-client | 546 | udp | DHCPv6 Client | [IESG] | [IETF_Chair] | 2018-05-21 | [RFC 9915] | ||||
| dhcpv6-server | 547 | tcp | DHCPv6 Server | [IESG] | [IETF_Chair] | 2018-05-21 | [RFC 5460] | ||||
| dhcpv6-server | 547 | udp | DHCPv6 Server | [IESG] | [IETF_Chair] | 2018-05-21 | [RFC 9915] | ||||
| new-rwho | 550 | tcp | new-who | [n/a] | |||||||
| new-rwho | 550 | udp | new-who | [n/a] | |||||||
| devshr-nts | 552 | tcp | DeviceShare | [Benjamin_Rosenberg] | [Benjamin_Rosenberg] | ||||||
| devshr-nts | 552 | udp | DeviceShare | [Benjamin_Rosenberg] | [Benjamin_Rosenberg] | ||||||
| openvms-sysipc | 557 | tcp | openvms-sysipc | [Alan_Potter] | [Alan_Potter] | ||||||
| openvms-sysipc | 557 | udp | openvms-sysipc | [Alan_Potter] | [Alan_Potter] | ||||||
| banyan-rpc | 567 | tcp | banyan-rpc | [Tom_Lemaire] | [Tom_Lemaire] | ||||||
| banyan-rpc | 567 | udp | banyan-rpc | [Tom_Lemaire] | [Tom_Lemaire] | ||||||
| ms-shuttle | 568 | tcp | microsoft shuttle | [Rudolph_Balaz] | [Rudolph_Balaz] | ||||||
| ms-shuttle | 568 | udp | microsoft shuttle | [Rudolph_Balaz] | [Rudolph_Balaz] | ||||||
| ms-rome | 569 | tcp | microsoft rome | [Rudolph_Balaz] | [Rudolph_Balaz] | ||||||
| ms-rome | 569 | udp | microsoft rome | [Rudolph_Balaz] | [Rudolph_Balaz] | ||||||
| banyan-vip | 573 | tcp | banyan-vip | [Denis_Leclerc] | [Denis_Leclerc] | ||||||
| banyan-vip | 573 | udp | banyan-vip | [Denis_Leclerc] | [Denis_Leclerc] | ||||||
| ftp-agent | 574 | tcp | FTP Software Agent System | [Michael_S_Greenberg] | [Michael_S_Greenberg] | ||||||
| ftp-agent | 574 | udp | FTP Software Agent System | [Michael_S_Greenberg] | [Michael_S_Greenberg] |