Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
bhmds 310 tcp bhmds John Kelly John Kelly
bhmds 310 udp bhmds John Kelly John Kelly
asip-webadmin 311 tcp AppleShare IP WebAdmin Ann Huang Ann Huang
asip-webadmin 311 udp AppleShare IP WebAdmin Ann Huang Ann Huang
vslmp 312 tcp VSLMP Gerben Wierda Gerben Wierda
vslmp 312 udp VSLMP Gerben Wierda Gerben Wierda
magenta-logic 313 tcp Magenta Logic Karl Rousseau Karl Rousseau
magenta-logic 313 udp Magenta Logic Karl Rousseau Karl Rousseau
opalis-robot 314 tcp Opalis Robot Laurent Domenech Laurent Domenech
opalis-robot 314 udp Opalis Robot Laurent Domenech Laurent Domenech
dpsi 315 tcp DPSI Tony Scamurra Tony Scamurra
dpsi 315 udp DPSI Tony Scamurra Tony Scamurra
decauth 316 tcp decAuth Michael Agishtein Michael Agishtein
decauth 316 udp decAuth Michael Agishtein Michael Agishtein
zannet 317 tcp Zannet Zan Oliphant Zan Oliphant
zannet 317 udp Zannet Zan Oliphant Zan Oliphant
pkix-timestamp 318 tcp PKIX TimeStamp Robert Zuccherato Robert Zuccherato
pkix-timestamp 318 udp PKIX TimeStamp Robert Zuccherato Robert Zuccherato
ptp-event 319 tcp PTP Event Kang Lee Kang Lee 2010-07-27
ptp-event 319 udp PTP Event Kang Lee Kang Lee 2010-07-27
pip 321 tcp PIP Gordon Mohr Gordon Mohr
pip 321 udp PIP Gordon Mohr Gordon Mohr
rpki-rtr 323 tcp Resource PKI to Router Protocol IESG IETF Chair RFC 6810
rpki-rtr-tls 324 tcp Resource PKI to Router Protocol over TLS IESG IETF Chair RFC 6810
matip-type-a 350 tcp MATIP Type A Alain Robert Alain Robert RFC 2351
matip-type-a 350 udp MATIP Type A Alain Robert Alain Robert RFC 2351
matip-type-b 351 tcp MATIP Type B Alain Robert Alain Robert RFC 2351
matip-type-b 351 udp MATIP Type B Alain Robert Alain Robert RFC 2351
bhoetty 351 tcp bhoetty John Kelly John Kelly This entry records an unassigned but widespread use (added 5/21/97)
bhoetty 351 udp bhoetty John Kelly John Kelly This entry records an unassigned but widespread use (added 5/21/97)
bhoedap4 352 tcp bhoedap4 John Kelly John Kelly This entry records an unassigned but widespread use (added 5/21/97)
bhoedap4 352 udp bhoedap4 John Kelly John Kelly This entry records an unassigned but widespread use (added 5/21/97)
bh611 354 tcp bh611 John Kelly John Kelly
bh611 354 udp bh611 John Kelly John Kelly
cloanto-net-1 356 tcp Cloanto Net 1 Michael Battilana Michael Battilana 2010-04-30
cloanto-net-1 356 udp Cloanto Net 1 Michael Battilana Michael Battilana 2010-04-30
359 tcp Reserved 2023-11-16 De-Assigned on 2023-11-16.
359 udp Reserved 2023-11-16 De-Assigned on 2023-11-16.
semantix 361 tcp Semantix Semantix Semantix
semantix 361 udp Semantix Semantix Semantix
clearcase 371 tcp Clearcase Dave LeBlang Dave LeBlang
clearcase 371 udp Clearcase Dave LeBlang Dave LeBlang
legent-1 373 tcp Legent Corporation
legent-1 373 udp Legent Corporation
hp-collector 381 tcp hp performance data collector
hp-collector 381 udp hp performance data collector
synotics-relay 391 tcp SynOptics SNMP Relay Port
synotics-relay 391 udp SynOptics SNMP Relay Port
ups 401 tcp Uninterruptible Power Supply Charles Bennett Charles Bennett 2008-08-29
ups 401 udp Uninterruptible Power Supply Charles Bennett Charles Bennett 2008-08-29
decladebug 410 tcp DECLadebug Remote Debug Protocol Hewlett Packard Hewlett Packard
decladebug 410 udp DECLadebug Remote Debug Protocol Hewlett Packard Hewlett Packard
rmt 411 tcp Remote MT Protocol Peter Eriksson Peter Eriksson
rmt 411 udp Remote MT Protocol Peter Eriksson Peter Eriksson
synoptics-trap 412 tcp Trap Convention Port Illan Raab Illan Raab
synoptics-trap 412 udp Trap Convention Port Illan Raab Illan Raab
smsp 413 tcp Storage Management Services Protocol Murthy Srinivas Murthy Srinivas
smsp 413 udp Storage Management Services Protocol Murthy Srinivas Murthy Srinivas
infoseek 414 tcp InfoSeek Steve Kirsch Steve Kirsch
infoseek 414 udp InfoSeek Steve Kirsch Steve Kirsch
bnet 415 tcp BNet Jim Mertz Jim Mertz
bnet 415 udp BNet Jim Mertz Jim Mertz
silverplatter 416 tcp Silverplatter Peter Ciuffetti Peter Ciuffetti
silverplatter 416 udp Silverplatter Peter Ciuffetti Peter Ciuffetti
onmux 417 tcp Onmux Stephen Hanna Stephen Hanna
onmux 417 udp Onmux Stephen Hanna Stephen Hanna
hyper-g 418 tcp Hyper-G Frank Kappe Frank Kappe
hyper-g 418 udp Hyper-G Frank Kappe Frank Kappe
ariel1 419 tcp Ariel 1 Joel Karafin Joel Karafin
ariel1 419 udp Ariel 1 Joel Karafin Joel Karafin
ariel2 421 tcp Ariel 2
ariel2 421 udp Ariel 2
utmpcd 431 tcp UTMPCD
utmpcd 431 udp UTMPCD
decvms-sysmgt 441 tcp decvms-sysmgt Lee Barton Lee Barton
decvms-sysmgt 441 udp decvms-sysmgt Lee Barton Lee Barton
https 443 tcp http protocol over TLS/SSL IESG IETF Chair 2021-10-01 RFC 9110
https 443 udp http protocol over TLS/SSL IESG IETF Chair 2021-10-01 RFC 9110
snpp 444 tcp Simple Network Paging Protocol RFC 1568
snpp 444 udp Simple Network Paging Protocol RFC 1568
sfs-smp-net 451 tcp Cray Network Semaphore server
sfs-smp-net 451 udp Cray Network Semaphore server
datasurfsrv 461 tcp DataRampSrv
datasurfsrv 461 udp DataRampSrv
submissions 465 tcp Message Submission over TLS protocol IESG IETF Chair 2017-12-12 RFC 8314
mondex 471 tcp Mondex Bill Reding Bill Reding
mondex 471 udp Mondex Bill Reding Bill Reding
tn-tl-w1 474 tcp tn-tl-w1
tn-tl-fd1 476 tcp tn-tl-fd1 Ed Kress Ed Kress
tn-tl-fd1 476 udp tn-tl-fd1 Ed Kress Ed Kress
ph 481 tcp Ph service Roland Hedberg Roland Hedberg
ph 481 udp Ph service Roland Hedberg Roland Hedberg
go-login 491 tcp go-login Troy Morrison Troy Morrison
go-login 491 udp go-login Troy Morrison Troy Morrison
ticf-1 492 tcp Transport Independent Convergence for FNA
ticf-1 492 udp Transport Independent Convergence for FNA
stmf 501 tcp STMF Alan Ungar Alan Ungar
stmf 501 udp STMF Alan Ungar Alan Ungar
fcp 510 tcp FirstClass Protocol Mike Marshburn Mike Marshburn
fcp 510 udp FirstClass Protocol Mike Marshburn Mike Marshburn
passgo 511 tcp PassGo John Rainford John Rainford

Contact Information

Name Organization Contact URI Last Updated
Alain Robert arobert&par.sita.int
Alan Ungar aungar&farradyne.com
Ann Huang annhuang&apple.com
Bill Reding redingb&nwdt.natwest.co.uk
Charles Bennett bennettc&ohio.edu 2008-08-29
Dave LeBlang leglang&atria.com
Ed Kress eskress&thinknet.com
Frank Kappe fkappe&iicm.tu-graz.ac.at
Gerben Wierda Gerben_Wierda&rna.nl
Gordon Mohr gojomo&usa.net
Hewlett Packard
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Illan Raab iraab&synoptics.com
Jim Mertz JMertz+RV09&rvdc.unisys.com
Joel Karafin jkarafin&infotrieve.com
John Kelly johnk&bellhow.com
John Rainford jrainford&passgo.com
Kang Lee I&M Society TC-9 kang.lee&nist.gov 2010-07-27
Karl Rousseau kr&netfusion.co.uk
Laurent Domenech Opalis ldomenech&opalis.com
Lee Barton barton&star.enet.dec.com
Michael Agishtein misha&unx.dec.com
Michael Battilana mcb-iana&cloanto.net 2010-04-30
Mike Marshburn paul&softarc.com
Murthy Srinivas murthy&novell.com
Peter Ciuffetti petec&silverplatter.com
Peter Eriksson pen&lysator.liu.se
Robert Zuccherato robert.zuccherato&entrust.com
Roland Hedberg Roland.Hedberg&umdac.umu.se
Semantix xsSupport&semantix.com
Stephen Hanna hanna&world.std.com
Steve Kirsch stk&infoseek.com
Tony Scamurra Tony&desktoppaging.com
Troy Morrison troy&graphon.com
Zan Oliphant zan&accessone.com