Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-27
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| noaaport | 2210 | udp | NOAAPORT Broadcast Network | ||||||||
| sdclient | 2310 | tcp | SD Client | Jeurgen Broesamle | Jeurgen Broesamle | ||||||
| sdclient | 2310 | udp | SD Client | Jeurgen Broesamle | Jeurgen Broesamle | ||||||
| iec-104 | 2404 | tcp | IEC 60870-5-104 process control over IP | Walter K. Eichelburg | Walter K. Eichelburg | ||||||
| iec-104 | 2404 | udp | IEC 60870-5-104 process control over IP | Walter K. Eichelburg | Walter K. Eichelburg | ||||||
| vrts-registry | 2410 | tcp | VRTS Registry | Pranay Varma | Pranay Varma | ||||||
| vrts-registry | 2410 | udp | VRTS Registry | Pranay Varma | Pranay Varma | ||||||
| fjappmgrbulk | 2510 | tcp | fjappmgrbulk | Hiroyuki Kawabuchi | Hiroyuki Kawabuchi | ||||||
| fjappmgrbulk | 2510 | udp | fjappmgrbulk | Hiroyuki Kawabuchi | Hiroyuki Kawabuchi | ||||||
| vcnet-link-v10 | 2554 | tcp | VCnet-Link v10 | Csaba Mate | Csaba Mate | ||||||
| vcnet-link-v10 | 2554 | udp | VCnet-Link v10 | Csaba Mate | Csaba Mate | ||||||
| versa-tek | 2610 | tcp | VersaTek | James Kou | James Kou | ||||||
| versa-tek | 2610 | udp | VersaTek | James Kou | James Kou | ||||||
| sso-service | 2710 | tcp | SSO Service | ||||||||
| sso-service | 2710 | udp | SSO Service | ||||||||
| netsteward | 2810 | tcp | Active Net Steward | Keith Morley | Keith Morley | ||||||
| netsteward | 2810 | udp | Active Net Steward | Keith Morley | Keith Morley | ||||||
| tdaccess | 2910 | tcp | TDAccess | Tom Haapanen | Tom Haapanen | ||||||
| tdaccess | 2910 | udp | TDAccess | Tom Haapanen | Tom Haapanen | ||||||
| gw | 3010 | tcp | Telerate Workstation | ||||||||
| ping-pong | 3010 | udp | Telerate Workstation | Timo Sivonen | Timo Sivonen | ||||||
| opcon-xps | 3100 | tcp | OpCon/xps | David Bourland | David Bourland | ||||||
| opcon-xps | 3100 | udp | OpCon/xps | David Bourland | David Bourland | ||||||
| hp-pxpib | 3101 | tcp | HP PolicyXpert PIB Server | Brian O'Keefe | Brian O'Keefe | ||||||
| hp-pxpib | 3101 | udp | HP PolicyXpert PIB Server | Brian O'Keefe | Brian O'Keefe | ||||||
| slslavemon | 3102 | tcp | SoftlinK Slave Mon Port | Moshe Livne | Moshe Livne | ||||||
| slslavemon | 3102 | udp | SoftlinK Slave Mon Port | Moshe Livne | Moshe Livne | ||||||
| autocuesmi | 3103 | tcp | Autocue SMI Protocol | ||||||||
| autocuesmi | 3103 | udp | Autocue SMI Protocol | ||||||||
| autocuelog | 3104 | tcp | Autocue Logger Protocol | ||||||||
| autocuetime | 3104 | udp | Autocue Time Service | Geoff Back | Geoff Back | ||||||
| cardbox | 3105 | tcp | Cardbox | ||||||||
| cardbox | 3105 | udp | Cardbox | ||||||||
| cardbox-http | 3106 | tcp | Cardbox HTTP | Martin Kochanski | Martin Kochanski | ||||||
| cardbox-http | 3106 | udp | Cardbox HTTP | Martin Kochanski | Martin Kochanski | ||||||
| business | 3107 | tcp | Business protocol | ||||||||
| business | 3107 | udp | Business protocol | ||||||||
| geolocate | 3108 | tcp | Geolocate protocol | ||||||||
| geolocate | 3108 | udp | Geolocate protocol | ||||||||
| personnel | 3109 | tcp | Personnel protocol | William Randolph Royere III | William Randolph Royere III | ||||||
| personnel | 3109 | udp | Personnel protocol | William Randolph Royere III | William Randolph Royere III | ||||||
| sim-control | 3110 | tcp | simulator control port | Ian Bell | Ian Bell | ||||||
| sim-control | 3110 | udp | simulator control port | Ian Bell | Ian Bell | ||||||
| flamenco-proxy | 3210 | tcp | Flamenco Networks Proxy | Corey Corrick | Corey Corrick | ||||||
| flamenco-proxy | 3210 | udp | Flamenco Networks Proxy | Corey Corrick | Corey Corrick | ||||||
| dyna-access | 3310 | tcp | Dyna Access | Dave Belliveau | Dave Belliveau | ||||||
| dyna-access | 3310 | udp | Dyna Access | Dave Belliveau | Dave Belliveau | ||||||
| networklenss | 3410 | tcp | NetworkLens SSL Event | Greg Bailey | Greg Bailey | 2002-02 | |||||
| networklenss | 3410 | udp | NetworkLens SSL Event | Greg Bailey | Greg Bailey | 2002-02 | |||||
| xss-port | 3510 | tcp | XSS Port | Joe Purcell | Joe Purcell | 2002-05 | |||||
| xss-port | 3510 | udp | XSS Port | Joe Purcell | Joe Purcell | 2002-05 | |||||
| echonet | 3610 | tcp | ECHONET | Takeshi Saito | Takeshi Saito | 2002-09 | |||||
| echonet | 3610 | udp | ECHONET | Takeshi Saito | Takeshi Saito | 2002-09 | |||||
| portgate-auth | 3710 | tcp | PortGate Authentication | Scott Harris | Scott Harris | 2003-02 | |||||
| portgate-auth | 3710 | udp | PortGate Authentication | Scott Harris | Scott Harris | 2003-02 | |||||
| wlanauth | 3810 | tcp | WLAN AS server | Bianling Zhang | Bianling Zhang | 2004-02 | |||||
| wlanauth | 3810 | udp | WLAN AS server | Bianling Zhang | Bianling Zhang | 2004-02 | |||||
| prnrequest | 3910 | tcp | Printer Request Port | Brett Green | Brett Green | 2003-11 | |||||
| prnrequest | 3910 | udp | Printer Request Port | Brett Green | Brett Green | 2003-11 | |||||
| samsung-unidex | 4010 | tcp | Samsung Unidex | Konstantin V. Vyaznikov | Konstantin V. Vyaznikov | ||||||
| samsung-unidex | 4010 | udp | Samsung Unidex | Konstantin V. Vyaznikov | Konstantin V. Vyaznikov | ||||||
| igo-incognito | 4100 | tcp | IGo Incognito Data Port | Paul Reddy | Paul Reddy | 2002-02 | |||||
| igo-incognito | 4100 | udp | IGo Incognito Data Port | Paul Reddy | Paul Reddy | 2002-02 | |||||
| brlp-0 | 4101 | tcp | Braille protocol | ||||||||
| brlp-0 | 4101 | udp | Braille protocol | ||||||||
| brlp-1 | 4102 | tcp | Braille protocol | ||||||||
| brlp-1 | 4102 | udp | Braille protocol | ||||||||
| brlp-2 | 4103 | tcp | Braille protocol | ||||||||
| brlp-2 | 4103 | udp | Braille protocol | ||||||||
| brlp-3 | 4104 | tcp | Braille protocol | Sébastien Hinderer | Sébastien Hinderer | 2006-03 | |||||
| brlp-3 | 4104 | udp | Braille protocol | Sébastien Hinderer | Sébastien Hinderer | 2006-03 | |||||
| shofar | 4105 | tcp | Shofar | ShofarNexus.com | John Kozlowski | 2006-07 | 2012-02-20 | ||||
| shofar | 4105 | udp | Shofar | ShofarNexus.com | John Kozlowski | 2006-07 | 2012-02-20 | ||||
| synchronite | 4106 | tcp | Synchronite | James Figgins | James Figgins | 2006-07 | |||||
| synchronite | 4106 | udp | Synchronite | James Figgins | James Figgins | 2006-07 | |||||
| j-ac | 4107 | tcp | JDL Accounting LAN Service | Takashi Sahara | Takashi Sahara | 2006-09 | |||||
| j-ac | 4107 | udp | JDL Accounting LAN Service | Takashi Sahara | Takashi Sahara | 2006-09 | |||||
| accel | 4108 | tcp | ACCEL | Masahiro Koiwai | Masahiro Koiwai | 2006-10 | |||||
| accel | 4108 | udp | ACCEL | Masahiro Koiwai | Masahiro Koiwai | 2006-10 | |||||
| izm | 4109 | tcp | Instantiated Zero-control Messaging | David Miller | David Miller | 2007-02 | |||||
| izm | 4109 | udp | Instantiated Zero-control Messaging | David Miller | David Miller | 2007-02 | |||||
| g2tag | 4110 | tcp | G2 RFID Tag Telemetry Data | David Goodall | David Goodall | 2007-02 | |||||
| g2tag | 4110 | udp | G2 RFID Tag Telemetry Data | David Goodall | David Goodall | 2007-02 | |||||
| agslb | 4149 | tcp | A10 GSLB Service | John Chiong | John Chiong | 2007-07-02 | |||||
| agslb | 4149 | udp | A10 GSLB Service | John Chiong | John Chiong | 2007-07-02 | |||||
| mirrtex | 4310 | tcp | Mir-RT exchange service | Sylvain Robert | Sylvain Robert | 2008-02-14 | |||||
| mirrtex | 4310 | udp | Mir-RT exchange service | Sylvain Robert | Sylvain Robert | 2008-02-14 | |||||
| l2c-control | 4371 | tcp | LAN2CAN Control | Phil Tolson | Phil Tolson | 2008-07-07 | Modified: 21 January 2010 | ||||
| l2c-data | 4372 | tcp | LAN2CAN Data | Phil Tolson | Phil Tolson | 2008-07-07 | Modified: 21 January 2010 | ||||
| itwo-server | 4410 | tcp | RIB iTWO Application Server | Kristean Heisler | Kristean Heisler | 2009-12-16 | |||||
| 4410 | udp | Reserved | |||||||||
| rsip | 4555 | tcp | RSIP Port | RFC 3103 | |||||||
| rsip | 4555 | udp | RSIP Port | RFC 3103 | |||||||
| 4705-4710 | Unassigned | ||||||||||
| telelpathstart | 5010 | tcp | TelepathStart | Helmuth Breitenfellner | Helmuth Breitenfellner | ||||||
| telelpathstart | 5010 | udp | TelepathStart | Helmuth Breitenfellner | Helmuth Breitenfellner | ||||||
| 5030 | tcp | Reserved | 2006-12 | 2022-01-10 | Historic usage was surfpass. De-Assigned on 2022-01-10 | ||||||
| 5030 | udp | Reserved | 2006-12 | 2022-01-10 | Historic usage was surfpass. De-Assigned on 2022-01-10 | ||||||
| socalia | 5100 | tcp | Socalia service mux | Alberto Raydan | Alberto Raydan | 2005-08 | |||||
| socalia | 5100 | udp | Socalia service mux | Alberto Raydan | Alberto Raydan | 2005-08 | |||||
| talarian-tcp | 5101 | tcp | Talarian_TCP | Leo Martins | Leo Martins |