Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-22
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| gtp-control | 2123 | udp | GTP-Control Plane (3GPP) | Alessio Casati | Alessio Casati | ||||||
| elatelink | 2124 | tcp | ELATELINK | Tim Lawrence | Tim Lawrence | ||||||
| elatelink | 2124 | udp | ELATELINK | Tim Lawrence | Tim Lawrence | ||||||
| lockstep | 2125 | tcp | LOCKSTEP | Karl Forster | Karl Forster | ||||||
| lockstep | 2125 | udp | LOCKSTEP | Karl Forster | Karl Forster | ||||||
| pktcable-cops | 2126 | tcp | PktCable-COPS | Glenn Russell | Glenn Russell | ||||||
| pktcable-cops | 2126 | udp | PktCable-COPS | Glenn Russell | Glenn Russell | ||||||
| index-pc-wb | 2127 | tcp | INDEX-PC-WB | James David Fisher | James David Fisher | ||||||
| index-pc-wb | 2127 | udp | INDEX-PC-WB | James David Fisher | James David Fisher | ||||||
| net-steward | 2128 | tcp | Net Steward Control | Martin Norman | Martin Norman | ||||||
| net-steward | 2128 | udp | Net Steward Control | Martin Norman | Martin Norman | ||||||
| cs-live | 2129 | tcp | cs-live.com | Matt Lachance | Matt Lachance | ||||||
| cs-live | 2129 | udp | cs-live.com | Matt Lachance | Matt Lachance | ||||||
| leecoposserver | 2212 | tcp | LeeCO POS Server Service | Patrick Lee | Patrick Lee | 2008-03-10 | |||||
| leecoposserver | 2212 | udp | LeeCO POS Server Service | Patrick Lee | Patrick Lee | 2008-03-10 | |||||
| wanscaler | 2312 | tcp | WANScaler Communication Service | Allen Samuels | Allen Samuels | 2006-11 | |||||
| wanscaler | 2312 | udp | WANScaler Communication Service | Allen Samuels | Allen Samuels | 2006-11 | |||||
| 2408 | udp | Reserved | 2012-03-09 | This entry is being removed on 2012-03-09. | |||||||
| cdn | 2412 | tcp | CDN | Alan Noble | Alan Noble | ||||||
| cdn | 2412 | udp | CDN | Alan Noble | Alan Noble | ||||||
| citrixima | 2512 | tcp | Citrix IMA | ||||||||
| citrixima | 2512 | udp | Citrix IMA | ||||||||
| qpasa-agent | 2612 | tcp | Qpasa Agent | Craig Ching | Craig Ching | ||||||
| qpasa-agent | 2612 | udp | Qpasa Agent | Craig Ching | Craig Ching | ||||||
| aocp | 2712 | tcp | Axapta Object Communication Protocol | Jakob Steen Hansen | Jakob Steen Hansen | ||||||
| aocp | 2712 | udp | Axapta Object Communication Protocol | Jakob Steen Hansen | Jakob Steen Hansen | ||||||
| atmtcp | 2812 | tcp | atmtcp | Werner Almesberger | Werner Almesberger | ||||||
| atmtcp | 2812 | udp | atmtcp | Werner Almesberger | Werner Almesberger | ||||||
| epicon | 2912 | tcp | Epicon | Michael Khalandovsky | Michael Khalandovsky | ||||||
| epicon | 2912 | udp | Epicon | Michael Khalandovsky | Michael Khalandovsky | ||||||
| 2925 | Unassigned (FRP-Released 12/7/00) | ||||||||||
| twsdss | 3012 | tcp | Trusted Web Client | Alex Duncan | Alex Duncan | ||||||
| twsdss | 3012 | udp | Trusted Web Client | Alex Duncan | Alex Duncan | ||||||
| ksysguard | 3112 | tcp | KDE System Guard | Chris Schlaeger | Chris Schlaeger | ||||||
| ksysguard | 3112 | udp | KDE System Guard | Chris Schlaeger | Chris Schlaeger | ||||||
| d2000webserver | 3120 | tcp | D2000 Webserver Port | Tomas Rajcan | Tomas Rajcan | ||||||
| d2000webserver | 3120 | udp | D2000 Webserver Port | Tomas Rajcan | Tomas Rajcan | ||||||
| pcmk-remote | 3121 | tcp | The pacemaker remote (pcmk-remote) service extends high availability functionality outside of the Linux cluster into remote nodes. | David Vossel | Andrew Beekhof | 2013-03-15 | port 3121 previously noted "Removed on 2003-09-17" | ||||
| 3121 | udp | Reserved | 2013-03-15 | port 3121 previously noted "Removed on 2003-09-17" | |||||||
| vtr-emulator | 3122 | tcp | MTI VTR Emulator port | John Mertus | John Mertus | ||||||
| vtr-emulator | 3122 | udp | MTI VTR Emulator port | John Mertus | John Mertus | ||||||
| edix | 3123 | tcp | EDI Translation Protocol | William Randolph Royere III | William Randolph Royere III | ||||||
| edix | 3123 | udp | EDI Translation Protocol | William Randolph Royere III | William Randolph Royere III | ||||||
| beacon-port | 3124 | tcp | Beacon Port | James Paul Duncan | James Paul Duncan | ||||||
| beacon-port | 3124 | udp | Beacon Port | James Paul Duncan | James Paul Duncan | ||||||
| a13-an | 3125 | tcp | A13-AN Interface | Douglas Knisely | Douglas Knisely | ||||||
| a13-an | 3125 | udp | A13-AN Interface | Douglas Knisely | Douglas Knisely | ||||||
| 3126 | Unassigned | 2007-10-04 | |||||||||
| ctx-bridge | 3127 | tcp | CTX Bridge Port | Alexander Dubrovsky | Alexander Dubrovsky | ||||||
| ctx-bridge | 3127 | udp | CTX Bridge Port | Alexander Dubrovsky | Alexander Dubrovsky | ||||||
| ndl-aas | 3128 | tcp | Active API Server Port | Martin Norman | Martin Norman | ||||||
| ndl-aas | 3128 | udp | Active API Server Port | Martin Norman | Martin Norman | ||||||
| netport-id | 3129 | tcp | NetPort Discovery Port | P.T.K. Farrar | P.T.K. Farrar | ||||||
| netport-id | 3129 | udp | NetPort Discovery Port | P.T.K. Farrar | P.T.K. Farrar | ||||||
| surveyinst | 3212 | tcp | Survey Instrument | Al Amet | Al Amet | ||||||
| surveyinst | 3212 | udp | Survey Instrument | Al Amet | Al Amet | ||||||
| appman-server | 3312 | tcp | Application Management Server | ||||||||
| appman-server | 3312 | udp | Application Management Server | ||||||||
| xmlblaster | 3412 | tcp | xmlBlaster | Marcel Ruff | Marcel Ruff | 2002-02 | |||||
| xmlblaster | 3412 | udp | xmlBlaster | Marcel Ruff | Marcel Ruff | 2002-02 | |||||
| aztec | 3512 | tcp | Aztec Distribution Port | Alan Francis | Alan Francis | 2002-05 | |||||
| aztec | 3512 | udp | Aztec Distribution Port | Alan Francis | Alan Francis | 2002-05 | |||||
| dataprotector | 3612 | tcp | Micro Focus Data Protector | Micro Focus | Shishir Misra | 2002-09 | 2019-09-30 | ||||
| dataprotector | 3612 | udp | Micro Focus Data Protector | Micro Focus | Shishir Misra | 2002-09 | 2019-09-30 | ||||
| sentinel-ent | 3712 | tcp | Sentinel Enterprise | Ian Gordon | Ian Gordon | 2003-03 | |||||
| sentinel-ent | 3712 | udp | Sentinel Enterprise | Ian Gordon | Ian Gordon | 2003-03 | |||||
| neto-wol-server | 3812 | tcp | netO WOL Server | Martin Bestmann | Martin Bestmann | 2004-03 | |||||
| neto-wol-server | 3812 | udp | netO WOL Server | Martin Bestmann | Martin Bestmann | 2004-03 | |||||
| gbmt-stars | 3912 | tcp | Global Maintech Stars | Harry Goldschmitt | Harry Goldschmitt | 2003-11 | |||||
| gbmt-stars | 3912 | udp | Global Maintech Stars | Harry Goldschmitt | Harry Goldschmitt | 2003-11 | |||||
| 3980 | tcp | Reserved | 2006-06 | 2020-12-29 | Historic usage was acms. De-Assigned on 2020-12-29 | ||||||
| pda-gate | 4012 | tcp | PDA Gate | Masakuni Okada | Masakuni Okada | ||||||
| pda-gate | 4012 | udp | PDA Gate | Masakuni Okada | Masakuni Okada | ||||||
| apple-vpns-rp | 4112 | tcp | Apple VPN Server Reporting Protocol | Christophe Allie | Christophe Allie | 2006-08 | |||||
| apple-vpns-rp | 4112 | udp | Apple VPN Server Reporting Protocol | Christophe Allie | Christophe Allie | 2006-08 | |||||
| minirem | 4120 | tcp | MiniRem Remote Telemetry and Control | MobilePro Systems | Sean Solberg | 2017-09-28 | |||||
| 4120 | udp | Reserved | |||||||||
| e-builder | 4121 | tcp | e-Builder Application Communication | James Caza | James Caza | 2006-12 | |||||
| e-builder | 4121 | udp | e-Builder Application Communication | James Caza | James Caza | 2006-12 | |||||
| fprams | 4122 | tcp | Fiber Patrol Alarm Service | Zhizhong Zhuang | Zhizhong Zhuang | 2006-12 | |||||
| fprams | 4122 | udp | Fiber Patrol Alarm Service | Zhizhong Zhuang | Zhizhong Zhuang | 2006-12 | |||||
| z-wave | 4123 | tcp | Z-Wave Protocol | Sigma Designs, Inc. | Anders Brandt; Mary Miller | 2007-02 | 2012-11-08 | ||||
| z-wave | 4123 | udp | Z-Wave Protocol | Sigma Designs, Inc. | Anders Brandt; Mary Miller | 2007-02 | 2012-11-08 | ||||
| tigv2 | 4124 | tcp | Rohill TetraNode Ip Gateway v2 | Bert Bouwers | Bert Bouwers | 2007-05 | |||||
| tigv2 | 4124 | udp | Rohill TetraNode Ip Gateway v2 | Bert Bouwers | Bert Bouwers | 2007-05 | |||||
| opsview-envoy | 4125 | tcp | Opsview Envoy | Ton Voon | Ton Voon | 2008-09-26 | |||||
| opsview-envoy | 4125 | udp | Opsview Envoy | Ton Voon | Ton Voon | 2008-09-26 | |||||
| ddrepl | 4126 | tcp | Data Domain Replication Service | Pratik Wadher | Pratik Wadher | 2007-05 | |||||
| ddrepl | 4126 | udp | Data Domain Replication Service | Pratik Wadher | Pratik Wadher | 2007-05 | |||||
| unikeypro | 4127 | tcp | NetUniKeyServer | Raymond Chaw | Raymond Chaw | 2007-05 | |||||
| unikeypro | 4127 | udp | NetUniKeyServer | Raymond Chaw | Raymond Chaw | 2007-05 | |||||
| nufw | 4128 | tcp | NuFW decision delegation protocol | ||||||||
| nufw | 4128 | udp | NuFW decision delegation protocol | ||||||||
| nuauth | 4129 | tcp | NuFW authentication protocol | Eric Leblond | Eric Leblond | 2007-06 | |||||
| nuauth | 4129 | udp | NuFW authentication protocol | Eric Leblond | Eric Leblond | 2007-06 | |||||
| pscl-mgt | 4312 | tcp | Parascale Membership Manager | John Muth | John Muth | 2010-01-21 | |||||
| 4312 | udp | Reserved | |||||||||
| 4324 | Reserved | 2015-05-12 | This entry is being removed on 2015-05-12. | ||||||||
| 4412 | tcp | Reserved | |||||||||
| smallchat | 4412 | udp | SmallChat | Valentino_Giudice | Valentino_Giudice | 2015-08-18 | |||||
| dtn-bundle | 4556 | udp | DTN Bundle UDP CL Protocol | 2006-11 | 2014-02-21 | RFC 7122 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Al Amet | aamet&point-inc.com | ||
| Alan Francis | AlanF&zonal.co.uk | 2002-05 | |
| Alan Noble | noble&netmind.com | ||
| Alessio Casati | a.casati&computer.org | ||
| Alex Duncan | alex.duncan&sse.ie | ||
| Alexander Dubrovsky | dubrovsky_alex&emc.com | ||
| Allen Samuels | allen.samuels&citrix.com | 2006-11 | |
| Anders Brandt | Sigma Designs, Inc. | Anders_Brandt&sigmadesigns.com | 2012-11-08 |
| Andrew Beekhof | andrew&beekhof.net | 2013-03-15 | |
| Bert Bouwers | e.bouwers&rohill.nl | 2007-05 | |
| Chris Schlaeger | cs&kde.org | ||
| Christophe Allie | callie&apple.com | 2006-08 | |
| Craig Ching | cching&mqsoftware.com | ||
| David Vossel | dvossel&redhat.com | 2013-03-15 | |
| Douglas Knisely | dnk&lucent.com | ||
| Eric Leblond | eric&inl.fr | 2007-06 | |
| Glenn Russell | grussell&cablelabs.com | ||
| Harry Goldschmitt | hgoldschmitt&hgac.com | 2003-11 | |
| Ian Gordon | ian&n-genltd.co.uk | 2003-03 | |
| Jakob Steen Hansen | jsh&dk.damgaard.com | ||
| James Caza | jcaza&e-builder.net | 2006-12 | |
| James David Fisher | jfisher1&avaya.com | ||
| James Paul Duncan | pduncan&beaconcrm.com | ||
| John Mertus | mertus&mathtech.com | ||
| John Muth | muth¶scale.com | 2010-01-21 | |
| Karl Forster | kforster&lockstep.com | ||
| Marcel Ruff | mr&marcelruff.info | 2002-02 | |
| Martin Bestmann | martin&no.netopia.com | 2004-03 | |
| Martin Norman | martin&ndl.co.uk | ||
| Mary Miller | Sigma Designs, Inc. | Mary_Miller&sigmadesigns.com | 2012-11-08 |
| Masakuni Okada | masakuni&jp.ibm.com | ||
| Matt Lachance | matt&cs-live.com | ||
| Michael Khalandovsky | mlk&epicon.com | ||
| Micro Focus | swpdl.dp.rdµfocus.com | 2019-09-30 | |
| MobilePro Systems | info&mobileprosystems.com | 2017-09-28 | |
| P.T.K. Farrar | farrarp&teccon.co.uk | ||
| Patrick Lee | leecotechnologies&comcast.net | 2008-03-10 | |
| Pratik Wadher | pratik&datadomain.com | 2007-05 | |
| Raymond Chaw | Raymond&esecutech.com | 2007-05 | |
| Sean Solberg | sean.solberg&mobileprosystems.com | 2017-09-28 | |
| Shishir Misra | shishir.misraµfocus.com | 2019-09-30 | |
| Sigma Designs, Inc. | pr&sdesigns.com | 2012-11-08 | |
| Tim Lawrence | lawrence&tao-group.com | ||
| Tomas Rajcan | trajcan&ipesoft.sk | ||
| Ton Voon | ton.voon&opsera.com | 2008-09-26 | |
| valentino.giudice&vallauri.edu | 2015-08-18 | ||
| Werner Almesberger | Werner.Almesberger&epfl.ch | ||
| William Randolph Royere III | william&royere.net | ||
| Zhizhong Zhuang | ZZhuang&optellios.com | 2006-12 |