Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-09
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER REGISTERED OR NOT.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| elm-momentum | 1914 | tcp | Elm-Momentum | Willie Wu | Willie Wu | ||||||
| elm-momentum | 1914 | udp | Elm-Momentum | Willie Wu | Willie Wu | ||||||
| troff | 2014 | tcp | |||||||||
| raid-sf | 2014 | udp | |||||||||
| radsec | 2083 | tcp | Secure Radius Service | IESG | IETF Chair | 2005-05 | RFC 6614 | The TCP port 2083 was already previously assigned by IANA for "RadSec", an early implementation of RADIUS/TLS, prior to issuance of this RFC. This early implementation can be configured to be compatible to RADIUS/TLS as specified by the IETF. See RFC 6614, Appendix A for details. | |||
| ariascribe | 2114 | tcp | Classical Music Meta-Data Access and Enhancement | Aria Scribe Software Ltd | Michael Levy | 2018-02-05 | |||||
| ariascribe | 2114 | udp | Classical Music Meta-Data Access and Enhancement | Aria Scribe Software Ltd | Michael Levy | 2018-02-05 | |||||
| ias-reg | 2140 | tcp | IAS-REG | ||||||||
| ias-reg | 2140 | udp | IAS-REG | ||||||||
| ias-admind | 2141 | tcp | IAS-ADMIND | Baiju V. Patel | Baiju V. Patel | ||||||
| ias-admind | 2141 | udp | IAS-ADMIND | Baiju V. Patel | Baiju V. Patel | ||||||
| tdmoip | 2142 | tcp | TDM OVER IP | Yaakov Stein | Yaakov Stein | 2016-09-21 | RFC 5087 | ||||
| tdmoip | 2142 | udp | TDM OVER IP | Yaakov Stein | Yaakov Stein | 2016-09-21 | RFC 5087 | ||||
| lv-jc | 2143 | tcp | Live Vault Job Control | ||||||||
| lv-jc | 2143 | udp | Live Vault Job Control | ||||||||
| lv-ffx | 2144 | tcp | Live Vault Fast Object Transfer | ||||||||
| lv-ffx | 2144 | udp | Live Vault Fast Object Transfer | ||||||||
| lv-pici | 2145 | tcp | Live Vault Remote Diagnostic Console Support | ||||||||
| lv-pici | 2145 | udp | Live Vault Remote Diagnostic Console Support | ||||||||
| lv-not | 2146 | tcp | Live Vault Admin Event Notification | ||||||||
| lv-not | 2146 | udp | Live Vault Admin Event Notification | ||||||||
| lv-auth | 2147 | tcp | Live Vault Authentication | Ted Hess | Ted Hess | ||||||
| lv-auth | 2147 | udp | Live Vault Authentication | Ted Hess | Ted Hess | ||||||
| veritas-ucl | 2148 | tcp | VERITAS UNIVERSAL COMMUNICATION LAYER | Songlin Ren | Songlin Ren | ||||||
| veritas-ucl | 2148 | udp | VERITAS UNIVERSAL COMMUNICATION LAYER | Songlin Ren | Songlin Ren | ||||||
| acptsys | 2149 | tcp | ACPTSYS | Michael Lekias | Michael Lekias | ||||||
| acptsys | 2149 | udp | ACPTSYS | Michael Lekias | Michael Lekias | ||||||
| rpi | 2214 | tcp | RDQ Protocol Interface | Les Mather | Les Mather | 2005-12 | |||||
| rpi | 2214 | udp | RDQ Protocol Interface | Les Mather | Les Mather | 2005-12 | |||||
| cr-websystems | 2314 | tcp | CR WebSystems | Robin Giese | Robin Giese | ||||||
| cr-websystems | 2314 | udp | CR WebSystems | Robin Giese | Robin Giese | ||||||
| beeyond | 2414 | tcp | Beeyond | Bob Deblier | Bob Deblier | ||||||
| beeyond | 2414 | udp | Beeyond | Bob Deblier | Bob Deblier | ||||||
| facsys-ntp | 2514 | tcp | Facsys NTP | ||||||||
| facsys-ntp | 2514 | udp | Facsys NTP | ||||||||
| neveroffline | 2614 | tcp | Never Offline | Dustin Brand | Dustin Brand | ||||||
| neveroffline | 2614 | udp | Never Offline | Dustin Brand | Dustin Brand | ||||||
| raventdm | 2714 | tcp | Raven Trinity Data Mover | Daniel Sorlov | Daniel Sorlov | ||||||
| raventdm | 2714 | udp | Raven Trinity Data Mover | Daniel Sorlov | Daniel Sorlov | ||||||
| llm-csv | 2814 | tcp | llm-csv | Loftware | Glen Sansoucie | 2020-07-20 | |||||
| llm-csv | 2814 | udp | llm-csv | Loftware | Glen Sansoucie | 2020-07-20 | |||||
| gamelobby | 2914 | tcp | Game Lobby | Paul Ford-Hutchinson | Paul Ford-Hutchinson | ||||||
| gamelobby | 2914 | udp | Game Lobby | Paul Ford-Hutchinson | Paul Ford-Hutchinson | ||||||
| broker-service | 3014 | tcp | Broker Service IANA assigned this well-formed service name as a replacement for "broker_service". |
Dale Bethers | Dale Bethers | ||||||
| broker_service | 3014 | tcp | Broker Service | Dale Bethers | Dale Bethers | This entry is an alias to "broker-service". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| broker-service | 3014 | udp | Broker Service IANA assigned this well-formed service name as a replacement for "broker_service". |
Dale Bethers | Dale Bethers | ||||||
| broker_service | 3014 | udp | Broker Service | Dale Bethers | Dale Bethers | This entry is an alias to "broker-service". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| ccmad | 3114 | tcp | CCM AutoDiscover | Ram Sudama | Ram Sudama | ||||||
| ccmad | 3114 | udp | CCM AutoDiscover | Ram Sudama | Ram Sudama | ||||||
| ariliamulti | 3140 | tcp | Arilia Multiplexor | Stephane Bourque | Stephane Bourque | ||||||
| ariliamulti | 3140 | udp | Arilia Multiplexor | Stephane Bourque | Stephane Bourque | ||||||
| vmodem | 3141 | tcp | VMODEM | Ray Gwinn | Ray Gwinn | ||||||
| vmodem | 3141 | udp | VMODEM | Ray Gwinn | Ray Gwinn | ||||||
| rdc-wh-eos | 3142 | tcp | RDC WH EOS | Udi Nir | Udi Nir | ||||||
| rdc-wh-eos | 3142 | udp | RDC WH EOS | Udi Nir | Udi Nir | ||||||
| seaview | 3143 | tcp | Sea View | Jim Flaherty | Jim Flaherty | ||||||
| seaview | 3143 | udp | Sea View | Jim Flaherty | Jim Flaherty | ||||||
| tarantella | 3144 | tcp | Tarantella | Roger Binns | Roger Binns | ||||||
| tarantella | 3144 | udp | Tarantella | Roger Binns | Roger Binns | ||||||
| csi-lfap | 3145 | tcp | CSI-LFAP | Paul Amsden | Paul Amsden | Known UNAUTHORIZED USE: port 3145 | |||||
| csi-lfap | 3145 | udp | CSI-LFAP | Paul Amsden | Paul Amsden | Known UNAUTHORIZED USE: port 3145 | |||||
| bears-02 | 3146 | tcp | bears-02 | Bruce McKinnon | Bruce McKinnon | ||||||
| bears-02 | 3146 | udp | bears-02 | Bruce McKinnon | Bruce McKinnon | ||||||
| rfio | 3147 | tcp | RFIO | Frederic Hemmer | Frederic Hemmer | ||||||
| rfio | 3147 | udp | RFIO | Frederic Hemmer | Frederic Hemmer | ||||||
| nm-game-admin | 3148 | tcp | NetMike Game Administrator | ||||||||
| nm-game-admin | 3148 | udp | NetMike Game Administrator | ||||||||
| nm-game-server | 3149 | tcp | NetMike Game Server | ||||||||
| nm-game-server | 3149 | udp | NetMike Game Server | ||||||||
| jmq-daemon-1 | 3214 | tcp | JMQ Daemon Port 1 | ||||||||
| jmq-daemon-1 | 3214 | udp | JMQ Daemon Port 1 | ||||||||
| iscsi-target | 3260 | tcp | iSCSI port | IESG | IETF Chair | 2013-08-27 | RFC 7143 | ||||
| iscsi-target | 3260 | udp | iSCSI port | IESG | IETF Chair | 2013-08-27 | RFC 7143 | ||||
| uohost | 3314 | tcp | Unify Object Host | Daegis, Inc. | Chris Anderson | 2012-07-31 | |||||
| uohost | 3314 | udp | Unify Object Host | Daegis, Inc. | Chris Anderson | 2012-07-31 | |||||
| wip-port | 3414 | tcp | BroadCloud WIP Port | ||||||||
| wip-port | 3414 | udp | BroadCloud WIP Port | ||||||||
| must-p2p | 3514 | tcp | MUST Peer to Peer | ||||||||
| must-p2p | 3514 | udp | MUST Peer to Peer | ||||||||
| a14 | 3597 | tcp | A14 (AN-to-SC/MM) | ||||||||
| a14 | 3597 | udp | A14 (AN-to-SC/MM) | ||||||||
| sigma-port | 3614 | tcp | Satchwell Sigma | Dave Chapman | Dave Chapman | 2011-06-06 | |||||
| sigma-port | 3614 | udp | Satchwell Sigma | Dave Chapman | Dave Chapman | 2011-06-06 | |||||
| delos-dms | 3714 | tcp | DELOS Direct Messaging | Ekkehard Morgenstern | Ekkehard Morgenstern | 2003-03 | |||||
| delos-dms | 3714 | udp | DELOS Direct Messaging | Ekkehard Morgenstern | Ekkehard Morgenstern | 2003-03 | |||||
| neto-dcs | 3814 | tcp | netO DCS | Martin Bestmann | Martin Bestmann | 2004-03 | |||||
| neto-dcs | 3814 | udp | netO DCS | Martin Bestmann | Martin Bestmann | 2004-03 | |||||
| listcrt-port-2 | 3914 | tcp | ListCREATOR Port 2 | Tomokazu Asai | Tomokazu Asai | 2003-11 | |||||
| listcrt-port-2 | 3914 | udp | ListCREATOR Port 2 | Tomokazu Asai | Tomokazu Asai | 2003-11 | |||||
| taiclock | 4014 | tcp | TAICLOCK | D. J. Bernstein | D. J. Bernstein | 2018-04-05 | |||||
| taiclock | 4014 | udp | TAICLOCK | D. J. Bernstein | D. J. Bernstein | 2018-04-05 | |||||
| jomamqmonitor | 4114 | tcp | JomaMQMonitor | Marcel Hofstetter | Marcel Hofstetter | 2003-01 | |||||
| jomamqmonitor | 4114 | udp | JomaMQMonitor | Marcel Hofstetter | Marcel Hofstetter | 2003-01 | |||||
| cedros-fds | 4140 | tcp | Cedros Fraud Detection System IANA assigned this well-formed service name as a replacement for "cedros_fds". |
Markus Michels | Markus Michels | 2006-10 | |||||
| cedros_fds | 4140 | tcp | Cedros Fraud Detection System | Markus Michels | Markus Michels | 2006-10 | This entry is an alias to "cedros-fds". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| cedros-fds | 4140 | udp | Cedros Fraud Detection System IANA assigned this well-formed service name as a replacement for "cedros_fds". |
Markus Michels | Markus Michels | 2006-10 | |||||
| cedros_fds | 4140 | udp | Cedros Fraud Detection System | Markus Michels | Markus Michels | 2006-10 | This entry is an alias to "cedros-fds". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| oirtgsvc | 4141 | tcp | Workflow Server | ||||||||
| oirtgsvc | 4141 | udp | Workflow Server | ||||||||
| oidocsvc | 4142 | tcp | Document Server | ||||||||
| oidocsvc | 4142 | udp | Document Server |