Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
raw-serial 2167 tcp Raw Async Serial Link Benjamin Green Benjamin Green
raw-serial 2167 udp Raw Async Serial Link Benjamin Green Benjamin Green
easy-soft-mux 2168 tcp easy-soft Multiplexer Norbert Kintzler Norbert Kintzler 2004-11
easy-soft-mux 2168 udp easy-soft Multiplexer Norbert Kintzler Norbert Kintzler 2004-11
brain 2169 tcp Backbone for Academic Information Notification (BRAIN) Archishmat Gore Archishmat Gore 2004-11
brain 2169 udp Backbone for Academic Information Notification (BRAIN) Archishmat Gore Archishmat Gore 2004-11
vtu-comms 2216 tcp VTU data service David Barrass David Barrass 2006-01
vtu-comms 2216 udp VTU data service David Barrass David Barrass 2006-01
sent-lm 2316 tcp SENT License Manager Pisharath Krishnan Pisharath Krishnan
sent-lm 2316 udp SENT License Manager Pisharath Krishnan Pisharath Krishnan
rmtserver 2416 tcp RMT Server Yvon Marineau Yvon Marineau
rmtserver 2416 udp RMT Server Yvon Marineau Yvon Marineau
maincontrol 2516 tcp Main Control Nathan Sadia Nathan Sadia
maincontrol 2516 udp Main Control Nathan Sadia Nathan Sadia
appswitch-emp 2616 tcp appswitch-emp Ted Ross Ted Ross
appswitch-emp 2616 udp appswitch-emp Ted Ross Ted Ross
gbjd816 2626 tcp gbjd816 George Balesta George Balesta
gbjd816 2626 udp gbjd816 George Balesta George Balesta
inova-ip-disco 2716 tcp Inova IP Disco Chris Koeritz Chris Koeritz
inova-ip-disco 2716 udp Inova IP Disco Chris Koeritz Chris Koeritz
lbc-watchdog 2816 tcp LBC Watchdog Akiyoshi Ochi Akiyoshi Ochi
lbc-watchdog 2816 udp LBC Watchdog Akiyoshi Ochi Akiyoshi Ochi
elvin-server 2916 tcp Elvin Server

IANA assigned this well-formed service name as a replacement for "elvin_server".
elvin_server 2916 tcp Elvin Server This entry is an alias to "elvin-server". This entry is now historic, not usable for use with many common service discovery mechanisms.
elvin-server 2916 udp Elvin Server

IANA assigned this well-formed service name as a replacement for "elvin_server".
elvin_server 2916 udp Elvin Server This entry is an alias to "elvin-server". This entry is now historic, not usable for use with many common service discovery mechanisms.
notify-srvr 3016 tcp Notify Server

IANA assigned this well-formed service name as a replacement for "notify_srvr".
Hugo Parra Hugo Parra
notify_srvr 3016 tcp Notify Server Hugo Parra Hugo Parra This entry is an alias to "notify-srvr". This entry is now historic, not usable for use with many common service discovery mechanisms.
notify-srvr 3016 udp Notify Server

IANA assigned this well-formed service name as a replacement for "notify_srvr".
Hugo Parra Hugo Parra
notify_srvr 3016 udp Notify Server Hugo Parra Hugo Parra This entry is an alias to "notify-srvr". This entry is now historic, not usable for use with many common service discovery mechanisms.
mctet-gateway 3116 tcp MCTET Gateway
mctet-gateway 3116 udp MCTET Gateway
tip-app-server 3160 tcp TIP Application Server Integral Software Olivier Mascia 2023-11-07
tip-app-server 3160 udp TIP Application Server Integral Software Olivier Mascia 2023-11-07
doc1lm 3161 tcp DOC1 License Manager Greg Goodson Greg Goodson
doc1lm 3161 udp DOC1 License Manager Greg Goodson Greg Goodson
sflm 3162 tcp SFLM System Administrator System Administrator
sflm 3162 udp SFLM System Administrator System Administrator
res-sap 3163 tcp RES-SAP Bob Janssen Bob Janssen
res-sap 3163 udp RES-SAP Bob Janssen Bob Janssen
imprs 3164 tcp IMPRS Lars Bohn Lars Bohn
imprs 3164 udp IMPRS Lars Bohn Lars Bohn
newgenpay 3165 tcp Newgenpay Engine Service Ilan Zisser Ilan Zisser
newgenpay 3165 udp Newgenpay Engine Service Ilan Zisser Ilan Zisser
sossecollector 3166 tcp Quest Spotlight Out-Of-Process Collector Greg Cottman Greg Cottman 2008-10-23
sossecollector 3166 udp Quest Spotlight Out-Of-Process Collector Greg Cottman Greg Cottman 2008-10-23
nowcontact 3167 tcp Now Contact Public Server
nowcontact 3167 udp Now Contact Public Server
poweronnud 3168 tcp Now Up-to-Date Public Server John Wallace John Wallace
poweronnud 3168 udp Now Up-to-Date Public Server John Wallace John Wallace
serverview-as 3169 tcp SERVERVIEW-AS
serverview-as 3169 udp SERVERVIEW-AS
ferrari-foam 3216 tcp Ferrari electronic FOAM Johann Deutinger Johann Deutinger
ferrari-foam 3216 udp Ferrari electronic FOAM Johann Deutinger Johann Deutinger
aicc-cmi 3316 tcp AICC/CMI William McDonald William McDonald
aicc-cmi 3316 udp AICC/CMI William McDonald William McDonald
commandport 3416 tcp AirMobile IS Command Port Mike Klein Mike Klein 2002-02
commandport 3416 udp AirMobile IS Command Port Mike Klein Mike Klein 2002-02
smartcard-port 3516 tcp Smartcard Port Scott Guthery Scott Guthery 2002-05
smartcard-port 3516 udp Smartcard Port Scott Guthery Scott Guthery 2002-05
m2pa 3565 tcp M2PA RFC 4165
m2pa 3565 sctp M2PA RFC 4165
cd3o-protocol 3616 tcp cd3o Control Protocol Chris Wilcox Chris Wilcox 2002-10
cd3o-protocol 3616 udp cd3o Control Protocol Chris Wilcox Chris Wilcox 2002-10
wv-csp-sms-cir 3716 tcp WV CSP SMS CIR Channel
wv-csp-sms-cir 3716 udp WV CSP SMS CIR Channel
sunlps-http 3816 tcp Sun Local Patch Server Barry Greenberg Barry Greenberg 2004-04
sunlps-http 3816 udp Sun Local Patch Server Barry Greenberg Barry Greenberg 2004-04
wysdmc 3916 tcp WysDM Controller Jim McDonald Jim McDonald 2003-11
wysdmc 3916 udp WysDM Controller Jim McDonald Jim McDonald 2003-11
talarian-mcast2 4016 tcp Talarian Mcast
talarian-mcast2 4016 udp Talarian Mcast
smartcard-tls 4116 tcp smartcard-TLS Ilan Mahalal Ilan Mahalal 2006-04
smartcard-tls 4116 udp smartcard-TLS Ilan Mahalal Ilan Mahalal 2006-04
jini-discovery 4160 tcp Jini Discovery Mark Hodapp Mark Hodapp
jini-discovery 4160 udp Jini Discovery Mark Hodapp Mark Hodapp
omscontact 4161 tcp OMS Contact
omscontact 4161 udp OMS Contact
omstopology 4162 tcp OMS Topology David Page David Page 2005-08
omstopology 4162 udp OMS Topology David Page David Page 2005-08
silverpeakpeer 4163 tcp Silver Peak Peer Protocol Damon Ennis Damon Ennis 2007-03
silverpeakpeer 4163 udp Silver Peak Peer Protocol Damon Ennis Damon Ennis 2007-03
silverpeakcomm 4164 tcp Silver Peak Communication Protocol Damon Ennis Damon Ennis 2007-03
silverpeakcomm 4164 udp Silver Peak Communication Protocol Damon Ennis Damon Ennis 2007-03
altcp 4165 tcp ArcLink over Ethernet Dmitry Brant Dmitry Brant 2007-03
altcp 4165 udp ArcLink over Ethernet Dmitry Brant Dmitry Brant 2007-03
joost 4166 tcp Joost Peer to Peer Protocol Colm MacCarthaigh Colm MacCarthaigh 2007-04
joost 4166 udp Joost Peer to Peer Protocol Colm MacCarthaigh Colm MacCarthaigh 2007-04
ddgn 4167 tcp DeskDirect Global Network Laurie Charlwood Laurie Charlwood 2007-08-22
ddgn 4167 udp DeskDirect Global Network Laurie Charlwood Laurie Charlwood 2007-08-22
pslicser 4168 tcp PrintSoft License Server David Weisgerber David Weisgerber 2007-09-27
pslicser 4168 udp PrintSoft License Server David Weisgerber David Weisgerber 2007-09-27
iadt 4169 tcp Automation Drive Interface Transport Paul Suhler Paul Suhler 2008-02-15
iadt-disc 4169 udp Internet ADT Discovery Protocol Paul A. Suhler Paul A. Suhler 2009-02-06
choiceview-clt 4316 tcp ChoiceView Client Radish Systems Richard A. Davis 2013-03-28
4316 udp Reserved
rwhois 4321 tcp Remote Who Is Mark Kosters Mark Kosters RFC 2167
rwhois 4321 udp Remote Who Is Mark Kosters Mark Kosters RFC 2167
newmood-player 4416 tcp Newmood Media Player Creation Newmood Inc. Bruno Frechette 2015-11-18 2026-09-30
newmood-player 4416 udp Newmood Media Player discovery Creation Newmood Inc. Bruno Frechette 2015-11-18 2026-09-30
dtn-bundle 4556 dccp DTN Bundle DCCP CL Protocol 2013-11-12 2014-02-21 RFC 7122 1685351985

Contact Information

Name Organization Contact URI Last Updated
Akiyoshi Ochi akiyoshi&net.paso.fujitsu.co.jp
Archishmat Gore archisgore&yahoo.com 2004-11
Barry Greenberg barry.greenberg&sun.com 2004-04
Benjamin Green ben&lh.co.nz
Bob Janssen bob&res.nl
Bruno Frechette Creation Newmood Inc. bruno&newmood.com 2026-09-30
Chris Koeritz ckoeritz&inovacorp.com
Chris Wilcox cwilcox&cd3o.com 2002-10
Colm MacCarthaigh colm.maccarthaigh&joost.com 2007-04
Creation Newmood Inc. it&newmood.com 2026-09-30
Damon Ennis damon&silver-peak.com 2007-03
David Barrass dbarrass&bartecautoid.com 2006-01
David Page david.page&sun.com 2005-08
David Weisgerber david.weisgerber&printsoft.de 2007-09-27
Dmitry Brant dmitry_brant&lincolnelectric.com 2007-03
George Balesta George.Baletsa&tfn.com
Greg Cottman greg.cottman&quest.com 2008-10-23
Greg Goodson ggoodson&group1software.co.uk
Hugo Parra hparra&novell.com
Ilan Mahalal imahalal&axalto.com 2006-04
Ilan Zisser ilan&newgenpay.com
Integral Software om&integral.software 2023-11-07
Jim McDonald jim.mcdonald&sysdm.com 2003-11
Johann Deutinger deutinger&ferrari-electronic.de
John Wallace john&nowsoftware.com
Lars Bohn Lars.Bohn&nokia.com
Laurie Charlwood laurie.charlwood&printsoft.com 2007-08-22
Mark Hodapp mark.hodapp&sun.com
Mark Kosters markk&internic.net
Mike Klein m.klein&motorla.com 2002-02
Nathan Sadia sadia&maincontrol.com
Norbert Kintzler NKintzler&easy-soft-dresden.de 2004-11
Olivier Mascia om&integral.software 2023-11-07
Paul A. Suhler paul.suhler&quantum.com 2009-02-06
Paul Suhler paul.suhler&quantum.com 2008-02-15
Pisharath Krishnan krishnan&axis-inc.com
Radish Systems rad&radishsystems.com 2013-03-28
Richard A. Davis Radish Systems rad&radishsystems.com 2013-03-28
Scott Guthery sguthery&mobile-mind.com 2002-05
System Administrator sysadmin&silvaco.com 2003-06
Ted Ross ross&toplayer.com
William McDonald billmc&atc.boeing.com
Yvon Marineau yvon&simware.com