Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
rapi 2176 udp Microsoft ActiveSync Remote API Jon Xu Jon Xu 2005-08
qwave 2177 tcp qWAVE Bandwidth Estimate Gabe Frost Gabe Frost 2005-08
qwave 2177 udp qWAVE Bandwidth Estimate Gabe Frost Gabe Frost 2005-08
bitspeer 2178 tcp Peer Services for BITS Jeff Roberts Jeff Roberts 2005-11
bitspeer 2178 udp Peer Services for BITS Jeff Roberts Jeff Roberts 2005-11
vmrdp 2179 tcp Microsoft RDP for virtual machines Brian Henry Brian Henry 2007-03
vmrdp 2179 udp Microsoft RDP for virtual machines Brian Henry Brian Henry 2007-03
gotodevice 2217 tcp GoToDevice Device Management John Lisek John Lisek 2006-01
gotodevice 2217 udp GoToDevice Device Management John Lisek John Lisek 2006-01
attachmate-g32 2317 tcp Attachmate G32 Bryce Bhatnagar Bryce Bhatnagar
attachmate-g32 2317 udp Attachmate G32 Bryce Bhatnagar Bryce Bhatnagar
composit-server 2417 tcp Composit Server Katsuaki Naoi Katsuaki Naoi
composit-server 2417 udp Composit Server Katsuaki Naoi Katsuaki Naoi
call-sig-trans 2517 tcp H.323 Annex E Call Control Signalling Transport ITU-T ITU-T TSB 2013-01-31
call-sig-trans 2517 udp H.323 Annex E Call Control Signalling Transport ITU-T ITU-T TSB 2013-01-31
cmadmin 2617 tcp Clinical Context Managers Mark Morwood Mark Morwood
cmadmin 2617 udp Clinical Context Managers Mark Morwood Mark Morwood
pn-requester 2717 tcp PN REQUESTER
pn-requester 2717 udp PN REQUESTER
nmsigport 2817 tcp NMSig Port Peter Egli Peter Egli
nmsigport 2817 udp NMSig Port Peter Egli Peter Egli
elvin-client 2917 tcp Elvin Client

IANA assigned this well-formed service name as a replacement for "elvin_client".
David Arnold David Arnold
elvin_client 2917 tcp Elvin Client David Arnold David Arnold This entry is an alias to "elvin-client". This entry is now historic, not usable for use with many common service discovery mechanisms.
elvin-client 2917 udp Elvin Client

IANA assigned this well-formed service name as a replacement for "elvin_client".
David Arnold David Arnold
elvin_client 2917 udp Elvin Client David Arnold David Arnold This entry is an alias to "elvin-client". This entry is now historic, not usable for use with many common service discovery mechanisms.
event-listener 3017 tcp Event Listener

IANA assigned this well-formed service name as a replacement for "event_listener".
Ted Tronson Ted Tronson
event_listener 3017 tcp Event Listener Ted Tronson Ted Tronson This entry is an alias to "event-listener". This entry is now historic, not usable for use with many common service discovery mechanisms.
event-listener 3017 udp Event Listener

IANA assigned this well-formed service name as a replacement for "event_listener".
Ted Tronson Ted Tronson
event_listener 3017 udp Event Listener Ted Tronson Ted Tronson This entry is an alias to "event-listener". This entry is now historic, not usable for use with many common service discovery mechanisms.
mctet-jserv 3117 tcp MCTET Jserv Portnoy Boxman Portnoy Boxman
mctet-jserv 3117 udp MCTET Jserv Portnoy Boxman Portnoy Boxman
pcmk-remote 3121 tcp The pacemaker remote (pcmk-remote) service extends high availability functionality outside of the Linux cluster into remote nodes. David Vossel Andrew Beekhof 2013-03-15 port 3121 previously noted "Removed on 2003-09-17"
3121 udp Reserved 2013-03-15 port 3121 previously noted "Removed on 2003-09-17"
serverview-asn 3170 tcp SERVERVIEW-ASN
serverview-asn 3170 udp SERVERVIEW-ASN
serverview-gf 3171 tcp SERVERVIEW-GF
serverview-gf 3171 udp SERVERVIEW-GF
serverview-rm 3172 tcp SERVERVIEW-RM
serverview-rm 3172 udp SERVERVIEW-RM
serverview-icc 3173 tcp SERVERVIEW-ICC Detlef Rothe Detlef Rothe 2009-05-15
serverview-icc 3173 udp SERVERVIEW-ICC Detlef Rothe Detlef Rothe 2009-05-15
armi-server 3174 tcp ARMI Server Bobby Martin Bobby Martin
armi-server 3174 udp ARMI Server Bobby Martin Bobby Martin
t1-e1-over-ip 3175 tcp T1_E1_Over_IP Mark Doyle Mark Doyle
t1-e1-over-ip 3175 udp T1_E1_Over_IP Mark Doyle Mark Doyle
ars-master 3176 tcp ARS Master Portnoy Boxman Portnoy Boxman
ars-master 3176 udp ARS Master Portnoy Boxman Portnoy Boxman
phonex-port 3177 tcp Phonex Protocol Doug Grover Doug Grover
phonex-port 3177 udp Phonex Protocol Doug Grover Doug Grover
radclientport 3178 tcp Radiance UltraEdge Port Sri Subramaniam Sri Subramaniam
radclientport 3178 udp Radiance UltraEdge Port Sri Subramaniam Sri Subramaniam
h2gf-w-2m 3179 tcp H2GF W.2m Handover prot. Arne Norefors Arne Norefors
h2gf-w-2m 3179 udp H2GF W.2m Handover prot. Arne Norefors Arne Norefors
isns 3205 tcp iSNS Server Port RFC 4171
isns 3205 udp iSNS Server Port RFC 4171
unite 3217 tcp Unified IP & Telecom Environment Christer Gunnarsson Christer Gunnarsson 2009-03-26
unite 3217 udp Unified IP & Telecom Environment Christer Gunnarsson Christer Gunnarsson 2009-03-26
vsaiport 3317 tcp VSAI PORT Rieko Asai Rieko Asai
vsaiport 3317 udp VSAI PORT Rieko Asai Rieko Asai
csvr 3417 tcp ConServR file translation Albert Leung Albert Leung 2002-02
csvr 3417 udp ConServR file translation Albert Leung Albert Leung 2002-02
ifcp-port 3420 tcp iFCP User Port RFC 4172
ifcp-port 3420 udp iFCP User Port RFC 4172
802-11-iapp 3517 tcp IEEE 802.11 WLANs WG IAPP Stuart J. Kerry Stuart J. Kerry 2002-05
802-11-iapp 3517 udp IEEE 802.11 WLANs WG IAPP Stuart J. Kerry Stuart J. Kerry 2002-05
sharp-server 3617 tcp ATI SHARP Logic Engine Bill Reveile Bill Reveile
sharp-server 3617 udp ATI SHARP Logic Engine Bill Reveile Bill Reveile
wv-csp-udp-cir 3717 tcp WV CSP UDP/IP CIR Channel Jon Ingi Ingimundarson Jon Ingi Ingimundarson 2003-03
wv-csp-udp-cir 3717 udp WV CSP UDP/IP CIR Channel Jon Ingi Ingimundarson Jon Ingi Ingimundarson 2003-03
tapeware 3817 tcp Yosemite Tech Tapeware Luke Dion Luke Dion 2004-04
tapeware 3817 udp Yosemite Tech Tapeware Luke Dion Luke Dion 2004-04
aftmux 3917 tcp AFT multiplex port Alfred Schmidt Alfred Schmidt 2003-11
aftmux 3917 udp AFT multiplex port Alfred Schmidt Alfred Schmidt 2003-11
talarian-mcast3 4017 tcp Talarian Mcast
talarian-mcast3 4017 udp Talarian Mcast
hillrserv 4117 tcp Hillr Connection Manager Freddy A. Ayuso-Henson Freddy A. Ayuso-Henson 2008-05-22
hillrserv 4117 udp Hillr Connection Manager Freddy A. Ayuso-Henson Freddy A. Ayuso-Henson 2008-05-22
d-cinema-csp 4170 tcp SMPTE Content Synchonization Protocol Michael Karagosian Michael Karagosian 2008-09-04
4170 udp Reserved
ml-svnet 4171 tcp Maxlogic Supervisor Communication Taha Paksu Taha Paksu 2009-12-21
4171 udp Reserved
pcoip 4172 tcp PC over IP HP Inc. Jeff Jeansonne 2009-12-23 2026-03-10
pcoip 4172 udp PC over IP HP Inc. Jeff Jeansonne 2009-12-23 2026-03-10
4173 tcp Reserved
mma-discovery 4173 udp MMA Device Discovery MIDI Manufacturers Assoc Inc Tom White 2011-11-14
smcluster 4174 tcp StorMagic Cluster Services Chris Farey Chris Farey 2011-03-09
sm-disc 4174 udp StorMagic Discovery StorMagic Ltd Chris Farey 2011-12-16
bccp 4175 tcp Brocade Cluster Communication Protocol Norival Figueira Norival Figueira 2010-04-07
4175 udp Reserved
tl-ipcproxy 4176 tcp Translattice Cluster IPC Proxy Michael Lyle Michael Lyle 2009-11-03
4176 udp Reserved
wello 4177 tcp Wello P2P pubsub service Christian Westbrook Christian Westbrook 2007-11-15
wello 4177 udp Wello P2P pubsub service Christian Westbrook Christian Westbrook 2007-11-15
storman 4178 tcp StorMan Werner Guertler Werner Guertler 2009-05-11
storman 4178 udp StorMan Werner Guertler Werner Guertler 2009-05-11
MaxumSP 4179 tcp Maxum Services Greg Stine Greg Stine 2007-07-05
MaxumSP 4179 udp Maxum Services Greg Stine Greg Stine 2007-07-05
opentelemetry 4317 tcp OpenTelemetry Protocol OpenTelemetry Morgan McLean 2020-12-09
4317 udp Reserved
workflowdir 4417 tcp Workflow Director Communication WfDir Brian Doyle 2015-12-11
4417 udp Reserved

Contact Information

Name Organization Contact URI Last Updated
Albert Leung aleung&biscom.com 2006-04
Alfred Schmidt a.schmidt&aft-werdohl.de 2003-11
Andrew Beekhof andrew&beekhof.net 2013-03-15
Arne Norefors Arne.Norefors&ericsson.com
Bill Reveile breveile&allentek.com
Bobby Martin bobbymartin&hotmail.com
Brian Doyle bd&wfdir.com 2015-12-11
Brian Henry brian.henry&microsoft.com 2007-03
Bryce Bhatnagar BRYCEBH&attachmate.com
Chris Farey StorMagic Ltd chris_farey&stormagic.com 2011-12-16
Christer Gunnarsson christer.gunnarsson&ascom.com 2020-09-30
Christian Westbrook cw&wellohorld.com 2007-11-15
David Arnold davida&pobox.com
David Vossel dvossel&redhat.com 2013-03-15
Detlef Rothe detlef.rothe&ts.fujitsu.com 2009-05-15
Doug Grover dgrover&phonex.com
Freddy A. Ayuso-Henson fayusohenson&hillr.com 2008-05-22
Gabe Frost gfrost&microsoft.com 2005-08
Greg Stine greg.stine&siemens.com 2007-07-05
HP Inc. jeff.jeansonne&hp.com 2026-03-10
ITU-T tsbsg16&itu.int 2013-01-31
ITU-T TSB ITU-T tsbsg16&itu.int 2013-01-31
Jeff Jeansonne jeff.jeansonne&hp.com 2026-03-10
Jeff Roberts jroberts&microsoft.com 2005-11
John Lisek jl&gotodevice.com 2006-01
Jon Ingi Ingimundarson jii&oz.com 2003-03
Jon Xu jonxu&microsoft.com 2005-08
Katsuaki Naoi naoi&pfu.co.jp
Luke Dion ldion&tapeware.com 2004-04
Mark Doyle mark&engagecom.com
Mark Morwood markm&sentillion.com
Michael Karagosian michael.karagosian&mkpe.com 2008-09-04
Michael Lyle protocols&translattice.com 2009-11-03
MIDI Manufacturers Assoc Inc info&midi.org 2011-11-14
Morgan McLean OpenTelemetry morgan_mclean&hotmail.com 2020-12-09
Norival Figueira nfigueir&brocade.com 2010-04-07
OpenTelemetry cncf-opentelemetry-governance&lists.cncf.io 2020-12-09
Peter Egli peter.egli&mail.inalp.com
Portnoy Boxman portnoy_boxman&bmc.com 2005-01
Rieko Asai asai&isl.mei.co.jp
Sri Subramaniam sri&radiance.com
StorMagic Ltd chris_farey&stormagic.com 2011-12-16
Stuart J. Kerry Chair IEEE 802.11 WG stuart&ok-brit.com 2002-05
Taha Paksu tahapaksu&mavili.com.tr 2009-12-21
Ted Tronson ttronson&novell.com
Tom White MIDI Manufacturers Assoc Inc info&midi.org 2011-11-14
Werner Guertler werner.guertler&fujitsu.com 2025-04-03
WfDir bd&wfdir.com 2015-12-11