Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 2189 | udp | Reserved | |||||||||
| bounzza | 2218 | tcp | Bounzza IRC Proxy | Danko Alexeyev | Danko Alexeyev | 2006-02 | |||||
| bounzza | 2218 | udp | Bounzza IRC Proxy | Danko Alexeyev | Danko Alexeyev | 2006-02 | |||||
| cadencecontrol | 2318 | tcp | Cadence Control | Buck Caldwell | Buck Caldwell | ||||||
| cadencecontrol | 2318 | udp | Cadence Control | Buck Caldwell | Buck Caldwell | ||||||
| cas | 2418 | tcp | cas | Akiyoshi Ochi | Akiyoshi Ochi | ||||||
| cas | 2418 | udp | cas | Akiyoshi Ochi | Akiyoshi Ochi | ||||||
| willy | 2518 | tcp | Willy | Carl-Johan Wik | Carl-Johan Wik | ||||||
| willy | 2518 | udp | Willy | Carl-Johan Wik | Carl-Johan Wik | ||||||
| priority-e-com | 2618 | tcp | Priority E-Com | Marcelo Einhorn | Marcelo Einhorn | ||||||
| priority-e-com | 2618 | udp | Priority E-Com | Marcelo Einhorn | Marcelo Einhorn | ||||||
| pn-requester2 | 2718 | tcp | PN REQUESTER 2 | Portnoy Boxman | Portnoy Boxman | ||||||
| pn-requester2 | 2718 | udp | PN REQUESTER 2 | Portnoy Boxman | Portnoy Boxman | ||||||
| rmlnk | 2818 | tcp | rmlnk | ||||||||
| rmlnk | 2818 | udp | rmlnk | ||||||||
| kastenchasepad | 2918 | tcp | Kasten Chase Pad | Marc Gauthier | Marc Gauthier | ||||||
| kastenchasepad | 2918 | udp | Kasten Chase Pad | Marc Gauthier | Marc Gauthier | ||||||
| srvc-registry | 3018 | tcp | Service Registry IANA assigned this well-formed service name as a replacement for "srvc_registry". |
Mark Killgore | Mark Killgore | ||||||
| srvc_registry | 3018 | tcp | Service Registry | Mark Killgore | Mark Killgore | This entry is an alias to "srvc-registry". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| srvc-registry | 3018 | udp | Service Registry IANA assigned this well-formed service name as a replacement for "srvc_registry". |
Mark Killgore | Mark Killgore | ||||||
| srvc_registry | 3018 | udp | Service Registry | Mark Killgore | Mark Killgore | This entry is an alias to "srvc-registry". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| pkagent | 3118 | tcp | PKAgent | Michael Douglass | Michael Douglass | ||||||
| pkagent | 3118 | udp | PKAgent | Michael Douglass | Michael Douglass | ||||||
| mc-brk-srv | 3180 | tcp | Millicent Broker Server | Steve Glassman | Steve Glassman | ||||||
| mc-brk-srv | 3180 | udp | Millicent Broker Server | Steve Glassman | Steve Glassman | ||||||
| bmcpatrolagent | 3181 | tcp | BMC Patrol Agent | ||||||||
| bmcpatrolagent | 3181 | udp | BMC Patrol Agent | ||||||||
| bmcpatrolrnvu | 3182 | tcp | BMC Patrol Rendezvous | Portnoy Boxman | Portnoy Boxman | ||||||
| bmcpatrolrnvu | 3182 | udp | BMC Patrol Rendezvous | Portnoy Boxman | Portnoy Boxman | ||||||
| cops-tls | 3183 | tcp | COPS/TLS | Mark Stevens | Mark Stevens | ||||||
| cops-tls | 3183 | udp | COPS/TLS | Mark Stevens | Mark Stevens | ||||||
| apogeex-port | 3184 | tcp | ApogeeX Port | Tom Nys | Tom Nys | ||||||
| apogeex-port | 3184 | udp | ApogeeX Port | Tom Nys | Tom Nys | ||||||
| smpppd | 3185 | tcp | SuSE Meta PPPD | Arvin Schnell | Arvin Schnell | ||||||
| smpppd | 3185 | udp | SuSE Meta PPPD | Arvin Schnell | Arvin Schnell | ||||||
| iiw-port | 3186 | tcp | IIW Monitor User Port | Corey Burnett | Corey Burnett | ||||||
| iiw-port | 3186 | udp | IIW Monitor User Port | Corey Burnett | Corey Burnett | ||||||
| odi-port | 3187 | tcp | Open Design Listen Port | Phivos Aristides | Phivos Aristides | ||||||
| odi-port | 3187 | udp | Open Design Listen Port | Phivos Aristides | Phivos Aristides | ||||||
| brcm-comm-port | 3188 | tcp | Broadcom Port | Thomas L. Johnson | Thomas L. Johnson | ||||||
| brcm-comm-port | 3188 | udp | Broadcom Port | Thomas L. Johnson | Thomas L. Johnson | ||||||
| pcle-infex | 3189 | tcp | Pinnacle Sys InfEx Port | Anthon van der Neut | Anthon van der Neut | ||||||
| pcle-infex | 3189 | udp | Pinnacle Sys InfEx Port | Anthon van der Neut | Anthon van der Neut | ||||||
| smartpackets | 3218 | tcp | EMC SmartPackets | Steve Spataro | Steve Spataro | ||||||
| smartpackets | 3218 | udp | EMC SmartPackets | Steve Spataro | Steve Spataro | ||||||
| ssrip | 3318 | tcp | Swith to Swith Routing Information Protocol | Baba Hidekazu | Baba Hidekazu | ||||||
| ssrip | 3318 | udp | Swith to Swith Routing Information Protocol | Baba Hidekazu | Baba Hidekazu | ||||||
| rnmap | 3418 | tcp | Remote nmap | Tuomo Makinen | Tuomo Makinen | 2002-02 | |||||
| rnmap | 3418 | udp | Remote nmap | Tuomo Makinen | Tuomo Makinen | 2002-02 | |||||
| artifact-msg | 3518 | tcp | Artifact Message Server | Ron Capwell | Ron Capwell | 2002-06 | |||||
| artifact-msg | 3518 | udp | Artifact Message Server | Ron Capwell | Ron Capwell | 2002-06 | |||||
| aairnet-1 | 3618 | tcp | AAIR-Network 1 | ||||||||
| aairnet-1 | 3618 | udp | AAIR-Network 1 | ||||||||
| opus-services | 3718 | tcp | OPUS Server Port | Detlef Stoever | Detlef Stoever | 2003-03 | |||||
| opus-services | 3718 | udp | OPUS Server Port | Detlef Stoever | Detlef Stoever | 2003-03 | |||||
| crinis-hb | 3818 | tcp | Crinis Heartbeat | Eric McMurry | Eric McMurry | 2004-04 | |||||
| crinis-hb | 3818 | udp | Crinis Heartbeat | Eric McMurry | Eric McMurry | 2004-04 | |||||
| pktcablemmcops | 3918 | tcp | PacketCableMultimediaCOPS | Eric Rosenfeld | Eric Rosenfeld | 2003-11 | |||||
| pktcablemmcops | 3918 | udp | PacketCableMultimediaCOPS | Eric Rosenfeld | Eric Rosenfeld | 2003-11 | |||||
| talarian-mcast4 | 4018 | tcp | Talarian Mcast | ||||||||
| talarian-mcast4 | 4018 | udp | Talarian Mcast | ||||||||
| netscript | 4118 | tcp | Netadmin Systems NETscript service | Göran Runfeldt | Göran Runfeldt | 2006-12 | |||||
| netscript | 4118 | udp | Netadmin Systems NETscript service | Göran Runfeldt | Göran Runfeldt | 2006-12 | |||||
| httpx | 4180 | tcp | HTTPX | Paul McGough | Paul McGough | 2007-02 | |||||
| httpx | 4180 | udp | HTTPX | Paul McGough | Paul McGough | 2007-02 | 2016-01-05 | ||||
| macbak | 4181 | tcp | MacBak | Wes Peters | Wes Peters | 2007-04 | |||||
| macbak | 4181 | udp | MacBak | Wes Peters | Wes Peters | 2007-04 | |||||
| pcptcpservice | 4182 | tcp | Production Company Pro TCP Service | Ben McNeill | Ben McNeill | 2007-05 | |||||
| pcptcpservice | 4182 | udp | Production Company Pro TCP Service | Ben McNeill | Ben McNeill | 2007-05 | |||||
| cyborgnet | 4183 | tcp | CyborgNet communications protocol | Gareth Nelson | Gareth Nelson | 2015-11-13 | |||||
| cyborgnet | 4183 | udp | CyborgNet communications protocol | Gareth Nelson | Gareth Nelson | 2015-11-13 | |||||
| universe-suite | 4184 | tcp | UNIVERSE SUITE MESSAGE SERVICE IANA assigned this well-formed service name as a replacement for "universe_suite". |
Gary ANDREWS | Gary ANDREWS | 2008-01-07 | |||||
| universe_suite | 4184 | tcp | UNIVERSE SUITE MESSAGE SERVICE | Gary ANDREWS | Gary ANDREWS | 2008-01-07 | This entry is an alias to "universe-suite". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| universe-suite | 4184 | udp | UNIVERSE SUITE MESSAGE SERVICE IANA assigned this well-formed service name as a replacement for "universe_suite". |
Gary ANDREWS | Gary ANDREWS | 2008-01-07 | |||||
| universe_suite | 4184 | udp | UNIVERSE SUITE MESSAGE SERVICE | Gary ANDREWS | Gary ANDREWS | 2008-01-07 | This entry is an alias to "universe-suite". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| wcpp | 4185 | tcp | Woven Control Plane Protocol | Christopher LILJENSTOLPE | Christopher LILJENSTOLPE | 2008-04-14 | |||||
| wcpp | 4185 | udp | Woven Control Plane Protocol | Christopher LILJENSTOLPE | Christopher LILJENSTOLPE | 2008-04-14 | |||||
| boxbackupstore | 4186 | tcp | Box Backup Store Service | Chris Wilson | Chris Wilson | 2008-09-11 | |||||
| 4186 | udp | Reserved | |||||||||
| csc-proxy | 4187 | tcp | Cascade Proxy IANA assigned this well-formed service name as a replacement for "csc_proxy". |
Matt Craighead | Matt Craighead | 2008-09-11 | |||||
| csc_proxy | 4187 | tcp | Cascade Proxy | Matt Craighead | Matt Craighead | 2008-09-11 | This entry is an alias to "csc-proxy". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| 4187 | udp | Reserved | |||||||||
| vatata | 4188 | tcp | Vatata Peer to Peer Protocol | Song Jian | Song Jian | 2008-09-15 | |||||
| vatata | 4188 | udp | Vatata Peer to Peer Protocol | Song Jian | Song Jian | 2008-09-15 | |||||
| pcep | 4189 | tcp | Path Computation Element Communication Protocol | ||||||||
| 4189 | udp | Reserved | RFC 5440 | ||||||||
| 4318 | Unassigned | ||||||||||
| 4418 | tcp | Reserved | |||||||||
| axysbridge | 4418 | udp | AXYS communication protocol | Duran Audio B.V. | Gerald van Beuningen | 2016-03-14 | |||||
| 5118-5119 | Unassigned | ||||||||||
| 5153 | tcp | Reserved | 2009-07-01 | 2018-04-19 | Historic usage was toruxserver. De-Assigned on 2018-04-19 | ||||||
| 5173-5189 | Unassigned | ||||||||||
| pkix-cmc | 5318 | tcp | PKIX Certificate Management using CMS (CMC) | IESG | IETF Chair | 2026-02-13 | RFC 10003 | ||||
| 5318 | udp | Reserved | |||||||||
| mcntp | 5418 | tcp | MCNTP | Heiko Rupp | Heiko Rupp | ||||||
| mcntp | 5418 | udp | MCNTP | Heiko Rupp | Heiko Rupp | ||||||
| efr | 5618 | tcp | Fiscal Registering Protocol | efsta IT Services GmbH | Ernst Bewersdorff | 2013-08-13 | 2022-02-02 | ||||
| 5618 | udp | Reserved | |||||||||
| dpm | 5718 | tcp | DPM Communication Server | Sundar Srinivasan; Vinay Badami | Sundar Srinivasan; Vinay Badami | ||||||
| dpm | 5718 | udp | DPM Communication Server | Sundar Srinivasan; Vinay Badami | Sundar Srinivasan; Vinay Badami | ||||||
| tipc | 6118 | udp | Transparent Inter Process Communication | Ericsson | Erik Hugne | 2012-09-05 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Akiyoshi Ochi | akiyoshi&net.paso.fujitsu.co.jp | ||
| Anthon van der Neut | anthon&mnt.org | ||
| Arvin Schnell | arvin&suse.de | ||
| Baba Hidekazu | baba&flare.nd.net.fujitsu.co.jp | ||
| Ben McNeill | ben.mcneill&cinexec.com | 2007-05 | |
| Buck Caldwell | buck_c&polygon.com | ||
| Carl-Johan Wik | cjw&hudsmoar.com | ||
| Chris Wilson | chris+iana&qwirx.com | 2008-09-11 | |
| Christopher LILJENSTOLPE | cdl&asgaard.org | 2008-04-14 | |
| Corey Burnett | corey.burnett&biopop.com | ||
| Danko Alexeyev | virtuall&virtuall.info | 2007-08-08 | |
| Detlef Stoever | mail&ivotec.com | 2003-03 | |
| Duran Audio B.V. | info&duran-audio.com | 2016-03-14 | |
| efsta IT Services GmbH | admin&efsta.eu | 2022-02-02 | |
| Eric McMurry | emcmurry&crinisnetworks.com | 2004-04 | |
| Eric Rosenfeld | e.rosenfeld&cablelabs.com | 2003-11 | |
| Ericsson | erik.hugne&ericsson.com | 2012-09-05 | |
| Erik Hugne | Ericsson | erik.hugne&ericsson.com | 2012-09-05 |
| Ernst Bewersdorff | efsta IT Services GmbH | e.bewersdorff&efsta.eu | 2022-02-02 |
| Gareth Nelson | gareth&garethnelson.com | 2015-11-13 | |
| Gary ANDREWS | gan&orsyp.com | 2008-01-07 | |
| Gerald van Beuningen | gerald.van.beuningen&duran-audio.com | 2016-03-14 | |
| Göran Runfeldt | goran&netadmin.se | 2006-12 | |
| Heiko Rupp | hwr&pilhuhn.de | ||
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Marc Gauthier | mgau&kastenchase.com | ||
| Marcelo Einhorn | marcelo&eshbel.com | ||
| Mark Killgore | MKillgore&novell.com | ||
| Mark Stevens | mstevens&ellacoya.com | ||
| Matt Craighead | matt.craighead&conifersystems.com | 2008-09-11 | |
| Michael Douglass | mikedoug&datafoundry.net | ||
| Paul McGough | paulmcgough&yahoo.com | 2016-01-05 | |
| Phivos Aristides | phivos&opendesign.com | ||
| Portnoy Boxman | portnoy_boxman&bmc.com | 2005-01 | |
| Ron Capwell | ron&artifactsoftware.com | 2002-06 | |
| Song Jian | info&vatata.com | 2008-09-15 | |
| Steve Glassman | steveg&pa.dec.com | ||
| Steve Spataro | spataro_steve&emc.com | ||
| Sundar Srinivasan | sundarsµsoft.com | 2006-05 | |
| Thomas L. Johnson | tjohnson&broadcom.com | ||
| Tom Nys | tom.nys.tn&belgium.agfa.com | ||
| Tuomo Makinen | tmakinen&pp.htv.fi | 2002-02 | |
| Vinay Badami | VinayBµsoft.com | 2006-05 | |
| Wes Peters | wes&softweyr.com | 2007-04 |