Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-11-10
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| gotodevice | 2217 | udp | GoToDevice Device Management | John Lisek | John Lisek | 2006-01 | |||||
| bounzza | 2218 | tcp | Bounzza IRC Proxy | Danko Alexeyev | Danko Alexeyev | 2006-02 | |||||
| bounzza | 2218 | udp | Bounzza IRC Proxy | Danko Alexeyev | Danko Alexeyev | 2006-02 | |||||
| netiq-ncap | 2219 | tcp | NetIQ NCAP Protocol | Roger Huebner | Roger Huebner | 2010-08-25 | |||||
| netiq-ncap | 2219 | udp | NetIQ NCAP Protocol | Roger Huebner | Roger Huebner | 2010-08-25 | |||||
| ethernet-ip-s | 2221 | tcp | EtherNet/IP over TLS | ODVA, Inc. | Brian Batke | 2015-05-28 | |||||
| ethernet-ip-s | 2221 | udp | EtherNet/IP over DTLS | ODVA, Inc. | Brian Batke | 2015-05-28 | |||||
| rdlap | 2321 | tcp | RDLAP | Robert Wiebe | Robert Wiebe | ||||||
| rdlap | 2321 | udp | RDLAP | Robert Wiebe | Robert Wiebe | ||||||
| g-talk | 2421 | tcp | G-Talk | Matt Hammond | Matt Hammond | ||||||
| g-talk | 2421 | udp | G-Talk | Matt Hammond | Matt Hammond | ||||||
| adaptecmgr | 2521 | tcp | Adaptec Manager | Mark Parenti | Mark Parenti | ||||||
| adaptecmgr | 2521 | udp | Adaptec Manager | Mark Parenti | Mark Parenti | ||||||
| miles-apart | 2621 | tcp | Miles Apart Jukebox Server | Michael Rathmann | Michael Rathmann | ||||||
| miles-apart | 2621 | udp | Miles Apart Jukebox Server | Michael Rathmann | Michael Rathmann | ||||||
| smart-diagnose | 2721 | tcp | Smart Diagnose | Geoffry Meek | Geoffry Meek | ||||||
| smart-diagnose | 2721 | udp | Smart Diagnose | Geoffry Meek | Geoffry Meek | ||||||
| vrts-at-port | 2821 | tcp | VERITAS Authentication Service | Stefan Winkel | Stefan Winkel | ||||||
| vrts-at-port | 2821 | udp | VERITAS Authentication Service | Stefan Winkel | Stefan Winkel | ||||||
| cesdcdman | 2921 | tcp | CESD Contents Delivery Management | Shinya Abe | Shinya Abe | ||||||
| cesdcdman | 2921 | udp | CESD Contents Delivery Management | Shinya Abe | Shinya Abe | ||||||
| agriserver | 3021 | tcp | AGRI Server | Frank Neulichedl | Frank Neulichedl | ||||||
| agriserver | 3021 | udp | AGRI Server | Frank Neulichedl | Frank Neulichedl | ||||||
| itu-bicc-stc | 3097 | sctp | ITU-T Q.1902.1/Q.2150.3 | Greg Sidebottom | Greg Sidebottom | ||||||
| pcmk-remote | 3121 | tcp | The pacemaker remote (pcmk-remote) service extends high availability functionality outside of the Linux cluster into remote nodes. | David Vossel | Andrew Beekhof | 2013-03-15 | port 3121 previously noted "Removed on 2003-09-17" | ||||
| 3121 | udp | Reserved | 2013-03-15 | port 3121 previously noted "Removed on 2003-09-17" | |||||||
| flamenco-proxy | 3210 | tcp | Flamenco Networks Proxy | Corey Corrick | Corey Corrick | ||||||
| flamenco-proxy | 3210 | udp | Flamenco Networks Proxy | Corey Corrick | Corey Corrick | ||||||
| avsecuremgmt | 3211 | tcp | Avocent Secure Management | Brian S. Stewart | Brian S. Stewart | ||||||
| avsecuremgmt | 3211 | udp | Avocent Secure Management | Brian S. Stewart | Brian S. Stewart | ||||||
| surveyinst | 3212 | tcp | Survey Instrument | Al Amet | Al Amet | ||||||
| surveyinst | 3212 | udp | Survey Instrument | Al Amet | Al Amet | ||||||
| neon24x7 | 3213 | tcp | NEON 24X7 Mission Control | Tony Lubrano | Tony Lubrano | ||||||
| neon24x7 | 3213 | udp | NEON 24X7 Mission Control | Tony Lubrano | Tony Lubrano | ||||||
| jmq-daemon-1 | 3214 | tcp | JMQ Daemon Port 1 | ||||||||
| jmq-daemon-1 | 3214 | udp | JMQ Daemon Port 1 | ||||||||
| jmq-daemon-2 | 3215 | tcp | JMQ Daemon Port 2 | Martin West | Martin West | ||||||
| jmq-daemon-2 | 3215 | udp | JMQ Daemon Port 2 | Martin West | Martin West | ||||||
| ferrari-foam | 3216 | tcp | Ferrari electronic FOAM | Johann Deutinger | Johann Deutinger | ||||||
| ferrari-foam | 3216 | udp | Ferrari electronic FOAM | Johann Deutinger | Johann Deutinger | ||||||
| unite | 3217 | tcp | Unified IP & Telecom Environment | Christer Gunnarsson | Christer Gunnarsson | 2009-03-26 | |||||
| unite | 3217 | udp | Unified IP & Telecom Environment | Christer Gunnarsson | Christer Gunnarsson | 2009-03-26 | |||||
| smartpackets | 3218 | tcp | EMC SmartPackets | Steve Spataro | Steve Spataro | ||||||
| smartpackets | 3218 | udp | EMC SmartPackets | Steve Spataro | Steve Spataro | ||||||
| wms-messenger | 3219 | tcp | WMS Messenger | WM Software Inc. | WM Software Inc. | 2022-07-18 | |||||
| wms-messenger | 3219 | udp | WMS Messenger | WM Software Inc. | WM Software Inc. | 2022-07-18 | |||||
| xnm-clear-text | 3221 | tcp | XML NM over TCP | Mark Trostler | Mark Trostler | ||||||
| xnm-clear-text | 3221 | udp | XML NM over TCP | Mark Trostler | Mark Trostler | ||||||
| fcip-port | 3225 | tcp | FCIP | RFC 3821 | |||||||
| fcip-port | 3225 | udp | FCIP | RFC 3821 | |||||||
| vnsstr | 3321 | tcp | VNSSTR | Takeshi Ohmura | Takeshi Ohmura | ||||||
| vnsstr | 3321 | udp | VNSSTR | Takeshi Ohmura | Takeshi Ohmura | ||||||
| bmap | 3421 | tcp | Bull Apprise portmapper | Jeremy Gilbert | Jeremy Gilbert | ||||||
| bmap | 3421 | udp | Bull Apprise portmapper | Jeremy Gilbert | Jeremy Gilbert | ||||||
| mc3ss | 3521 | tcp | Telequip Labs MC3SS | Michael Sparks | Michael Sparks | 2002-06 | |||||
| mc3ss | 3521 | udp | Telequip Labs MC3SS | Michael Sparks | Michael Sparks | 2002-06 | |||||
| ep-nsp | 3621 | tcp | EPSON Network Screen Port | SEIKO EPSON | SEIKO EPSON | 2002-10 | |||||
| ep-nsp | 3621 | udp | EPSON Network Screen Port | SEIKO EPSON | SEIKO EPSON | 2002-10 | |||||
| xsync | 3721 | tcp | Xsync | ||||||||
| xsync | 3721 | udp | Xsync | ||||||||
| pmcp | 3821 | tcp | ATSC PMCP Standard | Graham Jones | Graham Jones | 2004-11 | |||||
| pmcp | 3821 | udp | ATSC PMCP Standard | Graham Jones | Graham Jones | 2004-11 | |||||
| herodotus-net | 3921 | tcp | Herodotus Net | Adam Gawne-Cain | Adam Gawne-Cain | 2003-11 | |||||
| herodotus-net | 3921 | udp | Herodotus Net | Adam Gawne-Cain | Adam Gawne-Cain | 2003-11 | |||||
| nexus-portal | 4021 | tcp | Nexus Portal | Damian Tarnawsky | Damian Tarnawsky | ||||||
| nexus-portal | 4021 | udp | Nexus Portal | Damian Tarnawsky | Damian Tarnawsky | ||||||
| e-builder | 4121 | tcp | e-Builder Application Communication | James Caza | James Caza | 2006-12 | |||||
| e-builder | 4121 | udp | e-Builder Application Communication | James Caza | James Caza | 2006-12 | |||||
| rwhois | 4321 | tcp | Remote Who Is | Mark Kosters | Mark Kosters | RFC 2167 | |||||
| rwhois | 4321 | udp | Remote Who Is | Mark Kosters | Mark Kosters | RFC 2167 | |||||
| l2c-control | 4371 | tcp | LAN2CAN Control | Phil Tolson | Phil Tolson | 2008-07-07 | Modified: 21 January 2010 | ||||
| l2c-data | 4372 | tcp | LAN2CAN Data | Phil Tolson | Phil Tolson | 2008-07-07 | Modified: 21 January 2010 | ||||
| scaleft | 4421 | tcp | Multi-Platform Remote Management for Cloud Infrastructure | ScaleFT, Inc | Paul Querna | 2016-04-07 | |||||
| 4421 | udp | Reserved | |||||||||
| a21-an-1xbs | 4597 | tcp | A21 (AN-1xBS) | David Ott | David Ott | 2006-02 | |||||
| a21-an-1xbs | 4597 | udp | A21 (AN-1xBS) | David Ott | David Ott | 2006-02 | |||||
| 4621 | tcp | Reserved | |||||||||
| ventoso | 4621 | udp | Bidirectional single port remote radio VOIP and Control stream | Ventoso Integrated Peripherals | John Lindsey | 2016-03-04 | |||||
| zenginkyo-2 | 5021 | tcp | zenginkyo-2 | Masashi Suzaki | Masashi Suzaki | ||||||
| zenginkyo-2 | 5021 | udp | zenginkyo-2 | Masashi Suzaki | Masashi Suzaki | ||||||
| 5121-5132 | Unassigned | ||||||||||
| 5210-5214 | Unassigned | ||||||||||
| noteza | 5215 | tcp | NOTEZA Data Safety Service | CNS a.s. (IT company registered in Czech republic) | Pavel Mendl | 2014-06-12 | |||||
| 5215 | udp | Reserved | |||||||||
| noteza | 5215 | sctp | NOTEZA Data Safety Service | CNS a.s. (IT company registered in Czech republic) | Pavel Mendl | 2014-06-12 | |||||
| 5216-5220 | Unassigned | ||||||||||
| 3exmp | 5221 | tcp | 3eTI Extensible Management Protocol for OAMP | Bill Rettig | Bill Rettig | 2010-05-19 | |||||
| 5221 | udp | Reserved | |||||||||
| bsfsvr-zn-ssl | 5321 | tcp | Webservices-based Zn interface of BSF over SSL | Bert Paul | Bert Paul | 2008-07-03 | |||||
| 5321 | udp | Reserved | |||||||||
| netsupport2 | 5421 | tcp | Net Support 2 | Paul Sanders | Paul Sanders | ||||||
| netsupport2 | 5421 | udp | Net Support 2 | Paul Sanders | Paul Sanders | ||||||
| dtpt | 5721 | tcp | Desktop Passthru Service | Dan Leising | Dan Leising | 2005-01 | |||||
| dtpt | 5721 | udp | Desktop Passthru Service | Dan Leising | Dan Leising | 2005-01 | |||||
| 5821-5840 | Unassigned | ||||||||||
| spdy | 6121 | tcp | SPDY for a faster web | Matthew Lloyd | Matthew Lloyd | 2010-04-26 | |||||
| 6121 | udp | Reserved | |||||||||
| 6210-6221 | Unassigned | ||||||||||
| emp-server1 | 6321 | tcp | Empress Software Connectivity Server 1 | Srdjan Holovac | Srdjan Holovac | ||||||
| emp-server1 | 6321 | udp | Empress Software Connectivity Server 1 | Srdjan Holovac | Srdjan Holovac | ||||||
| nim-wan | 6421 | tcp | NIM_WAN | Rik Ditter | Rik Ditter | 2006-02 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Adam Gawne-Cain | adam&gawncainresearch.co.uk | 2003-11 | |
| Al Amet | aamet&point-inc.com | ||
| Andrew Beekhof | andrew&beekhof.net | 2013-03-15 | |
| Bert Paul | bert.paul&apertio.com | 2008-07-03 | |
| Bill Rettig | WRettig&efji.com | 2010-05-19 | |
| Brian Batke | Chair of the EtherNet/IP System Architecture SIG | babatke&ra.rockwell.com | 2015-05-28 |
| Brian S. Stewart | Brian.Stewart&avocent.com | ||
| Christer Gunnarsson | christer.gunnarsson&ascom.com | 2020-09-30 | |
| CNS a.s. (IT company registered in Czech republic) | HAJN.L&cns.cz | 2014-06-12 | |
| Corey Corrick | corey.corrick&flamenconetworks.com | ||
| Damian Tarnawsky | support&nexusconcepts.com | ||
| Dan Leising | dleisingµsoft.com | 2005-01 | |
| Danko Alexeyev | virtuall&virtuall.info | 2007-08-08 | |
| David Ott | dott&qualcomm.com | 2010-10-15 | |
| David Vossel | dvossel&redhat.com | 2013-03-15 | |
| Frank Neulichedl | frank&websmile.com | ||
| Geoffry Meek | geoff&meek.com | ||
| Graham Jones | gjones&nab.org | 2004-11 | |
| Greg Sidebottom | gregside&home.com | ||
| James Caza | jcaza&e-builder.net | 2006-12 | |
| Jeremy Gilbert | J.Gilbert&ma30.bull.com | ||
| Johann Deutinger | deutinger&ferrari-electronic.de | ||
| John Lindsey | john.lindsey&nilesradio.com | 2016-03-04 | |
| John Lisek | jl&gotodevice.com | 2006-01 | |
| Mark Kosters | markk&internic.net | ||
| Mark Parenti | map&ntc.adaptec.com | ||
| Mark Trostler | trostler&juniper.net | ||
| Martin West | Martin.West&spirit-soft.com | ||
| Masashi Suzaki | susakim&noa.nttdata.jp | ||
| Matt Hammond | matt_hammond&four-sight.co.uk | ||
| Matthew Lloyd | mlloyd&google.com | 2010-04-26 | |
| Michael Rathmann | rathmann_ia&milesinfo.com | ||
| Michael Sparks | msparks&telequiplabs.com | 2002-06 | |
| ODVA, Inc. | babatke&ra.rockwell.com | 2015-05-28 | |
| Paul Querna | paul.querna&scaleft.com | 2016-04-07 | |
| Paul Sanders | p.sanders&dial.pipex.com | ||
| Pavel Mendl | CNS a.s. (IT company registered in Czech republic) | Pavel.MENDL&cns.cz | 2014-06-12 |
| Phil Tolson | philtolson&eaton.com | 2010-01-21 | |
| Rik Ditter | managers&generationtechnologies.com | 2006-02 | |
| Robert Wiebe | crw010&email.mot.com | ||
| Roger Huebner | iana-ports&netiq.com | 2010-08-25 | |
| SEIKO EPSON | Sato.Minoru3&exc.epson.co.jp | 2002-10 | |
| ScaleFT, Inc | notices&scaleft.com | 2016-04-07 | |
| Shinya Abe | abeabe&pfu.co.jp | ||
| Srdjan Holovac | srdjan&empress.com | ||
| Stefan Winkel | stefan&veritas.com | 2004-04 | |
| Steve Spataro | spataro_steve&emc.com | ||
| Takeshi Ohmura | ohmura&isl.mei.co.jp | ||
| Tony Lubrano | tlubrano&neonsys.com | ||
| Ventoso Integrated Peripherals | john.lindsey&nilesradio.com | 2016-03-04 | |
| WM Software Inc. | support&wmsoftware.com | 2022-07-18 |