Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-27

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
fast-rem-serv 2495 udp Fast Remote Services Scott St. Clair Scott St. Clair
dirgis 2496 tcp DIRGIS Deutschland Informations und Reservierungsgesellschaft mbH Deutschland Informations und Reservierungsgesellschaft mbH
dirgis 2496 udp DIRGIS Deutschland Informations und Reservierungsgesellschaft mbH Deutschland Informations und Reservierungsgesellschaft mbH
quaddb 2497 tcp Quad DB Jeff Rosenthal Jeff Rosenthal
quaddb 2497 udp Quad DB Jeff Rosenthal Jeff Rosenthal
odn-castraq 2498 tcp ODN-CasTraq Richard Hodges Richard Hodges
odn-castraq 2498 udp ODN-CasTraq Richard Hodges Richard Hodges
unicontrol 2499 tcp UniControl Ing. Markus Huemer Ing. Markus Huemer
unicontrol 2499 udp UniControl Ing. Markus Huemer Ing. Markus Huemer
optiwave-lm 2524 tcp Optiwave License Management Slawomir Krzesinski Slawomir Krzesinski
optiwave-lm 2524 udp Optiwave License Management Slawomir Krzesinski Slawomir Krzesinski
aria 2624 tcp Aria Logan Bruns Logan Bruns
aria 2624 udp Aria Logan Bruns Logan Bruns
qotps 2724 tcp qotps Piotr Parlewicz Piotr Parlewicz
qotps 2724 udp qotps Piotr Parlewicz Piotr Parlewicz
cqg-netlan-1 2824 tcp CQG Net/LAN 1 Jeff Wood Jeff Wood
cqg-netlan-1 2824 udp CQG Net/Lan 1 Jeff Wood Jeff Wood
precise-vip 2924 tcp PRECISE-VIP Michael Landwehr Michael Landwehr
precise-vip 2924 udp PRECISE-VIP Michael Landwehr Michael Landwehr
megaco-h248 2944 tcp Megaco H-248 Tom Taylor Tom Taylor
megaco-h248 2944 udp Megaco H-248 Tom Taylor Tom Taylor
megaco-h248 2944 sctp Megaco-H.248 text Tom Taylor Tom Taylor 2006-09
h248-binary 2945 tcp H248 Binary Tom Taylor Tom Taylor
h248-binary 2945 udp H248 Binary Tom Taylor Tom Taylor
h248-binary 2945 sctp Megaco/H.248 binary Tom Taylor Tom Taylor 2006-09
nds-sso 3024 tcp NDS_SSO

IANA assigned this well-formed service name as a replacement for "nds_sso".
Mel Oyler Mel Oyler
nds_sso 3024 tcp NDS_SSO Mel Oyler Mel Oyler This entry is an alias to "nds-sso". This entry is now historic, not usable for use with many common service discovery mechanisms.
nds-sso 3024 udp NDS_SSO

IANA assigned this well-formed service name as a replacement for "nds_sso".
Mel Oyler Mel Oyler
nds_sso 3024 udp NDS_SSO Mel Oyler Mel Oyler This entry is an alias to "nds-sso". This entry is now historic, not usable for use with many common service discovery mechanisms.
beacon-port 3124 tcp Beacon Port James Paul Duncan James Paul Duncan
beacon-port 3124 udp Beacon Port James Paul Duncan James Paul Duncan
neon24x7 3213 tcp NEON 24X7 Mission Control Tony Lubrano Tony Lubrano
neon24x7 3213 udp NEON 24X7 Mission Control Tony Lubrano Tony Lubrano
aes-discovery 3224 tcp AES Discovery Port Ken Richard Ken Richard
aes-discovery 3224 udp AES Discovery Port Ken Richard Ken Richard
triomotion 3240 tcp Trio Motion Control Port Tony Matthews Tony Matthews 2002-02
triomotion 3240 udp Trio Motion Control Port Tony Matthews Tony Matthews 2002-02
sysorb 3241 tcp SysOrb Monitoring Server Jakob Oestergaard Jakob Oestergaard 2002-02
sysorb 3241 udp SysOrb Monitoring Server Jakob Oestergaard Jakob Oestergaard 2002-02
sdp-id-port 3242 tcp Session Description ID Greg Rose Greg Rose 2002-02
sdp-id-port 3242 udp Session Description ID Greg Rose Greg Rose 2002-02
timelot 3243 tcp Timelot Port David Ferguson David Ferguson 2002-02
timelot 3243 udp Timelot Port David Ferguson David Ferguson 2002-02
onesaf 3244 tcp OneSAF Gene McCulley Gene McCulley 2002-02
onesaf 3244 udp OneSAF Gene McCulley Gene McCulley 2002-02
vieo-fe 3245 tcp VIEO Fabric Executive James Cox James Cox 2002-02
vieo-fe 3245 udp VIEO Fabric Executive James Cox James Cox 2002-02
dvt-system 3246 tcp DVT SYSTEM PORT
dvt-system 3246 udp DVT SYSTEM PORT
dvt-data 3247 tcp DVT DATA LINK Phillip Heil Phillip Heil 2002-02
dvt-data 3247 udp DVT DATA LINK Phillip Heil Phillip Heil 2002-02
procos-lm 3248 tcp PROCOS LM Torsten Rendelmann Torsten Rendelmann
procos-lm 3248 udp PROCOS LM Torsten Rendelmann Torsten Rendelmann
ssp 3249 tcp State Sync Protocol Stephane Beaulieu Stephane Beaulieu 2002-02
ssp 3249 udp State Sync Protocol Stephane Beaulieu Stephane Beaulieu 2002-02
odette-ftp 3305 tcp ODETTE-FTP David Nash David Nash RFC 5024
odette-ftp 3305 udp ODETTE-FTP David Nash David Nash RFC 5024
xtrms 3424 tcp xTrade over TLS/SSL Mats Nilsson Mats Nilsson 2002-02
xtrms 3424 udp xTrade over TLS/SSL Mats Nilsson Mats Nilsson 2002-02
ecmport 3524 tcp ECM Server port
ecmport 3524 udp ECM Server port
dist-upgrade 3624 tcp Distributed Upgrade Port Jason Schoon Jason Schoon 2002-10
dist-upgrade 3624 udp Distributed Upgrade Port Jason Schoon Jason Schoon 2002-10
blizwow 3724 tcp World of Warcraft Domain Tech Domain Tech 2005-04
blizwow 3724 udp World of Warcraft Domain Tech Domain Tech 2005-04
acp-policy 3824 tcp Compute Pool Policy Andy Belk Andy Belk 2005-02
acp-policy 3824 udp Compute Pool Policy Andy Belk Andy Belk 2005-02
mpl-gprs-port 3924 tcp MPL_GPRS_PORT David Barrass David Barrass 2003-11
mpl-gprs-port 3924 udp MPL_GPRS_Port David Barrass David Barrass 2003-11
tnp1-port 4024 tcp TNP1 User Port Tony Gibbs Tony Gibbs
tnp1-port 4024 udp TNP1 User Port Tony Gibbs Tony Gibbs
tigv2 4124 tcp Rohill TetraNode Ip Gateway v2 Bert Bouwers Bert Bouwers 2007-05
tigv2 4124 udp Rohill TetraNode Ip Gateway v2 Bert Bouwers Bert Bouwers 2007-05
4324 Reserved 2015-05-12 This entry is being removed on 2015-05-12.
4424 Unassigned
krb524 4444 tcp KRB524 B. Clifford Neuman B. Clifford Neuman krb524 assigned the port, nv used it without an assignment
krb524 4444 udp KRB524 B. Clifford Neuman B. Clifford Neuman krb524 assigned the port, nv used it without an assignment
nv-video 4444 tcp NV Video default Ron Frederick Ron Frederick krb524 assigned the port, nv used it without an assignment
nv-video 4444 udp NV Video default Ron Frederick Ron Frederick krb524 assigned the port, nv used it without an assignment
4712-4724 Unassigned
scpi-telnet 5024 tcp SCPI-TELNET Interchangeable Virtual Instruments Foundation, Inc. Larry Ostheimer 2021-05-06
scpi-telnet 5024 udp SCPI-TELNET Interchangeable Virtual Instruments Foundation, Inc. Larry Ostheimer 2021-05-06
hpvirtctrl 5224 tcp HP Virtual Machine Console Operations John Williams John Williams 2007-06
hpvirtctrl 5224 udp HP Virtual Machine Console Operations John Williams John Williams 2007-06
5238-5241 Unassigned
attune 5242 tcp ATTUne API Bellvedi Ltd. Sean D. Sollé 2022-06-01
5242 udp Reserved
xycstatus 5243 tcp xyClient Status API and rendevous point Xycare Ltd Luke Bailey 2022-06-06
5243 udp Reserved
5244 Unassigned
downtools 5245 tcp DownTools Control Protocol Jarrod Sayers Jarrod Sayers 2009-04-07
downtools-disc 5245 udp DownTools Discovery Protocol Jarrod Sayers Jarrod Sayers 2009-04-07
5246 tcp Reserved
capwap-control 5246 udp CAPWAP Control Protocol RFC 5415
5247 tcp Reserved
capwap-data 5247 udp CAPWAP Data Protocol RFC 5415
caacws 5248 tcp CA Access Control Web Service Gabriel Kalmar Gabriel Kalmar 2008-03-06
caacws 5248 udp CA Access Control Web Service Gabriel Kalmar Gabriel Kalmar 2008-03-06
caaclang2 5249 tcp CA AC Lang Service Gabriel Kalmar Gabriel Kalmar 2008-02-19
caaclang2 5249 udp CA AC Lang Service Gabriel Kalmar Gabriel Kalmar 2008-02-19
beyond-remote 5424 tcp Beyond Remote Michael Berg Michael Berg 2004-11

Contact Information

Name Organization Contact URI Last Updated
Andy Belk register1&azulsystems.com 2005-02
B. Clifford Neuman bcn&isi.edu 2022-02-18
Bellvedi Ltd. iana&bellvedi.com 2022-06-01
Bert Bouwers e.bouwers&rohill.nl 2007-05
David Barrass david.barrass&minorplante.com 2003-11
David Ferguson dferguson&xtralot.com 2002-02
David Nash dnash&ford.com
Deutschland Informations und Reservierungsgesellschaft mbH beratung&dirg.de
Domain Tech Domainnametech&blizzard.com 2005-04
Gabriel Kalmar kalga01&ca.com 2008-03-06
Gene McCulley mcculley&cuspy.com 2002-02
Greg Rose ggr&qualcomm.com 2002-02
Ing. Markus Huemer markus.huemer&hsd.at
Interchangeable Virtual Instruments Foundation, Inc. ivi.contact&ivifoundation.org 2021-05-06
Jakob Oestergaard joe&sysorb.com 2002-02
James Cox jocox&view.com 2002-02
James Paul Duncan pduncan&beaconcrm.com
Jarrod Sayers jarrod&downtools.com.au 2009-04-07
Jason Schoon jason.schoon&intermec.com 2002-10
Jeff Rosenthal jrosenthal&quad-sys.com
Jeff Wood jw&cqg.com
John Williams John.H.Williams&hp.com 2007-06
Ken Richard kenr&aeseducation.com
Larry Ostheimer larry_ostheimer&keysight.com 2021-05-06
Logan Bruns logan&andromedia.com
Luke Bailey Xycare Ltd luke.bailey&xycare.co.uk 2022-06-06
Mats Nilsson mats.nilsson&xware.se 2002-02
Mel Oyler mel&novell.com
Michael Berg mike&dataapples.com 2005-08
Michael Landwehr mikel&precisesoft.co.il
Phillip Heil phil.heil&dvtsensors.com 2002-02
Piotr Parlewicz pparlewicz&queryobject.com
Richard Hodges rh&source.net
Ron Frederick frederick&parc.xerox.com
Scott St. Clair stclair&ntc.adaptec.com
Sean D. Sollé Bellvedi Ltd. iana&bellvedi.com 2022-06-01
Slawomir Krzesinski slavek&optiwave.com
Stephane Beaulieu stephane&cisco.com 2002-02
Tom Taylor taylor&nortelnetworks.com
Tom Taylor taylor&nortel.com 2006-09
Tony Gibbs tony.gibbs&europe.simoco.com
Tony Lubrano tlubrano&neonsys.com
Tony Matthews tmatthews&triomotion.com 2002-02
Torsten Rendelmann torsten.rendelmann&procos.com
Xycare Ltd luke.bailey&xycare.co.uk 2022-06-06