Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
dts 2594 udp Data Base Server Andreas Roene Andreas Roene
worldfusion1 2595 tcp World Fusion 1
worldfusion1 2595 udp World Fusion 1
worldfusion2 2596 tcp World Fusion 2 World Fusion World Fusion
worldfusion2 2596 udp World Fusion 2 World Fusion World Fusion
homesteadglory 2597 tcp Homestead Glory John Tokash John Tokash
homesteadglory 2597 udp Homestead Glory John Tokash John Tokash
citriximaclient 2598 tcp Citrix MA Client Myk Willis Myk Willis
citriximaclient 2598 udp Citrix MA Client Myk Willis Myk Willis
snapd 2599 tcp Snap Discovery Kevin Osborn Kevin Osborn
snapd 2599 udp Snap Discovery Kevin Osborn Kevin Osborn
blwnkl-port 2625 tcp Blwnkl Port Weng Chin (Winson) Yung Weng Chin (Winson) Yung
blwnkl-port 2625 udp Blwnkl Port Weng Chin (Winson) Yung Weng Chin (Winson) Yung
msolap-ptp2 2725 tcp MSOLAP PTP2 Cristian Petculescu Cristian Petculescu
msolap-ptp2 2725 udp MSOLAP PTP2 Cristian Petculescu Cristian Petculescu
2825 (unassigned) Possibly assigned
2925 Unassigned (FRP-Released 12/7/00)
origo-native 3001 tcp OrigoDB Server Native Interface Devrex Labs Robert Friberg 2013-03-29 port 3001 previously "Removed on 2006-05-25"
3001 udp Reserved 2013-03-29 port 3001 previously "Removed on 2006-05-25"
arepa-raft 3025 tcp Arepa Raft Stuart Schaefer Stuart Schaefer
arepa-raft 3025 udp Arepa Raft Stuart Schaefer Stuart Schaefer
a13-an 3125 tcp A13-AN Interface Douglas Knisely Douglas Knisely
a13-an 3125 udp A13-AN Interface Douglas Knisely Douglas Knisely
fcip-port 3225 tcp FCIP RFC 3821
fcip-port 3225 udp FCIP RFC 3821
hicp 3250 tcp HMS hicp port Joel Palsson Joel Palsson 2002-02
hicp 3250 udp HMS hicp port Joel Palsson Joel Palsson 2002-02
sysscanner 3251 tcp Sys Scanner Dick Georges Dick Georges 2002-02
sysscanner 3251 udp Sys Scanner Dick Georges Dick Georges 2002-02
dhe 3252 tcp DHE port Fabrizio Massimo Ferrara Fabrizio Massimo Ferrara 2002-02
dhe 3252 udp DHE port Fabrizio Massimo Ferrara Fabrizio Massimo Ferrara 2002-02
pda-data 3253 tcp PDA Data
pda-data 3253 udp PDA Data
pda-sys 3254 tcp PDA System Jian Fan Jian Fan 2002-02
pda-sys 3254 udp PDA System Jian Fan Jian Fan 2002-02
semaphore 3255 tcp Semaphore Connection Port Jay Eckles Jay Eckles 2002-02
semaphore 3255 udp Semaphore Connection Port Jay Eckles Jay Eckles 2002-02
cpqrpm-agent 3256 tcp Compaq RPM Agent Port
cpqrpm-agent 3256 udp Compaq RPM Agent Port
cpqrpm-server 3257 tcp Compaq RPM Server Port Royal King Royal King 2002-02
cpqrpm-server 3257 udp Compaq RPM Server Port Royal King Royal King 2002-02
ivecon-port 3258 tcp Ivecon Server Port Serguei Tevs Serguei Tevs 2002-02
ivecon-port 3258 udp Ivecon Server Port Serguei Tevs Serguei Tevs 2002-02
epncdp2 3259 tcp Epson Network Common Devi Oishi Toshiaki Oishi Toshiaki 2002-02
epncdp2 3259 udp Epson Network Common Devi Oishi Toshiaki Oishi Toshiaki 2002-02
active-net 3322-3325 Active Networks Bob Braden Bob Braden
agps-port 3425 tcp AGPS Access Port Kristoffer Nilsson Kristoffer Nilsson 2002-02
agps-port 3425 udp AGPS Access Port Kristoffer Nilsson Kristoffer Nilsson 2002-02
eisport 3525 tcp EIS Server port Paul Kraus Paul Kraus 2002-06
eisport 3525 udp EIS Server port Paul Kraus Paul Kraus 2002-06
volley 3625 tcp Volley David Catmull David Catmull 2002-10
volley 3625 udp Volley David Catmull David Catmull 2002-10
na-er-tip 3725 tcp Netia NA-ER Port Jean-Pierre Garcia Jean-Pierre Garcia 2003-04
na-er-tip 3725 udp Netia NA-ER Port Jean-Pierre Garcia Jean-Pierre Garcia 2003-04
ffserver 3825 tcp Antera FlowFusion Process Simulation Armin Liebchen Armin Liebchen 2007-06
ffserver 3825 udp Antera FlowFusion Process Simulation Armin Liebchen Armin Liebchen 2007-06
zmp 3925 tcp Zoran Media Port Gerard Cerchio Gerard Cerchio 2003-11
zmp 3925 udp Zoran Media Port Gerard Cerchio Gerard Cerchio 2003-11
partimage 4025 tcp Partition Image Port Franck Ladurelle Franck Ladurelle
partimage 4025 udp Partition Image Port Franck Ladurelle Franck Ladurelle
opsview-envoy 4125 tcp Opsview Envoy Ton Voon Ton Voon 2008-09-26
opsview-envoy 4125 udp Opsview Envoy Ton Voon Ton Voon 2008-09-26
geognosisadmin 4325 tcp Cadcorp GeognoSIS Administrator Computer Aided Development Corporation Ltd (Cadcorp) Martin Daly 2022-08-12
geognosisman 4325 udp Cadcorp GeognoSIS Administrator Computer Aided Development Corporation Ltd (Cadcorp) Martin Daly 2022-08-12
netrockey6 4425 tcp NetROCKEY6 SMART Plus Service Feitian Technologies Feitian Technologies 2010-09-15
netrockey6 4425 udp NetROCKEY6 SMART Plus Service Feitian Technologies Feitian Technologies 2010-09-15
a25-fap-fgw 4502 sctp A25 (FAP-FGW) 3GPP2 Zhiming Li 2012-01-11
truckstar 4725 tcp TruckStar Service Brian Toothill Brian Toothill 2010-10-15
truckstar 4725 udp TruckStar Service Brian Toothill Brian Toothill 2010-10-15
scpi-raw 5025 tcp SCPI-RAW Interchangeable Virtual Instruments Foundation, Inc. Larry Ostheimer 2021-05-06
scpi-raw 5025 udp SCPI-RAW Interchangeable Virtual Instruments Foundation, Inc. Larry Ostheimer 2021-05-06
hp-server 5225 tcp HP Server Brett Green Brett Green
hp-server 5225 udp HP Server Brett Green Brett Green
soagateway 5250 tcp soaGateway Greg Bodine Greg Bodine 2002-02
soagateway 5250 udp soaGateway Greg Bodine Greg Bodine 2002-02
caevms 5251 tcp CA eTrust VM Service Kevin Bond Kevin Bond 2004-11
caevms 5251 udp CA eTrust VM Service Kevin Bond Kevin Bond 2004-11
movaz-ssc 5252 tcp Movaz SSC Lou Berger Lou Berger 2004-11
movaz-ssc 5252 udp Movaz SSC Lou Berger Lou Berger 2004-11
kpdp 5253 tcp Kohler Power Device Protocol Bill Gross Bill Gross 2010-11-01
5253 udp Reserved
logcabin 5254 tcp LogCabin storage service Diego Ongaro Diego Ongaro 2015-04-14
5254 udp Reserved
5255-5263 Unassigned
br-channel 5425 tcp Beyond Remote Command Channel Michael Berg Michael Berg 2005-08
br-channel 5425 udp Beyond Remote Command Channel Michael Berg Michael Berg 2005-08
coap 5683 udp Constrained Application Protocol IESG IETF Chair 2011-06-13 2013-07-25 RFC 7252
coaps 5684 udp DTLS-secured CoAP IESG IETF Chair 2013-07-25 RFC 7252
ms-ilm 5725 tcp Microsoft Identity Lifecycle Manager Rob Ward Rob Ward
5725 udp Reserved 2008-05-02
p25cai 6082 udp APCO Project 25 Common Air Interface - UDP encapsulation Steve Glass Steve Glass 2011-05-13
6125-6129 Unassigned
6245-6250 Unassigned
tl1-raw-ssl 6251 tcp TL1 Raw Over SSL/TLS Jim Humphreys Jim Humphreys 2008-01-29
tl1-raw-ssl 6251 udp TL1 Raw Over SSL/TLS Jim Humphreys Jim Humphreys 2008-01-29
tl1-ssh 6252 tcp TL1 over SSH Jim Humphreys Jim Humphreys 2008-01-25
tl1-ssh 6252 udp TL1 over SSH Jim Humphreys Jim Humphreys 2008-01-25
crip 6253 tcp CRIP Mike Rodbell Mike Rodbell
crip 6253 udp CRIP Mike Rodbell Mike Rodbell
6254-6266 Unassigned
dt-mgmtsvc 6325 tcp Double-Take Management Service Carbonite, Inc. James Wilkinson 2012-06-06 2019-08-23

Contact Information

Name Organization Contact URI Last Updated
3GPP2 lizhiming&huawei.com 2012-01-11
Steve Glass APCO Project 25 admin&sedition.org.au 2011-05-13
Andreas Roene andreas.roene&seolizer.de 2025-07-17
Armin Liebchen armin&anteradesign.com 2007-06
Bill Gross william.gross&kohler.com 2010-11-01
Bob Braden braden&isi.edu
Brett Green Brett_Green&hp.com
Brian Toothill brian.toothill&touchstar.co.uk 2010-10-15
Carbonite, Inc. jwilkinson&carbonite.com 2019-08-23
Computer Aided Development Corporation Ltd (Cadcorp) martin.daly&cadcorp.com 2022-08-12
Cristian Petculescu cristp&microsoft.com
David Catmull uncommon&uncommonplace.com 2006-01
Devrex Labs robert.friberg&devrex.se 2013-03-29
Dick Georges georges&monaco.net 2002-02
Diego Ongaro ongaro&cs.stanford.edu 2015-04-14
Douglas Knisely dnk&lucent.com
Fabrizio Massimo Ferrara fmf&gesi.it 2002-02
Feitian Technologies product&ftsafe.com 2010-09-15
Franck Ladurelle ladurelf&partimage.org
Gerard Cerchio gjpc&circlesoft.com 2003-11
Greg Bodine gregory.bodine&ca.com 2002-02
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Interchangeable Virtual Instruments Foundation, Inc. ivi.contact&ivifoundation.org 2021-05-06
James Wilkinson jwilkinson&carbonite.com 2019-08-23
Jay Eckles ecklesweb&yahoo.com 2002-02
Jean-Pierre Garcia jp.garcia&netia.net 2003-04
Jian Fan fjian&dmfsys.com 2002-02
Jim Humphreys jhumphre&ciena.com 2008-01-29
Joel Palsson HMS Industrial Networks AB ianacontact&hms.se 2002-02
John Tokash jtokash&homestead.com
Kevin Bond kevin.bond&ca.com 2004-11
Kevin Osborn kosborn&snapappliance.com
Kristoffer Nilsson kristoffer.nilsson&hutchison3g.com 2002-02
Larry Ostheimer larry_ostheimer&keysight.com 2021-05-06
Lou Berger lberger&movaz.com 2004-11
Martin Daly martin.daly&cadcorp.com 2022-08-12
Michael Berg mike&dataapples.com 2005-08
Mike Rodbell mrodbell&ciena.com
Myk Willis myk.willis&citrix.com
Oishi Toshiaki SEIKO EPSON Corporation Oishi.Toshiaki&exc.epson.co.jp 2002-02
Paul Kraus paul.kraus&veritas.com 2002-06
Rob Ward RobWard&microsoft.com 2008-05-02
Robert Friberg Devrex Labs robert.friberg&devrex.se 2013-03-29
Royal King royal.king&compaq.com 2002-02
Serguei Tevs STevs&ivecon.com 2002-02
Stuart Schaefer sschaefer&softricity.com
Ton Voon ton.voon&opsera.com 2008-09-26
Weng Chin (Winson) Yung Winson_Yung&3com.com
World Fusion net&worldfusion.com
Zhiming Li 3GPP2 lizhiming&huawei.com 2012-01-11