Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
ecomm 3477 tcp eComm link port Thomas Soerensen Thomas Soerensen 2002-04
ecomm 3477 udp eComm link port Thomas Soerensen Thomas Soerensen 2002-04
stun 3478 tcp Session Traversal Utilities for NAT (STUN) port IESG IETF Chair 2019-03-28 RFC 8489
stun 3478 udp Session Traversal Utilities for NAT (STUN) port IESG IETF Chair 2019-03-28 RFC 8489
turn 3478 tcp TURN over TCP 2019-08-02 RFC 8656
turn 3478 udp TURN over UDP 2019-08-02 RFC 8656
stun-behavior 3478 tcp STUN Behavior Discovery over TCP RFC 5780
stun-behavior 3478 udp STUN Behavior Discovery over UDP RFC 5780
twrpc 3479 tcp 2Wire RPC 2Wire IANA Contact 2Wire IANA Contact 2002-04
twrpc 3479 udp 2Wire RPC 2Wire IANA Contact 2Wire IANA Contact 2002-04
plethora 3480 tcp Secure Virtual Workspace Tim Simms Tim Simms 2002-04
plethora 3480 udp Secure Virtual Workspace Tim Simms Tim Simms 2002-04
cleanerliverc 3481 tcp CleanerLive remote ctrl David Mojdehi David Mojdehi 2002-04
cleanerliverc 3481 udp CleanerLive remote ctrl David Mojdehi David Mojdehi 2002-04
vulture 3482 tcp Vulture Monitoring System Jason Santos Jason Santos 2002-04
vulture 3482 udp Vulture Monitoring System Jason Santos Jason Santos 2002-04
slim-devices 3483 tcp Slim Devices Protocol Sean Adams Sean Adams 2002-05
slim-devices 3483 udp Slim Devices Protocol Sean Adams Sean Adams 2002-05
gbs-stp 3484 tcp GBS SnapTalk Protocol Eric Harris-Braun Eric Harris-Braun 2002-05
gbs-stp 3484 udp GBS SnapTalk Protocol Eric Harris-Braun Eric Harris-Braun 2002-05
celatalk 3485 tcp CelaTalk Carl Blundell Carl Blundell 2002-05
celatalk 3485 udp CelaTalk Carl Blundell Carl Blundell 2002-05
ifsf-hb-port 3486 tcp IFSF Heartbeat Port IFSF Secretary IFSF Secretary 2002-05
ifsf-hb-port 3486 udp IFSF Heartbeat Port IFSF Secretary IFSF Secretary 2002-05
ltctcp 3487 tcp LISA TCP Transfer Channel
ltcudp 3487 udp LISA UDP Transfer Channel Pit Vetterick Pit Vetterick 2002-05
fs-rh-srv 3488 tcp FS Remote Host Server Brian Nickles Brian Nickles 2002-05
fs-rh-srv 3488 udp FS Remote Host Server Brian Nickles Brian Nickles 2002-05
dtp-dia 3489 tcp DTP/DIA Alexei V. Soloviev Alexei V. Soloviev 2002-05
dtp-dia 3489 udp DTP/DIA Alexei V. Soloviev Alexei V. Soloviev 2002-05
colubris 3490 tcp Colubris Management Port Gilbert Moineau Gilbert Moineau 2002-05
colubris 3490 udp Colubris Management Port Gilbert Moineau Gilbert Moineau 2002-05
swr-port 3491 tcp SWR Port Ian Manning Ian Manning 2002-05
swr-port 3491 udp SWR Port Ian Manning Ian Manning 2002-05
tvdumtray-port 3492 tcp TVDUM Tray Port Peter Boers Peter Boers 2002-05
tvdumtray-port 3492 udp TVDUM Tray Port Peter Boers Peter Boers 2002-05
nut 3493 tcp Network UPS Tools Network UPS Tools Project Evgeny Klimov 2002-05 2022-05-18 RFC 9271
nut 3493 udp Network UPS Tools Network UPS Tools Project Evgeny Klimov 2002-05 2020-12-16
ibm3494 3494 tcp IBM 3494 Jeffrey Pilch Jeffrey Pilch
ibm3494 3494 udp IBM 3494 Jeffrey Pilch Jeffrey Pilch
seclayer-tcp 3495 tcp securitylayer over tcp
seclayer-tcp 3495 udp securitylayer over tcp
seclayer-tls 3496 tcp securitylayer over tls Arno Hollosi Arno Hollosi 2002-03
seclayer-tls 3496 udp securitylayer over tls Arno Hollosi Arno Hollosi 2002-03
ipether232port 3497 tcp ipEther232Port Marcus Leufgen Marcus Leufgen 2002-05
ipether232port 3497 udp ipEther232Port Marcus Leufgen Marcus Leufgen 2002-05
dashpas-port 3498 tcp DASHPAS user port Albrecht Mayer Albrecht Mayer 2002-05
dashpas-port 3498 udp DASHPAS user port Albrecht Mayer Albrecht Mayer 2002-05
sccip-media 3499 tcp SccIP Media David Yon David Yon 2002-05
sccip-media 3499 udp SccIP Media David Yon David Yon 2002-05
urld-port 3534 tcp URL Daemon Port Jim Binkley Jim Binkley 2002-06
urld-port 3534 udp URL Daemon Port Jim Binkley Jim Binkley 2002-06
hlibmgr 3634 tcp hNTSP Library Manager Kenji Tetsuyama Kenji Tetsuyama 2002-11
hlibmgr 3634 udp hNTSP Library Manager Kenji Tetsuyama Kenji Tetsuyama 2002-11
synel-data 3734 tcp Synel Data Collection Port David Ashkenazi David Ashkenazi 2003-04
synel-data 3734 udp Synel Data Collection Port David Ashkenazi David Ashkenazi 2003-04
spectardata 3834 tcp Spectar Data Stream Service
spectardata 3834 udp Spectar Data Stream Service
sunfm-port 3934 tcp PL/B File Manager Port Edward R. Boedecker Edward R. Boedecker 2003-11
sunfm-port 3934 udp PL/B File Manager Port Edward R. Boedecker Edward R. Boedecker 2003-11
ubxd 4034 tcp Ubiquinox Daemon Kit Smithers Kit Smithers
ubxd 4034 udp Ubiquinox Daemon Kit Smithers Kit Smithers
nifty-hmi 4134 tcp NIFTY-Serve HMI protocol Ryuichi Suzuki Ryuichi Suzuki
nifty-hmi 4134 udp NIFTY-Serve HMI protocol Ryuichi Suzuki Ryuichi Suzuki
netconf-ch-ssh 4334 tcp NETCONF Call Home (SSH) IESG IETF Chair 2016-01-12 RFC 8071
4334 udp Reserved
gaia 4340 tcp Gaia Connector Protocol Philippe Detournay Philippe Detournay 2007-11-12
gaia 4340 udp Gaia Connector Protocol Philippe Detournay Philippe Detournay 2007-11-12
4341 tcp Reserved 2007-11-12 2018-11-30
lisp-data 4341 udp LISP Data Packets IESG IETF Chair 2007-11-12 2021-02-17 RFC 9300
4342 tcp Reserved 2018-11-30
lisp-control 4342 udp LISP Control Packets IETF IESG 2007-05 2021-02-25 RFC 9301
unicall 4343 tcp UNICALL James Powell James Powell
unicall 4343 udp UNICALL James Powell James Powell
vinainstall 4344 tcp VinaInstall Jay Slupesky Jay Slupesky
vinainstall 4344 udp VinaInstall Jay Slupesky Jay Slupesky
m4-network-as 4345 tcp Macro 4 Network AS Paul Wren Paul Wren
m4-network-as 4345 udp Macro 4 Network AS Paul Wren Paul Wren
elanlm 4346 tcp ELAN LM Paul Ballew Paul Ballew
elanlm 4346 udp ELAN LM Paul Ballew Paul Ballew
lansurveyor 4347 tcp LAN Surveyor Michael Swan Michael Swan
lansurveyor 4347 udp LAN Surveyor Michael Swan Michael Swan
itose 4348 tcp ITOSE Michael Haeuptle Michael Haeuptle
itose 4348 udp ITOSE Michael Haeuptle Michael Haeuptle
fsportmap 4349 tcp File System Port Map Ron Minnich Ron Minnich
fsportmap 4349 udp File System Port Map Ron Minnich Ron Minnich
4434-4440 Unassigned
4534 tcp Reserved
armagetronad 4534 udp Armagetron Advanced Game Server Manuel Moos Yann Kaiser 2012-11-02
4734-4736 Unassigned
vxlan 4789 udp Virtual eXtensible Local Area Network (VXLAN) Lawrence Kreeger Lawrence Kreeger 2013-04-19 2014-06-17 RFC 7348
jtnetd-status 5034 tcp Janstor Status Janstor Technology Anthony Johnson 2015-06-08
5034 udp Reserved
ppactivation 5134 tcp PP ActivationServer Ian Bradley Ian Bradley 2009-10-14
5134 udp Reserved
eenet 5234 tcp EEnet communications Helmut Giritzer Helmut Giritzer 2005-11
eenet 5234 udp EEnet communications Helmut Giritzer Helmut Giritzer 2005-11
5322-5342 Unassigned
kfserver 5343 tcp Sculptor Database Server Keith Ashman Keith Ashman 2005-12
kfserver 5343 udp Sculptor Database Server Keith Ashman Keith Ashman 2005-12
xkotodrcp 5344 tcp xkoto DRCP Jeff Heisz Jeff Heisz 2006-02

Contact Information

Name Organization Contact URI Last Updated
Albrecht Mayer albrecht.mayer&infineon.com 2002-05
Alexei V. Soloviev avsolov&lab127.karelia.ru 2002-05
Anthony Johnson Janstor Technology jtadmin&janstor.com 2015-06-08
Arno Hollosi arno.hollosi&cio.gv.at 2002-03
Brian Nickles RogueSpear91&hotmail.com 2002-05
Carl Blundell cblundell&celador.co.uk 2002-05
David Ashkenazi david&synel.co.il 2010-03-23
David Mojdehi david.mojdehi&autodesk.com 2002-04
David Yon dyon&dialout.net 2002-05
Edward R. Boedecker boedeck1&flash.net 2003-11
Eric Harris-Braun eric&glassbead.com 2003-06
Evgeny Klimov jimklimov+nut&gmail.com 2020-12-16
Gilbert Moineau gilbert.moineau&colubris.com 2002-05
Helmut Giritzer helmut.giritzer&epluse.at 2005-11
IESG iesg&ietf.org
IETF iesg&ietf.org
IETF Chair IETF chair&ietf.org
IFSF Secretary secretary&ifsf.org 2002-05
Ian Bradley ian.bradley&pocketprograms.com
development&pocketprograms.com
2009-10-14
Ian Manning imanning&dtsuk.com 2002-05
James Powell james&enghp.unidata.comp
Janstor Technology jtadmin&janstor.com 2015-06-08
Jason Santos jason.santos&megaslow.net 2002-04
Jay Slupesky js&vina-tech.com
Jeff Heisz jeff.heisz&xkoto.com 2006-02
Jeffrey Pilch jpilch&us.ibm.com
Jim Binkley jrb&cs.pdx.edu 2002-06
Keith Ashman sciana&sculptor.co.uk 2005-12
Kenji Tetsuyama kenji&onkyo.co.jp 2002-11
Kit Smithers ksmithers&argogroup.com
Lawrence Kreeger kreeger&cisco.com 2013-04-19
Manuel Moos z-man&users.sf.net 2012-11-02
Marcus Leufgen leufgen&ipcas.de 2002-05
Michael Haeuptle Michael_Haeuptle&hp.com
Michael Swan swan&neon.com 2004-04
Network UPS Tools Project iana&networkupstools.org 2020-12-16
Paul Ballew ballew&projtech.com
Paul Wren Paul.Wren&macro4.com
Peter Boers boers&isisglobal.nl 2002-05
Philippe Detournay philippe.detournay&acrosoft.be 2007-11-12
Pit Vetterick pit&3dgo.com 2002-05
Ron Minnich rminnich&sarnoff.com
Ryuichi Suzuki SCI00376&niftyserve.or.jp
Sean Adams sean&slimdevices.com 2002-05
Thomas Soerensen thomassoerensen&stofanet.dk 2002-04
Tim Simms tsimms&plethoratech.com 2002-04
2Wire IANA Contact iana&2wire.com 2002-04
Yann Kaiser kaiser.yann&gmail.com 2012-11-02