Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-27
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| dof-eps | 3567 | tcp | DOF Protocol Stack | OpenDOF | Bryant Eastham | 2002-08 | 2015-04-23 | ||||
| dof-eps | 3567 | udp | DOF Protocol Stack | OpenDOF | Bryant Eastham | 2002-08 | 2015-04-23 | ||||
| dof-tunnel-sec | 3568 | tcp | DOF Secure Tunnel | OpenDOF | Bryant Eastham | 2003-01 | 2015-04-23 | ||||
| dof-tunnel-sec | 3568 | udp | DOF Secure Tunnel | OpenDOF | Bryant Eastham | 2003-01 | 2015-04-23 | ||||
| mbg-ctrl | 3569 | tcp | Meinberg Control Service | Meinberg Funkuhren GmbH & Co. KG | Meinberg IANA Registrations | 2002-08 | 2019-04-23 | ||||
| mbg-ctrl | 3569 | udp | Meinberg Control Service | Meinberg Funkuhren GmbH & Co. KG | Meinberg IANA Registrations | 2002-08 | 2019-04-23 | ||||
| mccwebsvr-port | 3570 | tcp | MCC Web Server Port | ||||||||
| mccwebsvr-port | 3570 | udp | MCC Web Server Port | ||||||||
| megardsvr-port | 3571 | tcp | MegaRAID Server Port | ||||||||
| megardsvr-port | 3571 | udp | MegaRAID Server Port | ||||||||
| megaregsvrport | 3572 | tcp | Registration Server Port | Sreenivas Bagalkote | Sreenivas Bagalkote | 2002-08 | |||||
| megaregsvrport | 3572 | udp | Registration Server Port | Sreenivas Bagalkote | Sreenivas Bagalkote | 2002-08 | |||||
| tag-ups-1 | 3573 | tcp | Advantage Group UPS Suite | James Goddard | James Goddard | 2002-08 | |||||
| tag-ups-1 | 3573 | udp | Advantage Group UPS Suite | James Goddard | James Goddard | 2002-08 | |||||
| dmaf-server | 3574 | tcp | DMAF Server | ||||||||
| dmaf-caster | 3574 | udp | DMAF Caster | Ramakrishna Nadendla | Ramakrishna Nadendla | 2002-08 | |||||
| ccm-port | 3575 | tcp | Coalsere CCM Port | ||||||||
| ccm-port | 3575 | udp | Coalsere CCM Port | ||||||||
| cmc-port | 3576 | tcp | Coalsere CMC Port | Chris Hawkinson | Chris Hawkinson | 2002-08 | |||||
| cmc-port | 3576 | udp | Coalsere CMC Port | Chris Hawkinson | Chris Hawkinson | 2002-08 | |||||
| config-port | 3577 | tcp | Configuration Port | ||||||||
| config-port | 3577 | udp | Configuration Port | ||||||||
| data-port | 3578 | tcp | Data Port | Anupam Bharali | Anupam Bharali | 2002-08 | |||||
| data-port | 3578 | udp | Data Port | Anupam Bharali | Anupam Bharali | 2002-08 | |||||
| ttat3lb | 3579 | tcp | Tarantella Load Balancing | Jim Musgrave | Jim Musgrave | 2002-08 | |||||
| ttat3lb | 3579 | udp | Tarantella Load Balancing | Jim Musgrave | Jim Musgrave | 2002-08 | |||||
| nati-svrloc | 3580 | tcp | NATI-ServiceLocator | Jason Case | Jason Case | 2002-08 | |||||
| nati-svrloc | 3580 | udp | NATI-ServiceLocator | Jason Case | Jason Case | 2002-08 | |||||
| kfxaclicensing | 3581 | tcp | Ascent Capture Licensing | Brad Hamilton | Brad Hamilton | 2002-08 | |||||
| kfxaclicensing | 3581 | udp | Ascent Capture Licensing | Brad Hamilton | Brad Hamilton | 2002-08 | |||||
| press | 3582 | tcp | PEG PRESS Server | Jim DeLisle | Jim DeLisle | 2002-08 | |||||
| press | 3582 | udp | PEG PRESS Server | Jim DeLisle | Jim DeLisle | 2002-08 | |||||
| canex-watch | 3583 | tcp | CANEX Watch System | Peter Kollath | Peter Kollath | 2002-08 | |||||
| canex-watch | 3583 | udp | CANEX Watch System | Peter Kollath | Peter Kollath | 2002-08 | |||||
| u-dbap | 3584 | tcp | U-DBase Access Protocol | Bodo Rueskamp | Bodo Rueskamp | 2002-08 | |||||
| u-dbap | 3584 | udp | U-DBase Access Protocol | Bodo Rueskamp | Bodo Rueskamp | 2002-08 | |||||
| emprise-lls | 3585 | tcp | Emprise License Server | ||||||||
| emprise-lls | 3585 | udp | Emprise License Server | ||||||||
| emprise-lsc | 3586 | tcp | License Server Console | James J. Diaz | James J. Diaz | 2002-08 | |||||
| emprise-lsc | 3586 | udp | License Server Console | James J. Diaz | James J. Diaz | 2002-08 | |||||
| p2pgroup | 3587 | tcp | Peer to Peer Grouping | Igor Kostic | Igor Kostic | 2002-08 | |||||
| p2pgroup | 3587 | udp | Peer to Peer Grouping | Igor Kostic | Igor Kostic | 2002-08 | |||||
| sentinel | 3588 | tcp | Sentinel Server | Ian Gordon | Ian Gordon | 2002-08 | |||||
| sentinel | 3588 | udp | Sentinel Server | Ian Gordon | Ian Gordon | 2002-08 | |||||
| isomair | 3589 | tcp | isomair | Richard Fleming | Richard Fleming | 2002-08 | |||||
| isomair | 3589 | udp | isomair | Richard Fleming | Richard Fleming | 2002-08 | |||||
| wv-csp-sms | 3590 | tcp | WV CSP SMS Binding | Matti Salmi | Matti Salmi | 2002-08 | |||||
| wv-csp-sms | 3590 | udp | WV CSP SMS Binding | Matti Salmi | Matti Salmi | 2002-08 | |||||
| gtrack-server | 3591 | tcp | LOCANIS G-TRACK Server | ||||||||
| gtrack-server | 3591 | udp | LOCANIS G-TRACK Server | ||||||||
| gtrack-ne | 3592 | tcp | LOCANIS G-TRACK NE Port | Juergen Edelhaeuser | Juergen Edelhaeuser | 2002-08 | |||||
| gtrack-ne | 3592 | udp | LOCANIS G-TRACK NE Port | Juergen Edelhaeuser | Juergen Edelhaeuser | 2002-08 | |||||
| bpmd | 3593 | tcp | BP Model Debugger | Keith Fligg | Keith Fligg | 2002-09 | |||||
| bpmd | 3593 | udp | BP Model Debugger | Keith Fligg | Keith Fligg | 2002-09 | |||||
| mediaspace | 3594 | tcp | MediaSpace | ||||||||
| mediaspace | 3594 | udp | MediaSpace | ||||||||
| shareapp | 3595 | tcp | ShareApp | Jeff King | Jeff King | 2002-09 | |||||
| shareapp | 3595 | udp | ShareApp | Jeff King | Jeff King | 2002-09 | |||||
| iw-mmogame | 3596 | tcp | Illusion Wireless MMOG | Jan Vrsinsky | Jan Vrsinsky | 2002-09 | |||||
| iw-mmogame | 3596 | udp | Illusion Wireless MMOG | Jan Vrsinsky | Jan Vrsinsky | 2002-09 | |||||
| a14 | 3597 | tcp | A14 (AN-to-SC/MM) | ||||||||
| a14 | 3597 | udp | A14 (AN-to-SC/MM) | ||||||||
| a15 | 3598 | tcp | A15 (AN-to-AN) | David Ott | David Ott | 2002-09 | |||||
| a15 | 3598 | udp | A15 (AN-to-AN) | David Ott | David Ott | 2002-09 | |||||
| quasar-server | 3599 | tcp | Quasar Accounting Server | Brad Pepers | Brad Pepers | 2002-09 | |||||
| quasar-server | 3599 | udp | Quasar Accounting Server | Brad Pepers | Brad Pepers | 2002-09 | |||||
| sdo | 3635 | tcp | Simple Distributed Objects | Alexander Philippou | Alexander Philippou | 2002-11 | |||||
| sdo | 3635 | udp | Simple Distributed Objects | Alexander Philippou | Alexander Philippou | 2002-11 | |||||
| pwdis | 3735 | tcp | Password Distribution | Robert Erl | Robert Erl | 2003-04 | |||||
| pwdis | 3735 | udp | Password Distribution | Robert Erl | Robert Erl | 2003-04 | |||||
| gsakmp | 3761 | tcp | gsakmp port | RFC 4535 | |||||||
| gsakmp | 3761 | udp | gsakmp port | RFC 4535 | |||||||
| radius-dynauth | 3799 | tcp | RADIUS Dynamic Authorization | RFC 3576 | |||||||
| radius-dynauth | 3799 | udp | RADIUS Dynamic Authorization | RFC 3576 | |||||||
| spectardb | 3835 | tcp | Spectar Database Rights Service | Jan Rutger Voorhorst | Jan Rutger Voorhorst | 2006-10 | |||||
| spectardb | 3835 | udp | Spectar Database Rights Service | Jan Rutger Voorhorst | Jan Rutger Voorhorst | 2006-10 | |||||
| asap-udp | 3863 | udp | asap udp port | RFC 5352 | |||||||
| asap-sctp | 3863 | sctp | asap sctp | RFC 5352 | |||||||
| asap-tcp-tls | 3864 | tcp | asap/tls tcp port | RFC 5352 | |||||||
| asap-sctp-tls | 3864 | sctp | asap-sctp/tls | RFC 5352 | |||||||
| diameter | 3868 | sctp | DIAMETER | RFC 3588 | |||||||
| sdp-portmapper | 3935 | tcp | SDP Port Mapper Protocol | James Pinkerton | James Pinkerton | 2003-11 | |||||
| sdp-portmapper | 3935 | udp | SDP Port Mapper Protocol | James Pinkerton | James Pinkerton | 2003-11 | |||||
| wap-push-http | 4035 | tcp | WAP Push OTA-HTTP port | ||||||||
| wap-push-http | 4035 | udp | WAP Push OTA-HTTP port | ||||||||
| cl-db-attach | 4135 | tcp | Classic Line Database Server Attach | ||||||||
| cl-db-attach | 4135 | udp | Classic Line Database Server Attach | ||||||||
| netconf-ch-tls | 4335 | tcp | NETCONF Call Home (TLS) | IESG | IETF Chair | 2016-01-12 | RFC 8071 | ||||
| 4335 | udp | Reserved | |||||||||
| net-device | 4350 | tcp | Net Device | Glenn Peterson | Glenn Peterson | ||||||
| net-device | 4350 | udp | Net Device | Glenn Peterson | Glenn Peterson | ||||||
| plcy-net-svcs | 4351 | tcp | PLCY Net Services | J.J. Ekstrom | J.J. Ekstrom | ||||||
| plcy-net-svcs | 4351 | udp | PLCY Net Services | J.J. Ekstrom | J.J. Ekstrom | ||||||
| pjlink | 4352 | tcp | Projector Link | Mitsuo Kodama | Mitsuo Kodama | 2005-06 | |||||
| pjlink | 4352 | udp | Projector Link | Mitsuo Kodama | Mitsuo Kodama | 2005-06 | |||||
| f5-iquery | 4353 | tcp | F5 iQuery | Tom Kee | Tom Kee | ||||||
| f5-iquery | 4353 | udp | F5 iQuery | Tom Kee | Tom Kee | ||||||
| qsnet-trans | 4354 | tcp | QSNet Transmitter | ||||||||
| qsnet-trans | 4354 | udp | QSNet Transmitter | ||||||||
| qsnet-workst | 4355 | tcp | QSNet Workstation | ||||||||
| qsnet-workst | 4355 | udp | QSNet Workstation |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Alexander Philippou | alex&noemax.com | 2003-10 | |
| Anupam Bharali | ianaports&juniper.net | 2002-08 | |
| Bodo Rueskamp | iana+spam&pinda.de | 2020-06-04 | |
| Brad Hamilton | brad_hamilton&kofax.com | 2002-08 | |
| Brad Pepers | brad&linuxcanada.com | 2002-09 | |
| Bryant Eastham | OenDOF | protocol&opendof.org | 2015-04-23 |
| Chris Hawkinson | chawkinson&coalsere.com | 2002-08 | |
| David Ott | dott&qualcomm.com | 2010-10-15 | |
| Glenn Peterson | glennpµsoft.com | ||
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Ian Gordon | ian.s.gordon&btopenworld.com | 2002-08 | |
| Igor Kostic | igorkoµsoft.com | 2002-08 | |
| J.J. Ekstrom | |||
| James Goddard | jamesg&taglim.com | 2005-08 | |
| James J. Diaz | JDiaz&emprisecorporation.com | 2002-08 | |
| James Pinkerton | jpinkµsoft.com | 2003-11 | |
| Jan Rutger Voorhorst | janrutger&roadware.nl | 2006-10 | |
| Jan Vrsinsky | jan.vrsinsky&illusionsoftworks.com | 2002-09 | |
| Jason Case | jason.case&ni.com | 2002-08 | |
| Jeff King | jking&wave3software.com | 2002-09 | |
| Jim DeLisle | jdelisle&swellsoftware.com | 2002-08 | |
| Jim Musgrave | jimm&tarantella.com | 2002-08 | |
| Juergen Edelhaeuser | Juergen.Edelhaeuser&locanis.com | 2002-08 | |
| Keith Fligg | keith&projtech.com | 2002-09 | |
| Matti Salmi | matti.salmi&nokia.com | 2002-08 | |
| Meinberg Funkuhren GmbH & Co. KG | martin.burnicki&meinberg.de | 2019-04-23 | |
| Meinberg IANA Registrations | iana-admin&meinberg.de | 2019-04-23 | |
| Mitsuo Kodama | kodama&jbmia.or.jp | 2005-06 | |
| OpenDOF | protocol&opendof.org | 2015-04-23 | |
| Peter Kollath | peter.kollath&canex.sk | 2002-08 | |
| Ramakrishna Nadendla | rama_nadendla&agilent.com | 2002-08 | |
| Richard Fleming | richard&apoapsis.com | 2002-08 | |
| Robert Erl | roerl&web.de | 2003-04 | |
| Sreenivas Bagalkote | sreenib&lsil.com | 2002-08 | |
| Tom Kee | t.kee&f5.com |