Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
ati-ip-to-ncpe 3965 udp Avanti IP to NCPE API Steve Meyer Sr. Steve Meyer Sr. 2005-08
bflckmgr 3966 tcp BuildForge Lock Manager Joe Senner Joe Senner 2005-08
bflckmgr 3966 udp BuildForge Lock Manager Joe Senner Joe Senner 2005-08
ppsms 3967 tcp PPS Message Service Bart Schaefer Bart Schaefer 2005-08
ppsms 3967 udp PPS Message Service Bart Schaefer Bart Schaefer 2005-08
ianywhere-dbns 3968 tcp iAnywhere DBNS Graeme Perrow Graeme Perrow 2005-08
ianywhere-dbns 3968 udp iAnywhere DBNS Graeme Perrow Graeme Perrow 2005-08
landmarks 3969 tcp Landmark Messages Petri Rauhala Petri Rauhala 2005-08
landmarks 3969 udp Landmark Messages Petri Rauhala Petri Rauhala 2005-08
lanrevagent 3970 tcp LANrev Agent Martin Bestmann Martin Bestmann Defined TXT keys:
txtvers
server=<main LANrev server for agent>
vers=<version of LANrev Agent>
build=<build number of LANrev Agent>
id=<agent identifier>
lanrevagent 3970 udp LANrev Agent Martin Bestmann Martin Bestmann Defined TXT keys:
txtvers
server=<main LANrev server for agent>
vers=<version of LANrev Agent>
build=<build number of LANrev Agent>
id=<agent identifier>
lanrevserver 3971 tcp LANrev Server Martin Bestmann Martin Bestmann 2005-08
lanrevserver 3971 udp LANrev Server Martin Bestmann Martin Bestmann 2005-08
iconp 3972 tcp ict-control Protocol Roel Harbers Roel Harbers 2005-08
iconp 3972 udp ict-control Protocol Roel Harbers Roel Harbers 2005-08
progistics 3973 tcp ConnectShip Progistics ConnectShip, Inc. Robert Kinyon 2005-08 2019-12-12
progistics 3973 udp ConnectShip Progistics ConnectShip, Inc. Robert Kinyon 2005-08 2019-12-12
xk22 3974 tcp Remote Applicant Tracking Service Marc Castelluccio Marc Castelluccio 2005-08 2022-09-09
xk22 3974 udp Remote Applicant Tracking Service Marc Castelluccio Marc Castelluccio 2005-08 2022-09-09
airshot 3975 tcp Air Shot Shingo Kimura Shingo Kimura 2005-08
airshot 3975 udp Air Shot Shingo Kimura Shingo Kimura 2005-08
opswagent 3976 tcp Server Automation Agent Hewlett Packard Enterprise Cristi Fati 2016-04-14
opswagent 3976 udp Server Automation Agent Hewlett Packard Enterprise Cristi Fati 2016-04-14
opswmanager 3977 tcp Opsware Manager Dave Jagoda Dave Jagoda 2006-06
opswmanager 3977 udp Opsware Manager Dave Jagoda Dave Jagoda 2006-06
secure-cfg-svr 3978 tcp Secured Configuration Server Dr. Anupam Bharali Dr. Anupam Bharali 2006-06
secure-cfg-svr 3978 udp Secured Configuration Server Dr. Anupam Bharali Dr. Anupam Bharali 2006-06
smwan 3979 tcp Smith Micro Wide Area Network Service David Sperling David Sperling 2006-06
smwan 3979 udp Smith Micro Wide Area Network Service David Sperling David Sperling 2006-06
3980 tcp Reserved 2006-06 2020-12-29 Historic usage was acms. De-Assigned on 2020-12-29
3980 udp Reserved
starfish 3981 tcp Starfish System Admin Dan Razzell Dan Razzell 2006-06
starfish 3981 udp Starfish System Admin Dan Razzell Dan Razzell 2006-06
eis 3982 tcp ESRI Image Server
eis 3982 udp ESRI Image Server
eisp 3983 tcp ESRI Image Service Keith Ryden Keith Ryden 2006-07
eisp 3983 udp ESRI Image Service Keith Ryden Keith Ryden 2006-07
mapper-nodemgr 3984 tcp MAPPER network node manager
mapper-nodemgr 3984 udp MAPPER network node manager
mapper-mapethd 3985 tcp MAPPER TCP/IP server
mapper-mapethd 3985 udp MAPPER TCP/IP server
mapper-ws-ethd 3986 tcp MAPPER workstation server

IANA assigned this well-formed service name as a replacement for "mapper-ws_ethd".
John C. Horton John C. Horton
mapper-ws_ethd 3986 tcp MAPPER workstation server John C. Horton John C. Horton This entry is an alias to "mapper-ws-ethd". This entry is now historic, not usable for use with many common service discovery mechanisms.
mapper-ws-ethd 3986 udp MAPPER workstation server

IANA assigned this well-formed service name as a replacement for "mapper-ws_ethd".
John C. Horton John C. Horton
mapper-ws_ethd 3986 udp MAPPER workstation server John C. Horton John C. Horton This entry is an alias to "mapper-ws-ethd". This entry is now historic, not usable for use with many common service discovery mechanisms.
centerline 3987 tcp Centerline Mark Simpson Mark Simpson
centerline 3987 udp Centerline Mark Simpson Mark Simpson
dcs-config 3988 tcp DCS Configuration Port Ian Cargill Ian Cargill 2005-08
dcs-config 3988 udp DCS Configuration Port Ian Cargill Ian Cargill 2005-08
bv-queryengine 3989 tcp BindView-Query Engine
bv-queryengine 3989 udp BindView-Query Engine
bv-is 3990 tcp BindView-IS
bv-is 3990 udp BindView-IS
bv-smcsrv 3991 tcp BindView-SMCServer
bv-smcsrv 3991 udp BindView-SMCServer
bv-ds 3992 tcp BindView-DirectoryServer
bv-ds 3992 udp BindView-DirectoryServer
bv-agent 3993 tcp BindView-Agent David A. Gayler David A. Gayler 2005-08
bv-agent 3993 udp BindView-Agent David A. Gayler David A. Gayler 2005-08
3994 Unassigned 2008-04-24
iss-mgmt-ssl 3995 tcp ISS Management Svcs SSL Wes Wilson Wes Wilson 2003-10
iss-mgmt-ssl 3995 udp ISS Management Svcs SSL Wes Wilson Wes Wilson 2003-10
abcsoftware 3996 tcp abcsoftware-01 Andrew Zimmerman Andrew Zimmerman 2004-06
abcsoftware 3996 udp abcsoftware-01 Andrew Zimmerman Andrew Zimmerman 2004-06
agentsease-db 3997 tcp aes_db Colin Hughes Colin Hughes 2006-02
agentsease-db 3997 udp aes_db Colin Hughes Colin Hughes 2006-02
dnx 3998 tcp Distributed Nagios Executor Service John Calcote John Calcote 2007-11-06
dnx 3998 udp Distributed Nagios Executor Service John Calcote John Calcote 2007-11-06
nvcnet 3999 tcp Norman distributes scanning service Kristian A. Bognaes Kristian A. Bognaes 2007-11-06
nvcnet 3999 udp Norman distributes scanning service Kristian A. Bognaes Kristian A. Bognaes 2007-11-06
fazzt-admin 4039 tcp Fazzt Administration Lewis Wolfgang Lewis Wolfgang 2006-05
fazzt-admin 4039 udp Fazzt Administration Lewis Wolfgang Lewis Wolfgang 2006-05
thrtx 4139 tcp Imperfect Networks Server Dinkar Chivaluri Dinkar Chivaluri 2006-02
thrtx 4139 udp Imperfect Networks Server Dinkar Chivaluri Dinkar Chivaluri 2006-02
4337-4339 Unassigned
wiegand 4390 tcp Physical Access Control Scott Guthery Scott Guthery 2008-08-25
wiegand 4390 udp Physical Access Control Scott Guthery Scott Guthery 2008-08-25
apwi-imserver 4391 tcp American Printware IMServer Protocol Lech Lakomy Lech Lakomy 2009-02-12
4391 udp Reserved
apwi-rxserver 4392 tcp American Printware RXServer Protocol Lech Lakomy Lech Lakomy 2009-02-12
4392 udp Reserved
apwi-rxspooler 4393 tcp American Printware RXSpooler Protocol Lech Lakomy Lech Lakomy 2009-02-12
4393 udp Reserved
4394 tcp Reserved
apwi-disc 4394 udp American Printware Discovery Lech Lakomy Lech Lakomy 2009-02-12
omnivisionesx 4395 tcp OmniVision communication for Virtual environments Vacquier Serge Vacquier Serge 2009-02-12
omnivisionesx 4395 udp OmniVision communication for Virtual environments Vacquier Serge Vacquier Serge 2009-02-12
fly 4396 tcp Fly Object Space Nigel Warren Nigel Warren 2009-02-12
4396 udp Reserved
4397-4399 Unassigned
ipsec-nat-t 4500 udp IPsec NAT-Traversal 2017-07-07 RFC 3948; RFC 7296
4539-4544 Unassigned
ipfix 4739 tcp IP Flow Info Export Nevil Brownlee Nevil Brownlee 2005-08
ipfix 4739 udp IP Flow Info Export Nevil Brownlee Nevil Brownlee 2005-08
ipfix 4739 sctp IP Flow Info Export Nevil Brownlee Nevil Brownlee 2006-01
varadero-2 4839 tcp Varadero-2 Carlos Arteaga Carlos Arteaga
varadero-2 4839 udp Varadero-2 Carlos Arteaga Carlos Arteaga
4938-4939 Unassigned
5365-5396 Unassigned
stresstester 5397 tcp StressTester(tm) Injector Graham Parsons Graham Parsons 2005-08
stresstester 5397 udp StressTester(tm) Injector Graham Parsons Graham Parsons 2005-08

Contact Information

Name Organization Contact URI Last Updated
Andrew Zimmerman andrew&zimmerman.net 2004-06
Bart Schaefer bart&suburbansoftware.com 2005-08
Carlos Arteaga carteaga&abacoinc.com
Colin Hughes chughes&agentsease.net 2006-02
ConnectShip, Inc. ConnectShipIT&connectship.com 2019-12-12
Cristi Fati cristi.fati&hpe.com 2016-04-13
Dan Razzell dan&starfishsystems.ca 2006-06
Dave Jagoda dj&opsware.com 2006-06
David A. Gayler David.Gayler&bindview.com 2005-08
David Sperling dsperling&smithmicro.com 2006-06
Dinkar Chivaluri dchivaluri&imperfectnetworks.com 2006-02
Dr. Anupam Bharali paniana&gmail.com 2006-06
Graeme Perrow gperrow&ianywhere.com 2005-08
Graham Parsons graham.parsons&reflective.com 2005-08
Hewlett Packard Enterprise 2016-04-14
Ian Cargill ian.cargill&e-dendrite.com 2005-08
Joe Senner jsenner&buildforge.com 2005-08
John C. Horton jch&unirsvl.rsvl.unisys.com
John Calcote jcalcote&users.sourceforge.net 2007-11-06
Keith Ryden kryden&esri.com 2006-07
Kristian A. Bognaes Norman Safeground AS kristian.bognaes&norman.com 2014-01-15
Lech Lakomy llakomy&apwi.com 2009-02-12
Lewis Wolfgang wolfgang&kencast.com 2006-05
Marc Castelluccio marc&xk22.com 2022-08-16
Mark Simpson simpson&centerline.com
Martin Bestmann martin&poleposition-sw.com 2005-08
Nevil Brownlee n.brownlee&auckland.ac.nz 2006-10
Nigel Warren info&flyobjectspace.com 2009-02-12
Petri Rauhala petri.rauhala&nokia.com 2005-08
Robert Kinyon rkinyon&connectship.com 2019-12-12
Roel Harbers r.harbers&ict-control.com 2005-08
Scott Guthery sguthery&hidcorp.com 2008-08-25
Shingo Kimura Shingo.Kimura&jp.sony.com 2005-08
Steve Meyer Sr. stevem&avanti-tech.com 2007-02
Vacquier Serge vacquier&systar.fr 2009-02-12
Wes Wilson wwilson&iss.net 2003-10