Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-27
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| iscape | 5047 | udp | iSCAPE Data Broadcasting | Roland van der Veen | Roland van der Veen | 2010-06-17 | |||||
| 5147-5149 | Unassigned | ||||||||||
| 5247 | tcp | Reserved | |||||||||
| capwap-data | 5247 | udp | CAPWAP Data Protocol | RFC 5415 | |||||||
| apsolab-col | 5470 | tcp | The Apsolab company's data collection protocol (native api) | Apsolab Inc. | Jean-Francois Gauthier | 2014-11-10 | |||||
| 5470 | udp | Reserved | |||||||||
| apsolab-cols | 5471 | tcp | The Apsolab company's secure data collection protocol (native api) | Apsolab Inc. | Jean-Francois Gauthier | 2014-11-10 | |||||
| 5471 | udp | Reserved | |||||||||
| apsolab-tag | 5472 | tcp | The Apsolab company's dynamic tag protocol | Apsolab Inc. | Jean-Francois Gauthier | 2014-11-10 | |||||
| 5472 | udp | Reserved | |||||||||
| apsolab-tags | 5473 | tcp | The Apsolab company's secure dynamic tag protocol | Apsolab Inc. | Jean-Francois Gauthier | 2014-11-10 | |||||
| 5473 | udp | Reserved | |||||||||
| apsolab-rpc | 5474 | udp | The Apsolab company's status query protocol | Apsolab Inc. | Jean-Francois Gauthier | 2014-11-10 | |||||
| 5474 | tcp | Reserved | |||||||||
| apsolab-data | 5475 | tcp | The Apsolab company's data retrieval protocol | Apsolab Inc. | Jean-Francois Gauthier | 2014-11-10 | |||||
| 5475 | udp | Reserved | |||||||||
| 5476-5499 | Unassigned | ||||||||||
| 5647-5665 | Unassigned | ||||||||||
| tunatic | 5747 | tcp | Wildbits Tunatic | Sylvain Demongeot | Sylvain Demongeot | 2005-08 | |||||
| tunatic | 5747 | udp | Wildbits Tunatic | Sylvain Demongeot | Sylvain Demongeot | 2005-08 | |||||
| montage-lm | 6147 | tcp | Montage License Manager | Michael Ubell | Michael Ubell | ||||||
| montage-lm | 6147 | udp | Montage License Manager | Michael Ubell | Michael Ubell | ||||||
| gnutella-rtr | 6347 | tcp | gnutella-rtr | Serguei Osokine | Serguei Osokine | ||||||
| gnutella-rtr | 6347 | udp | gnutella-rtr | Serguei Osokine | Serguei Osokine | ||||||
| 6447-6454 | Unassigned | ||||||||||
| 6465-6470 | Unassigned | ||||||||||
| lvision-lm | 6471 | tcp | LVision License Manager | Brian McKinnon | Brian McKinnon | ||||||
| lvision-lm | 6471 | udp | LVision License Manager | Brian McKinnon | Brian McKinnon | ||||||
| 6472-6479 | Unassigned | ||||||||||
| apc-6547 | 6547 | tcp | APC 6547 | American Power Conversion | American Power Conversion | ||||||
| apc-6547 | 6547 | udp | APC 6547 | American Power Conversion | American Power Conversion | ||||||
| ovsdb | 6640 | tcp | Open vSwitch Database protocol | Bruce Davie | Bruce Davie | 2013-07-31 | RFC 7047 | ||||
| 6947-6950 | Unassigned | ||||||||||
| 7444-7470 | Unassigned | ||||||||||
| sttunnel | 7471 | tcp | Stateless Transport Tunneling Protocol | Bruce Davie | Bruce Davie | 2014-04-28 | |||||
| 7471 | udp | Reserved | |||||||||
| 7472 | Unassigned | ||||||||||
| rise | 7473 | tcp | Rise: The Vieneo Province | Jason Reskin | Jason Reskin | 2007-03 | |||||
| rise | 7473 | udp | Rise: The Vieneo Province | Jason Reskin | Jason Reskin | 2007-03 | |||||
| neo4j | 7474 | tcp | Neo4j Graph Database | Neo Technology, Inc | Julian Simpson | 2013-02-08 | |||||
| 7474 | udp | Reserved | |||||||||
| 7475-7477 | Unassigned | ||||||||||
| openit | 7478 | tcp | IT Asset Management | OpeniT Inc. | Monette Maano | 2016-11-17 | |||||
| 7478 | udp | Reserved | |||||||||
| 7479-7490 | Unassigned | ||||||||||
| cwmp | 7547 | tcp | Broadband Forum CWMP | Broadband Forum | Broadband Forum | 2006-01 | 2019-12-13 | ||||
| cwmp | 7547 | udp | Broadband Forum CWMP | Broadband Forum | Broadband Forum | 2006-01 | 2019-12-13 | ||||
| 7634-7647 | Unassigned | ||||||||||
| raqmon-pdu | 7744 | tcp | RAQMON PDU | RFC 4712 | |||||||
| raqmon-pdu | 7744 | udp | RAQMON PDU | RFC 4712 | |||||||
| prgp | 7747 | tcp | Put/Run/Get Protocol | Jayasooriah | Jayasooriah | 2008-02-22 | |||||
| prgp | 7747 | udp | Put/Run/Get Protocol | Jayasooriah | Jayasooriah | 2008-02-22 | |||||
| csoauth | 7847 | tcp | A product key authentication protocol made by CSO | Jeff Wamsley | Jacob Kiesel | 2013-09-04 | |||||
| 7847 | udp | Reserved | |||||||||
| 8141-8147 | Unassigned | ||||||||||
| 8446-8447 | Unassigned | ||||||||||
| cisco-avp | 8470 | tcp | Cisco Address Validation Protocol | Cullen Jennings | Cullen Jennings | 2009-02-13 | |||||
| 8470 | udp | Reserved | |||||||||
| pim-port | 8471 | tcp | PIM over Reliable Transport | IESG | IETF Chair | 2008-08-21 | RFC 6559 | ||||
| pim-port | 8471 | sctp | PIM over Reliable Transport | IESG | IETF Chair | 2008-08-21 | RFC 6559 | ||||
| 8471 | udp | Reserved | |||||||||
| otv | 8472 | tcp | Overlay Transport Virtualization (OTV) | Dino Farinacci | Dino Farinacci | 2008-01-07 | |||||
| otv | 8472 | udp | Overlay Transport Virtualization (OTV) | Dino Farinacci | Dino Farinacci | 2008-01-07 | |||||
| vp2p | 8473 | tcp | Virtual Point to Point | Jerome Grimbert | Jerome Grimbert | ||||||
| vp2p | 8473 | udp | Virtual Point to Point | Jerome Grimbert | Jerome Grimbert | ||||||
| noteshare | 8474 | tcp | AquaMinds NoteShare | Michael McNabb | Michael McNabb | 2005-10 | |||||
| noteshare | 8474 | udp | AquaMinds NoteShare | Michael McNabb | Michael McNabb | 2005-10 | |||||
| 8475-8499 | Unassigned | ||||||||||
| 9347-9373 | Unassigned | ||||||||||
| l5nas-parchan | 9747 | tcp | L5NAS Parallel Channel | Lawrence J. Dickson | Lawrence J. Dickson | 2002-03 | |||||
| l5nas-parchan | 9747 | udp | L5NAS Parallel Channel | Lawrence J. Dickson | Lawrence J. Dickson | 2002-03 | |||||
| 10545-10547 | Unassigned | ||||||||||
| 12547-12752 | Unassigned | ||||||||||
| 20047-20047 | Unassigned | ||||||||||
| 20223-20479 | Unassigned | ||||||||||
| netspeak-cs | 21847 | tcp | NetSpeak Corp. Connection Services | Toby Hosterman | Toby Hosterman | ||||||
| netspeak-cs | 21847 | udp | NetSpeak Corp. Connection Services | Toby Hosterman | Toby Hosterman | ||||||
| wibukey | 22347 | tcp | WibuKey Standard WkLan | Wolfgang Voelker | Wolfgang Voelker | 2007-06 | |||||
| wibukey | 22347 | udp | WibuKey Standard WkLan | Wolfgang Voelker | Wolfgang Voelker | 2007-06 | |||||
| 23547-23999 | Unassigned | ||||||||||
| 24681-24726 | Unassigned | ||||||||||
| 24727 | Unassigned | Unauthorized Use Known on port 24727 | |||||||||
| 24728-24753 | Unassigned | ||||||||||
| cslg | 24754 | tcp | Citrix StorageLink Gateway | Mark Nijmeijer | Mark Nijmeijer | 2009-04-17 | |||||
| 24754 | udp | Reserved | |||||||||
| 24755-24849 | Unassigned | ||||||||||
| 25101-25470 | Unassigned | ||||||||||
| rna | 25471 | sctp | RNSAP User Adaptation for Iurh | Dario S. Tonesi | Dario S. Tonesi | 2011-02-07 | |||||
| 25472-25575 | Unassigned | ||||||||||
| 31766-31947 | Unassigned | ||||||||||
| 36866-37471 | Unassigned | ||||||||||
| 37472 | tcp | Reserved | |||||||||
| 37472 | udp | Reserved | |||||||||
| 3gpp-w1ap | 37472 | sctp | W1 signalling transport | 3GPP | Lionel Morand | 2020-07-16 | |||||
| 37473-37474 | Unassigned | ||||||||||
| neckar | 37475 | tcp | science + computing's Venus Administration Port | Ralf Allrutz | Ralf Allrutz | 2002-02 | |||||
| neckar | 37475 | udp | science + computing's Venus Administration Port | Ralf Allrutz | Ralf Allrutz | 2002-02 | |||||
| 37476-37482 | Unassigned | ||||||||||
| 38463-38471 | Unassigned | ||||||||||
| 38472 | tcp | Reserved | |||||||||
| 38472 | udp | Reserved |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| 3GPP | lionel.morand&orange.com | 2020-07-16 | |
| American Power Conversion | ports&apcc.com | 2002-02 | |
| Apsolab Inc. | admin&apsolab.com | 2014-11-10 | |
| Brian McKinnon | bmk&lvision.com | ||
| Broadband Forum | help&broadband-forum.org | 2020-03-17 | |
| Bruce Davie | bdavie&vmware.com | 2013-07-31 | |
| Bruce Davie | bdavie&vmware.com | 2014-04-28 | |
| Cullen Jennings | fluffy&cisco.com | 2010-02-03 | |
| Dario S. Tonesi | dario.tonesi&nsn.com | 2011-02-07 | |
| Dino Farinacci | dino&cisco.com | 2008-08-21 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Jacob Kiesel | gocso.net | jake.k&gocso.net | 2013-09-04 |
| Jason Reskin | cases&unistellar.fogbugz.com | 2019-11-22 | |
| Jayasooriah | jayasooriah&cast.com.au | 2008-02-22 | |
| Jean-Francois Gauthier | Apsolab Inc. | jfgauthier&apsolab.com | 2014-11-10 |
| Jeff Wamsley | gocso.net | jeffw&gocso.net | 2013-09-04 |
| Jerome Grimbert | jerome.grimbert&atosorigin.com | ||
| Julian Simpson | Neo Technology, Inc | julian.simpson&neotechnology.com | 2016-09-29 |
| Lawrence J. Dickson | Land-5 Corporation | ldickson&land-5.com | 2002-03 |
| Lionel Morand | lionel.morand&orange.com | 2020-07-16 | |
| Mark Nijmeijer | Mark.Nijmeijer&citrix.com | 2009-04-17 | |
| Michael McNabb | michael&aquaminds.com | 2005-10 | |
| Michael Ubell | michael&montage.com | ||
| Monette Maano | mmaano&openit.com | 2016-11-17 | |
| Neo Technology, Inc | admins&neotechnology.com | 2016-09-29 | |
| OpeniT Inc. | mmaano&openit.com | 2016-11-17 | |
| Ralf Allrutz | R.Allrutz&science-computing.de | 2002-02 | |
| Roland van der Veen | rvdveen&aqualectra.nl | 2010-06-17 | |
| Serguei Osokine | osokin¶graph.com | ||
| Sylvain Demongeot | sylvain.demongeot&wildbits.com | 2005-08 | |
| Toby Hosterman | root&netspeak.com | ||
| Wolfgang Voelker | wolfgang.voelker&wibu.com | 2007-06 |