Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| intecom-ps2 | 5057 | udp | Intecom Pointspan 2 | David Meermans | David Meermans | ||||||
| 5058 | tcp | Reserved | |||||||||
| locus-disc | 5058 | udp | Locus Discovery | Alan King | Alan King | 2009-08-13 | |||||
| sds | 5059 | tcp | SIP Directory Services | Arthur Wilton | Arthur Wilton | 2006-03 | |||||
| sds | 5059 | udp | SIP Directory Services | Arthur Wilton | Arthur Wilton | 2006-03 | |||||
| sip | 5060 | tcp | SIP | 2014-04-09 | RFC 3263 | ||||||
| sip | 5060 | udp | SIP | 2014-04-09 | RFC 3263 | ||||||
| sip | 5060 | sctp | SIP | RFC 4168 | |||||||
| sips | 5061 | tcp | SIP-TLS | 2014-04-09 | RFC 3263 | ||||||
| sips | 5061 | udp | SIP-TLS | 2014-04-09 | RFC 3263 | ||||||
| sips | 5061 | sctp | SIP-TLS | RFC 4168 | |||||||
| na-localise | 5062 | tcp | Localisation access | Jean-Pierre Garcia | Jean-Pierre Garcia | 2009-10-28 | |||||
| na-localise | 5062 | udp | Localisation access | Jean-Pierre Garcia | Jean-Pierre Garcia | 2009-10-28 | |||||
| csrpc | 5063 | tcp | centrify secure RPC | Paul Moore | Paul Moore | 2009-10-28 | |||||
| 5063 | udp | Reserved | |||||||||
| ca-1 | 5064 | tcp | Channel Access 1 | Jeffrey Hill | Jeffrey Hill | 2002-08 | |||||
| ca-1 | 5064 | udp | Channel Access 1 | Jeffrey Hill | Jeffrey Hill | 2002-08 | |||||
| ca-2 | 5065 | tcp | Channel Access 2 | Jeffrey Hill | Jeffrey Hill | 2002-08 | |||||
| ca-2 | 5065 | udp | Channel Access 2 | Jeffrey Hill | Jeffrey Hill | 2002-08 | |||||
| stanag-5066 | 5066 | tcp | STANAG-5066-SUBNET-INTF | Rickard Berg | Rickard Berg | 2025-10-22 | |||||
| stanag-5066 | 5066 | udp | STANAG-5066-SUBNET-INTF | Rickard Berg | Rickard Berg | 2025-10-22 | |||||
| authentx | 5067 | tcp | Authentx Service | Alberto Fernandez | Alberto Fernandez | 2006-01 | |||||
| authentx | 5067 | udp | Authentx Service | Alberto Fernandez | Alberto Fernandez | 2006-01 | |||||
| bitforestsrv | 5068 | tcp | Bitforest Data Service | Ville-Pekka Vahteala | Ville-Pekka Vahteala | 2008-06-05 | |||||
| 5068 | udp | Reserved | |||||||||
| i-net-2000-npr | 5069 | tcp | I/Net 2000-NPR | Chris Megede | Chris Megede | ||||||
| i-net-2000-npr | 5069 | udp | I/Net 2000-NPR | Chris Megede | Chris Megede | ||||||
| vtsas | 5070 | tcp | VersaTrans Server Agent Service | Christopher Miller | Christopher Miller | 2006-02 | |||||
| vtsas | 5070 | udp | VersaTrans Server Agent Service | Christopher Miller | Christopher Miller | 2006-02 | |||||
| powerschool | 5071 | tcp | PowerSchool | Greg Porter | Greg Porter | ||||||
| powerschool | 5071 | udp | PowerSchool | Greg Porter | Greg Porter | ||||||
| ayiya | 5072 | tcp | Anything In Anything | Jeroen Massar | Jeroen Massar | 2005-08 | |||||
| ayiya | 5072 | udp | Anything In Anything | Jeroen Massar | Jeroen Massar | 2005-08 | |||||
| tag-pm | 5073 | tcp | Advantage Group Port Mgr | James Goddard | James Goddard | 2005-08 | |||||
| tag-pm | 5073 | udp | Advantage Group Port Mgr | James Goddard | James Goddard | 2005-08 | |||||
| alesquery | 5074 | tcp | ALES Query | Tim Maloney | Tim Maloney | 2005-08 | |||||
| alesquery | 5074 | udp | ALES Query | Tim Maloney | Tim Maloney | 2005-08 | |||||
| pvaccess | 5075 | tcp | Experimental Physics and Industrial Control System | Matej Sekoranja | Matej Sekoranja | 2012-03-23 | |||||
| 5075 | udp | Reserved | |||||||||
| 5076-5077 | Unassigned | ||||||||||
| pixelpusher | 5078 | udp | PixelPusher pixel data | heroicrobotics.com | Jasmine Strong | 2014-06-24 | |||||
| 5078 | tcp | Reserved | |||||||||
| 5079 | tcp | Reserved | |||||||||
| cp-spxrpts | 5079 | udp | Cambridge Pixel SPx Reports | Richard Warren | Richard Warren | 2008-09-17 | |||||
| onscreen | 5080 | tcp | OnScreen Data Collection Service | Christopher Miller | Christopher Miller | 2008-01-14 | |||||
| onscreen | 5080 | udp | OnScreen Data Collection Service | Christopher Miller | Christopher Miller | 2008-01-14 | |||||
| sdl-ets | 5081 | tcp | SDL - Ent Trans Server | Marc Morin | Marc Morin | 2002-04 | |||||
| sdl-ets | 5081 | udp | SDL - Ent Trans Server | Marc Morin | Marc Morin | 2002-04 | |||||
| qcp | 5082 | tcp | Qpur Communication Protocol | Joachim Kluemper | Joachim Kluemper | 2008-03-19 | |||||
| qcp | 5082 | udp | Qpur Communication Protocol | Joachim Kluemper | Joachim Kluemper | 2008-03-19 | |||||
| qfp | 5083 | tcp | Qpur File Protocol | Joachim Kluemper | Joachim Kluemper | 2008-03-19 | |||||
| qfp | 5083 | udp | Qpur File Protocol | Joachim Kluemper | Joachim Kluemper | 2008-03-19 | |||||
| llrp | 5084 | tcp | EPCglobal Low-Level Reader Protocol | Margaret Cullen; Paul Dietrich | Margaret Cullen; Paul Dietrich | 2006-11 | Defined TXT keys: None. RFID reader Low Level Reader Protocol | ||||
| llrp | 5084 | udp | EPCglobal Low-Level Reader Protocol | Margaret Cullen; Paul Dietrich | Margaret Cullen; Paul Dietrich | 2006-11 | Defined TXT keys: None. RFID reader Low Level Reader Protocol | ||||
| encrypted-llrp | 5085 | tcp | EPCglobal Encrypted LLRP | Margaret Cullen | Margaret Cullen | 2006-11 | |||||
| encrypted-llrp | 5085 | udp | EPCglobal Encrypted LLRP | Margaret Cullen | Margaret Cullen | 2006-11 | |||||
| aprigo-cs | 5086 | tcp | Aprigo Collection Service | Ron Zalkind | Ron Zalkind | 2010-05-28 | |||||
| 5086 | udp | Reserved | |||||||||
| biotic | 5087 | tcp | BIOTIC - Binary Internet of Things Interoperable Communication | Waher Data AB | Peter Waher | 2014-06-16 | 2015-11-25 | ||||
| 5087 | udp | Reserved | |||||||||
| 5088-5089 | Unassigned | ||||||||||
| car | 5090 | sctp | Candidate AR | ||||||||
| cxtp | 5091 | sctp | Context Transfer Protocol | 2005-07 | RFC 4065 | ||||||
| 5092 | tcp | Reserved | |||||||||
| magpie | 5092 | udp | Magpie Binary | Phil Maker | Phil Maker | 2008-06-18 | |||||
| sentinel-lm | 5093 | tcp | Sentinel LM | Derick Snyder | Derick Snyder | ||||||
| sentinel-lm | 5093 | udp | Sentinel LM | Derick Snyder | Derick Snyder | ||||||
| hart-ip | 5094 | tcp | HART-IP | Wally Pratt Jr | Wally Pratt Jr | 2010-03-02 | |||||
| hart-ip | 5094 | udp | HART-IP | Wally Pratt Jr | Wally Pratt Jr | 2010-03-02 | |||||
| 5095-5098 | Unassigned | ||||||||||
| sentlm-srv2srv | 5099 | tcp | SentLM Srv2Srv | Derick Snyder | Derick Snyder | ||||||
| sentlm-srv2srv | 5099 | udp | SentLM Srv2Srv | Derick Snyder | Derick Snyder | ||||||
| atmp | 5150 | tcp | Ascend Tunnel Management Protocol | Kory Hamzeh | Kory Hamzeh | ||||||
| atmp | 5150 | udp | Ascend Tunnel Management Protocol | Kory Hamzeh | Kory Hamzeh | ||||||
| soagateway | 5250 | tcp | soaGateway | Greg Bodine | Greg Bodine | 2002-02 | |||||
| soagateway | 5250 | udp | soaGateway | Greg Bodine | Greg Bodine | 2002-02 | |||||
| stuns | 5349 | udp | STUN over DTLS | IESG | IETF Chair | 2014-07-03 | RFC 7350 | This service name was initially created by RFC 5389. | |||
| turns | 5349 | udp | TURN over DTLS | IESG | IETF Chair | 2019-08-02 | RFC 7350 | This service name was initially created by RFC 8656. | |||
| 5350 | tcp | Reserved | |||||||||
| pcp-multicast | 5350 | udp | Port Control Protocol Multicast | IESG | IETF Chair | RFC 6887 | |||||
| tiepie | 5450 | tcp | TiePie engineering data acquisition | TiePie engineering | Reinder Feenstra | 2016-04-01 | |||||
| tiepie-disc | 5450 | udp | TiePie engineering data acquisition (discovery) | TiePie engineering | Reinder Feenstra | 2016-04-01 | |||||
| fcp-addr-srvr1 | 5500 | tcp | fcp-addr-srvr1 | Ken Wittmer | Ken Wittmer | ||||||
| fcp-addr-srvr1 | 5500 | udp | fcp-addr-srvr1 | Ken Wittmer | Ken Wittmer | ||||||
| fcp-addr-srvr2 | 5501 | tcp | fcp-addr-srvr2 | Ken Wittmer | Ken Wittmer | ||||||
| fcp-addr-srvr2 | 5501 | udp | fcp-addr-srvr2 | Ken Wittmer | Ken Wittmer | ||||||
| fcp-srvr-inst1 | 5502 | tcp | fcp-srvr-inst1 | Ken Wittmer | Ken Wittmer | ||||||
| fcp-srvr-inst1 | 5502 | udp | fcp-srvr-inst1 | Ken Wittmer | Ken Wittmer | ||||||
| fcp-srvr-inst2 | 5503 | tcp | fcp-srvr-inst2 | Ken Wittmer | Ken Wittmer | ||||||
| fcp-srvr-inst2 | 5503 | udp | fcp-srvr-inst2 | Ken Wittmer | Ken Wittmer | ||||||
| fcp-cics-gw1 | 5504 | tcp | fcp-cics-gw1 | Ken Wittmer | Ken Wittmer | ||||||
| fcp-cics-gw1 | 5504 | udp | fcp-cics-gw1 | Ken Wittmer | Ken Wittmer | ||||||
| checkoutdb | 5505 | tcp | Checkout Database | Dirk Stoop | Dirk Stoop | 2007-04 | |||||
| checkoutdb | 5505 | udp | Checkout Database | Dirk Stoop | Dirk Stoop | 2007-04 | |||||
| amc | 5506 | tcp | Amcom Mobile Connect | Aaron Fracht-Monroe | Aaron Fracht-Monroe | 2010-06-03 | |||||
| amc | 5506 | udp | Amcom Mobile Connect | Aaron Fracht-Monroe | Aaron Fracht-Monroe | 2010-06-03 | |||||
| psl-management | 5507 | tcp | PowerSysLab Electrical Management | PowerSysLab | Lucas Lorensi | 2015-07-20 | |||||
| 5507 | udp | Reserved | |||||||||
| 5508-5539 | Unassigned | ||||||||||
| cbus | 5550 | tcp | Model Railway control using the CBUS message protocol | MERG | Pete Brownlow | 2017-01-03 | |||||
| 5550 | udp | Reserved |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Aaron Fracht-Monroe | afracht-monroe&amcomsoft.com | 2010-06-03 | |
| Alan King | Enabling Technology Pty. Ltd. | aking&etdesigners.com | 2009-08-13 |
| Alberto Fernandez | af&xtec.com | 2006-01 | |
| Arthur Wilton | art&awilton.com | 2006-03 | |
| Chris Megede | chris.megede&tac.com | ||
| Christopher Miller | Chris.Miller&versatrans.com | 2006-02 | |
| Christopher Miller | chris.miller&versatrans.com | 2008-01-14 | |
| David Meermans | david.meermans&aastra.com | ||
| Derick Snyder | dsnyder&rainbow.com | ||
| Dirk Stoop | dirk&madebysofa.com | 2007-04 | |
| Greg Bodine | gregory.bodine&ca.com | 2002-02 | |
| Greg Porter | gporter&powerschool.com | ||
| heroicrobotics.com | jasmine&heroicrobotics.com | 2014-06-24 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| James Goddard | jamesg&taglim.com | 2005-08 | |
| Jasmine Strong | heroicrobotics.com | jasmine&heroicrobotics.com | 2014-06-24 |
| Jean-Pierre Garcia | jp.garcia&netia.com | 2009-10-28 | |
| Jeffrey Hill | johill&lanl.gov | 2002-08 | |
| Jeroen Massar | jeroen&unfix.org | 2005-08 | |
| Joachim Kluemper | ports&raikosoft.com | 2008-03-19 | |
| Ken Wittmer | kenneth.m.wittmer&accenture.com | ||
| Kory Hamzeh | kory&ascend.com | ||
| Lucas Lorensi | lucas.lorensi&powersyslab.com | 2015-07-20 | |
| Marc Morin | mmorin&sdlintl.com | 2002-04 | |
| Margaret Cullen | mrcullen42&gmail.com | 2023-06-07 | |
| Matej Sekoranja | matej.sekoranja&cosylab.com | 2012-03-23 | |
| MERG | merg&upsys.co.uk | 2017-01-03 | |
| Paul Dietrich | registrar&impinj.com | ||
| Paul Moore | paul.moore¢rify.com | 2009-10-28 | |
| Pete Brownlow | merg&upsys.co.uk | 2017-01-03 | |
| Peter Waher | Waher Data AB | peterwaher&hotmail.com | 2015-11-25 |
| Phil Maker | pjm&gnu.org | 2008-06-18 | |
| PowerSysLab | info&powersyslab.com | 2015-07-20 | |
| Reinder Feenstra | r.feenstra&tiepie.nl | 2016-04-01 | |
| Richard Warren | richard&cambridgepixel.com | 2008-09-17 | |
| Rickard Berg | rickard.berg&fmv.se | 2025-10-22 | |
| Ron Zalkind | ron&aprigo.com | 2010-05-28 | |
| Tim Maloney | tim.maloney&allianceconsultingllc.com | 2005-08 | |
| TiePie engineering | tiepie&tiepie.nl | 2016-04-01 | |
| Ville-Pekka Vahteala | ville-pekka.vahteala&bitcomp.fi | 2008-06-05 | |
| Waher Data AB | peterwaher&hotmail.com | 2015-11-25 | |
| Wally Pratt Jr | wpratt&fieldcommgroup.org | 2012-12-14 |