Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| dns-llq | 5352 | udp | DNS Long-Lived Queries | Stuart Cheshire | Stuart Cheshire | 2005-08 | 2019-08-26 | RFC 8764 | |||
| 5451-5452 | Unassigned | ||||||||||
| 5551-5552 | Unassigned | ||||||||||
| coap | 5683 | udp | Constrained Application Protocol | IESG | IETF Chair | 2011-06-13 | 2013-07-25 | RFC 7252 | |||
| coaps | 5684 | udp | DTLS-secured CoAP | IESG | IETF Chair | 2013-07-25 | RFC 7252 | ||||
| tl1-ssh | 6252 | tcp | TL1 over SSH | Jim Humphreys | Jim Humphreys | 2008-01-25 | |||||
| tl1-ssh | 6252 | udp | TL1 over SSH | Jim Humphreys | Jim Humphreys | 2008-01-25 | |||||
| 6552-6555 | Unassigned | ||||||||||
| 6641-6652 | Unassigned | ||||||||||
| 6952-6960 | Unassigned | ||||||||||
| pon-ictp | 7202 | tcp | Inter-Channel Termination Protocol (ICTP) for multi-wavelength PON (Passive Optical Network) systems | Broadband Forum | Broadband Forum | 2017-02-22 | 2019-12-16 | TR-352; Inter-Channel-Termination protocol (ICTP) is a peer-to-peer protocol with a binary message format that is used by a set of optical line terminal (OLT) channel terminations (CT) comprising a 40-Gigabit-capable next-generation passive optical network (NG-PON2) system to exchange channel profile configuration and status information and to coordinate the operation of tunable optical network units (ONUs) in a multi-wavelength channel environment. | |||
| 7552-7559 | Unassigned | ||||||||||
| senomix01 | 8052 | tcp | Senomix Timesheets Server | Charles O'Dale | Charles O'Dale | 2006-07 | |||||
| senomix01 | 8052 | udp | Senomix Timesheets Server | Charles O'Dale | Charles O'Dale | 2006-07 | |||||
| 8150-8152 | Unassigned | ||||||||||
| 8352-8375 | Unassigned | ||||||||||
| 8938-8952 | Unassigned | ||||||||||
| 9052-9059 | Unassigned | ||||||||||
| 9501-9521 | Unassigned | ||||||||||
| 9522 | tcp | Reserved | |||||||||
| sma-spw | 9522 | udp | SMA Speedwire | SMA Solar Techology AG | SMA Solar Techology AG | 2011-03-08 | |||||
| 9523-9534 | Unassigned | ||||||||||
| 9751-9752 | Unassigned | ||||||||||
| apc-9952 | 9952 | tcp | APC 9952 | American Power Conversion | American Power Conversion | ||||||
| apc-9952 | 9952 | udp | APC 9952 | American Power Conversion | American Power Conversion | ||||||
| 10052-10054 | Unassigned | ||||||||||
| apollo-relay | 10252 | tcp | Apollo Relay Port | Anthony Carrabino | Anthony Carrabino | 2003-08 | |||||
| apollo-relay | 10252 | udp | Apollo Relay Port | Anthony Carrabino | Anthony Carrabino | 2003-08 | |||||
| 11752-11795 | Unassigned | ||||||||||
| 12547-12752 | Unassigned | ||||||||||
| 21338-21552 | Unassigned | ||||||||||
| 22352-22536 | Unassigned | ||||||||||
| 22952-22999 | Unassigned | ||||||||||
| 23006-23052 | Unassigned | ||||||||||
| 36463-36523 | Unassigned | ||||||||||
| febooti-aw | 36524 | tcp | Febooti Automation Workshop | Maris Bormanis | Maris Bormanis | 2011-06-10 | |||||
| 36524 | udp | Reserved | |||||||||
| 36525-36601 | Unassigned | ||||||||||
| 40844-40852 | Unassigned | ||||||||||
| 44545-44552 | Unassigned | ||||||||||
| 48620-48652 | Unassigned | ||||||||||
| carddav | tcp | vCard Extensions to WebDAV (CardDAV) - non-TLS | IESG | IETF Chair | 2012-02-17 | RFC 6352 | This is an extension of the http service. Defined TXT keys: path=<context path> | ||||
| carddavs | tcp | vCard Extensions to WebDAV (CardDAV) - over TLS | IESG | IETF Chair | 2012-02-17 | RFC 6352 | This is an extension of the https service. Defined TXT keys: path=<context path> | ||||
| jnx-kcsync | tcp | jollys keychain cloud sync protocol | Patrick Stein | Patrick Stein | 2011-10-24 | Defined TXT keys: hash=<40hex characters> salt=<40hex characters> uuid=<40hex characters> Example: hash=5e7580598c0d7064d4fc79faaeb42585e1a675f8 salt=f0164cb3a0c3d7efe75abea8fda86d2d56c8dda9 uuid=db61dc092922252e45bbb264f59147138c7fd5fa | |||||
| lontalk | LonTalk over IP (ANSI 852) | Michael Tennefoss | Michael Tennefoss | Defined TXT keys: None |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| American Power Conversion | ports&apcc.com | 2002-02 | |
| Anthony Carrabino | anthonyc&vistasoftware.com | 2003-08 | |
| Broadband Forum | help&broadband-forum.org | 2020-03-17 | |
| Charles O'Dale | codale&hfx.andara.com | 2006-07 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Jim Humphreys | jhumphre&ciena.com | 2008-01-29 | |
| Maris Bormanis | info&febooti.com | 2011-06-10 | |
| Michael Tennefoss | mtennefoss&echelon.com | ||
| Patrick Stein | Patrick.Stein&jinx.eu | 2011-10-24 | |
| SMA Solar Techology AG | thomas.weber&sma.de | 2011-03-08 | |
| Stuart Cheshire | cheshire&apple.com | 2022-07-11 |