Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
crip 6253 tcp CRIP Mike Rodbell Mike Rodbell
crip 6253 udp CRIP Mike Rodbell Mike Rodbell
openflow 6653 tcp OpenFlow Open Networking Foundation Puneet Agarwal 2013-07-18
openflow 6653 udp OpenFlow Open Networking Foundation Puneet Agarwal 2013-07-18
senomix02 8053 tcp Senomix Timesheets Client [1 year assignment] Charles O'Dale Charles O'Dale 2006-07
senomix02 8053 udp Senomix Timesheets Client [1 year assignment] Charles O'Dale Charles O'Dale 2006-07
quantastor 8153 tcp QuantaStor Management Interface OS NEXUS, Inc. Steven Umbehocker 2012-09-21
8153 udp Reserved
8504-8553 Unassigned
ub-dns-control 8953 tcp unbound dns nameserver control NLnet Labs Support NLnet Labs Support 2011-05-10 2011-07-11
8953 udp Reserved
9523-9534 Unassigned
mngsuite 9535 tcp Management Suite Remote Control Trevor Perkes Trevor Perkes 2010-02-01
mngsuite 9535 udp Management Suite Remote Control Trevor Perkes Trevor Perkes 2010-02-01
laes-bf 9536 tcp Surveillance buffering function Glen Myers Glen Myers 2007-05
laes-bf 9536 udp Surveillance buffering function Glen Myers Glen Myers 2007-05
9537-9554 Unassigned
rasadv 9753 tcp rasadv Dave Thaler Dave Thaler
rasadv 9753 udp rasadv Dave Thaler Dave Thaler
enrp-sctp 9901 sctp enrp server channel RFC 5353
enrp-sctp-tls 9902 sctp enrp/tls server channel RFC 5353
acis 9953 tcp 9953 Thomas Guth Thomas Guth 2006-01
acis 9953 udp 9953 Thomas Guth Thomas Guth 2006-01
snmptls 10161 tcp SNMP-TLS RFC 6353
snmpdtls 10161 udp SNMP-DTLS RFC 6353
snmptls-trap 10162 tcp SNMP-Trap-TLS RFC 6353
snmpdtls-trap 10162 udp SNMP-Trap-DTLS RFC 6353
eapol-relay 10253 udp Relay of EAPOL frames Wi-SUN Alliance Phil Beecher 2015-06-26
10253 tcp Reserved
10501-10539 Unassigned
tsaf 12753 tcp tsaf port Andreas Fehr Andreas Fehr
tsaf 12753 udp tsaf port Andreas Fehr Andreas Fehr
14151-14153 Unassigned
15119-15344 Unassigned
xpilot 15345 tcp XPilot Contact Port Bert Gijsbers Bert Gijsbers
xpilot 15345 udp XPilot Contact Port Bert Gijsbers Bert Gijsbers
15346-15362 Unassigned
3link 15363 tcp 3Link Negotiation Brant Thomsen Brant Thomsen 2003-01
3link 15363 udp 3Link Negotiation Brant Thomsen Brant Thomsen 2003-01
15364-15554 Unassigned
17730-17753 Unassigned
19413-19538 Unassigned
fxuptp 19539 tcp FXUPTP Keiji Okuma Keiji Okuma 2005-08
fxuptp 19539 udp FXUPTP Keiji Okuma Keiji Okuma 2005-08
rdm-tfs 21553 tcp Raima RDM TFS Paul Johnson Paul Johnson 2011-05-02
21553 udp Reserved
22352-22536 Unassigned
caldsoft-backup 22537 tcp CaldSoft Backup server file transfer CaldSoft Mark Caldwell 2011-08-12
22537 udp Reserved
22538-22554 Unassigned
gntp 23053 tcp Generic Notification Transport Protocol The Growl Project Chris Forsythe 2012-02-07
23053 udp Reserved
24466-24553 Unassigned
24728-24753 Unassigned
25904-25953 Unassigned
33436-33655 Unassigned Known Unauthorized Use on ports 33436-33534
35101-35353 Unassigned
kitim 35354 tcp KIT Messenger Rudi Visser Rudi Visser 2011-07-07
35354 udp Reserved
altova-lm 35355 tcp Altova License Management Alexander Falk Alexander Falk 2011-07-07
altova-lm-disc 35355 udp Altova License Management Discovery Alexander Falk Alexander Falk 2011-07-07
guttersnex 35356 tcp Gutters Note Exchange Squee! Application Development Tristan Seifert 2011-07-19
35356 udp Reserved
openstack-id 35357 tcp OpenStack ID Service Rackspace Hosting Ziad Sawalha 2011-08-15
35357 udp Reserved
35358-36000 Unassigned
37602-37653 Unassigned
40853 tcp Reserved
ortec-disc 40853 udp ORTEC Service Discovery Jesse Ursery Jesse Ursery 2010-11-22
44323 udp Unassigned "pcp" assignment withdrawn, moved to port 5351 per RFC 6887
rbr-debug 44553 tcp REALbasic Remote Debug Aaron Ballman Aaron Ballman 2004-11
rbr-debug 44553 udp REALbasic Remote Debug Aaron Ballman Aaron Ballman 2004-11
45046-45053 Unassigned
robotraconteur 48653 tcp Robot Raconteur transport Wason Technology, LLC John Wason 2014-01-27
robotraconteur 48653 udp Robot Raconteur transport Wason Technology, LLC John Wason 2014-01-27
dns-update tcp DNS Dynamic Update Service Stuart Cheshire Stuart Cheshire 2019-05-04 DNS Dynamic Update Service for a given domain may not necessarily be provided by the principal name servers as advertised by the domain's "NS" records, and may not necessarily always be provided on port 53. The "_dns-update._udp.<domain>." SRV record gives the target host and port where DNS Dynamic Update Service is provided for the named domain.
dns-update udp DNS Dynamic Update Service Stuart Cheshire Stuart Cheshire 2019-05-04 DNS Dynamic Update Service for a given domain may not necessarily be provided by the principal name servers as advertised by the domain's "NS" records, and may not necessarily always be provided on port 53. The "_dns-update._udp.<domain>." SRV record gives the target host and port where DNS Dynamic Update Service is provided for the named domain.
dns-update-tls tcp DNS Dynamic Update Service over TLS Stuart Cheshire Stuart Cheshire 2019-05-04 RFC 6281 DNS Dynamic Update Service for a given domain may not necessarily be provided by the principal name servers as advertised by the domain's "NS" records, and may not necessarily always be provided on port 53. The "_dns-update._udp.<domain>." SRV record gives the target host and port where DNS Dynamic Update Service is provided for the named domain.
lobby Gobby 0x539 dev group 0x539 dev group Defined TXT keys: None

Contact Information

Name Organization Contact URI Last Updated
Aaron Ballman aaron&realsoftware.com 2004-11
Alexander Falk Altova, Inc. al&altova.com 2011-07-07
Andreas Fehr andreas&mrs.ch
Bert Gijsbers bert&xpilot.org
Brant Thomsen brant_thomsen&3com.com 2003-01
CaldSoft development&caldsoft.co.uk 2011-08-12
Charles O'Dale codale&hfx.andara.com 2006-07
Chris Forsythe The Growl Project chris&growl.info 2012-02-07
Dave Thaler dthaler&microsoft.com
Glen Myers glen.myers&ipfabrics.com 2007-05
0x539 dev group http://darcs.0x539.de/trac/obby/cgi-bin/trac.cgi
The Growl Project support&growl.info 2012-02-07
Jesse Ursery jesse.ursery&ametek.com 2010-11-22
John Wason Wason Technology, LLC wason&wasontech.com 2014-01-27
Keiji Okuma okuma&silex.jp 2005-08
Mark Caldwell development&caldsoft.co.uk 2011-08-12
Mike Rodbell mrodbell&ciena.com
NLnet Labs Support NLnet Labs support&nlnetlabs.nl 2011-07-11
Open Networking Foundation iana&opennetworking.org 2013-07-18
OS NEXUS, Inc. info&osnexus.com 2012-09-21
Paul Johnson paul.johnson&raima.com 2011-05-02
Phil Beecher Wi-SUN Alliance pbeecher&wi-sun.org 2015-06-26
Puneet Agarwal pagarwal&broadcom.com 2013-07-18
Rackspace Hosting ziad.sawalha&rackspace.com 2011-08-15
Rudi Visser rudi.visser&ljund.eu 2011-07-07
Squee! Application Development tristan&squee.co 2011-07-19
Steven Umbehocker OS NEXUS, Inc. steven.umbehocker&osnexus.com 2012-09-21
Stuart Cheshire cheshire&apple.com 2022-07-11
Thomas Guth t.guth&zeiss.de 2006-01
Trevor Perkes trevor.perkes&landesk.com 2010-02-01
Tristan Seifert Squee! Application Development tristan&squee.co 2011-07-19
Wason Technology, LLC wason&wasontech.com 2014-01-27
Wi-SUN Alliance admin&wi-sun.org 2015-06-26
Ziad Sawalha Rackspace Hosting ziad.sawalha&rackspace.com 2011-08-15