Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 7550 | tcp | Reserved | |||||||||
| cloudsignaling | 7550 | udp | Cloud Signaling Service | Scott Dawson | Scott Dawson | 2011-07-01 | |||||
| controlone-con | 7551 | tcp | ControlONE Console signaling | BYNE | Andre Nazario | 2014-11-07 | 2017-06-13 | ||||
| 7551 | udp | Reserved | |||||||||
| 7552-7559 | Unassigned | ||||||||||
| senomix04 | 8055 | tcp | Senomix Timesheets Server [1 year assignment] | Charles O'Dale | Charles O'Dale | 2006-07 | |||||
| senomix04 | 8055 | udp | Senomix Timesheets Server [1 year assignment] | Charles O'Dale | Charles O'Dale | 2006-07 | |||||
| pim-port | 8471 | tcp | PIM over Reliable Transport | IESG | IETF Chair | 2008-08-21 | RFC 6559 | ||||
| pim-port | 8471 | sctp | PIM over Reliable Transport | IESG | IETF Chair | 2008-08-21 | RFC 6559 | ||||
| 8504-8553 | Unassigned | ||||||||||
| rtsp-alt | 8554 | tcp | RTSP Alternate (see port 554) | Stephen Casner | Stephen Casner | ||||||
| rtsp-alt | 8554 | udp | RTSP Alternate (see port 554) | Stephen Casner | Stephen Casner | ||||||
| d-fence | 8555 | tcp | SYMAX D-FENCE | Thomas Geisel | Thomas Geisel | 2003-01 | |||||
| d-fence | 8555 | udp | SYMAX D-FENCE | Thomas Geisel | Thomas Geisel | 2003-01 | |||||
| 8556-8566 | Unassigned | ||||||||||
| 8955-8979 | Unassigned | ||||||||||
| mon | 9255 | tcp | Manager On Network | David Rouchet | David Rouchet | 2007-05 | |||||
| mon | 9255 | udp | Manager On Network | David Rouchet | David Rouchet | 2007-05 | |||||
| 9537-9554 | Unassigned | ||||||||||
| trispen-sra | 9555 | tcp | Trispen Secure Remote Access | Jaco Botha | Jaco Botha | 2004-11 | |||||
| trispen-sra | 9555 | udp | Trispen Secure Remote Access | Jaco Botha | Jaco Botha | 2004-11 | |||||
| 9556-9558 | Unassigned | ||||||||||
| p4runtime | 9559 | tcp | P4Runtime gRPC Service | Open Networking Foundation | Antonin Bas | 2020-09-22 | |||||
| 9559 | udp | Reserved | |||||||||
| alljoyn-stm | 9955 | tcp | Contact Port for AllJoyn standard messaging | Qualcomm Innovation Center, Inc. | Craig Dowell | 2012-03-14 | |||||
| alljoyn-mcm | 9955 | udp | Contact Port for AllJoyn multiplexed constrained messaging | Qualcomm Innovation Center, Inc. | Craig Dowell | 2012-03-14 | |||||
| qptlmd | 10055 | tcp | Quantapoint FLEXlm Licensing Service | Justin Vegso | Justin Vegso | 2010-07-01 | |||||
| 10055 | udp | Reserved | |||||||||
| 14155-14249 | Unassigned | ||||||||||
| 15364-15554 | Unassigned | ||||||||||
| cisco-snat | 15555 | tcp | Cisco Stateful NAT | Kaushik Biswas | Kaushik Biswas | 2006-03 | |||||
| cisco-snat | 15555 | udp | Cisco Stateful NAT | Kaushik Biswas | Kaushik Biswas | 2006-03 | |||||
| 15556-15659 | Unassigned | ||||||||||
| 17501-17554 | Unassigned | ||||||||||
| ailith | 17555 | tcp | Ailith management of routers | Thomas Boje | Thomas Boje | 2014-03-27 | |||||
| 17555 | udp | Reserved | |||||||||
| 17556-17728 | Unassigned | ||||||||||
| zigbee-ip | 17755 | tcp | ZigBee IP Transport Service | Chris Herzog | Chris Herzog | 2006-05 | |||||
| zigbee-ip | 17755 | udp | ZigBee IP Transport Service | Chris Herzog | Chris Herzog | 2006-05 | |||||
| 21338-21552 | Unassigned | ||||||||||
| rdm-tfs | 21553 | tcp | Raima RDM TFS | Paul Johnson | Paul Johnson | 2011-05-02 | |||||
| 21553 | udp | Reserved | |||||||||
| dfserver | 21554 | tcp | MineScape Design File Server | Michael Purser | Michael Purser | 2006-06 | |||||
| dfserver | 21554 | udp | MineScape Design File Server | Michael Purser | Michael Purser | 2006-06 | |||||
| 21555-21589 | Unassigned | ||||||||||
| 22538-22554 | Unassigned | ||||||||||
| vocaltec-wconf | 22555 | tcp | Vocaltec Web Conference | Scott Petrack | Scott Petrack | ||||||
| vocaltec-phone | 22555 | udp | Vocaltec Internet Phone | Scott Petrack | Scott Petrack | ||||||
| 22556-22762 | Unassigned | ||||||||||
| 23403-23455 | Unassigned | ||||||||||
| 24466-24553 | Unassigned | ||||||||||
| binkp | 24554 | tcp | BINKP | Maxim Masiutin | Maxim Masiutin | 2020-06-02 | |||||
| binkp | 24554 | udp | BINKP | Maxim Masiutin | Maxim Masiutin | 2020-06-02 | |||||
| 24555-24576 | Unassigned | ||||||||||
| 24755-24849 | Unassigned | ||||||||||
| 25472-25575 | Unassigned | ||||||||||
| sauterdongle | 25576 | tcp | Sauter Dongle | Christian Brecht | Christian Brecht | 2010-12-15 | |||||
| 25576 | udp | Reserved | |||||||||
| 25577-25603 | Unassigned | ||||||||||
| bf-master | 25955 | udp | Bitfighter master server | Christopher Eykamp | Christopher Eykamp | 2012-08-16 | |||||
| 25955 | tcp | Reserved | |||||||||
| 33436-33655 | Unassigned | Known Unauthorized Use on ports 33436-33534 | |||||||||
| altova-lm | 35355 | tcp | Altova License Management | Alexander Falk | Alexander Falk | 2011-07-07 | |||||
| altova-lm-disc | 35355 | udp | Altova License Management Discovery | Alexander Falk | Alexander Falk | 2011-07-07 | |||||
| 37655-37999 | Unassigned | ||||||||||
| 44545-44552 | Unassigned | ||||||||||
| rbr-debug | 44553 | tcp | REALbasic Remote Debug | Aaron Ballman | Aaron Ballman | 2004-11 | |||||
| rbr-debug | 44553 | udp | REALbasic Remote Debug | Aaron Ballman | Aaron Ballman | 2004-11 | |||||
| 44554-44599 | Unassigned | ||||||||||
| 45055-45184 | Unassigned | ||||||||||
| 45186-45513 | Unassigned | ||||||||||
| cloudcheck | 45514 | tcp | ASSIA CloudCheck WiFi Management System | ASSIA Inc. | Leonardo Dagum | 2016-08-29 | |||||
| cloudcheck-ping | 45514 | udp | ASSIA CloudCheck WiFi Management keepalive | ASSIA Inc. | Leonardo Dagum | 2016-08-29 | |||||
| 45515-45677 | Unassigned | ||||||||||
| 47101-47556 | Unassigned | ||||||||||
| dbbrowse | 47557 | tcp | Databeam Corporation | Cindy Martin | Cindy Martin | ||||||
| dbbrowse | 47557 | udp | Databeam Corporation | Cindy Martin | Cindy Martin | ||||||
| 47558-47623 | Unassigned | ||||||||||
| 48130-48555 | Unassigned | ||||||||||
| com-bardac-dw | 48556 | tcp | com-bardac-dw | Nicholas J Howes | Nicholas J Howes | ||||||
| com-bardac-dw | 48556 | udp | com-bardac-dw | Nicholas J Howes | Nicholas J Howes | ||||||
| 48557-48618 | Unassigned |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Aaron Ballman | aaron&realsoftware.com | 2004-11 | |
| Alexander Falk | Altova, Inc. | al&altova.com | 2011-07-07 |
| Andre Nazario | andre.nazario&byne.com.br | 2017-06-13 | |
| Antonin Bas | Open Networking Foundation | antonin.bas&gmail.com | 2020-09-22 |
| ASSIA Inc. | info&assia-inc.com | 2016-08-29 | |
| BYNE | devel&byne.com.br | 2017-06-13 | |
| Charles O'Dale | codale&hfx.andara.com | 2006-07 | |
| Chris Herzog | zog&stg.com | 2006-05 | |
| Christian Brecht | Christian.Brecht&sauter-gmbh.de | 2010-12-15 | |
| Christopher Eykamp | chris&eykamp.com | 2012-08-16 | |
| Cindy Martin | cmartin&databeam.com | ||
| Craig Dowell | Qualcomm Innovation Center, Inc. | cdowell&quicinc.com | 2011-12-21 |
| David Rouchet | david.rouchet&medialon.com | 2007-05 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Jaco Botha | jaco.botha&trispen.com | 2004-11 | |
| Justin Vegso | jvegso&quantapoint.com | 2010-07-01 | |
| Kaushik Biswas | kbiswas&cisco.com | 2006-03 | |
| Leonardo Dagum | ldagum&assia-inc.com | 2016-08-29 | |
| Maxim Masiutin | maxim.masiutin&gmail.com | 2020-06-02 | |
| Michael Purser | mrp&mincom.com | 2006-06 | |
| Nicholas J Howes | nick&ghostwood.org | ||
| Open Networking Foundation | iana&opennetworking.org | 2013-07-18 | |
| Paul Johnson | paul.johnson&raima.com | 2011-05-02 | |
| Qualcomm Innovation Center, Inc. | cdowell&quicinc.com | 2011-12-21 | |
| Scott Dawson | sdawson&arbor.net | 2011-07-01 | |
| Scott Petrack | Scott_Petrack&vocaltec.com | ||
| Stephen Casner | casner&precept.com | ||
| Thomas Boje | thomas.boje&gmx.de | 2014-03-27 | |
| Thomas Geisel | tgeisel&symax.de | 2003-01 |