Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-27

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
3par-mgmt-ssl 5783 udp 3PAR Management Service with SSL Don Marselle Don Marselle 2008-03-19
5784 tcp Reserved
ibar 5784 udp Cisco Interbox Application Redundancy Cullen Jennings Cullen Jennings 2010-02-03
3par-rcopy 5785 tcp 3PAR Inform Remote Copy Don Marselle Don Marselle 2010-02-03
3par-rcopy 5785 udp 3PAR Inform Remote Copy Don Marselle Don Marselle 2008-04-09
5786 tcp Reserved
cisco-redu 5786 udp redundancy notification Ming Zhang Ming Zhang 2010-02-04
5787 tcp Reserved
waascluster 5787 udp Cisco WAAS Cluster Protocol Winston Chou Winston Chou 2011-02-08
5788-5792 Unassigned
xtreamx 5793 tcp XtreamX Supervised Peer message Ahmad Tajuddin Samsudin Ahmad Tajuddin Samsudin 2007-02
xtreamx 5793 udp XtreamX Supervised Peer message Ahmad Tajuddin Samsudin Ahmad Tajuddin Samsudin 2007-02
5794 tcp Reserved
spdp 5794 udp Simple Peered Discovery Protocol Dave Lindquist Dave Lindquist 2010-05-27
5795-5797 Unassigned
enlabel-dpl 5798 tcp Proprietary Website deployment service enLabel Global Services Clay S. Didier 2021-10-12
5798 udp Reserved
5799-5812 Unassigned
6457-6463 Unassigned
6557 Unassigned
6569-6578 Unassigned
affiliate 6579 tcp Affiliate David Catmull David Catmull 2006-01
affiliate 6579 udp Affiliate David Catmull David Catmull 2006-01
6657 tcp Reserved
palcom-disc 6657 udp PalCom Discovery Boris Magnusson Boris Magnusson 2010-12-06
aries-kfinder 7570 tcp Aries Kfinder James King III James King III
aries-kfinder 7570 udp Aries Kfinder James King III James King III
7571-7573 Unassigned
coherence 7574 tcp Oracle Coherence Cluster Service Oracle Mark Falco 2014-07-09
coherence-disc 7574 udp Oracle Coherence Cluster discovery service Oracle Mark Falco 2014-07-09
wtmi-panel 7575 tcp Main access port for WTMI Panel WTMI LLC Jay Dubinsky 2024-08-13
7575 udp Reserved
7576-7587 Unassigned
senomix06 8057 tcp Senomix Timesheets Client [1 year assignment] Charles O'Dale Charles O'Dale 2006-07
senomix06 8057 udp Senomix Timesheets Client [1 year assignment] Charles O'Dale Charles O'Dale 2006-07
nexentamv 8457 tcp Nexenta Management GUI John S. Howard Andrew Galloway 2012-12-07
8457 udp Reserved
9957-9965 Unassigned
hip-nat-t 10500 udp HIP NAT-Traversal IESG IETF Chair 2020-08-12 RFC 5770; RFC 9028
15661-15739 Unassigned
ptp 15740 tcp Picture Transfer Protocol Petronel Bigioi Petronel Bigioi 2004-11 Defined TXT keys: guid=<Device guid>
ptp 15740 udp Picture Transfer Protocol Petronel Bigioi Petronel Bigioi 2004-11 Defined TXT keys: guid=<Device guid>
15741-15997 Unassigned
17757-17776 Unassigned
avesterra 20057 tcp AvesTerra Hypergraph Transfer Protocol (HGTP) Georgetown University J.C. Smart 2016-06-06
20057 udp Reserved
aequus-alt 23457 tcp Aequus Service Mgmt James Anson James Anson 2009-02-12
23457 udp Reserved
24555-24576 Unassigned
bilobit 24577 tcp bilobit Service bilobit GmbH Martin Schmuker 2014-08-15
bilobit-update 24577 udp bilobit Service Update bilobit GmbH Martin Schmuker 2014-08-15
24578-24600 Unassigned
25472-25575 Unassigned
sauterdongle 25576 tcp Sauter Dongle Christian Brecht Christian Brecht 2010-12-15
25576 udp Reserved
25577-25603 Unassigned
25605-25792 Unassigned
vocaltec-hos 25793 tcp Vocaltec Address Server Scott Petrack Scott Petrack
vocaltec-hos 25793 udp Vocaltec Address Server Scott Petrack Scott Petrack
25794-25899 Unassigned
cockroach 26257 tcp CockroachDB Cockroach Labs, Inc. Ben_Darnell 2015-09-29
26257 udp Reserved
tetrinet 31457 tcp TetriNET Protocol Emmanuel Bourg Emmanuel Bourg 2004-11
tetrinet 31457 udp TetriNET Protocol Emmanuel Bourg Emmanuel Bourg 2004-11
33657-33889 Unassigned
openstack-id 35357 tcp OpenStack ID Service Rackspace Hosting Ziad Sawalha 2011-08-15
35357 udp Reserved
dbbrowse 47557 tcp Databeam Corporation Cindy Martin Cindy Martin
dbbrowse 47557 udp Databeam Corporation Cindy Martin Cindy Martin
48557-48618 Unassigned
dccp-ping dccp ping/traceroute using DCCP Samuel Jero Samuel Jero 2012-11-14 1885957735 Defined TXT keys: None
sztp tcp This service name is used to construct the SRV service label "_sztp" for discovering SZTP bootstrap servers. IESG IETF Chair 2019-01-17 RFC 8572 This protocol uses HTTPS as a substrate.

Contact Information

Name Organization Contact URI Last Updated
Ahmad Tajuddin Samsudin tajuddin&tmrnd.com.my 2007-02
Andrew Galloway Nexenta andrew.galloway&nexenta.com 2012-12-07
ben&cockroachlabs.com 2015-09-29
bilobit GmbH ms&bilobit.com 2014-08-15
Boris Magnusson boris&cs.lth.se 2010-12-06
Charles O'Dale codale&hfx.andara.com 2006-07
Christian Brecht Christian.Brecht&sauter-gmbh.de 2010-12-15
Cindy Martin cmartin&databeam.com
Clay S. Didier enLabel Global Services cdidier&enlabel.com 2021-10-12
Cockroach Labs, Inc. iana-contact&cockroachlabs.com 2015-09-29
Cullen Jennings fluffy&cisco.com 2010-02-03
Dave Lindquist dlindquist&egistix.com 2010-05-27
David Catmull uncommon&uncommonplace.com 2006-01
Don Marselle don.marselle&3par.com 2008-04-09
Emmanuel Bourg smanux&lfjr.net 2004-11
enLabel Global Services support&enlabel.com 2021-10-12
Georgetown University smart&georgetown.edu 2016-06-06
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
J.C. Smart smart&georgetown.edu 2016-06-06
James Anson janson&bigpond.com 2009-02-12
James King III jking&ariessys.com
Jay Dubinsky WTMI LLC jay&wtmi.com 2024-08-13
Mark Falco Oracle mark.falco&oracle.com 2014-07-09
Martin Schmuker bilobit GmbH ms&bilobit.com 2014-08-15
Ming Zhang mzhang&cisco.com 2010-02-04
John S. Howard Nexenta jsh&nexenta.com 2012-12-07
Oracle mark.falco&oracle.com 2014-07-09
Petronel Bigioi petronel&fotonation.com 2004-11
Rackspace Hosting ziad.sawalha&rackspace.com 2011-08-15
Samuel Jero sj323707&ohio.edu 2012-11-14
Scott Petrack Scott_Petrack&vocaltec.com
Winston Chou wichou&cisco.com 2011-02-08
WTMI LLC engineering&wtmi.com 2024-08-13
Ziad Sawalha Rackspace Hosting ziad.sawalha&rackspace.com 2011-08-15