Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
oob-ws-http 623 tcp DMTF out-of-band web services management protocol Jim Davis Jim Davis 2007-06
asf-rmcp 623 udp ASF Remote Management and Control Protocol Carl First Carl First
cryptoadmin 624 tcp Crypto Admin Tony Walker Tony Walker
cryptoadmin 624 udp Crypto Admin Tony Walker Tony Walker
dec-dlm 625 tcp DEC DLM

IANA assigned this well-formed service name as a replacement for "dec_dlm".
Rudi Martin Rudi Martin
dec_dlm 625 tcp DEC DLM Rudi Martin Rudi Martin This entry is an alias to "dec-dlm". This entry is now historic, not usable for use with many common service discovery mechanisms.
dec-dlm 625 udp DEC DLM

IANA assigned this well-formed service name as a replacement for "dec_dlm".
Rudi Martin Rudi Martin
dec_dlm 625 udp DEC DLM Rudi Martin Rudi Martin This entry is an alias to "dec-dlm". This entry is now historic, not usable for use with many common service discovery mechanisms.
asia 626 tcp ASIA Michael Dasenbrock Michael Dasenbrock
asia 626 udp ASIA Michael Dasenbrock Michael Dasenbrock
passgo-tivoli 627 tcp PassGo Tivoli John Rainford John Rainford
passgo-tivoli 627 udp PassGo Tivoli John Rainford John Rainford
qmqp 628 tcp QMQP D. J. Bernstein D. J. Bernstein 2018-04-05
qmqp 628 udp QMQP D. J. Bernstein D. J. Bernstein 2018-04-05
3com-amp3 629 tcp 3Com AMP3 Prakash Banthia Prakash Banthia
3com-amp3 629 udp 3Com AMP3 Prakash Banthia Prakash Banthia
rda 630 tcp RDA John Hadjioannou John Hadjioannou
rda 630 udp RDA John Hadjioannou John Hadjioannou
ipp 631 tcp IPP (Internet Printing Protocol) IESG IETF Chair 2018-07-06 RFC 8011 Defined TXT keys: See BonjourPrinting.pdf.
ipp 631 udp IPP (Internet Printing Protocol) IESG IETF Chair 2018-07-06 RFC 8011 Defined TXT keys: See BonjourPrinting.pdf.
ipps 631 tcp Internet Printing Protocol over HTTPS IESG IETF Chair 2018-07-06 RFC 8011
bmpp 632 tcp bmpp Troy Rollo Troy Rollo
bmpp 632 udp bmpp Troy Rollo Troy Rollo
servstat 633 tcp Service Status update (Sterling Software) Greg Rose Greg Rose
servstat 633 udp Service Status update (Sterling Software) Greg Rose Greg Rose
ginad 634 tcp ginad Mark Crother Mark Crother
ginad 634 udp ginad Mark Crother Mark Crother
rlzdbase 635 tcp RLZ DBase Michael Ginn Michael Ginn
rlzdbase 635 udp RLZ DBase Michael Ginn Michael Ginn
ldaps 636 tcp ldap protocol over TLS/SSL (was sldap) Pat Richard Pat Richard
ldaps 636 udp ldap protocol over TLS/SSL (was sldap) Pat Richard Pat Richard
lanserver 637 tcp lanserver Chris Larsson Chris Larsson
lanserver 637 udp lanserver Chris Larsson Chris Larsson
mcns-sec 638 tcp mcns-sec Kaz Ozawa Kaz Ozawa
mcns-sec 638 udp mcns-sec Kaz Ozawa Kaz Ozawa
msdp 639 tcp MSDP Dino Farinacci Dino Farinacci
msdp 639 udp MSDP Dino Farinacci Dino Farinacci
entrust-sps 640 tcp entrust-sps Marek Buchler Marek Buchler
entrust-sps 640 udp entrust-sps Marek Buchler Marek Buchler
repcmd 641 tcp repcmd Scott Dale Scott Dale
repcmd 641 udp repcmd Scott Dale Scott Dale
esro-emsdp 642 tcp ESRO-EMSDP V1.3 Mohsen Banan Mohsen Banan
esro-emsdp 642 udp ESRO-EMSDP V1.3 Mohsen Banan Mohsen Banan
sanity 643 tcp SANity Peter Viscarola Peter Viscarola
sanity 643 udp SANity Peter Viscarola Peter Viscarola
dwr 644 tcp dwr Bill Fenner Bill Fenner
dwr 644 udp dwr Bill Fenner Bill Fenner
pssc 645 tcp PSSC Egon Meier-Engelen Egon Meier-Engelen
pssc 645 udp PSSC Egon Meier-Engelen Egon Meier-Engelen
ldp 646 tcp LDP Bob Thomas Bob Thomas
ldp 646 udp LDP Bob Thomas Bob Thomas
dhcp-failover 647 tcp DHCP Failover IESG IETF Chair 2018-05-21 RFC 8156
dhcp-failover 647 udp DHCP Failover Bernard Volz Bernard Volz
rrp 648 tcp Registry Registrar Protocol (RRP) Scott Hollenbeck Scott Hollenbeck
rrp 648 udp Registry Registrar Protocol (RRP) Scott Hollenbeck Scott Hollenbeck
cadview-3d 649 tcp Cadview-3d - streaming 3d models over the internet David Cooper David Cooper
cadview-3d 649 udp Cadview-3d - streaming 3d models over the internet David Cooper David Cooper
obex 650 tcp OBEX Jeff Garbers Jeff Garbers
obex 650 udp OBEX Jeff Garbers Jeff Garbers
ieee-mms 651 tcp IEEE MMS Curtis Anderson Curtis Anderson
ieee-mms 651 udp IEEE MMS Curtis Anderson Curtis Anderson
hello-port 652 tcp HELLO_PORT Patrick Cipiere Patrick Cipiere
hello-port 652 udp HELLO_PORT Patrick Cipiere Patrick Cipiere
repscmd 653 tcp RepCmd Scott Dale Scott Dale
repscmd 653 udp RepCmd Scott Dale Scott Dale
aodv 654 tcp AODV Charles Perkins Charles Perkins
aodv 654 udp AODV Charles Perkins Charles Perkins
tinc 655 tcp TINC Ivo Timmermans Ivo Timmermans
tinc 655 udp TINC Ivo Timmermans Ivo Timmermans
spmp 656 tcp SPMP Jakob Kaivo Jakob Kaivo
spmp 656 udp SPMP Jakob Kaivo Jakob Kaivo
rmc 657 tcp RMC Michael Schmidt Michael Schmidt
rmc 657 udp RMC Michael Schmidt Michael Schmidt
tenfold 658 tcp TenFold Louis Olszyk Louis Olszyk
tenfold 658 udp TenFold Louis Olszyk Louis Olszyk
659 Removed 2001-06-06
mac-srvr-admin 660 tcp MacOS Server Admin Forest Hill Forest Hill
mac-srvr-admin 660 udp MacOS Server Admin Forest Hill Forest Hill
hap 661 tcp HAP Igor Plotnikov Igor Plotnikov
hap 661 udp HAP Igor Plotnikov Igor Plotnikov
pftp 662 tcp PFTP Ben Schluricke Ben Schluricke
pftp 662 udp PFTP Ben Schluricke Ben Schluricke
purenoise 663 tcp PureNoise Sam Osa Sam Osa
purenoise 663 udp PureNoise Sam Osa Sam Osa
oob-ws-https 664 tcp DMTF out-of-band secure web services management protocol Jim Davis Jim Davis 2007-06
asf-secure-rmcp 664 udp ASF Secure Remote Management and Control Protocol Carl First Carl First
sun-dr 665 tcp Sun DR Harinder Bhasin Harinder Bhasin
sun-dr 665 udp Sun DR Harinder Bhasin Harinder Bhasin
mdqs 666 tcp
mdqs 666 udp
doom 666 tcp doom Id Software ddt ddt
doom 666 udp doom Id Software ddt ddt
disclose 667 tcp campaign contribution disclosures - SDR Technologies Jim Dixon Jim Dixon
disclose 667 udp campaign contribution disclosures - SDR Technologies Jim Dixon Jim Dixon
mecomm 668 tcp MeComm
mecomm 668 udp MeComm
meregister 669 tcp MeRegister Armin Sawusch Armin Sawusch
meregister 669 udp MeRegister Armin Sawusch Armin Sawusch
vacdsm-sws 670 tcp VACDSM-SWS
vacdsm-sws 670 udp VACDSM-SWS
vacdsm-app 671 tcp VACDSM-APP

Contact Information

Name Organization Contact URI Last Updated
Armin Sawusch armin&esd1.esd.de
Ben Schluricke support&pftp.de
Bernard Volz bevolz&gmail.com 2022-08-03
Bill Fenner fenner&parc.xerox.com
Bob Thomas rhthomas&cisco.com
Carl First Carl.L.First&intel.com
Charles Perkins cperkins&eng.sun.com
Chris Larsson clarsson&vnet.ibm.com
Curtis Anderson canderson&turbolinux.com
D. J. Bernstein ports&box.cr.yp.to 2018-04-05
David Cooper david.cooper&oracle.com
Dino Farinacci dino&cisco.com 2008-08-21
Egon Meier-Engelen egon.meier-engelen&dlr.de
Forest Hill forest&apple.com
Greg Rose Greg_Rose&sydney.sterling.com
Harinder Bhasin Harinder.Bhasin&sun.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Igor Plotnikov igor&uroam.com
Ivo Timmermans itimmermans&bigfoot.com
Jakob Kaivo jkaivo&nodomainname.net
Jeff Garbers FJG030&email.mot.com
Jim Davis jim.davis&wbemsolutions.com 2007-06
Jim Dixon jim&lambda.com
John Hadjioannou john&minster.co.uk
John Rainford john.rainford&passgo.com
Kaz Ozawa k.ozawa&cablelabs.com
Louis Olszyk lolszyk&10fold.com
Marek Buchler Marek.Buchler&entrust.com
Mark Crother mark&eis.calstate.edu
Michael Dasenbrock dasenbro&apple.com
Michael Ginn ginn&tyxar.com
Michael Schmidt mmaass&us.ibm.com
Mohsen Banan mohsen&neda.com
Pat Richard patr&xcert.com
Patrick Cipiere Patrick.Cipiere&udcast.com
Peter Viscarola PeterGV&osr.com
Prakash Banthia prakash_banthia&3com.com
Rudi Martin Rudi.Martin&edo.mts.dec.com
Sam Osa pristine&mailcity.com
Scott Dale scott&replicase.com
Scott Dale scott&tioga.com
Scott Hollenbeck shollenb&netsol.com
Tony Walker tony&cryptocard.com
Troy Rollo troy&kroll.corvu.com.au
ddt&idcube.idsoftware.com