Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
11623 udp Reserved
11624-11719 Unassigned Unauthorized Use Known on port 11711
15346-15362 Unassigned
solaris-audit 16162 tcp Solaris Audit - secure remote audit log Jan Friedel Jan Friedel 2009-05-07
16162 udp Reserved
16362-16366 Unassigned
16620-16664 Unassigned
gv-pf 18262 tcp GV NetConfig Service Scott Libert Scott Libert 2008-01-29
gv-pf 18262 udp GV NetConfig Service Scott Libert Scott Libert 2008-01-29
18263-18462 Unassigned
22556-22762 Unassigned
26134-26207 Unassigned
wnn6-ds 26208 tcp wnn6-ds Yasunari Gon Yamasita Yasunari Gon Yamasita
wnn6-ds 26208 udp wnn6-ds Yasunari Gon Yamasita Yasunari Gon Yamasita
26209-26256 Unassigned
cockroach 26257 tcp CockroachDB Cockroach Labs, Inc. Ben_Darnell 2015-09-29
26257 udp Reserved
26258-26259 Unassigned
ezproxy 26260 tcp eZproxy Albert C. Yang Albert C. Yang
ezproxy 26260 udp eZproxy Albert C. Yang Albert C. Yang
ezmeeting 26261 tcp eZmeeting Albert C. Yang Albert C. Yang
ezmeeting 26261 udp eZmeeting Albert C. Yang Albert C. Yang
k3software-svr 26262 tcp K3 Software-Server Jim Baldridge Jim Baldridge
k3software-svr 26262 udp K3 Software-Server Jim Baldridge Jim Baldridge
k3software-cli 26263 tcp K3 Software-Client Jim Baldridge Jim Baldridge
k3software-cli 26263 udp K3 Software-Client Jim Baldridge Jim Baldridge
26264 De-registered 2006-04-06
26265-26485 Unassigned
lm-mon 31620 tcp lm mon System Administrator System Administrator 2003-06
lm-mon 31620 udp lm mon System Administrator System Administrator 2003-06
31621-31684 Unassigned
profinet-rt 34962 tcp PROFInet RT Unicast PNO – PROFIBUS Nutzerorganisation e.V. Dietmar Bohn 2004-11 2026-03-16
profinet-rt 34962 udp PROFInet RT Unicast PNO – PROFIBUS Nutzerorganisation e.V. Dietmar Bohn 2004-11 2026-03-16
36462 tcp Reserved
36462 udp Reserved
xw-control 36462 sctp Xw-Control Plane (3GPP) Boubacar KIMNBA DIT ADAMOU Boubacar KIMNBA DIT ADAMOU 2015-11-13
38462 tcp Reserved
38462 udp Reserved
e1-interface 38462 sctp E1 signalling transport (3GPP) Huawei Technologies France Yang Xudong; Issam Toufik 2018-11-06 2018-11-15
38866-39062 Unassigned
47558-47623 Unassigned
directplaysrvr 47624 tcp Direct Play Server Ajay Jindal Ajay Jindal
directplaysrvr 47624 udp Direct Play Server Ajay Jindal Ajay Jindal
47625-47805 Unassigned
48620-48652 Unassigned
autotunnel udp IPSEC VPN tunnel over UDP Stuart Cheshire Stuart Cheshire 2019-05-04 RFC 6281 Defined TXT Keys: None
dns-llq-tls tcp DNS Long-Lived Queries over TLS Stuart Cheshire Stuart Cheshire 2019-05-04 RFC 6281 Defined TXT Keys: None
dns-update-tls tcp DNS Dynamic Update Service over TLS Stuart Cheshire Stuart Cheshire 2019-05-04 RFC 6281 DNS Dynamic Update Service for a given domain may not necessarily be provided by the principal name servers as advertised by the domain's "NS" records, and may not necessarily always be provided on port 53. The "_dns-update._udp.<domain>." SRV record gives the target host and port where DNS Dynamic Update Service is provided for the named domain.
jmap tcp JSON Meta Application Protocol IESG IETF Chair 2016-01-22 2019-07-16 RFC 8620 This service name was previously assigned under the name "JSON Mail Access Protocol". This has been de-assigned and re-assigned with the approval of the previous assignee.

Contact Information

Name Organization Contact URI Last Updated
Ajay Jindal ajayj&microsoft.com
Albert C. Yang albert.yang&ezmeeting.com 2002-03
ben&cockroachlabs.com 2015-09-29
Boubacar KIMNBA DIT ADAMOU jinba&chinamobile.com 2015-11-13
Cockroach Labs, Inc. iana-contact&cockroachlabs.com 2015-09-29
Dietmar Bohn standards.central-office&profibus.com 2026-03-10
Huawei Technologies France yangxudong&huawei.com 2018-11-06
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Issam Toufik Huawei Technologies France yangxudong&huawei.com 2018-11-06
Jan Friedel Jan.Friedel&sun.com 2009-05-07
Jim Baldridge jimb&rpower.com
PNO – PROFIBUS Nutzerorganisation e.V. standards.central-office&profibus.com 2026-03-10
Scott Libert scott.libert&thomson.net 2008-01-29
Stuart Cheshire cheshire&apple.com 2022-07-11
System Administrator sysadmin&silvaco.com 2003-06
Yang Xudong Huawei Technologies France yangxudong&huawei.com 2018-11-06
Yasunari Gon Yamasita yamasita&omronsoft.co.jp