Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-11-10

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
metaedit-ws 6390 udp MetaEdit+ WebService API Steven Kelly Steven Kelly 2007-11-12
6391-6399 Unassigned
6457-6463 Unassigned
6630 Unassigned
6631 Unassigned 2004-05-28
mxodbc-connect 6632 tcp eGenix mxODBC Connect Marc-Andre Lemburg Marc-Andre Lemburg 2009-11-13 Unauthorized Use Known on port 6632
6632 udp Reserved
6633 tcp Reserved
cisco-vpath-tun 6633 udp Cisco vPath Services Overlay Cisco Surendra Kumar 2012-06-11
mpls-pm 6634 udp MPLS Performance Measurement out-of-band response Cisco Systems Sagar Soni 2014-02-20
6634 tcp Reserved
6635 tcp Reserved
mpls-udp 6635 udp Encapsulate MPLS packets in UDP tunnels. IESG IETF Chair 2015-02-10 RFC 7510
6636 tcp Reserved
mpls-udp-dtls 6636 udp Encapsulate MPLS packets in UDP tunnels with DTLS. IESG IETF Chair 2015-02-10 RFC 7510
6637-6639 Unassigned
swismgr1 6963 tcp swismgr1 Yutaka Ono Yutaka Ono
swismgr1 6963 udp swismgr1 Yutaka Ono Yutaka Ono
cacsambroker 7163 tcp CA Connection Broker David Roberts David Roberts 2005-05
cacsambroker 7163 udp CA Connection Broker David Roberts David Roberts 2005-05
7263-7271 Unassigned
cfw 7563 tcp Control Framework RFC 6230
7563 udp Reserved
hawk 7630 tcp HA Web Konsole Tim Serong Tim Serong 2010-03-31
7630 udp Reserved
tesla-sys-msg 7631 tcp TESLA System Messaging Andy Perreault Andy Perreault 2010-03-31
7631 udp Reserved
7632 Unassigned
pmdfmgt 7633 tcp PMDF Management Hunter Goatley Hunter Goatley
pmdfmgt 7633 udp PMDF Management Hunter Goatley Hunter Goatley
7634-7647 Unassigned
rome 7663 tcp Proprietary immutable distributed data storage TFOR David von Vistauxx 2018-02-07
rome 7663 udp Proprietary immutable distributed data storage TFOR David von Vistauxx 2018-02-07
7963-7966 Unassigned
8163-8180 Unassigned
mc-appserver 8763 tcp MC-APPSERVER Romeo Kasanwidjojo Romeo Kasanwidjojo
mc-appserver 8763 udp MC-APPSERVER Romeo Kasanwidjojo Romeo Kasanwidjojo
apani4 9163 tcp apani4 Neal Taylor Neal Taylor
apani4 9163 udp apani4 Neal Taylor Neal Taylor
peoctlr 9630 tcp Peovica Controller Adrian Hungate Adrian Hungate 2009-09-14
9630 udp Reserved
peocoll 9631 tcp Peovica Collector Adrian Hungate Adrian Hungate 2009-09-14
9631 udp Reserved
9632 tcp Reserved
mc-comm 9632 udp Mobile-C Communications David Ko David Ko 2009-09-14
9633-9639 Unassigned
9763-9799 Unassigned
snmptls 10161 tcp SNMP-TLS RFC 6353
snmpdtls 10161 udp SNMP-DTLS RFC 6353
snmptls-trap 10162 tcp SNMP-Trap-TLS RFC 6353
snmpdtls-trap 10162 udp SNMP-Trap-DTLS RFC 6353
10163-10199 Unassigned
10549-10630 Unassigned
printopia 10631 tcp Printopia Serve Decisive Tactics, Inc. Chris Kent 2011-10-24 2015-04-09
10631 udp Reserved
10632-10799 Unassigned
suncacao-rmi 11163 tcp sun cacao rmi registry access point Nick Stephen Nick Stephen 2005-08
suncacao-rmi 11163 udp sun cacao rmi registry access point Nick Stephen Nick Stephen 2005-08
3link 15363 tcp 3Link Negotiation Brant Thomsen Brant Thomsen 2003-01
3link 15363 udp 3Link Negotiation Brant Thomsen Brant Thomsen 2003-01
16163-16308 Unassigned
etb4j 16309 tcp etb4j Christopher R. Smith Christopher R. Smith 2004-11
etb4j 16309 udp etb4j Christopher R. Smith Christopher R. Smith 2004-11
pduncs 16310 tcp Policy Distribute, Update Notification Diane I. Shannon Diane I. Shannon 2006-08
pduncs 16310 udp Policy Distribute, Update Notification Diane I. Shannon Diane I. Shannon 2006-08
pdefmns 16311 tcp Policy definition and update management Diane I. Shannon Diane I. Shannon 2007-04
pdefmns 16311 udp Policy definition and update management Diane I. Shannon Diane I. Shannon 2007-04
16312-16359 Unassigned
netserialext1 16360 tcp Network Serial Extension Ports One Michael J Hoy Michael J Hoy
netserialext1 16360 udp Network Serial Extension Ports One Michael J Hoy Michael J Hoy
netserialext2 16361 tcp Network Serial Extension Ports Two Michael J Hoy Michael J Hoy
netserialext2 16361 udp Network Serial Extension Ports Two Michael J Hoy Michael J Hoy
16362-16366 Unassigned
netserialext3 16367 tcp Network Serial Extension Ports Three Michael J Hoy Michael J Hoy
netserialext3 16367 udp Network Serial Extension Ports Three Michael J Hoy Michael J Hoy
netserialext4 16368 tcp Network Serial Extension Ports Four Michael J Hoy Michael J Hoy
netserialext4 16368 udp Network Serial Extension Ports Four Michael J Hoy Michael J Hoy
16369-16383 Unassigned
connected 16384 tcp Connected Corp Nicole C. Ouellette Nicole C. Ouellette 2004-02
connected 16384 udp Connected Corp Nicole C. Ouellette Nicole C. Ouellette 2004-02
rdgs 16385 tcp Reliable Datagram Sockets Oracle Corp Sowmini Varadhan 2015-04-30
16385 udp Reserved
16386-16618 Unassigned
18263-18462 Unassigned
ac-cluster 18463 tcp AC Cluster Lisa Zhong Lisa Zhong
ac-cluster 18463 udp AC Cluster Lisa Zhong Lisa Zhong
18517-18633 Unassigned
rds-ib 18634 tcp Reliable Datagram Service Andy Grover Andy Grover 2009-02-27
rds-ib 18634 udp Reliable Datagram Service Andy Grover Andy Grover 2009-02-27
rds-ip 18635 tcp Reliable Datagram Service over IP Andy Grover Andy Grover 2009-05-20
rds-ip 18635 udp Reliable Datagram Service over IP Andy Grover Andy Grover 2009-05-20
18636-18667 Unassigned
talikaserver 22763 tcp Talika Main Server Laxman C. Marathe Laxman C. Marathe 2006-12
talikaserver 22763 udp Talika Main Server Laxman C. Marathe Laxman C. Marathe 2006-12
k3software-cli 26263 tcp K3 Software-Client Jim Baldridge Jim Baldridge
k3software-cli 26263 udp K3 Software-Client Jim Baldridge Jim Baldridge
32484-32634 Unassigned
sec-ntb-clnt 32635 tcp SecureNotebook-CLNT Eric Cantineau Eric Cantineau 2004-11
sec-ntb-clnt 32635 udp SecureNotebook-CLNT Eric Cantineau Eric Cantineau 2004-11
DMExpress 32636 tcp DMExpress Arnie Farrelly Arnie Farrelly
DMExpress 32636 udp DMExpress Arnie Farrelly Arnie Farrelly

Contact Information

Name Organization Contact URI Last Updated
Adrian Hungate adrian&tlspu.com 2014-07-11
Andy Grover andy.grover&oracle.com 2009-05-20
Andy Perreault aperreault&erlphase.com 2010-03-31
Arnie Farrelly afarrelly&syncsort.com
Brant Thomsen brant_thomsen&3com.com 2003-01
Chris Kent Decisive Tactics, Inc. ckent&decisivetactics.com 2015-04-09
Christopher R. Smith csmith4&us.ibm.com 2004-11
Cisco smkumar&cisco.com 2012-06-11
Cisco Systems sagsoni&cisco.com 2014-02-20
David Ko david.dk.ko&gmail.com 2009-09-14
David Roberts David.Roberts&ca.com 2005-05
David von Vistauxx vistauxx&tfor.infrastructuresecurity.com 2018-02-07
Decisive Tactics, Inc. ckent&decisivetactics.com 2015-04-09
Diane I. Shannon shannond&us.ibm.com 2007-04
Eric Cantineau eric&securenotebook.com 2004-11
Hunter Goatley goathunter&goatley.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jim Baldridge jimb&rpower.com
Laxman C. Marathe lcmarathe&thomsonpress.com 2006-12
Lisa Zhong lzhong&cup.hp.com
Marc-Andre Lemburg mal&egenix.com 2009-11-13
Michael J Hoy mhoy&canberra-abq.com
Neal Taylor ianareg&apani.com
Nick Stephen nick.stephen&sun.com 2005-08
Nicole C. Ouellette nouellette&connected.com 2004-02
Oracle Corp sowmini.varadhan&oracle.com 2015-04-30
Romeo Kasanwidjojo romeo&microcomgroup.com
Sagar Soni Cisco Systems sagsoni&cisco.com 2014-02-20
Sowmini Varadhan Oracle Corp sowmini.varadhan&oracle.com 2015-04-30
Steven Kelly stevek&metacase.com 2007-11-12
Surendra Kumar Cisco smkumar&cisco.com 2012-06-11
TFOR vistauxx&tfor.infrastructuresecurity.com 2018-02-07
Tim Serong tserong&novell.com 2010-03-31
Yutaka Ono ono&saint.nm.fujitsu.co.jp