Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-11-10
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 6717-6766 | Unassigned | ||||||||||
| swispol | 6966 | tcp | swispol | Yutaka Ono | Yutaka Ono | ||||||
| swispol | 6966 | udp | swispol | Yutaka Ono | Yutaka Ono | ||||||
| aruba-server | 7166 | tcp | Aruba eDiscovery Server | Micha Ben-Efraim | Micha Ben-Efraim | 2008-01-07 | |||||
| aruba-server | 7166 | udp | Aruba eDiscovery Server | Micha Ben-Efraim | Micha Ben-Efraim | 2008-01-07 | |||||
| 7366-7390 | Unassigned | 2006-02-06 | |||||||||
| vsi-omega | 7566 | tcp | VSI Omega | Curtis Smith | Curtis Smith | ||||||
| vsi-omega | 7566 | udp | VSI Omega | Curtis Smith | Curtis Smith | ||||||
| 7649-7662 | Unassigned | ||||||||||
| rome | 7663 | tcp | Proprietary immutable distributed data storage | TFOR | David von Vistauxx | 2018-02-07 | |||||
| rome | 7663 | udp | Proprietary immutable distributed data storage | TFOR | David von Vistauxx | 2018-02-07 | |||||
| 7664-7667 | Unassigned | ||||||||||
| authoritygate | 7668 | tcp | AuthorityGate Secure API communication for Orchestrated task sequencing | AuthorityGate Inc | Kevin Komlosy | 2025-03-28 | |||||
| 7668 | udp | Reserved | |||||||||
| 7669-7671 | Unassigned | ||||||||||
| mipv6tls | 7872 | udp | TLS-based Mobile IPv6 Security | IESG | IETF Chair | 2012-04-12 | RFC 6618 | ||||
| 7963-7966 | Unassigned | ||||||||||
| toad-bi-appsrvr | 8066 | tcp | Toad BI Application Server | Quest Software | Greg Cottman | 2013-04-19 | |||||
| 8066 | udp | Reserved | |||||||||
| 8266 | tcp | Reserved | |||||||||
| espeasy-p2p | 8266 | udp | ESPeasy peer-2-peer communication | ESPeasy | Gijs Noorlander | 2018-11-28 | |||||
| 8556-8566 | Unassigned | ||||||||||
| 8616-8664 | Unassigned | Unauthorized Use Known on ports 8616 and 8617 | |||||||||
| monetra | 8665 | tcp | Monetra | Main Street Softworks Inc | Brad House | 2013-04-02 | |||||
| 8665 | udp | Reserved | |||||||||
| monetra-admin | 8666 | tcp | Monetra Administrative Access | Main Street Softworks Inc | Brad House | 2013-04-02 | |||||
| 8666 | udp | Reserved | |||||||||
| 8667 | Unassigned | ||||||||||
| spartan | 8668 | tcp | Spartan management | Tenebris Technologies Inc. | Eric Jacksch | 2023-10-26 | |||||
| 8668 | udp | Reserved | |||||||||
| 8669-8674 | Unassigned | ||||||||||
| amcs | 8766 | tcp | Agilent Connectivity Service | Keysight Technologies, Inc. | Tom Fay | 2013-01-16 | 2016-09-12 | ||||
| amcs | 8766 | udp | Agilent Connectivity Service | Keysight Technologies, Inc. | Tom Fay | 2013-01-16 | 2016-09-12 | ||||
| 9641-9665 | Unassigned | ||||||||||
| zoomcp | 9666 | tcp | Zoom Control Panel Game Server Management | Zoom Control Panel | Joshua Pedroza | 2014-02-26 | |||||
| 9666 | udp | Reserved | |||||||||
| xmms2 | 9667 | tcp | Cross-platform Music Multiplexing System | Juho Vähä-Herttua | Juho Vähä-Herttua | 2009-04-14 | |||||
| xmms2 | 9667 | udp | Cross-platform Music Multiplexing System | Juho Vähä-Herttua | Juho Vähä-Herttua | ||||||
| tec5-sdctp | 9668 | tcp | tec5 Spectral Device Control Protocol | Michael Muth | Michael Muth | 2009-05-11 | |||||
| tec5-sdctp | 9668 | udp | tec5 Spectral Device Control Protocol | Michael Muth | Michael Muth | 2009-05-11 | |||||
| 9669-9693 | Unassigned | ||||||||||
| odnsp | 9966 | tcp | OKI Data Network Setting Protocol | Masato Sato | Masato Sato | 2006-05 | |||||
| odnsp | 9966 | udp | OKI Data Network Setting Protocol | Masato Sato | Masato Sato | 2006-05 | |||||
| 11166-11170 | Unassigned | ||||||||||
| 11322-11366 | Unassigned | ||||||||||
| 11878-11966 | Unassigned | ||||||||||
| 12866-13159 | Unassigned | ||||||||||
| bex-xr | 15660 | tcp | Backup Express Restore Server | Catalogic Software, Inc. | Chi Shih Chang | 2008-03-19 | 2015-02-04 | ||||
| bex-xr | 15660 | udp | Backup Express Restore Server | Catalogic Software, Inc. | Chi Shih Chang | 2008-03-19 | 2015-02-04 | ||||
| 15661-15739 | Unassigned | ||||||||||
| 16362-16366 | Unassigned | ||||||||||
| 16386-16618 | Unassigned | ||||||||||
| xoms | 16619 | tcp | X509 Objects Management Service | Francis GASCHET | Francis GASCHET | 2008-09-08 | |||||
| 16619 | udp | Reserved | |||||||||
| 16620-16664 | Unassigned | ||||||||||
| axon-tunnel | 16665 | tcp | Reliable multipath data transport for high latencies | Bridgeworks | Mihai Popa | 2014-09-26 | 2026-09-11 | ||||
| 16665 | udp | Reserved | |||||||||
| 16666 | tcp | Reserved | |||||||||
| vtp | 16666 | udp | Vidder Tunnel Protocol | Vidder, Inc. | Ted Schroeder | 2011-10-24 | |||||
| 16667-16788 | Unassigned | ||||||||||
| 18636-18667 | Unassigned | ||||||||||
| vdmmesh | 18668 | tcp | Manufacturing Execution Systems Mesh Communication | Van Doren MES | Edwin van de Burgt | 2016-10-31 | |||||
| vdmmesh-disc | 18668 | udp | Manufacturing Execution Systems Mesh Communication | Van Doren MES | Edwin van de Burgt | 2016-10-31 | |||||
| 18669-18768 | Unassigned | ||||||||||
| 20058-20166 | Unassigned | ||||||||||
| 20481-20669 | Unassigned | ||||||||||
| 24466-24553 | Unassigned | ||||||||||
| 24602-24665 | Unassigned | ||||||||||
| sdtvwcam | 24666 | tcp | Service used by SmarDTV to communicate between a CAM and a second screen application | SmarDTV | Vincent Demortier | 2015-03-04 | |||||
| 24666 | udp | Reserved | |||||||||
| 24667-24675 | Unassigned | ||||||||||
| 29119-29166 | Unassigned | ||||||||||
| 31766-31947 | Unassigned | ||||||||||
| 32637-32766 | Unassigned | ||||||||||
| 34380-34566 | Unassigned | ||||||||||
| 34966 | tcp | Reserved | |||||||||
| profinet-rt-sec | 34966 | udp | PROFINET secure real-time data transfer over UDP (unicast and multicast) | PNO – PROFIBUS Nutzerorganisation e.V. | Dietmar Bohn | 2026-03-10 | |||||
| 36525-36601 | Unassigned | ||||||||||
| observium-agent | 36602 | tcp | Observium statistics collection agent | Observium | Adam Armstrong | 2013-05-10 | |||||
| 36602 | udp | Reserved | |||||||||
| 36603-36699 | Unassigned | ||||||||||
| 36866-37471 | Unassigned | ||||||||||
| 38866-39062 | Unassigned | ||||||||||
| ssr-servermgr | 45966 | tcp | SSRServerMgr | Jeremy Gilliat | Jeremy Gilliat | ||||||
| ssr-servermgr | 45966 | udp | SSRServerMgr | Jeremy Gilliat | Jeremy Gilliat | ||||||
| dnssd-srp | tcp | DNS-Based Service Discovery | IESG | IETF Chair | 2024-04-12 | 2024-09-05 | RFC 9665 | Defined TXT keys: None | |||
| dnssd-srp-tls | tcp | DNS-Based Service Discovery (TLS) | IESG | IETF Chair | 2024-04-12 | 2024-09-05 | RFC 9665 | Defined TXT keys: None | |||
| nfs-domainroot | tcp | NFS service for the domain root, the root of an organization's published file namespace. | IESG | IETF Chair | 2012-04-24 | RFC 6641 | Defined TXT keys: None |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Adam Armstrong | Observium | adama&observium.org | 2013-05-10 |
| AuthorityGate Inc | support&authoritygate.com | 2025-03-28 | |
| Brad House | Main Street Softworks Inc | brad&mainstreetsoftworks.com | 2013-04-02 |
| Bridgeworks | mihai.popa&4bridgeworks.com | 2026-09-11 | |
| Catalogic Software, Inc. | cchang&catalogicsoftware.com | 2015-02-04 | |
| Chi Shih Chang | Catalogic Software, Inc. | cchang&catalogicsoftware.com | 2015-02-04 |
| Curtis Smith | curtis.smith&vsin.com | ||
| David von Vistauxx | vistauxx&tfor.infrastructuresecurity.com | 2018-02-07 | |
| Dietmar Bohn | standards.central-office&profibus.com | 2026-03-10 | |
| Edwin van de Burgt | edwin.van.de.burgt&vandoren.nl | 2016-10-31 | |
| Eric Jacksch | eric&tenebris.com | 2023-10-26 | |
| ESPeasy | gijs.noorlander&gmail.com | 2018-11-28 | |
| Francis GASCHET | NUMLOG | fg&numlog.fr | 2008-09-08 |
| Gijs Noorlander | gijs.noorlander&gmail.com | 2018-11-28 | |
| Greg Cottman | Quest Software | Greg.Cottman&quest.com | 2013-04-19 |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Jeremy Gilliat | jeremy.gilliat&geac.com | ||
| Joshua Pedroza | Zoom Control Panel | info&zoomcp.com | 2014-02-26 |
| Juho Vähä-Herttua | juhovh&iki.fi | 2009-04-14 | |
| Kevin Komlosy | AuthorityGate Inc | support&authoritygate.com | 2025-03-28 |
| Keysight Technologies, Inc. | iana.contact&keysight.com | 2016-09-12 | |
| Main Street Softworks Inc | info&mainstreetsoftworks.com | 2013-04-02 | |
| Masato Sato | satou203&oki.com | 2006-05 | |
| Micha Ben-Efraim | benmi07&ca.com | 2008-01-07 | |
| Michael Muth | m.muth&tec5.com | 2009-05-11 | |
| Mihai Popa | mihai.popa&4bridgeworks.com | 2026-09-11 | |
| Observium | adama&observium.org | 2013-05-10 | |
| PNO – PROFIBUS Nutzerorganisation e.V. | standards.central-office&profibus.com | 2026-03-10 | |
| Quest Software | Greg.Cottman&quest.com | 2013-04-19 | |
| SmarDTV | vincent.demortier&smardtv.com | 2015-03-04 | |
| Ted Schroeder | Vidder, Inc. | ted&vidder.com | 2011-10-24 |
| Tenebris Technologies Inc. | info&tenebris.com | 2023-10-26 | |
| TFOR | vistauxx&tfor.infrastructuresecurity.com | 2018-02-07 | |
| Tom Fay | iana.contact&keysight.com | 2016-09-12 | |
| Van Doren MES | mes&vandoren.nl | 2016-10-31 | |
| Vidder, Inc. | ted&vidder.com | 2011-10-24 | |
| Vincent Demortier | SmarDTV | vincent.demortier&smardtv.com | 2015-03-04 |
| Yutaka Ono | ono&saint.nm.fujitsu.co.jp | ||
| Zoom Control Panel | ianaport&zoomcp.com | 2014-02-26 |