Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| netviewdm2 | 730 | udp | IBM NetView DM/6000 send/tcp | ||||||||
| netviewdm3 | 731 | tcp | IBM NetView DM/6000 receive/tcp | Philippe Binet | Philippe Binet | ||||||
| netviewdm3 | 731 | udp | IBM NetView DM/6000 receive/tcp | Philippe Binet | Philippe Binet | ||||||
| 732-740 | Unassigned | ||||||||||
| netgw | 741 | tcp | netGW | Oliver Korfmacher | Oliver Korfmacher | ||||||
| netgw | 741 | udp | netGW | Oliver Korfmacher | Oliver Korfmacher | ||||||
| netrcs | 742 | tcp | Network based Rev. Cont. Sys. | Gordon C. Galligher | Gordon C. Galligher | ||||||
| netrcs | 742 | udp | Network based Rev. Cont. Sys. | Gordon C. Galligher | Gordon C. Galligher | ||||||
| 743 | Unassigned | ||||||||||
| flexlm | 744 | tcp | Flexible License Manager | Matt Christiano | Matt Christiano | ||||||
| flexlm | 744 | udp | Flexible License Manager | Matt Christiano | Matt Christiano | ||||||
| 745-746 | Unassigned | ||||||||||
| fujitsu-dev | 747 | tcp | Fujitsu Device Control | ||||||||
| fujitsu-dev | 747 | udp | Fujitsu Device Control | ||||||||
| ris-cm | 748 | tcp | Russell Info Sci Calendar Manager | ||||||||
| ris-cm | 748 | udp | Russell Info Sci Calendar Manager | ||||||||
| kerberos-adm | 749 | tcp | kerberos administration | ||||||||
| kerberos-adm | 749 | udp | kerberos administration | ||||||||
| rfile | 750 | tcp | |||||||||
| loadav | 750 | udp | |||||||||
| kerberos-iv | 750 | udp | kerberos version iv | Martin Hamilton | Martin Hamilton | ||||||
| pump | 751 | tcp | |||||||||
| pump | 751 | udp | |||||||||
| qrh | 752 | tcp | |||||||||
| qrh | 752 | udp | |||||||||
| rrh | 753 | tcp | |||||||||
| rrh | 753 | udp | |||||||||
| tell | 754 | tcp | send | Josyula R. Rao | Josyula R. Rao | ||||||
| tell | 754 | udp | send | Josyula R. Rao | Josyula R. Rao | ||||||
| 755-757 | Unassigned | ||||||||||
| nlogin | 758 | tcp | |||||||||
| nlogin | 758 | udp | |||||||||
| con | 759 | tcp | |||||||||
| con | 759 | udp | |||||||||
| ns | 760 | tcp | |||||||||
| ns | 760 | udp | |||||||||
| rxe | 761 | tcp | |||||||||
| rxe | 761 | udp | |||||||||
| quotad | 762 | tcp | |||||||||
| quotad | 762 | udp | |||||||||
| cycleserv | 763 | tcp | |||||||||
| cycleserv | 763 | udp | |||||||||
| omserv | 764 | tcp | |||||||||
| omserv | 764 | udp | |||||||||
| webster | 765 | tcp | Josyula R. Rao | Josyula R. Rao | |||||||
| webster | 765 | udp | Josyula R. Rao | Josyula R. Rao | |||||||
| 766 | Unassigned | ||||||||||
| phonebook | 767 | tcp | phone | Josyula R. Rao | Josyula R. Rao | ||||||
| phonebook | 767 | udp | phone | Josyula R. Rao | Josyula R. Rao | ||||||
| 768 | Unassigned | ||||||||||
| vid | 769 | tcp | |||||||||
| vid | 769 | udp | |||||||||
| cadlock | 770 | tcp | |||||||||
| cadlock | 770 | udp | |||||||||
| rtip | 771 | tcp | |||||||||
| rtip | 771 | udp | |||||||||
| cycleserv2 | 772 | tcp | |||||||||
| cycleserv2 | 772 | udp | |||||||||
| submit | 773 | tcp | |||||||||
| notify | 773 | udp | |||||||||
| rpasswd | 774 | tcp | |||||||||
| acmaint-dbd | 774 | udp | IANA assigned this well-formed service name as a replacement for "acmaint_dbd". | ||||||||
| acmaint_dbd | 774 | udp | This entry is an alias to "acmaint-dbd". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||||||
| entomb | 775 | tcp | |||||||||
| acmaint-transd | 775 | udp | IANA assigned this well-formed service name as a replacement for "acmaint_transd". | ||||||||
| acmaint_transd | 775 | udp | This entry is an alias to "acmaint-transd". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||||||
| wpages | 776 | tcp | Josyula R. Rao | Josyula R. Rao | |||||||
| wpages | 776 | udp | Josyula R. Rao | Josyula R. Rao | |||||||
| multiling-http | 777 | tcp | Multiling HTTP | Alejandro Bonet | Alejandro Bonet | ||||||
| multiling-http | 777 | udp | Multiling HTTP | Alejandro Bonet | Alejandro Bonet | ||||||
| 778-779 | Unassigned | ||||||||||
| wpgs | 780 | tcp | Josyula R. Rao | Josyula R. Rao | |||||||
| wpgs | 780 | udp | Josyula R. Rao | Josyula R. Rao | |||||||
| 781-785 | Unassigned | ||||||||||
| 786 | Unassigned | 2002-05-08 | |||||||||
| 787 | Unassigned | 2002-10-08 | |||||||||
| 788-799 | Unassigned | Unauthorized Use Known on port 796 | |||||||||
| 811-827 | Unassigned | ||||||||||
| dhcp-failover2 | 847 | tcp | dhcp-failover 2 | Bernard Volz | Bernard Volz | ||||||
| dhcp-failover2 | 847 | udp | dhcp-failover 2 | Bernard Volz | Bernard Volz | ||||||
| gdoi | 848 | tcp | GDOI | RFC 3547 | |||||||
| gdoi | 848 | udp | GDOI | RFC 3547 | |||||||
| domain-s | 853 | tcp | DNS query-response protocol run over TLS | IESG | IETF Chair | 2015-10-08 | 2022-04-11 | RFC 7858 | |||
| domain-s | 853 | udp | DNS query-response protocol run over DTLS or QUIC | IESG | IETF Chair | 2015-10-08 | 2022-04-01 | RFC 7858; RFC 8094; RFC 9250 | |||
| dlep | 854 | tcp | Dynamic Link Exchange Protocol (DLEP) | IESG | IETF Chair | 2017-04-03 | RFC 8175 | ||||
| dlep | 854 | udp | Dynamic Link Exchange Protocol (DLEP) | IESG | IETF Chair | 2017-04-03 | RFC 8175 | ||||
| iscsi | 860 | tcp | iSCSI | IESG | IETF Chair | 2013-08-27 | RFC 7143 | ||||
| iscsi | 860 | udp | iSCSI | IESG | IETF Chair | 2013-08-27 | RFC 7143 | ||||
| twamp-control | 862 | tcp | TWAMP-Control | IESG | IETF Chair | RFC 5357 | |||||
| 863-872 | Unassigned | ||||||||||
| rsync | 873 | tcp | rsync | Andrew Tridgell | Andrew Tridgell | ||||||
| rsync | 873 | udp | rsync | Andrew Tridgell | Andrew Tridgell | ||||||
| 874-885 | Unassigned | ||||||||||
| iclcnet-svinfo | 887 | tcp | ICL coNETion server info IANA assigned this well-formed service name as a replacement for "iclcnet_svinfo". |
Bob Lyon | Bob Lyon | ||||||
| iclcnet_svinfo | 887 | tcp | ICL coNETion server info | Bob Lyon | Bob Lyon | This entry is an alias to "iclcnet-svinfo". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| iclcnet-svinfo | 887 | udp | ICL coNETion server info IANA assigned this well-formed service name as a replacement for "iclcnet_svinfo". |
Bob Lyon | Bob Lyon | ||||||
| iclcnet_svinfo | 887 | udp | ICL coNETion server info | Bob Lyon | Bob Lyon | This entry is an alias to "iclcnet-svinfo". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| nas | 991 | tcp | Netnews Administration System | Vera Heinau; Heiko Schlichting | Vera Heinau; Heiko Schlichting | 2017-02-10 | RFC 4707 | ||||
| nas | 991 | udp | Netnews Administration System | Vera Heinau; Heiko Schlichting | Vera Heinau; Heiko Schlichting | 2017-02-10 | RFC 4707 | ||||
| maitrd | 997 | tcp | |||||||||
| maitrd | 997 | udp |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Alejandro Bonet | babel&ctv.es | ||
| Andrew Tridgell | tridge&samba.anu.edu.au | ||
| Bernard Volz | bevolz&gmail.com | 2022-08-03 | |
| Bob Lyon | bl&oasis.icl.co.uk | ||
| Gordon C. Galligher | gorpong&ping.chi.il.us | ||
| Heiko Schlichting | heiko.schlichting&fu-berlin.de | 2022-06-07 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Josyula R. Rao | jrrao&watson.ibm.com | ||
| Martin Hamilton | martin&mrrl.lut.as.uk | ||
| Matt Christiano | globes@matt&oliveb.atc.olivetti.com | ||
| Oliver Korfmacher | okorf&netcs.com | ||
| Philippe Binet | phbinet&vnet.ibm.com | ||
| Vera Heinau | vera.heinau&fu-berlin.de | 2022-06-07 |