Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
iposplanet 7031 tcp IPOSPLANET retailing multi devices protocol Fabrice Paget Fabrice Paget 2012-10-23
7031 udp Reserved
7032-7039 Unassigned
7040 tcp Reserved
quest-disc 7040 udp Quest application level network service discovery Quest Software Henrik Johnson 2012-04-09
7041-7069 Unassigned
arcp 7070 tcp ARCP Jude George Jude George
arcp 7070 udp ARCP Jude George Jude George
iwg1 7071 tcp IWGADTS Aircraft Housekeeping Message Don Sullivan Don Sullivan 2010-02-16
iwg1 7071 udp IWGADTS Aircraft Housekeeping Message Don Sullivan Don Sullivan 2010-02-16
iba-cfg 7072 tcp iba Device Configuration Protocol iba AG Alexander Melamed 2018-02-12
iba-cfg-disc 7072 udp iba Device Configuration Protocol iba AG Alexander Melamed 2018-02-12
martalk 7073 tcp MarTalk protocol Mahr GmbH Göttingen Kevin Bube 2013-09-02
7073 udp Reserved
7074-7079 Unassigned
empowerid 7080 tcp EmpowerID Communication Matthew Whited Matthew Whited 2008-01-16
empowerid 7080 udp EmpowerID Communication Matthew Whited Matthew Whited 2008-01-16
7081-7087 Unassigned
7088 tcp Reserved
zixi-transport 7088 udp Zixi live video transport protocol Zixi Igor Ratner 2015-11-16
7089-7094 Unassigned
jdp-disc 7095 udp Java Discovery Protocol OpenJDK Florian Weimer 2013-03-12
7095 tcp Reserved
7096-7098 Unassigned
lazy-ptop 7099 tcp lazy-ptop Guy Keren Guy Keren
lazy-ptop 7099 udp lazy-ptop Guy Keren Guy Keren
aes-x170 7107 udp AES-X170 Richard Foss Richard Foss 2011-02-10
nsrp 7170 tcp Adaptive Name/Service Resolution Geoff Back Geoff Back 2010-02-01
nsrp 7170 udp Adaptive Name/Service Resolution Geoff Back Geoff Back 2010-02-01
7444-7470 Unassigned
aries-kfinder 7570 tcp Aries Kfinder James King III James King III
aries-kfinder 7570 udp Aries Kfinder James King III James King III
em7-secom 7700 tcp EM7 Secure Communications Christopher Cordray Christopher Cordray 2008-06-05
7700 udp Reserved
7701 tcp Reserved
7701 udp Reserved
nfapi 7701 sctp SCF nFAPI defining MAC/PHY split Small Cell Forum Richard Kennedy 2017-01-24
7702-7706 Unassigned
sync-em7 7707 tcp EM7 Dynamic Updates Christopher Cordray Christopher Cordray 2004-11
sync-em7 7707 udp EM7 Dynamic Updates Christopher Cordray Christopher Cordray 2004-11
scinet 7708 tcp scientia.net Christoph Anton Mitterer Christoph Anton Mitterer 2006-01
scinet 7708 udp scientia.net Christoph Anton Mitterer Christoph Anton Mitterer 2006-01
7709-7719 Unassigned
rbt-smc 7870 tcp Riverbed Steelhead Mobile Service Gabriel Levy Gabriel Levy 2008-08-29
7870 udp Reserved
aero 8060 udp Asymmetric Extended Route Optimization (AERO) IESG IETF Chair RFC 6706
ucs-isc 8070 tcp Oracle Unified Communication Suite's Indexed Search Converter Oracle Corp Bharathi Sivaramakrishnan 2017-02-10
8070 udp Reserved
robot-remote 8270 tcp Robot Framework Remote Library Interface Robot Framework Foundation Chris Newman 2017-01-26
8270 udp Reserved
cisco-avp 8470 tcp Cisco Address Validation Protocol Cullen Jennings Cullen Jennings 2009-02-13
8470 udp Reserved
8700-8709 Unassigned
dpap 8770 tcp Digital Photo Access Protocol (iPhoto) Amandeep Jawa Amandeep Jawa 2004-11 Defined TXT keys: txtvers, Version, iPSh Version, Machine ID, Machine Name, Password
dpap 8770 udp Digital Photo Access Protocol (iPhoto) Amandeep Jawa Amandeep Jawa 2004-11 Defined TXT keys: txtvers, Version, iPSh Version, Machine ID, Machine Name, Password
board-roar 9700 tcp Board M.I.T. Service Francesco Rosi Francesco Rosi 2006-01
board-roar 9700 udp Board M.I.T. Service Francesco Rosi Francesco Rosi 2006-01
9701-9746 Unassigned
hip-nat-t 10500 udp HIP NAT-Traversal IESG IETF Chair 2020-08-12 RFC 5770; RFC 9028
11166-11170 Unassigned
11368-11370 Unassigned
11968-11970 Unassigned
16996-17006 Unassigned
isode-dua 17007 tcp
isode-dua 17007 udp
17008-17009 Unassigned
ncpu 17010 tcp Plan 9 cpu port Ronald G. Minnich Ronald G. Minnich 2022-05-13 Defined TXT keys: u=username; k=keypattern; f=fstabFILE; n=namespace; h=hostkey; r=root
17010 udp Reserved
17011-17183 Unassigned
18770-18880 Unassigned
iec-104-sec 19998 tcp IEC 60870-5-104 process control - secure Grant Gilchrist Grant Gilchrist 2010-10-18
track 20670 tcp Track Michael Sweet Michael Sweet
track 20670 udp Track Michael Sweet Michael Sweet
25101-25470 Unassigned
flex-lm 27000-27009 FLEX LM (1-10) Flexera Software Paul Bland 2018-02-15
flex-lmadmin 27010 tcp A protocol for managing license services Flexera Paul Bland 2018-08-22
27010 udp Reserved
27011-27015 Unassigned
chlenix 27016 tcp Cloud hosting environment network Vlad Bondarenko Vlad Bondarenko 2024-09-23
27016 udp Reserved
mongodb 27017 tcp Mongo database system MongoDB, Inc. Akshay Kumar 2019-02-21
27017 udp Reserved
27018-27344 Unassigned Unauthorized Use Known on ports 27018 and 27019
29170-29998 Unassigned
filenet-nch 32770 tcp Filenet NCH Daniel Whelan Daniel Whelan
filenet-nch 32770 udp Filenet NCH Daniel Whelan Daniel Whelan
mapx 36700 tcp MapX communication MicroTechniX Yarochkin Michail 2014-10-13
36700 udp Reserved
36701-36864 Unassigned
mbus 47000 tcp Message Bus Dirk Kutscher Dirk Kutscher
mbus 47000 udp Message Bus Dirk Kutscher Dirk Kutscher
winrm 47001 tcp Windows Remote Management Service Ryan Mack Ryan Mack 2009-04-29
47001 udp Reserved
47002-47099 Unassigned
est tcp Enrollment Over Secure Transport Jack Visoky Jack Visoky 2017-10-06 RFC 7030. Defined TXT keys: None
jnx-kcsync tcp jollys keychain cloud sync protocol Patrick Stein Patrick Stein 2011-10-24 Defined TXT keys: hash=<40hex characters> salt=<40hex characters> uuid=<40hex characters> Example: hash=5e7580598c0d7064d4fc79faaeb42585e1a675f8 salt=f0164cb3a0c3d7efe75abea8fda86d2d56c8dda9 uuid=db61dc092922252e45bbb264f59147138c7fd5fa

Contact Information

Name Organization Contact URI Last Updated
Akshay Kumar MongoDB, Inc. akshay&mongodb.com 2019-02-21
Alexander Melamed alexander.melamed&iba-ag.com 2018-02-12
Amandeep Jawa dpap&apple.com 2004-11
Bharathi Sivaramakrishnan bharathi.sivaramakrishnan&oracle.com 2017-02-10
Chris Newman chris.newman&oracle.com 2017-01-26
Christoph Anton Mitterer calestyo&scientia.net 2009-03-10
Christopher Cordray ccordray&sciencelogic.com 2008-06-05
Cullen Jennings fluffy&cisco.com 2010-02-03
Daniel Whelan dwhelan&filenet.com
Dirk Kutscher dku&informatik.uni-bremen.de
Don Sullivan donald.v.sullivan&nasa.gov 2010-02-16
Fabrice Paget onefrench&me.com 2012-10-23
Flexera pbland&flexera.com 2018-08-22
Flexera Software security&flexerasoftware.com 2016-07-19
Florian Weimer fweimer&redhat.com 2013-03-12
Francesco Rosi frosi&orenburg.com 2006-01
Gabriel Levy glevy&riverbed.com 2008-08-29
Geoff Back geoff&demonlair.co.uk 2010-02-01
Grant Gilchrist grant&enernex.com 2010-10-18
Guy Keren Guy_Keren&mail.stil.scitex.com
Henrik Johnson Quest Software henrik.johnson&quest.com 2012-04-09
iba AG info&iba-ag.com 2018-02-12
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Igor Ratner igor&zixi.com 2015-11-16
Jack Visoky jmvisoky&ra.rockwell.com 2017-10-06
James King III jking&ariessys.com
Jude George jude&nas.nasa.gov
Kevin Bube Mahr GmbH Göttingen kevin.bube&mahr.de 2013-09-02
Mahr GmbH Göttingen info&mahr.de 2013-09-02
Matthew Whited matt&thedotnetfactory.com 2008-01-16
Michael Sweet msweet&ctr.nawcad.navy.mil
MicroTechniX Info&microtechnix.com 2014-10-13
MongoDB, Inc. akshay&mongodb.com 2019-02-21
OpenJDK discuss&openjdk.java.net 2013-03-12
Oracle Corp bharathi.sivaramakrishnan&oracle.com
chris.newman&oracle.com
2017-02-10
Patrick Stein Patrick.Stein&jinx.eu 2011-10-24
Paul Bland pbland&flexera.com 2018-08-22
Quest Software iana.quest-disc&quest.com 2012-04-09
Richard Foss r.foss&ru.ac.za 2011-02-10
Richard Kennedy Richard&smallcellforum.org 2017-01-24
Robot Framework Foundation robotframework-foundation&googlegroups.com 2017-01-26
Ronald G. Minnich rminnich&gmail.com 2022-05-13
Ryan Mack rmack&microsoft.com 2009-04-29
Small Cell Forum Richard&smallcellforum.org 2017-01-24
Vlad Bondarenko bondarenko.vlad.univ&gmail.com 2024-09-23
Yarochkin Michail MicroTechniX Michail.Yarochkin&microtechnix.com 2014-10-13
Zixi igor&zixi.com 2015-11-16