Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| pim-port | 8471 | sctp | PIM over Reliable Transport | IESG | IETF Chair | 2008-08-21 | RFC 6559 | ||||
| 8471 | udp | Reserved | |||||||||
| semi-grpc | 8710 | tcp | gRPC for SEMI Standards implementations | SEMI | Albert Fuchigami | 2020-01-10 | |||||
| 8710 | udp | Reserved | |||||||||
| nvc | 8711 | tcp | Nuance Voice Control | Nuance Communications | Diego Negre | 2012-10-05 | |||||
| 8711 | udp | Reserved | |||||||||
| 8712-8731 | Unassigned | ||||||||||
| 8771-8777 | Unassigned | ||||||||||
| kca-service | 9878 | udp | The KX509 Kerberized Certificate Issuance Protocol in Use in 2012 | IESG | IETF Chair | 2012-07-12 | RFC 6717 | Historically, this service has been referred to as "kca_service", but this service name does not meet the registry requirements. | |||
| 11171 | tcp | Reserved | |||||||||
| snss | 11171 | udp | Surgical Notes Security Service Discovery (SNSS) | David Lethe | David Lethe | 2010-12-24 | |||||
| hkp | 11371 | tcp | OpenPGP HTTP Keyserver | David Shaw | David Shaw | 2003-05 | |||||
| hkp | 11371 | udp | OpenPGP HTTP Keyserver | David Shaw | David Shaw | 2003-05 | |||||
| 11624-11719 | Unassigned | Unauthorized Use Known on port 11711 | |||||||||
| tibsd | 11971 | tcp | TiBS Service | Teradactyl LLC | Kristen Webb | 2019-05-17 | |||||
| 11971 | udp | Reserved | |||||||||
| 12169-12171 | Unassigned | ||||||||||
| 13401-13719 | Unassigned | ||||||||||
| 17011-17183 | Unassigned | ||||||||||
| vestasdlp | 17184 | tcp | Vestas Data Layer Protocol | Vestas Wind Systems | Teunis de Wit | 2013-10-30 | |||||
| 17184 | udp | Reserved | |||||||||
| soundsvirtual | 17185 | tcp | Sounds Virtual | Richard Snider | Richard Snider | ||||||
| soundsvirtual | 17185 | udp | Sounds Virtual | Richard Snider | Richard Snider | ||||||
| 17186-17218 | Unassigned | ||||||||||
| 20671-20809 | Unassigned | ||||||||||
| 23054-23271 | Unassigned | ||||||||||
| rna | 25471 | sctp | RNSAP User Adaptation for Iurh | Dario S. Tonesi | Dario S. Tonesi | 2011-02-07 | |||||
| filenet-rmi | 32771 | tcp | FileNET RMI | Chris Adkins | Chris Adkins | ||||||
| filenet-rmi | 32771 | udp | FileNet RMI | Chris Adkins | Chris Adkins | ||||||
| 36866-37471 | Unassigned | ||||||||||
| 38463-38471 | Unassigned | ||||||||||
| jvl-mactalk | 47100 | udp | Configuration of motors connected to Industrial Ethernet | JVL Industri Elektronik | Kim Berthelsen | 2012-12-21 | |||||
| 47100 | tcp | Reserved | |||||||||
| 47101-47556 | Unassigned | ||||||||||
| jnx-kcsync | tcp | jollys keychain cloud sync protocol | Patrick Stein | Patrick Stein | 2011-10-24 | Defined TXT keys: hash=<40hex characters> salt=<40hex characters> uuid=<40hex characters> Example: hash=5e7580598c0d7064d4fc79faaeb42585e1a675f8 salt=f0164cb3a0c3d7efe75abea8fda86d2d56c8dda9 uuid=db61dc092922252e45bbb264f59147138c7fd5fa |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Albert Fuchigami | albert.fuchigami&peergroup.com | 2020-01-10 | |
| Chris Adkins | cadkins&filenet.com | 2006-10 | |
| Dario S. Tonesi | dario.tonesi&nsn.com | 2011-02-07 | |
| David Lethe | david&santools.com | 2010-12-24 | |
| David Shaw | dshaw&jabberwocky.com | 2003-05 | |
| Diego Negre | Nuance Communications | Diego.Negre&nuance.com | 2012-10-05 |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| JVL Industri Elektronik | jvl&jvl.dk | 2012-12-21 | |
| Kim Berthelsen | JVL Industri Elektronik | kb&jvl.dk | 2012-12-21 |
| Kristen Webb | kwebb&teradactyl.com | 2019-05-17 | |
| Nuance Communications | NOD_SolutionsArchitecture&nuance.com | 2012-10-05 | |
| Patrick Stein | Patrick.Stein&jinx.eu | 2011-10-24 | |
| Richard Snider | rsnider&sounds.com | ||
| SEMI | jamano&semi.org | 2020-01-10 | |
| Teradactyl LLC | vendors&teradactyl.com | 2019-05-17 | |
| Teunis de Wit | Vestas Wind Systems | tdwi&vestas.com | 2013-10-30 |
| Vestas Wind Systems | tdwi&vestas.com | 2013-10-30 |