Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-11-04

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
famdc 10081 udp FAM Archive Server Frode Randers Frode Randers 2006-01
10810 tcp Reserved
nmc-disc 10810 udp Nuance Mobile Care Discovery Gordon Waddell Gordon Waddell 2011-03-21
10811-10859 Unassigned
10881-10932 Unassigned
13725-13781 Unassigned
13787-13817 Unassigned
dsmcc-config 13818 tcp DSMCC Config Tim Addington Tim Addington ISO/IEC 13818-6 MPEG-2 DSM-CC
dsmcc-config 13818 udp DSMCC Config Tim Addington Tim Addington ISO/IEC 13818-6 MPEG-2 DSM-CC
dsmcc-session 13819 tcp DSMCC Session Messages Tim Addington Tim Addington ISO/IEC 13818-6 MPEG-2 DSM-CC
dsmcc-session 13819 udp DSMCC Session Messages Tim Addington Tim Addington ISO/IEC 13818-6 MPEG-2 DSM-CC
dsmcc-passthru 13820 tcp DSMCC Pass-Thru Messages Tim Addington Tim Addington ISO/IEC 13818-6 MPEG-2 DSM-CC
dsmcc-passthru 13820 udp DSMCC Pass-Thru Messages Tim Addington Tim Addington ISO/IEC 13818-6 MPEG-2 DSM-CC
dsmcc-download 13821 tcp DSMCC Download Protocol Tim Addington Tim Addington ISO/IEC 13818-6 MPEG-2 DSM-CC
dsmcc-download 13821 udp DSMCC Download Protocol Tim Addington Tim Addington ISO/IEC 13818-6 MPEG-2 DSM-CC
dsmcc-ccp 13822 tcp DSMCC Channel Change Protocol Tim Addington Tim Addington ISO/IEC 13818-6 MPEG-2 DSM-CC
dsmcc-ccp 13822 udp DSMCC Channel Change Protocol Tim Addington Tim Addington ISO/IEC 13818-6 MPEG-2 DSM-CC
18001-18103 Unassigned
radpdf 18104 tcp RAD PDF Service Christopher Truxaw Christopher Truxaw 2010-10-15
18104 udp Reserved
18105-18135 Unassigned
racf 18136 tcp z/OS Resource Access Control Facility Bruce Wells Bruce Wells 2010-10-04
18136 udp Reserved
18137-18180 Unassigned
opsec-cvp 18181 tcp OPSEC CVP Alon Kantor Alon Kantor
opsec-cvp 18181 udp OPSEC CVP Alon Kantor Alon Kantor
opsec-ufp 18182 tcp OPSEC UFP Alon Kantor Alon Kantor
opsec-ufp 18182 udp OPSEC UFP Alon Kantor Alon Kantor
opsec-sam 18183 tcp OPSEC SAM Alon Kantor Alon Kantor
opsec-sam 18183 udp OPSEC SAM Alon Kantor Alon Kantor
opsec-lea 18184 tcp OPSEC LEA Alon Kantor Alon Kantor
opsec-lea 18184 udp OPSEC LEA Alon Kantor Alon Kantor
opsec-omi 18185 tcp OPSEC OMI Alon Kantor Alon Kantor
opsec-omi 18185 udp OPSEC OMI Alon Kantor Alon Kantor
ohsc 18186 tcp Occupational Health SC David Fudge David Fudge 2003-08
ohsc 18186 udp Occupational Health Sc David Fudge David Fudge 2003-08
opsec-ela 18187 tcp OPSEC ELA Alon Kantor Alon Kantor
opsec-ela 18187 udp OPSEC ELA Alon Kantor Alon Kantor
18188-18240 Unassigned
infotos 18881 tcp Infotos Marcel Dube Marcel Dube 2004-11
infotos 18881 udp Infotos Marcel Dube Marcel Dube 2004-11
20481-20669 Unassigned
crtech-nlm 20810 tcp CRTech NLM Cullimore And Ring Technologies Dave Wilkins 2021-06-24
20810 udp Reserved
20811-20998 Unassigned
24681-24726 Unassigned
27505-27781 Unassigned
28081-28118 Unassigned
28119 tcp Reserved
a27-ran-ran 28119 udp A27 cdma2000 RAN Management 3GPP2 Zhiming Li 2012-04-13
28120-28199 Unassigned
32802-32810 Unassigned
retp 32811 tcp Real Estate Transport Protocol Corey Leong Corey Leong 2010-10-11
32811 udp Reserved
32812-32895 Unassigned
34981-34999 Unassigned
turbonote-1 39681 tcp TurboNote Default Port Peter Hyde Peter Hyde
turbonote-1 39681 udp TurboNote Default Port Peter Hyde Peter Hyde
44601-44817 Unassigned
EtherNet-IP-2 44818 tcp EtherNet/IP messaging

IANA assigned this well-formed service name as a replacement for "EtherNet/IP-2".
Brian Batke Brian Batke New contact added for port 44818 on 2008-02-01
EtherNet/IP-2 44818 tcp EtherNet/IP messaging Brian Batke Brian Batke New contact added for port 44818 on 2008-02-01 This entry is an alias to "EtherNet-IP-2". This entry is now historic, not usable for use with many common service discovery mechanisms.
EtherNet-IP-2 44818 udp EtherNet/IP messaging

IANA assigned this well-formed service name as a replacement for "EtherNet/IP-2".
Brian Batke Brian Batke New contact added for port 44818 on 2008-02-01
EtherNet/IP-2 44818 udp EtherNet/IP messaging Brian Batke Brian Batke New contact added for port 44818 on 2008-02-01 This entry is an alias to "EtherNet-IP-2". This entry is now historic, not usable for use with many common service discovery mechanisms.
44819-44899 Unassigned
47810-47999 Unassigned
48051-48127 Unassigned
isnetserv 48128 tcp Image Systems Network Services Bengt Gustafsson Bengt Gustafsson 2006-05
isnetserv 48128 udp Image Systems Network Services Bengt Gustafsson Bengt Gustafsson 2006-05
blp5 48129 tcp Bloomberg locator Albert Hou Albert Hou 2006-05
blp5 48129 udp Bloomberg locator Albert Hou Albert Hou 2006-05
48130-48555 Unassigned
autotunnel udp IPSEC VPN tunnel over UDP Stuart Cheshire Stuart Cheshire 2019-05-04 RFC 6281 Defined TXT Keys: None
dns-llq-tls tcp DNS Long-Lived Queries over TLS Stuart Cheshire Stuart Cheshire 2019-05-04 RFC 6281 Defined TXT Keys: None
dns-update-tls tcp DNS Dynamic Update Service over TLS Stuart Cheshire Stuart Cheshire 2019-05-04 RFC 6281 DNS Dynamic Update Service for a given domain may not necessarily be provided by the principal name servers as advertised by the domain's "NS" records, and may not necessarily always be provided on port 53. The "_dns-update._udp.<domain>." SRV record gives the target host and port where DNS Dynamic Update Service is provided for the named domain.

Contact Information

Name Organization Contact URI Last Updated
3GPP2 lizhiming&huawei.com 2012-01-11
Albert Hou ahou1&bloomberg.com 2006-05
Alon Kantor alonk&checkpoint.com
Bengt Gustafsson bengt.gustafsson&imagesystems.se 2006-05
Brian Batke eip.jsig&gmail.com
Bruce Wells brwells&us.ibm.com 2010-10-04
Christopher Truxaw ctruxaw&redsoftware.com 2010-10-15
Corey Leong cleong&gr8c.org 2010-10-11
Cullimore And Ring Technologies dave.wilkins&crtech.com 2021-06-24
Dave Wilkins dave.wilkins&crtech.com 2021-06-24
David Fudge david.fudge&tssi.co.uk 2003-08
Frode Randers Frode.Randers&tietoenator.com 2006-01
Gordon Waddell gordon.waddell&nuance.com 2011-03-21
Marcel Dube marceldube&videotron.ca 2004-11
Peter Hyde peter&spis.co.nz
Stuart Cheshire cheshire&apple.com 2022-07-11
Tim Addington Tim.Addington&sciatl.com
Zhiming Li 3GPP2 lizhiming&huawei.com 2012-01-11