Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-11-04

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
opsec-ela 18187 tcp OPSEC ELA Alon Kantor Alon Kantor
opsec-ela 18187 udp OPSEC ELA Alon Kantor Alon Kantor
18669-18768 Unassigned
ique 18769 tcp IQue Protocol Avi Drissman Avi Drissman 2002-07
ique 18769 udp IQue Protocol Avi Drissman Avi Drissman 2002-07
18770-18880 Unassigned
18882-18887 Unassigned
19542-19787 Unassigned
iec-104-sec 19998 tcp IEC 60870-5-104 process control - secure Grant Gilchrist Grant Gilchrist 2010-10-18
24387-24464 Unassigned
exoconfig 26487 tcp EXOconfig Urban Fosseus Urban Fosseus 2008-12-24
exoconfig 26487 udp EXOconfig Urban Fosseus Urban Fosseus 2008-12-24
27783-27875 Unassigned
astrolink 27876 tcp Astrolink Protocol Alanax Technologies, Inc Wesley Eddy 2013-01-14
27876 udp Reserved
27877-27998 Unassigned
mtrace 33435 udp IP Multicast Traceroute IESG IETF Chair 2017-12-13 2019-08-09 RFC 8487 Known Unauthorized Use on port 33435
38639-38799 Unassigned
43001-43187 Unassigned
44323 udp Unassigned "pcp" assignment withdrawn, moved to port 5351 per RFC 6887
dns-push-tls tcp DNS Push Notification Service Type IESG IETF Chair 2019-11-25 RFC 8765, Section 6.1 Defined TXT Keys: None

Contact Information

Name Organization Contact URI Last Updated
Alanax Technologies, Inc brian.barritt&alanax.com 2013-01-14
Alon Kantor alonk&checkpoint.com
Avi Drissman ique-protocol&harrisbaseview.com 2002-07
Grant Gilchrist grant&enernex.com 2010-10-18
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Urban Fosseus urban.fosseus&regin.se 2008-12-24
Wesley Eddy Alanax Technologies, Inc wesley.eddy&alanax.com 2013-01-14