Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| kerberos-adm | 749 | tcp | kerberos administration | ||||||||
| kerberos-adm | 749 | udp | kerberos administration | ||||||||
| con | 759 | tcp | |||||||||
| con | 759 | udp | |||||||||
| vid | 769 | tcp | |||||||||
| vid | 769 | udp | |||||||||
| 778-779 | Unassigned | ||||||||||
| 788-799 | Unassigned | Unauthorized Use Known on port 796 | |||||||||
| 803-809 | Unassigned | ||||||||||
| pkix-3-ca-ra | 829 | tcp | PKIX-3 CA/RA | Carlisle Adams | Carlisle Adams | ||||||
| pkix-3-ca-ra | 829 | udp | PKIX-3 CA/RA | Carlisle Adams | Carlisle Adams | ||||||
| 831 | tcp | Reserved | 2025-09-29 | Previously assigned to NETCONF over BEEP but released by RFC 9900 | |||||||
| 831 | udp | Reserved | 2025-09-29 | Previously assigned to NETCONF over BEEP but released by RFC 9900 | |||||||
| 832 | tcp | Reserved | 2025-09-29 | Previously assigned to NETCONF over SOAP but released by RFC 9900 | |||||||
| 832 | udp | Reserved | 2025-09-29 | Previously assigned to NETCONF over SOAP but released by RFC 9900 | |||||||
| 833 | tcp | Reserved | 2025-09-29 | Previously assigned to NETCONF over SOAP but released by RFC 9900 | |||||||
| 833 | udp | Reserved | 2025-09-29 | Previously assigned to NETCONF over SOAP but released by RFC 9900 | |||||||
| 849-852 | Unassigned | ||||||||||
| domain-s | 853 | udp | DNS query-response protocol run over DTLS or QUIC | IESG | IETF Chair | 2015-10-08 | 2022-04-01 | RFC 7858; RFC 8094; RFC 9250 | |||
| 855-859 | Unassigned | ||||||||||
| 889-899 | Unassigned | ||||||||||
| omginitialrefs | 900 | tcp | OMG Initial Refs | Christian Callsen | Christian Callsen | ||||||
| omginitialrefs | 900 | udp | OMG Initial Refs | Christian Callsen | Christian Callsen | ||||||
| smpnameres | 901 | tcp | SMPNAMERES | Leif Ekblad | Leif Ekblad | ||||||
| smpnameres | 901 | udp | SMPNAMERES | Leif Ekblad | Leif Ekblad | ||||||
| ideafarm-door | 902 | tcp | self documenting Telnet Door | ||||||||
| ideafarm-door | 902 | udp | self documenting Door: send 0x00 for info | ||||||||
| ideafarm-panic | 903 | tcp | self documenting Telnet Panic Door | Wo'o Ideafarm | Wo'o Ideafarm | ||||||
| ideafarm-panic | 903 | udp | self documenting Panic Door: send 0x00 for info | Wo'o Ideafarm | Wo'o Ideafarm | ||||||
| 904-909 | Unassigned | ||||||||||
| kink | 910 | tcp | Kerberized Internet Negotiation of Keys (KINK) | RFC 4430 | |||||||
| kink | 910 | udp | Kerberized Internet Negotiation of Keys (KINK) | RFC 4430 | |||||||
| xact-backup | 911 | tcp | xact-backup | Bill Carroll | Bill Carroll | ||||||
| xact-backup | 911 | udp | xact-backup | Bill Carroll | Bill Carroll | ||||||
| apex-mesh | 912 | tcp | APEX relay-relay service | ||||||||
| apex-mesh | 912 | udp | APEX relay-relay service | ||||||||
| apex-edge | 913 | tcp | APEX endpoint-relay service | RFC 3340 | |||||||
| apex-edge | 913 | udp | APEX endpoint-relay service | RFC 3340 | |||||||
| 914 | tcp | Reserved | |||||||||
| rift-lies | 914 | udp | Routing in Fat Trees Link Information Element | IESG | IETF Chair | 2023-02-17 | 2024-06-07 | RFC 9692 | |||
| 915 | tcp | Reserved | |||||||||
| rift-ties | 915 | udp | Routing in Fat Trees Topology Information Element | IESG | IETF Chair | 2023-02-17 | 2024-06-07 | RFC 9692 | |||
| 916-952 | Unassigned | ||||||||||
| rndc | 953 | tcp | BIND9 remote name daemon controller | Internet Systems Consortium, Inc. | Ray Bellis | 2017-06-08 | |||||
| 953 | udp | Reserved | |||||||||
| 954-988 | Unassigned | ||||||||||
| ftps-data | 989 | tcp | ftp protocol, data, over TLS/SSL | ||||||||
| ftps-data | 989 | udp | ftp protocol, data, over TLS/SSL | ||||||||
| ftps | 990 | tcp | ftp protocol, control, over TLS/SSL | Christopher Allen | Christopher Allen | ||||||
| ftps | 990 | udp | ftp protocol, control, over TLS/SSL | Christopher Allen | Christopher Allen | ||||||
| nas | 991 | tcp | Netnews Administration System | Vera Heinau; Heiko Schlichting | Vera Heinau; Heiko Schlichting | 2017-02-10 | RFC 4707 | ||||
| nas | 991 | udp | Netnews Administration System | Vera Heinau; Heiko Schlichting | Vera Heinau; Heiko Schlichting | 2017-02-10 | RFC 4707 | ||||
| telnets | 992 | tcp | telnet protocol over TLS/SSL | ||||||||
| telnets | 992 | udp | telnet protocol over TLS/SSL | ||||||||
| imaps | 993 | tcp | IMAP over TLS protocol | IESG | IETF Chair | 2021-02-22 | RFC 3501; RFC 8314; RFC 9051 | ||||
| 993 | udp | Reserved | 2021-02-22 | RFC 9051 | |||||||
| 994 | tcp | Reserved | 2011-08-31 | (previous contact was Christopher Allen) | |||||||
| 994 | udp | Reserved | |||||||||
| pop3s | 995 | tcp | POP3 over TLS protocol | IESG | IETF Chair | 2017-12-12 | RFC 8314 | ||||
| pop3s | 995 | udp | pop3 protocol over TLS/SSL (was spop3) | Gordon Mangione | Gordon Mangione | ||||||
| vsinet | 996 | tcp | vsinet | Rob Juergens | Rob Juergens | ||||||
| vsinet | 996 | udp | vsinet | Rob Juergens | Rob Juergens | ||||||
| maitrd | 997 | tcp | |||||||||
| maitrd | 997 | udp | |||||||||
| busboy | 998 | tcp | |||||||||
| puparp | 998 | udp | |||||||||
| garcon | 999 | tcp | |||||||||
| applix | 999 | udp | Applix ac | ||||||||
| puprouter | 999 | tcp | |||||||||
| puprouter | 999 | udp | |||||||||
| 1009 | Unassigned | ||||||||||
| exp1 | 1021 | tcp | RFC3692-style Experiment 1 | IESG | IETF Chair | [1]RFC 4727; RFC 6335 | |||||
| exp1 | 1021 | udp | RFC3692-style Experiment 1 | IESG | IETF Chair | [1]RFC 4727; RFC 6335 | |||||
| exp1 | 1021 | sctp | RFC3692-style Experiment 1 | IESG | IETF Chair | [1]RFC 4727; RFC 6335 | |||||
| exp1 | 1021 | dccp | RFC3692-style Experiment 1 | IESG | IETF Chair | [1]RFC 4727; RFC 6335 | |||||
| exp2 | 1022 | tcp | RFC3692-style Experiment 2 | IESG | IETF Chair | [1]RFC 4727; RFC 6335 | |||||
| exp2 | 1022 | udp | RFC3692-style Experiment 2 | IESG | IETF Chair | [1]RFC 4727; RFC 6335 | |||||
| exp2 | 1022 | sctp | RFC3692-style Experiment 2 | IESG | IETF Chair | [1]RFC 4727; RFC 6335 | |||||
| exp2 | 1022 | dccp | RFC3692-style Experiment 2 | IESG | IETF Chair | [1]RFC 4727; RFC 6335 | |||||
| solid-mux | 1029 | tcp | Solid Mux Server | Anders Borg | Anders Borg | 2004-11 | |||||
| solid-mux | 1029 | udp | Solid Mux Server | Anders Borg | Anders Borg | 2004-11 | |||||
| sbl | 1039 | tcp | Streamlined Blackhole | Jonathan A. Zdziaraski | Jonathan A. Zdziaraski | 2004-11 | |||||
| sbl | 1039 | udp | Streamlined Blackhole | Jonathan A. Zdziaraski | Jonathan A. Zdziaraski | 2004-11 | |||||
| td-postman | 1049 | tcp | Tobit David Postman VPMN | Franz-Josef Leuders | Franz-Josef Leuders | ||||||
| td-postman | 1049 | udp | Tobit David Postman VPMN | Franz-Josef Leuders | Franz-Josef Leuders | ||||||
| nimreg | 1059 | tcp | nimreg | Robert Gordon | Robert Gordon | ||||||
| nimreg | 1059 | udp | nimreg | Robert Gordon | Robert Gordon | ||||||
| cognex-insight | 1069 | tcp | COGNEX-INSIGHT | Steve Olson | Steve Olson | ||||||
| cognex-insight | 1069 | udp | COGNEX-INSIGHT | Steve Olson | Steve Olson | ||||||
| asprovatalk | 1079 | tcp | ASPROVATalk | Chiew Farn Chung | Chiew Farn Chung | ||||||
| asprovatalk | 1079 | udp | ASPROVATalk | Chiew Farn Chung | Chiew Farn Chung | ||||||
| ff-annunc | 1089 | tcp | FF Annunciation | ||||||||
| ff-annunc | 1089 | udp | FF Annunciation | ||||||||
| ff-fms | 1090 | tcp | FF Fieldbus Message Specification | ||||||||
| ff-fms | 1090 | udp | FF Fieldbus Message Specification | ||||||||
| ff-sm | 1091 | tcp | FF System Management | Fieldbus Foundation | Fieldbus Foundation | ||||||
| ff-sm | 1091 | udp | FF System Management | Fieldbus Foundation | Fieldbus Foundation | ||||||
| obrpd | 1092 | tcp | Open Business Reporting Protocol | William Randolph Royere III | William Randolph Royere III | ||||||
| obrpd | 1092 | udp | Open Business Reporting Protocol | William Randolph Royere III | William Randolph Royere III | ||||||
| proofd | 1093 | tcp | PROOFD | ||||||||
| proofd | 1093 | udp | PROOFD |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Anders Borg | anders.borg&solid.se | 2004-11 | |
| Bill Carroll | billc&xactlabs.com | ||
| Carlisle Adams | Cadams&entrust.com | ||
| Chiew Farn Chung | cfchung&asprova.com | ||
| Christian Callsen | Christian.Callsen&eng.sun.com | ||
| Christopher Allen | ChristopherA&consensus.com | ||
| Fieldbus Foundation | dave.glanzer&fieldbus.org | 2002-10 | |
| Franz-Josef Leuders | development&tobit.com | ||
| Gordon Mangione | gordmµsoft.com | ||
| Heiko Schlichting | heiko.schlichting&fu-berlin.de | 2022-06-07 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Internet Systems Consortium, Inc. | info&isc.org | 2017-06-08 | |
| Jonathan A. Zdziaraski | jonathan&nuclearelephant.com | 2004-11 | |
| Leif Ekblad | leif&rdos.net | ||
| Ray Bellis | ray&isc.org | 2017-06-08 | |
| Rob Juergens | robj&vsi.com | ||
| Robert Gordon | rbg&austin.ibm.com | ||
| Steve Olson | solson&cognex.com | ||
| Vera Heinau | vera.heinau&fu-berlin.de | 2022-06-07 | |
| William Randolph Royere III | william&royere.net | ||
| Wo'o Ideafarm | b85f3c23.9ad6f42c&ideafarm.com |