Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 9027-9049 | Unassigned | ||||||||||
| versiera | 9050 | tcp | Versiera Agent Listener | Frank Pikelner | Frank Pikelner | 2010-01-15 | |||||
| 9050 | udp | Reserved | |||||||||
| fio-cmgmt | 9051 | tcp | Fusion-io Central Manager Service | Jim Sermersheim | Jim Sermersheim | 2010-01-15 | |||||
| 9051 | udp | Reserved | |||||||||
| 9052-9059 | Unassigned | ||||||||||
| CardWeb-IO | 9060 | tcp | CardWeb request-response I/O exchange | CardWare, Inc | David Wyatt | 2016-10-07 | 2025-07-17 | ||||
| CardWeb-RT | 9060 | udp | CardWeb realtime device data | CardWare, Inc | David Wyatt | 2016-10-07 | 2025-07-17 | ||||
| 9061-9079 | Unassigned | ||||||||||
| glrpc | 9080 | tcp | Groove GLRPC | Adrian Popescu | Adrian Popescu | 2002-09 | |||||
| glrpc | 9080 | udp | Groove GLRPC | Adrian Popescu | Adrian Popescu | 2002-09 | |||||
| 9081 | tcp | Reserved | |||||||||
| cisco-aqos | 9081 | udp | Required for Adaptive Quality of Service | Manish Surolia | Manish Surolia | 2017-10-27 | |||||
| lcs-ap | 9082 | sctp | LCS Application Protocol | Kimmo Kymalainen | Kimmo Kymalainen | 2010-06-04 | |||||
| emc-pp-mgmtsvc | 9083 | tcp | EMC PowerPath Mgmt Service | Jim Perreault | Jim Perreault | 2010-06-04 | |||||
| 9083 | udp | Reserved | |||||||||
| aurora | 9084 | tcp | IBM AURORA Performance Visualizer | Jeroen Massar | Jeroen Massar | 2008-08-21 | |||||
| aurora | 9084 | udp | IBM AURORA Performance Visualizer | Jeroen Massar | Jeroen Massar | 2008-08-21 | |||||
| aurora | 9084 | sctp | IBM AURORA Performance Visualizer | Jeroen Massar | Jeroen Massar | 2008-08-21 | |||||
| ibm-rsyscon | 9085 | tcp | IBM Remote System Console | William LePera | William LePera | 2008-06-18 | |||||
| ibm-rsyscon | 9085 | udp | IBM Remote System Console | William LePera | William LePera | 2008-06-18 | |||||
| net2display | 9086 | tcp | Vesa Net2Display | Kenneth B. Ocheltree | Kenneth B. Ocheltree | 2008-01-07 | |||||
| net2display | 9086 | udp | Vesa Net2Display | Kenneth B. Ocheltree | Kenneth B. Ocheltree | 2008-01-07 | |||||
| classic | 9087 | tcp | Classic Data Server | Paul Cadarette | Paul Cadarette | 2007-01 | |||||
| classic | 9087 | udp | Classic Data Server | Paul Cadarette | Paul Cadarette | 2007-01 | |||||
| sqlexec | 9088 | tcp | IBM Informix SQL Interface | Jonathan Leffler | Jonathan Leffler | 2005-12 | |||||
| sqlexec | 9088 | udp | IBM Informix SQL Interface | Jonathan Leffler | Jonathan Leffler | 2005-12 | |||||
| sqlexec-ssl | 9089 | tcp | IBM Informix SQL Interface - Encrypted | Jonathan Leffler | Jonathan Leffler | 2005-12 | |||||
| sqlexec-ssl | 9089 | udp | IBM Informix SQL Interface - Encrypted | Jonathan Leffler | Jonathan Leffler | 2005-12 | |||||
| websm | 9090 | tcp | WebSM | I-Hsing Tsao | I-Hsing Tsao | ||||||
| websm | 9090 | udp | WebSM | I-Hsing Tsao | I-Hsing Tsao | ||||||
| xmltec-xmlmail | 9091 | tcp | xmltec-xmlmail | Mitch Kaufman | Mitch Kaufman | ||||||
| xmltec-xmlmail | 9091 | udp | xmltec-xmlmail | Mitch Kaufman | Mitch Kaufman | ||||||
| XmlIpcRegSvc | 9092 | tcp | Xml-Ipc Server Reg | Casey Harrington | Casey Harrington | 2006-01 | |||||
| XmlIpcRegSvc | 9092 | udp | Xml-Ipc Server Reg | Casey Harrington | Casey Harrington | 2006-01 | |||||
| copycat | 9093 | tcp | Copycat database replication service | Microtec Informatique | Raphael Neve | 2012-03-15 | |||||
| 9093 | udp | Reserved | |||||||||
| 9094-9099 | Unassigned | ||||||||||
| 9184-9190 | Unassigned | ||||||||||
| otp | 9390 | tcp | OpenVAS Transfer Protocol | Tim Brown | Tim Brown | 2008-12-24 | |||||
| 9390 | udp | Reserved | |||||||||
| 9890-9897 | Unassigned | ||||||||||
| iua | 9900 | tcp | IUA | Lyndon Ong | Lyndon Ong | ||||||
| iua | 9900 | udp | IUA | Lyndon Ong | Lyndon Ong | ||||||
| iua | 9900 | sctp | IUA | Lyndon Ong | Lyndon Ong | ||||||
| enrp | 9901 | udp | enrp server channel | ||||||||
| enrp-sctp | 9901 | sctp | enrp server channel | RFC 5353 | |||||||
| enrp-sctp-tls | 9902 | sctp | enrp/tls server channel | RFC 5353 | |||||||
| 9903 | tcp | Reserved | |||||||||
| multicast-ping | 9903 | udp | Multicast Ping Protocol | 2011-12-09 | RFC 6450 | ||||||
| 9904-9908 | Unassigned | ||||||||||
| domaintime | 9909 | tcp | domaintime | Jeffry Dwight | Jeffry Dwight | ||||||
| domaintime | 9909 | udp | domaintime | Jeffry Dwight | Jeffry Dwight | ||||||
| osm-appsrvr | 9990 | tcp | OSM Applet Server | Vinay Gupta | Vinay Gupta | 2003-08 | |||||
| osm-appsrvr | 9990 | udp | OSM Applet Server | Vinay Gupta | Vinay Gupta | 2003-08 | |||||
| hip-nat-t | 10500 | udp | HIP NAT-Traversal | IESG | IETF Chair | 2020-08-12 | RFC 5770; RFC 9028 | ||||
| rmiaux | 10990 | tcp | Auxiliary RMI Port | Eugen Bacic | Eugen Bacic | ||||||
| rmiaux | 10990 | udp | Auxiliary RMI Port | Eugen Bacic | Eugen Bacic | ||||||
| 11490-11599 | Unassigned | ||||||||||
| 16790-16899 | Unassigned | ||||||||||
| newbay-snc-mc | 16900 | tcp | Newbay Mobile Client Update Service | Srinivasa Nayudu | Srinivasa Nayudu | 2009-07-06 | |||||
| newbay-snc-mc | 16900 | udp | Newbay Mobile Client Update Service | Srinivasa Nayudu | Srinivasa Nayudu | 2009-07-06 | |||||
| 16901-16949 | Unassigned | ||||||||||
| 16951-16990 | Unassigned | ||||||||||
| igrid | 19000 | tcp | iGrid Server | Massimo Cafaro | Massimo Cafaro | 2004-11 | |||||
| igrid | 19000 | udp | iGrid Server | Massimo Cafaro | Massimo Cafaro | 2004-11 | |||||
| 19001-19006 | Unassigned | ||||||||||
| scintilla | 19007 | tcp | Scintilla protocol for device services | Veejansh Inc | Chirag Patel | 2014-03-04 | |||||
| scintilla | 19007 | udp | Scintilla protocol for device services | Veejansh Inc | Chirag Patel | 2014-03-04 | |||||
| 19008-19019 | Unassigned | ||||||||||
| j-link | 19020 | tcp | J-Link TCP/IP Protocol | SEGGER Microcontroller GmbH & Co. KG | SEGGER Microcontroller GmbH & Co. KG | ||||||
| 19020 | udp | Reserved | |||||||||
| 19021-19190 | Unassigned | ||||||||||
| faircom-db | 19790 | tcp | FairCom Database | FairCom Corporation | Michael Bowers | 2020-12-04 | |||||
| 19790 | udp | Reserved | |||||||||
| vofr-gateway | 21590 | tcp | VoFR Gateway | Marty Borden | Marty Borden | ||||||
| vofr-gateway | 21590 | udp | VoFR Gateway | Marty Borden | Marty Borden | ||||||
| tasp-net | 25900 | tcp | TASP Network Comm | Martin Ellis | Martin Ellis | 2004-11 | |||||
| tasp-net | 25900 | udp | TASP Network Comm | Martin Ellis | Martin Ellis | 2004-11 | |||||
| niobserver | 25901 | tcp | NIObserver | Roman Oliynyk | Roman Oliynyk | ||||||
| niobserver | 25901 | udp | NIObserver | Roman Oliynyk | Roman Oliynyk | ||||||
| nilinkanalyst | 25902 | tcp | NILinkAnalyst | Roman Oliynyk | Roman Oliynyk | 2007-08-30 | |||||
| nilinkanalyst | 25902 | udp | NILinkAnalyst | Roman Oliynyk | Roman Oliynyk | 2007-08-30 | |||||
| niprobe | 25903 | tcp | NIProbe | Roman Oliynyk | Roman Oliynyk | ||||||
| niprobe | 25903 | udp | NIProbe | Roman Oliynyk | Roman Oliynyk | ||||||
| 25904-25953 | Unassigned | ||||||||||
| 26490-26999 | Unassigned | ||||||||||
| 28590-28999 | Unassigned | ||||||||||
| saltd-licensing | 29000 | tcp | Siemens Licensing Server | Siemens Digital Industries Software | Tony Greatorex | 2020-06-08 | |||||
| 29000 | udp | Reserved | |||||||||
| 29001-29117 | Unassigned | ||||||||||
| digilent-adept | 33890 | tcp | Adept IP protocol | Digilent Inc. | Michael T. Alexander | 2020-06-25 | |||||
| 33890 | udp | Reserved | |||||||||
| 38866-39062 | Unassigned | ||||||||||
| vroa | 39063 | tcp | Children's hearing test/Telemedicine | Hearing Australia | Dan Zhou | 2021-12-23 | |||||
| 39063 | udp | Reserved | |||||||||
| 39064-39680 | Unassigned | ||||||||||
| ip-provision | 43190 | tcp | IP-PROVISION | Roman Kriis | Roman Kriis | ||||||
| ip-provision | 43190 | udp | IP-PROVISION | Roman Kriis | Roman Kriis | ||||||
| m3da | 44900 | tcp | M3DA is used for efficient machine-to-machine communications | Eclipse Foundation | Didier Lahay | 2013-02-22 | |||||
| m3da-disc | 44900 | udp | M3DA Discovery is used for efficient machine-to-machine communications | Eclipse Foundation | Didier Lahay | 2013-02-22 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Adrian Popescu | Adrian_Popescu&groove.net | 2002-09 | |
| CardWare, Inc | dwyatt&cardware.com | 2025-07-17 | |
| Casey Harrington | charrington&isxinc.com | 2006-01 | |
| Chirag Patel | Veejansh Inc | cpatel&veejansh.com | 2014-03-04 |
| Dan Zhou | Hearing Australia | dan.zhou&hearing.com.au | 2021-12-23 |
| David Wyatt | dwyatt&cardware.com | 2025-07-17 | |
| Didier Lahay | dlahay&sierrawireless.com | 2013-02-22 | |
| Digilent Inc. | software&digilent.com | 2020-06-25 | |
| Eclipse Foundation | license&eclipse.org | 2013-02-22 | |
| Eugen Bacic | eugen&texar.com | ||
| FairCom Corporation | alysha.brown&faircom.com | 2020-12-04 | |
| Frank Pikelner | frank.pikelner&netcraftcommunications.com | 2010-01-15 | |
| Hearing Australia | dan.zhou&hearing.com.au | 2021-12-23 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| I-Hsing Tsao | itsao&austin.ibm.com | ||
| Jeffry Dwight | jeffryd&greyware.com | ||
| Jeroen Massar | jma&zurich.ibm.com | 2008-08-21 | |
| Jim Perreault | jim.perreault&emc.com | 2010-06-04 | |
| Jim Sermersheim | jims&fusionio.com | 2010-01-15 | |
| Jonathan Leffler | jleffler&us.ibm.com | 2005-12 | |
| Kenneth B. Ocheltree | kennetho&us.ibm.com | 2008-01-07 | |
| Kimmo Kymalainen | kimmo.kymalainen&etsi.org | 2017-05-08 | |
| Lyndon Ong | Lyong&ciena.com | ||
| Manish Surolia | masurolia@cisco.com> | 2017-10-27 | |
| Martin Ellis | martin&clanleagues.net | 2004-11 | |
| Marty Borden | mborden&tollbridgetech.com | ||
| Massimo Cafaro | massimo.cafaro&unile.it | 2004-11 | |
| Michael Bowers | FairCom Corporation | mike.bowers&faircom.com | 2020-12-04 |
| Michael T. Alexander | malexander&digilentinc.com | 2020-06-25 | |
| Microtec Informatique | raphµtec.fr | 2012-03-15 | |
| Mitch Kaufman | mk&weconnectyou.com | ||
| Paul Cadarette | pcadaret&us.ibm.com | 2007-01 | |
| Raphael Neve | Microtec Informatique | raphµtec.fr | 2012-03-15 |
| Roman Kriis | roman&previo.ee | ||
| Roman Oliynyk | romano&netinst.com | ||
| Roman Oliynyk | roman&netinst.com | 2007-08-30 | |
| SEGGER Microcontroller GmbH & Co. KG | info&segger.com | 2009-01-16 | |
| Siemens Digital Industries Software | tony.greatorex&siemens.com | 2020-06-08 | |
| Srinivasa Nayudu | sn156n&att.com | 2009-07-06 | |
| Tim Brown | timb&openvas.org | 2008-12-24 | |
| Tony Greatorex | tony.greatorex&siemens.com | 2020-06-08 | |
| Veejansh Inc | admin&veejansh.com | 2014-03-04 | |
| Vinay Gupta | vinay.gupta&hp.com | 2003-08 | |
| William LePera | lepera&us.ibm.com | 2008-06-18 |