Service Name and Transport Protocol Port Number Registry

Last Updated
2026-10-09
Expert(s)
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell,
and Michael Scharf
SCTP: Michael Tuexen
DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
[RFC 6335]
Note
Service names and port numbers are used to distinguish between different
services that run over transport protocols such as TCP, UDP, DCCP, and
SCTP.

Service names are assigned on a first-come, first-served process, as
documented in [RFC 6335].

Port numbers are assigned in various ways, based on three ranges: System
Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private
Ports (49152-65535); the different uses of these ranges are described in
[RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are 
assigned by the "IETF Review" or "IESG Approval" procedures described in 
[RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, 
the "IESG Approval" process, or the "Expert Review" process, as per 
[RFC 6335]. Dynamic Ports are not assigned.

The registration procedures for service names and port numbers are
described in [RFC 6335].

Assigned ports both System and User ports SHOULD NOT be used without
or prior to IANA registration.

************************************************************************
* PLEASE NOTE THE FOLLOWING:                                           *
*                                                                      *
* ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN             *
* ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK  *
* TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT   *
* IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE     *
* ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD          *
* CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF    *
* THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER          *
* REGISTERED OR NOT.                                                   *
************************************************************************

Request an Assignment
  [https://www.iana.org/protocols/apply]

Available Formats

CSV

XML

HTML

TXT
Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
4324 Reserved 2015-05-12 This entry is being removed on 2015-05-12.
jaxer-web 4327 tcp Jaxer Web Protocol [Uri_Sarid] [Uri_Sarid] 2008-01-07
jaxer-web 4327 udp Jaxer Web Protocol [Uri_Sarid] [Uri_Sarid] 2008-01-07
jaxer-manager 4328 tcp Jaxer Manager Command Protocol [Uri_Sarid] [Uri_Sarid] 2008-01-22
jaxer-manager 4328 udp Jaxer Manager Command Protocol [Uri_Sarid] [Uri_Sarid] 2008-01-22
publiqare-sync 4329 tcp PubliQare Distributed Environment Synchronisation Engine [Tom_Maaswinkel] [Tom_Maaswinkel] 2011-02-07
dey-sapi 4330 tcp DEY Storage Administration REST API [DEY_Storage_Systems_Inc] [Garrett_D_Amore] 2013-03-01
ktickets-rest 4331 tcp ktickets REST API for event management and ticketing systems (embedded POS devices) [KeyTicket_Solutions] [MANG_Ioan-Alexandru] 2014-04-04
getty-focus 4332 tcp Getty Images FOCUS service [Matthew_Margolis] [Bryan_Ramirez] 2019-04-18
netconf-ch-ssh 4334 tcp NETCONF Call Home (SSH) [IESG] [IETF_Chair] 2016-01-12 [RFC 8071]
netconf-ch-tls 4335 tcp NETCONF Call Home (TLS) [IESG] [IETF_Chair] 2016-01-12 [RFC 8071]
restconf-ch-tls 4336 tcp RESTCONF Call Home (TLS) [IESG] [IETF_Chair] 2016-01-12 [RFC 8071]
4337-4339 Unassigned
lisp-data 4341 udp LISP Data Packets [IESG] [IETF_Chair] 2007-11-12 2021-02-17 [RFC 9300]
lisp-control 4342 udp LISP Control Packets [IETF] [IESG] 2007-05 2021-02-25 [RFC 9301]
m4-network-as 4345 tcp Macro 4 Network AS [Paul_Wren] [Paul_Wren]
m4-network-as 4345 udp Macro 4 Network AS [Paul_Wren] [Paul_Wren]
net-device 4350 tcp Net Device [Glenn_Peterson] [Glenn_Peterson]
net-device 4350 udp Net Device [Glenn_Peterson] [Glenn_Peterson]
plcy-net-svcs 4351 tcp PLCY Net Services [J_J_Ekstrom] [J_J_Ekstrom]
plcy-net-svcs 4351 udp PLCY Net Services [J_J_Ekstrom] [J_J_Ekstrom]
f5-iquery 4353 tcp F5 iQuery [Tom_Kee] [Tom_Kee]
f5-iquery 4353 udp F5 iQuery [Tom_Kee] [Tom_Kee]
qsnet-trans 4354 tcp QSNet Transmitter
qsnet-trans 4354 udp QSNet Transmitter
qsnet-workst 4355 tcp QSNet Workstation
qsnet-workst 4355 udp QSNet Workstation
qsnet-assist 4356 tcp QSNet Assistant
qsnet-assist 4356 udp QSNet Assistant
qsnet-cond 4357 tcp QSNet Conductor
qsnet-cond 4357 udp QSNet Conductor
qsnet-nucl 4358 tcp QSNet Nucleus [Neer_Kleinman] [Neer_Kleinman]
qsnet-nucl 4358 udp QSNet Nucleus [Neer_Kleinman] [Neer_Kleinman]
omabcastltkm 4359 tcp OMA BCAST Long-Term Key Messages [Frank_Hartung] [Frank_Hartung] 2007-09-07
omabcastltkm 4359 udp OMA BCAST Long-Term Key Messages [Frank_Hartung] [Frank_Hartung] 2007-09-07
matrix-vnet 4360 tcp Matrix VNet Communication Protocol

IANA assigned this well-formed service name as a replacement for "matrix_vnet".
[Rehan_Mahmood] [Rehan_Mahmood] 2009-03-18
matrix_vnet 4360 tcp Matrix VNet Communication Protocol [Rehan_Mahmood] [Rehan_Mahmood] 2009-03-18 This entry is an alias to "matrix-vnet". This entry is now historic, not usable for use with many common service discovery mechanisms.
afore-vdp-disc 4362 udp AFORE vNode Discovery protocol [Michael_Richardson] [Michael_Richardson] 2011-02-08
4363-4365 Unassigned
elpro-tunnel 4370 tcp ELPRO V2 Protocol Tunnel

IANA assigned this well-formed service name as a replacement for "elpro_tunnel".
[Harry_Courtice] [Harry_Courtice] 2008-04-14
elpro_tunnel 4370 tcp ELPRO V2 Protocol Tunnel [Harry_Courtice] [Harry_Courtice] 2008-04-14 This entry is an alias to "elpro-tunnel". This entry is now historic, not usable for use with many common service discovery mechanisms.
elpro-tunnel 4370 udp ELPRO V2 Protocol Tunnel

IANA assigned this well-formed service name as a replacement for "elpro_tunnel".
[Harry_Courtice] [Harry_Courtice] 2008-04-14
elpro_tunnel 4370 udp ELPRO V2 Protocol Tunnel [Harry_Courtice] [Harry_Courtice] 2008-04-14 This entry is an alias to "elpro-tunnel". This entry is now historic, not usable for use with many common service discovery mechanisms.
l2c-control 4371 tcp LAN2CAN Control [Phil_Tolson] [Phil_Tolson] 2008-07-07 Modified: 21 January 2010
l2c-disc 4371 udp LAN2CAN Discovery [Phil_Tolson] [Phil_Tolson] 2010-01-21
l2c-data 4372 tcp LAN2CAN Data [Phil_Tolson] [Phil_Tolson] 2008-07-07 Modified: 21 January 2010
l2c-data 4372 udp LAN2CAN Data [Phil_Tolson] [Phil_Tolson] 2010-01-21
psi-ptt 4374 tcp PSI Push-to-Talk Protocol [Frank_B] [Frank_B] 2008-07-17
cp-spxsvr 4377 tcp Cambridge Pixel SPx Server
cp-spxsvr 4377 udp Cambridge Pixel SPx Server
cp-spxdpy 4378 tcp Cambridge Pixel SPx Display [Richard_Warren] [Richard_Warren] 2007-07-05
cp-spxdpy 4378 udp Cambridge Pixel SPx Display [Richard_Warren] [Richard_Warren] 2007-07-05
4380-4388 Unassigned
xandros-cms 4389 tcp Xandros Community Management Service [Stephen_M_Webb] [Stephen_M_Webb] 2007-05
xandros-cms 4389 udp Xandros Community Management Service [Stephen_M_Webb] [Stephen_M_Webb] 2007-05
apwi-imserver 4391 tcp American Printware IMServer Protocol [Lech_Lakomy] [Lech_Lakomy] 2009-02-12
apwi-rxserver 4392 tcp American Printware RXServer Protocol [Lech_Lakomy] [Lech_Lakomy] 2009-02-12
apwi-rxspooler 4393 tcp American Printware RXSpooler Protocol [Lech_Lakomy] [Lech_Lakomy] 2009-02-12
apwi-disc 4394 udp American Printware Discovery [Lech_Lakomy] [Lech_Lakomy] 2009-02-12
4397-4399 Unassigned
ds-srv 4400 tcp ASIGRA Services [David_Farajun] [David_Farajun] 2004-11
ds-srv 4400 udp ASIGRA Services [David_Farajun] [David_Farajun] 2004-11
ds-srvr 4401 tcp ASIGRA Televaulting DS-System Service
ds-srvr 4401 udp ASIGRA Televaulting DS-System Service
ds-clnt 4402 tcp ASIGRA Televaulting DS-Client Service
ds-clnt 4402 udp ASIGRA Televaulting DS-Client Service
ds-user 4403 tcp ASIGRA Televaulting DS-Client Monitoring/Management
ds-user 4403 udp ASIGRA Televaulting DS-Client Monitoring/Management
ds-admin 4404 tcp ASIGRA Televaulting DS-System Monitoring/Management
ds-admin 4404 udp ASIGRA Televaulting DS-System Monitoring/Management
ds-mail 4405 tcp ASIGRA Televaulting Message Level Restore service
ds-mail 4405 udp ASIGRA Televaulting Message Level Restore service
ds-slp 4406 tcp ASIGRA Televaulting DS-Sleeper Service [Andrei_Litvinn] [Andrei_Litvinn] 2005-01
ds-slp 4406 udp ASIGRA Televaulting DS-Sleeper Service [Andrei_Litvinn] [Andrei_Litvinn] 2005-01
netcabinet-com 4409 tcp Net-Cabinet comunication [Ian_Manning_2] [Ian_Manning_2] 2009-12-16
itwo-server 4410 tcp RIB iTWO Application Server [Kristean_Heisler_2] [Kristean_Heisler_2] 2009-12-16
vision-mon 4413 tcp FORTÉ Vision Monitoring platform [FORTÉ] [Rob_Duram] 2015-09-18 2025-11-14
vision-mon-disc 4413 udp FORTÉ Vision Monitoring platform [FORTÉ] [Rob_Duram] 2015-09-18 2025-11-14
brcd-vr-req 4415 tcp Brocade Virtual Router Request [Brocade_Communications_Systems] [Nick_Carter] 2015-11-17
newmood-player 4416 tcp Newmood Media Player [Creation_Newmood_Inc] [Bruno_Frechette] 2015-11-18 2026-09-30
newmood-player 4416 udp Newmood Media Player discovery [Creation_Newmood_Inc] [Bruno_Frechette] 2015-11-18 2026-09-30
scaleft 4421 tcp Multi-Platform Remote Management for Cloud Infrastructure [ScaleFT_Inc] [Paul_Querna] 2016-04-07
beacon-port-2 4426 tcp SMARTS Beacon Port [Eyal_Yardeni] [Eyal_Yardeni] 2003-11
beacon-port-2 4426 udp SMARTS Beacon Port [Eyal_Yardeni] [Eyal_Yardeni] 2003-11
omviserver 4428 tcp OMV-Investigation Server-Client [Serge_Vacquier] [Serge_Vacquier] 2009-05-20
omviagent 4429 tcp OMV Investigation Agent-Server [Serge_Vacquier] [Serge_Vacquier] 2009-05-20
l-acoustics 4432 tcp L-ACOUSTICS management [L-ACOUSTICS] [Christophe_Pignon] 2012-08-13
l-acoustics 4432 udp L-ACOUSTICS management [L-ACOUSTICS] [Christophe_Pignon] 2012-08-13
4434-4440 Unassigned
nv-video 4444 tcp NV Video default [Ron_Frederick] [Ron_Frederick] krb524 assigned the port, nv used it without an assignment
nv-video 4444 udp NV Video default [Ron_Frederick] [Ron_Frederick] krb524 assigned the port, nv used it without an assignment
n1-fwp 4446 tcp N1-FWP
n1-fwp 4446 udp N1-FWP
n1-rmgmt 4447 tcp N1-RMGMT [Lori_Tassin] [Lori_Tassin]
n1-rmgmt 4447 udp N1-RMGMT [Lori_Tassin] [Lori_Tassin]
asc-slmd 4448 tcp ASC Licence Manager [Casper_Stoel] [Casper_Stoel]
asc-slmd 4448 udp ASC Licence Manager [Casper_Stoel] [Casper_Stoel]
prchat-user 4455 tcp PR Chat User
prchat-user 4455 udp PR Chat User
prchat-server 4456 tcp PR Chat Server
prchat-server 4456 udp PR Chat Server

Contact Information

ID Name Organization Contact URI Last Updated
[Andrei_Litvinn] Andrei Litvinn mailto:support&asigra.com 2005-01
[Brocade_Communications_Systems] Brocade Communications Systems mailto:ncarter&brocade.com 2015-11-17
[Bruno_Frechette] Bruno Frechette Creation Newmood Inc. mailto:bruno&newmood.com 2026-09-30
[Bryan_Ramirez] Bryan Ramirez mailto:bryan.ramirez&gettyimages.com 2019-04-18
[Casper_Stoel] Casper Stoel mailto:cbs&ascinc.com
[Christophe_Pignon] Christophe Pignon L-ACOUSTICS mailto:christophe.pignon&l-acoustics.com 2012-08-13
[Creation_Newmood_Inc] Creation Newmood Inc. mailto:it&newmood.com 2026-09-30
[David_Farajun] David Farajun mailto:dfarajun&asigra.com 2004-11
[DEY_Storage_Systems_Inc] DEY Storage Systems, Inc. mailto:garrett&dey-sys.com 2013-03-01
[Eyal_Yardeni] Eyal Yardeni mailto:eyal.yardeni&smarts.com 2003-11
[FORTÉ] FORTÉ mailto:rob.duram&ourforte.com 2025-10-30
[Frank_B] Frank Bredenbröcker mailto:fbredenbroecker&psi.de 2008-07-17
[Frank_Hartung] Frank Hartung mailto:Frank.Hartung&ericsson.com 2007-09-07
[Garrett_D_Amore] Garrett D'Amore DEY Storage Systems, Inc. mailto:garrett&dey-sys.com 2013-03-01
[Glenn_Peterson] Glenn Peterson mailto:glennp&microsoft.com
[Harry_Courtice] Harry Courtice mailto:harry.courtice&elprotech.com 2008-04-14
[IESG] IESG mailto:iesg&ietf.org
[IETF] IETF mailto:iesg&ietf.org
[IETF_Chair] IETF Chair IETF mailto:chair&ietf.org
[Ian_Manning_2] Ian Manning mailto:ian&baycastle.co.uk 2009-12-16
[J_J_Ekstrom] J.J. Ekstrom
[KeyTicket_Solutions] KeyTicket Solutions mailto:amang&keyticket.eu 2014-04-04
[Kristean_Heisler_2] Kristean Heisler mailto:Kristean.Heisler&rib-software.com 2009-12-16
[L-ACOUSTICS] L-ACOUSTICS mailto:christophe.pignon&l-acoustics.com 2012-08-13
[Lech_Lakomy] Lech Lakomy mailto:llakomy&apwi.com 2009-02-12
[Lori_Tassin] Lori Tassin mailto:Ramsey&network-1.com
[MANG_Ioan-Alexandru] MANG Ioan-Alexandru KeyTicket Solutions mailto:amang&keyticket.eu 2014-04-04
[Matthew_Margolis] Matthew Margolis mailto:matthew.margolis&gettyimages.com 2019-04-18
[Michael_Richardson] Michael Richardson mailto:mcr&sandelman.ca 2011-02-08
[Neer_Kleinman] Neer Kleinman mailto:neer&qsr.co.il
[Nick_Carter] Nick Carter mailto:ncarter&brocade.com 2015-11-17
[Paul_Querna] Paul Querna mailto:paul.querna&scaleft.com 2016-04-07
[Paul_Wren] Paul Wren mailto:Paul.Wren&macro4.com
[Phil_Tolson] Phil Tolson mailto:philtolson&eaton.com 2010-01-21
[Rehan_Mahmood] Rehan Mahmood mailto:rehan&matrixmultimedia.co.uk 2009-03-18
[Richard_Warren] Richard Warren mailto:richard&cambridgepixel.com 2008-09-17
[Rob_Duram] Rob Duram mailto:rob.duram&ourforte.com 2025-10-30
[Ron_Frederick] Ron Frederick mailto:frederick&parc.xerox.com
[ScaleFT_Inc] ScaleFT, Inc mailto:notices&scaleft.com 2016-04-07
[Serge_Vacquier] Serge Vacquier mailto:svacquier&axway.com 2019-03-29
[Stephen_M_Webb] Stephen M. Webb mailto:stephenw&xandros.com 2007-05
[Tom_Kee] Tom Kee mailto:t.kee&f5.com
[Tom_Maaswinkel] Tom Maaswinkel mailto:tom.maaswinkel&publiqare.nl 2011-02-07
[Uri_Sarid] Uri Sarid mailto:uri&aptana.com 2008-01-22