Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
menandmice-noh 4151 udp Men & Mice Remote Control

IANA assigned this well-formed service name as a replacement for "menandmice_noh".
Eggert Thorlacius Eggert Thorlacius 2007-08-30
menandmice_noh 4151 udp Men & Mice Remote Control Eggert Thorlacius Eggert Thorlacius 2007-08-30 This entry is an alias to "menandmice-noh". This entry is now historic, not usable for use with many common service discovery mechanisms.
idig-mux 4152 tcp iDigTech Multiplex

IANA assigned this well-formed service name as a replacement for "idig_mux".
Robin Findley Robin Findley 2007-05
idig_mux 4152 tcp iDigTech Multiplex Robin Findley Robin Findley 2007-05 This entry is an alias to "idig-mux". This entry is now historic, not usable for use with many common service discovery mechanisms.
idig-mux 4152 udp iDigTech Multiplex

IANA assigned this well-formed service name as a replacement for "idig_mux".
Robin Findley Robin Findley 2007-05
idig_mux 4152 udp iDigTech Multiplex Robin Findley Robin Findley 2007-05 This entry is an alias to "idig-mux". This entry is now historic, not usable for use with many common service discovery mechanisms.
mbl-battd 4153 tcp MBL Remote Battery Monitoring Claudio Procida Claudio Procida 2007-05
mbl-battd 4153 udp MBL Remote Battery Monitoring Claudio Procida Claudio Procida 2007-05
atlinks 4154 tcp atlinks device discovery Scott Griepentrog Scott Griepentrog 2002-10
atlinks 4154 udp atlinks device discovery Scott Griepentrog Scott Griepentrog 2002-10
bzr 4155 tcp Bazaar version control system Martin Pool Martin Pool 2007-02
bzr 4155 udp Bazaar version control system Martin Pool Martin Pool 2007-02
stat-results 4156 tcp STAT Results
stat-results 4156 udp STAT Results
stat-scanner 4157 tcp STAT Scanner Control
stat-scanner 4157 udp STAT Scanner Control
stat-cc 4158 tcp STAT Command Center Darwin Ammala Darwin Ammala 2007-03
stat-cc 4158 udp STAT Command Center Darwin Ammala Darwin Ammala 2007-03
nss 4159 tcp Network Security Service Dave Wierbowski Dave Wierbowski 2006-08
nss 4159 udp Network Security Service Dave Wierbowski Dave Wierbowski 2006-08
jini-discovery 4160 tcp Jini Discovery Mark Hodapp Mark Hodapp
jini-discovery 4160 udp Jini Discovery Mark Hodapp Mark Hodapp
omscontact 4161 tcp OMS Contact
omscontact 4161 udp OMS Contact
omstopology 4162 tcp OMS Topology David Page David Page 2005-08
omstopology 4162 udp OMS Topology David Page David Page 2005-08
silverpeakpeer 4163 tcp Silver Peak Peer Protocol Damon Ennis Damon Ennis 2007-03
silverpeakpeer 4163 udp Silver Peak Peer Protocol Damon Ennis Damon Ennis 2007-03
silverpeakcomm 4164 tcp Silver Peak Communication Protocol Damon Ennis Damon Ennis 2007-03
silverpeakcomm 4164 udp Silver Peak Communication Protocol Damon Ennis Damon Ennis 2007-03
altcp 4165 tcp ArcLink over Ethernet Dmitry Brant Dmitry Brant 2007-03
altcp 4165 udp ArcLink over Ethernet Dmitry Brant Dmitry Brant 2007-03
joost 4166 tcp Joost Peer to Peer Protocol Colm MacCarthaigh Colm MacCarthaigh 2007-04
joost 4166 udp Joost Peer to Peer Protocol Colm MacCarthaigh Colm MacCarthaigh 2007-04
ddgn 4167 tcp DeskDirect Global Network Laurie Charlwood Laurie Charlwood 2007-08-22
ddgn 4167 udp DeskDirect Global Network Laurie Charlwood Laurie Charlwood 2007-08-22
pslicser 4168 tcp PrintSoft License Server David Weisgerber David Weisgerber 2007-09-27
pslicser 4168 udp PrintSoft License Server David Weisgerber David Weisgerber 2007-09-27
iadt 4169 tcp Automation Drive Interface Transport Paul Suhler Paul Suhler 2008-02-15
iadt-disc 4169 udp Internet ADT Discovery Protocol Paul A. Suhler Paul A. Suhler 2009-02-06
d-cinema-csp 4170 tcp SMPTE Content Synchonization Protocol Michael Karagosian Michael Karagosian 2008-09-04
4170 udp Reserved
ml-svnet 4171 tcp Maxlogic Supervisor Communication Taha Paksu Taha Paksu 2009-12-21
4171 udp Reserved
pcoip 4172 tcp PC over IP HP Inc. Jeff Jeansonne 2009-12-23 2026-03-10
pcoip 4172 udp PC over IP HP Inc. Jeff Jeansonne 2009-12-23 2026-03-10
4173 tcp Reserved
mma-discovery 4173 udp MMA Device Discovery MIDI Manufacturers Assoc Inc Tom White 2011-11-14
smcluster 4174 tcp StorMagic Cluster Services Chris Farey Chris Farey 2011-03-09
sm-disc 4174 udp StorMagic Discovery StorMagic Ltd Chris Farey 2011-12-16
bccp 4175 tcp Brocade Cluster Communication Protocol Norival Figueira Norival Figueira 2010-04-07
4175 udp Reserved
tl-ipcproxy 4176 tcp Translattice Cluster IPC Proxy Michael Lyle Michael Lyle 2009-11-03
4176 udp Reserved
wello 4177 tcp Wello P2P pubsub service Christian Westbrook Christian Westbrook 2007-11-15
wello 4177 udp Wello P2P pubsub service Christian Westbrook Christian Westbrook 2007-11-15
storman 4178 tcp StorMan Werner Guertler Werner Guertler 2009-05-11
storman 4178 udp StorMan Werner Guertler Werner Guertler 2009-05-11
MaxumSP 4179 tcp Maxum Services Greg Stine Greg Stine 2007-07-05
MaxumSP 4179 udp Maxum Services Greg Stine Greg Stine 2007-07-05
httpx 4180 tcp HTTPX Paul McGough Paul McGough 2007-02
httpx 4180 udp HTTPX Paul McGough Paul McGough 2007-02 2016-01-05
macbak 4181 tcp MacBak Wes Peters Wes Peters 2007-04
macbak 4181 udp MacBak Wes Peters Wes Peters 2007-04
pcptcpservice 4182 tcp Production Company Pro TCP Service Ben McNeill Ben McNeill 2007-05
pcptcpservice 4182 udp Production Company Pro TCP Service Ben McNeill Ben McNeill 2007-05
cyborgnet 4183 tcp CyborgNet communications protocol Gareth Nelson Gareth Nelson 2015-11-13
cyborgnet 4183 udp CyborgNet communications protocol Gareth Nelson Gareth Nelson 2015-11-13
universe-suite 4184 tcp UNIVERSE SUITE MESSAGE SERVICE

IANA assigned this well-formed service name as a replacement for "universe_suite".
Gary ANDREWS Gary ANDREWS 2008-01-07
universe_suite 4184 tcp UNIVERSE SUITE MESSAGE SERVICE Gary ANDREWS Gary ANDREWS 2008-01-07 This entry is an alias to "universe-suite". This entry is now historic, not usable for use with many common service discovery mechanisms.
universe-suite 4184 udp UNIVERSE SUITE MESSAGE SERVICE

IANA assigned this well-formed service name as a replacement for "universe_suite".
Gary ANDREWS Gary ANDREWS 2008-01-07
universe_suite 4184 udp UNIVERSE SUITE MESSAGE SERVICE Gary ANDREWS Gary ANDREWS 2008-01-07 This entry is an alias to "universe-suite". This entry is now historic, not usable for use with many common service discovery mechanisms.
wcpp 4185 tcp Woven Control Plane Protocol Christopher LILJENSTOLPE Christopher LILJENSTOLPE 2008-04-14
wcpp 4185 udp Woven Control Plane Protocol Christopher LILJENSTOLPE Christopher LILJENSTOLPE 2008-04-14
boxbackupstore 4186 tcp Box Backup Store Service Chris Wilson Chris Wilson 2008-09-11
4186 udp Reserved
csc-proxy 4187 tcp Cascade Proxy

IANA assigned this well-formed service name as a replacement for "csc_proxy".
Matt Craighead Matt Craighead 2008-09-11
csc_proxy 4187 tcp Cascade Proxy Matt Craighead Matt Craighead 2008-09-11 This entry is an alias to "csc-proxy". This entry is now historic, not usable for use with many common service discovery mechanisms.
4187 udp Reserved
vatata 4188 tcp Vatata Peer to Peer Protocol Song Jian Song Jian 2008-09-15
vatata 4188 udp Vatata Peer to Peer Protocol Song Jian Song Jian 2008-09-15
pcep 4189 tcp Path Computation Element Communication Protocol
4189 udp Reserved RFC 5440
sieve 4190 tcp ManageSieve Protocol
4190 udp Reserved RFC 5804
4191 tcp Reserved
dsmipv6 4191 udp Dual Stack MIPv6 NAT Traversal RFC 5555
azeti 4192 tcp Azeti Agent Service Uwe Holz Uwe Holz 2009-11-09
azeti-bd 4192 udp azeti blinddate Michael Werski Michael Werski 2010-02-18
pvxplusio 4193 tcp PxPlus remote file srvr Mike King Mike King 2009-11-09
4193 udp Reserved
spdm 4194 tcp Security Protocol and Data Model DMTF Administration Robert Keyes 2022-01-10 2025-05-30
4194 udp Reserved
aws-wsp 4195 tcp AWS protocol for cloud remoting solution Amazon.com Services LLC Lauren Townsend 2020-04-06
aws-wsp 4195 udp AWS protocol for cloud remoting solution Amazon.com Services LLC Lauren Townsend 2020-04-06
aws-wsp 4195 sctp AWS protocol for cloud remoting solution Amazon.com Services LLC Lauren Townsend 2020-04-06
aws-wsp 4195 dccp AWS protocol for cloud remoting solution Amazon.com Services LLC Lauren Townsend 2020-04-06
4196 Unassigned
hctl 4197 tcp Harman HControl Protocol Harman International Industries Inc. Darin Smith 2017-02-16
hctl 4197 udp Harman HControl Protocol Harman International Industries Inc. Darin Smith 2017-02-16
4198 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Amazon.com Services LLC aws-iana&amazon.com 2022-11-07
Ben McNeill ben.mcneill&cinexec.com 2007-05
Chris Farey StorMagic Ltd chris_farey&stormagic.com 2011-12-16
Chris Wilson chris+iana&qwirx.com 2008-09-11
Christian Westbrook cw&wellohorld.com 2007-11-15
Christopher LILJENSTOLPE cdl&asgaard.org 2008-04-14
Claudio Procida claudio&emeraldion.it 2007-05
Colm MacCarthaigh colm.maccarthaigh&joost.com 2007-04
Damon Ennis damon&silver-peak.com 2007-03
Darin Smith darin.smith&harman.com 2017-02-16
Darwin Ammala dammala&harris.com 2007-03
Dave Wierbowski wierbows&us.ibm.com 2006-08
David Page david.page&sun.com 2005-08
David Weisgerber david.weisgerber&printsoft.de 2007-09-27
Dmitry Brant dmitry_brant&lincolnelectric.com 2007-03
DMTF Administration admin&dmtf.org 2025-05-30
Eggert Thorlacius eggert&menandmice.com 2007-08-30
Gareth Nelson gareth&garethnelson.com 2015-11-13
Gary ANDREWS gan&orsyp.com 2008-01-07
Greg Stine greg.stine&siemens.com 2007-07-05
Harman International Industries Inc. darin.smith&harman.com 2017-02-16
HP Inc. jeff.jeansonne&hp.com 2026-03-10
Jeff Jeansonne jeff.jeansonne&hp.com 2026-03-10
Lauren Townsend Amazon.com Services LLC townslau&amazon.com 2020-04-06
Laurie Charlwood laurie.charlwood&printsoft.com 2007-08-22
Mark Hodapp mark.hodapp&sun.com
Martin Pool mbp&canonical.com 2007-02
Matt Craighead matt.craighead&conifersystems.com 2008-09-11
Michael Karagosian michael.karagosian&mkpe.com 2008-09-04
Michael Lyle protocols&translattice.com 2009-11-03
Michael Werski michael.werski&azeti.net 2010-02-18
MIDI Manufacturers Assoc Inc info&midi.org 2011-11-14
Mike King mike.king&pvxplus.com 2009-11-09
Norival Figueira nfigueir&brocade.com 2010-04-07
Paul A. Suhler paul.suhler&quantum.com 2009-02-06
Paul McGough paulmcgough&yahoo.com 2016-01-05
Paul Suhler paul.suhler&quantum.com 2008-02-15
Robert Keyes robert&woldconsulting.com 2025-05-30
Robin Findley rfindley&usa.net 2007-05
Scott Griepentrog griepentrogs&atlinks.com 2002-10
Song Jian info&vatata.com 2008-09-15
StorMagic Ltd chris_farey&stormagic.com 2011-12-16
Taha Paksu tahapaksu&mavili.com.tr 2009-12-21
Tom White MIDI Manufacturers Assoc Inc info&midi.org 2011-11-14
Uwe Holz uwe.holz&azeti.net 2009-11-09
Werner Guertler werner.guertler&fujitsu.com 2025-04-03
Wes Peters wes&softweyr.com 2007-04