Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| cumulus-admin | 8954 | tcp | Cumulus Admin Port | Thomas Schleu | Thomas Schleu | ||||||
| cumulus-admin | 8954 | udp | Cumulus Admin Port | Thomas Schleu | Thomas Schleu | ||||||
| 8955-8979 | Unassigned | ||||||||||
| golem | 9005 | tcp | Golem Inter-System RPC | Jose Luis Tallon | Jose Luis Tallon | 2015-03-09 | |||||
| 9005 | udp | Reserved | |||||||||
| swa-3 | 9025 | tcp | Secure Web Access - 3 | Tim McGranaghan | Tim McGranaghan | ||||||
| swa-3 | 9025 | udp | Secure Web Access - 3 | Tim McGranaghan | Tim McGranaghan | ||||||
| versiera | 9050 | tcp | Versiera Agent Listener | Frank Pikelner | Frank Pikelner | 2010-01-15 | |||||
| 9050 | udp | Reserved | |||||||||
| fio-cmgmt | 9051 | tcp | Fusion-io Central Manager Service | Jim Sermersheim | Jim Sermersheim | 2010-01-15 | |||||
| 9051 | udp | Reserved | |||||||||
| 9052-9059 | Unassigned | ||||||||||
| ibm-rsyscon | 9085 | tcp | IBM Remote System Console | William LePera | William LePera | 2008-06-18 | |||||
| ibm-rsyscon | 9085 | udp | IBM Remote System Console | William LePera | William LePera | 2008-06-18 | |||||
| xadmin | 9105 | tcp | Xadmin Control Service | Ariën Huisken <xadmin&huisken-systems.nl> 15 June 2009 | |||||||
| xadmin | 9105 | udp | Xadmin Control Service | Ariën Huisken <xadmin&huisken-systems.nl> 15 June 2009 | |||||||
| 9132-9159 | Unassigned | ||||||||||
| apani5 | 9164 | tcp | apani5 | Neal Taylor | Neal Taylor | ||||||
| apani5 | 9164 | udp | apani5 | Neal Taylor | Neal Taylor | ||||||
| 9165-9182 | Unassigned | ||||||||||
| wap-vcal | 9205 | tcp | WAP vCal | WAP Forum | WAP Forum | ||||||
| wap-vcal | 9205 | udp | WAP vCal | WAP Forum | WAP Forum | ||||||
| insis | 9215 | tcp | Integrated Setup and Install Service | Markus Treinen | Markus Treinen | 2006-02 | |||||
| insis | 9215 | udp | Integrated Setup and Install Service | Markus Treinen | Markus Treinen | 2006-02 | |||||
| 9223-9254 | Unassigned | ||||||||||
| mon | 9255 | tcp | Manager On Network | David Rouchet | David Rouchet | 2007-05 | |||||
| mon | 9255 | udp | Manager On Network | David Rouchet | David Rouchet | 2007-05 | |||||
| 9256-9276 | Unassigned | ||||||||||
| n2h2server | 9285 | tcp | N2H2 Filter Service Port | Jim Irwin | Jim Irwin | 2002-02 | |||||
| n2h2server | 9285 | udp | N2H2 Filter Service Port | Jim Irwin | Jim Irwin | 2002-02 | |||||
| armcenterhttps | 9295 | tcp | ARMCenter https Service | Eric Thiebaut-George | Eric Thiebaut-George | 2006-04 | |||||
| armcenterhttps | 9295 | udp | ARMCenter https Service | Eric Thiebaut-George | Eric Thiebaut-George | 2006-04 | |||||
| 9301-9305 | Unassigned | ||||||||||
| rancher | 9345 | tcp | Rancher Agent | Rancher Labs, Inc. | Vincent Fiduccia | 2015-04-14 | |||||
| 9345 | udp | Reserved | |||||||||
| 9375-9379 | Unassigned | ||||||||||
| 9391-9395 | Unassigned | ||||||||||
| mindarray-ca | 9445 | tcp | MindArray Systems Console Agent | MINDARRAY SYSTEMS (P) LTD. | ALPESH DHAMELIA | 2011-10-25 | |||||
| 9445 | udp | Reserved | |||||||||
| sntlkeyssrvr | 9450 | tcp | Sentinel Keys Server | Martin Ziskind | Martin Ziskind | 2008-08-21 | |||||
| sntlkeyssrvr | 9450 | udp | Sentinel Keys Server | Martin Ziskind | Martin Ziskind | 2008-08-21 | |||||
| 9451-9499 | Unassigned | ||||||||||
| ismserver | 9500 | tcp | ismserver | Ian Gordon | Ian Gordon | ||||||
| ismserver | 9500 | udp | ismserver | Ian Gordon | Ian Gordon | ||||||
| 9501-9521 | Unassigned | ||||||||||
| 9522 | tcp | Reserved | |||||||||
| sma-spw | 9522 | udp | SMA Speedwire | SMA Solar Techology AG | SMA Solar Techology AG | 2011-03-08 | |||||
| 9523-9534 | Unassigned | ||||||||||
| mngsuite | 9535 | tcp | Management Suite Remote Control | Trevor Perkes | Trevor Perkes | 2010-02-01 | |||||
| mngsuite | 9535 | udp | Management Suite Remote Control | Trevor Perkes | Trevor Perkes | 2010-02-01 | |||||
| laes-bf | 9536 | tcp | Surveillance buffering function | Glen Myers | Glen Myers | 2007-05 | |||||
| laes-bf | 9536 | udp | Surveillance buffering function | Glen Myers | Glen Myers | 2007-05 | |||||
| 9537-9554 | Unassigned | ||||||||||
| trispen-sra | 9555 | tcp | Trispen Secure Remote Access | Jaco Botha | Jaco Botha | 2004-11 | |||||
| trispen-sra | 9555 | udp | Trispen Secure Remote Access | Jaco Botha | Jaco Botha | 2004-11 | |||||
| 9556-9558 | Unassigned | ||||||||||
| p4runtime | 9559 | tcp | P4Runtime gRPC Service | Open Networking Foundation | Antonin Bas | 2020-09-22 | |||||
| 9559 | udp | Reserved | |||||||||
| 9560-9591 | Unassigned | ||||||||||
| ldgateway | 9592 | tcp | LANDesk Gateway | Alan Butt | Alan Butt | 2006-03 | |||||
| ldgateway | 9592 | udp | LANDesk Gateway | Alan Butt | Alan Butt | 2006-03 | |||||
| cba8 | 9593 | tcp | LANDesk Management Agent (cba8) | Trevor Perkes | Trevor Perkes | 2010-02-01 | |||||
| cba8 | 9593 | udp | LANDesk Management Agent (cba8) | Trevor Perkes | Trevor Perkes | 2010-02-01 | |||||
| msgsys | 9594 | tcp | Message System | Alan Butt | Alan Butt | ||||||
| msgsys | 9594 | udp | Message System | Alan Butt | Alan Butt | ||||||
| pds | 9595 | tcp | Ping Discovery Service | Alan Butt | Alan Butt | ||||||
| pds | 9595 | udp | Ping Discovery Service | Alan Butt | Alan Butt | ||||||
| mercury-disc | 9596 | tcp | Mercury Discovery | Paul Mclachlan | Paul Mclachlan | 2005-11 | |||||
| mercury-disc | 9596 | udp | Mercury Discovery | Paul Mclachlan | Paul Mclachlan | 2005-11 | |||||
| pd-admin | 9597 | tcp | PD Administration | Duk Loi | Duk Loi | 2005-11 | |||||
| pd-admin | 9597 | udp | PD Administration | Duk Loi | Duk Loi | 2005-11 | |||||
| vscp | 9598 | tcp | Very Simple Ctrl Protocol | Ake Hedman | Ake Hedman | 2005-11 | |||||
| vscp | 9598 | udp | Very Simple Ctrl Protocol | Ake Hedman | Ake Hedman | 2005-11 | |||||
| robix | 9599 | tcp | Robix | Evan Rosen | Evan Rosen | 2005-11 | |||||
| robix | 9599 | udp | Robix | Evan Rosen | Evan Rosen | 2005-11 | |||||
| 9615 | Unassigned | ||||||||||
| 9641-9665 | Unassigned | ||||||||||
| tec5-sdctp | 9668 | tcp | tec5 Spectral Device Control Protocol | Michael Muth | Michael Muth | 2009-05-11 | |||||
| tec5-sdctp | 9668 | udp | tec5 Spectral Device Control Protocol | Michael Muth | Michael Muth | 2009-05-11 | |||||
| ccnx | 9695 | tcp | Content Centric Networking | Van Jacobson; Simon Barber | Van Jacobson; Simon Barber | 2009-09-29 | |||||
| ccnx | 9695 | udp | Content Centric Networking | Van Jacobson; Simon Barber | Van Jacobson; Simon Barber | 2009-09-29 | |||||
| l5nas-parchan | 9747 | tcp | L5NAS Parallel Channel | Lawrence J. Dickson | Lawrence J. Dickson | 2002-03 | |||||
| l5nas-parchan | 9747 | udp | L5NAS Parallel Channel | Lawrence J. Dickson | Lawrence J. Dickson | 2002-03 | |||||
| board-voip | 9750 | tcp | Board M.I.T. Synchronous Collaboration | Francesco Rosi | Francesco Rosi | 2006-01 | |||||
| board-voip | 9750 | udp | Board M.I.T. Synchronous Collaboration | Francesco Rosi | Francesco Rosi | 2006-01 | |||||
| 9751-9752 | Unassigned | ||||||||||
| rasadv | 9753 | tcp | rasadv | Dave Thaler | Dave Thaler | ||||||
| rasadv | 9753 | udp | rasadv | Dave Thaler | Dave Thaler | ||||||
| 9754-9761 | Unassigned | ||||||||||
| sapv1 | 9875 | tcp | Session Announcement v1 | RFC 2974 | |||||||
| sapv1 | 9875 | udp | Session Announcement v1 | RFC 2974 | |||||||
| x510 | 9877 | tcp | The X.510 wrapper protocol | ITU/TSB (ITU-T Study Group 17) | Erik Andersen | 2019-09-30 | ITU-T X.510 / ISO/IEC 9584-11 | ||||
| kca-service | 9878 | udp | The KX509 Kerberized Certificate Issuance Protocol in Use in 2012 | IESG | IETF Chair | 2012-07-12 | RFC 6717 | Historically, this service has been referred to as "kca_service", but this service name does not meet the registry requirements. | |||
| sctp-tunneling | 9899 | udp | SCTP TUNNELING | IESG | IETF Chair | 2013-04-10 | RFC 6951 | ||||
| enrp-sctp | 9901 | sctp | enrp server channel | RFC 5353 | |||||||
| enrp-sctp-tls | 9902 | sctp | enrp/tls server channel | RFC 5353 | |||||||
| multicast-ping | 9903 | udp | Multicast Ping Protocol | 2011-12-09 | RFC 6450 | ||||||
| xybrid-cloud | 9925 | tcp | XYBRID Cloud | Rx Networks Inc. | Drew Davies | 2013-04-25 | |||||
| 9925 | udp | Reserved | |||||||||
| apc-9950 | 9950 | tcp | APC 9950 | American Power Conversion | American Power Conversion | ||||||
| apc-9950 | 9950 | udp | APC 9950 | American Power Conversion | American Power Conversion |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Ake Hedman | akhe&eurosource.se | 2005-11 | |
| Alan Butt | alan.butt&landesk.com | 2006-03 | |
| ALPESH DHAMELIA | MINDARRAY SYSTEMS (P) LTD. | alpesh&mindarraysystems.com | 2011-10-25 |
| American Power Conversion | ports&apcc.com | 2002-02 | |
| Antonin Bas | Open Networking Foundation | antonin.bas&gmail.com | 2020-09-22 |
| Dave Thaler | dthalerµsoft.com | ||
| David Rouchet | david.rouchet&medialon.com | 2007-05 | |
| Drew Davies | Rx Networks Inc. | ddavies&rxnetworks.com | 2013-04-25 |
| Duk Loi | dloi&peerdirect.com | 2005-11 | |
| Eric Thiebaut-George | erict&aurema.com | 2006-04 | |
| Erik Andersen | era&x500.eu | 2019-08-13 | |
| Evan Rosen | evan&robix.com | 2005-11 | |
| Francesco Rosi | frosi&orenburg.com | 2006-01 | |
| Frank Pikelner | frank.pikelner&netcraftcommunications.com | 2010-01-15 | |
| Glen Myers | glen.myers&ipfabrics.com | 2007-05 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Ian Gordon | iangµmuse.co.uk | ||
| ITU/TSB (ITU-T Study Group 17) | tsbsg17&itu.int | 2019-09-30 | |
| Jaco Botha | jaco.botha&trispen.com | 2004-11 | |
| Jim Irwin | jirwin&n2h2.com | 2002-02 | |
| Jim Sermersheim | jims&fusionio.com | 2010-01-15 | |
| Jose Luis Tallon | joseluis&talloncorp.com | 2015-03-09 | |
| Lawrence J. Dickson | Land-5 Corporation | ldickson&land-5.com | 2002-03 |
| Markus Treinen | markus.treinen&siemens.com | 2006-02 | |
| Martin Ziskind | ziskind&us.ibm.com | 2008-08-21 | |
| Michael Muth | m.muth&tec5.com | 2009-05-11 | |
| MINDARRAY SYSTEMS (P) LTD. | info&mindarraysystems.com | 2011-10-25 | |
| Neal Taylor | ianareg&apani.com | ||
| Open Networking Foundation | iana&opennetworking.org | 2013-07-18 | |
| Paul Mclachlan | pmclachlan&mercury.com | 2005-11 | |
| Rancher Labs, Inc. | engineering&rancher.com | 2015-04-14 | |
| Rx Networks Inc. | ddavies&rxnetworks.com | 2013-04-25 | |
| SMA Solar Techology AG | thomas.weber&sma.de | 2011-03-08 | |
| Simon Barber | simon.barber&parc.com | 2009-09-29 | |
| Thomas Schleu | tschleu&canto.de | ||
| Tim McGranaghan | tim_mcgranaghan&mech.disa.mil | ||
| Trevor Perkes | trevor.perkes&landesk.com | 2010-02-01 | |
| Van Jacobson | van&parc.com | 2009-09-29 | |
| Vincent Fiduccia | Rancher Labs, Inc. | vincent&rancher.com | 2015-04-14 |
| WAP Forum | wap-feedback&mail.wapforum.org
pg&uplanet.com |
||
| William LePera | lepera&us.ibm.com | 2008-06-18 |