Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
filenet-nch 32770 tcp Filenet NCH Daniel Whelan Daniel Whelan
filenet-nch 32770 udp Filenet NCH Daniel Whelan Daniel Whelan
filenet-rmi 32771 tcp FileNET RMI Chris Adkins Chris Adkins
filenet-rmi 32771 udp FileNet RMI Chris Adkins Chris Adkins
filenet-pa 32772 tcp FileNET Process Analyzer Chris Adkins Chris Adkins 2003-01
filenet-pa 32772 udp FileNET Process Analyzer Chris Adkins Chris Adkins 2003-01
filenet-cm 32773 tcp FileNET Component Manager Chris Adkins Chris Adkins 2003-08
filenet-cm 32773 udp FileNET Component Manager Chris Adkins Chris Adkins 2003-08
filenet-re 32774 tcp FileNET Rules Engine Chris Adkins Chris Adkins 2003-08
filenet-re 32774 udp FileNET Rules Engine Chris Adkins Chris Adkins 2003-08
filenet-pch 32775 tcp Performance Clearinghouse Tim Morgan Tim Morgan 2005-11
filenet-pch 32775 udp Performance Clearinghouse Tim Morgan Tim Morgan 2005-11
filenet-peior 32776 tcp FileNET BPM IOR Chris Adkins Chris Adkins 2006-05
filenet-peior 32776 udp FileNET BPM IOR Chris Adkins Chris Adkins 2006-05
filenet-obrok 32777 tcp FileNet BPM CORBA Chris Adkins Chris Adkins 2006-10
filenet-obrok 32777 udp FileNet BPM CORBA Chris Adkins Chris Adkins 2006-10
32778-32800 Unassigned
32897-32999 Unassigned
mtrace 33435 udp IP Multicast Traceroute IESG IETF Chair 2017-12-13 2019-08-09 RFC 8487 Known Unauthorized Use on port 33435
33657-33889 Unassigned
34250-34377 Unassigned
p-net-local 34378 tcp P-Net on IP local Kurt Nissen Kurt Nissen 2004-02
p-net-local 34378 udp P-Net on IP local Kurt Nissen Kurt Nissen 2004-02
p-net-remote 34379 tcp P-Net on IP remote Kurt Nissen Kurt Nissen 2004-02
p-net-remote 34379 udp P-Net on IP remote Kurt Nissen Kurt Nissen 2004-02
dhanalakshmi 34567 tcp dhanalakshmi.org EDI Service Girish Gopalakrishnan Girish Gopalakrishnan 2010-04-20
edi_service 34567 udp dhanalakshmi.org EDI Service Girish Gopalakrishnan Girish Gopalakrishnan 2016-10-26
34967-34979 Unassigned
35007-35099 Unassigned
openstack-id 35357 tcp OpenStack ID Service Rackspace Hosting Ziad Sawalha 2011-08-15
35357 udp Reserved
mapx 36700 tcp MapX communication MicroTechniX Yarochkin Michail 2014-10-13
36700 udp Reserved
36701-36864 Unassigned
36866-37471 Unassigned
37472 tcp Reserved
37472 udp Reserved
3gpp-w1ap 37472 sctp W1 signalling transport 3GPP Lionel Morand 2020-07-16
37473-37474 Unassigned
neckar 37475 tcp science + computing's Venus Administration Port Ralf Allrutz Ralf Allrutz 2002-02
neckar 37475 udp science + computing's Venus Administration Port Ralf Allrutz Ralf Allrutz 2002-02
37476-37482 Unassigned
gdrive-sync 37483 tcp Google Drive Sync Google Inc. Jason Schiller 2013-02-01 2015-07-31
37483 udp Reserved
37484-37600 Unassigned
eftp 37601 tcp Epipole File Transfer Protocol Epipole Limited Colin Buchanan 2014-11-13
37601 udp Reserved
37602-37653 Unassigned
unisys-eportal 37654 tcp Unisys ClearPath ePortal Sung U. Ro Sung U. Ro 2006-01
unisys-eportal 37654 udp Unisys ClearPath ePortal Sung U. Ro Sung U. Ro 2006-01
37655-37999 Unassigned
galaxy7-data 38201 tcp Galaxy7 Data Tunnel Tatham Oddie Tatham Oddie 2002-09
galaxy7-data 38201 udp Galaxy7 Data Tunnel Tatham Oddie Tatham Oddie 2002-09
38463-38471 Unassigned
38472 tcp Reserved
38472 udp Reserved
f1-control 38472 sctp F1 Control Plane (3GPP) Luis Lopes Luis Lopes 2017-06-23
38473-38637 Unassigned
38639-38799 Unassigned
41231-41793 Unassigned
crestron-cip 41794 tcp Crestron Control Port Crestron Electronics, Inc. John Pavlik 2003-01 2019-10-17
crestron-cip 41794 udp Crestron Control Port Crestron Electronics, Inc. John Pavlik 2003-01 2019-10-17
crestron-ctp 41795 tcp Crestron Terminal Port Crestron Electronics, Inc. John Pavlik 2003-01 2019-10-17
crestron-ctp 41795 udp Crestron Terminal Port Crestron Electronics, Inc. John Pavlik 2003-01 2019-10-17
crestron-cips 41796 tcp Crestron Secure Control Port Crestron Electronics, Inc. John Pavlik 2012-06-27 2019-10-17
41796 udp Reserved
crestron-ctps 41797 tcp Crestron Secure Terminal Port Crestron Electronics, Inc. John Pavlik 2012-06-27 2019-10-17
41797 udp Reserved
41798-42507 Unassigned Unauthorized Use Known on port 42000
43001-43187 Unassigned
43211-43437 Unassigned
44323 udp Unassigned "pcp" assignment withdrawn, moved to port 5351 per RFC 6887
44601-44817 Unassigned
45515-45677 Unassigned
eba 45678 tcp EBA PRISE Patrick Kara Patrick Kara
eba 45678 udp EBA PRISE Patrick Kara Patrick Kara
45679-45823 Unassigned
45967-46335 Unassigned
46337-46997 Unassigned
mbus 47000 tcp Message Bus Dirk Kutscher Dirk Kutscher
mbus 47000 udp Message Bus Dirk Kutscher Dirk Kutscher
winrm 47001 tcp Windows Remote Management Service Ryan Mack Ryan Mack 2009-04-29
47001 udp Reserved
47002-47099 Unassigned
jvl-mactalk 47100 udp Configuration of motors connected to Industrial Ethernet JVL Industri Elektronik Kim Berthelsen 2012-12-21
47100 tcp Reserved
47101-47556 Unassigned
dbbrowse 47557 tcp Databeam Corporation Cindy Martin Cindy Martin
dbbrowse 47557 udp Databeam Corporation Cindy Martin Cindy Martin
47558-47623 Unassigned
directplaysrvr 47624 tcp Direct Play Server Ajay Jindal Ajay Jindal
directplaysrvr 47624 udp Direct Play Server Ajay Jindal Ajay Jindal
47625-47805 Unassigned
ap 47806 tcp ALC Protocol Dave Robin Dave Robin
ap 47806 udp ALC Protocol Dave Robin Dave Robin
47807 Unassigned
bacnet 47808 tcp Building Automation and Control Networks Coleman Brumley Coleman Brumley 2011-02-10
bacnet 47808 udp Building Automation and Control Networks Coleman Brumley Coleman Brumley 2011-02-10
presonus-ucnet 47809 udp PreSonus Universal Control Network Protocol PreSonus Audio Electronics, Inc Matthias Juwan 2013-07-12
47809 tcp Reserved
47810-47999 Unassigned

Contact Information

Name Organization Contact URI Last Updated
3GPP lionel.morand&orange.com 2020-07-16
Ajay Jindal ajayj&microsoft.com
Chris Adkins cadkins&filenet.com 2006-10
Cindy Martin cmartin&databeam.com
Coleman Brumley cbrumley&polarsoft.biz 2011-02-10
Colin Buchanan Epipole Limited colin&epipole.com 2014-11-13
Crestron Electronics, Inc. jpavlik&crestron.com 2019-10-17
Daniel Whelan dwhelan&filenet.com
Dave Robin iana_ports&daverobin.com
Dirk Kutscher dku&informatik.uni-bremen.de
Epipole Limited info&epipole.com 2014-11-13
Girish Gopalakrishnan girish&shankar-software.org 2016-10-26
Google Inc. numbers&google.com 2015-07-31
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jason Schiller Google Inc. jschiller&google.com 2015-07-31
John Pavlik jpavlik&crestron.com 2019-10-17
JVL Industri Elektronik jvl&jvl.dk 2012-12-21
Kim Berthelsen JVL Industri Elektronik kb&jvl.dk 2012-12-21
Kurt Nissen kn&proces-data.com 2004-02
Lionel Morand lionel.morand&orange.com 2020-07-16
Luis Lopes llopes&qti.qualcomm.com 2017-06-23
Matthias Juwan PreSonus Audio Electronics, Inc mjuwan&presonus.com 2013-07-12
MicroTechniX Info&microtechnix.com 2014-10-13
Patrick Kara Patrick&eba.net
PreSonus Audio Electronics, Inc mjuwan&presonus.com 2013-07-12
Rackspace Hosting ziad.sawalha&rackspace.com 2011-08-15
Ralf Allrutz R.Allrutz&science-computing.de 2002-02
Ryan Mack rmack&microsoft.com 2009-04-29
Sung U. Ro ePortalSupport&unisys.com 2006-01
Tatham Oddie tatham&e-oddie.com 2002-09
Tim Morgan tmorgan&filenet.com 2005-11
Yarochkin Michail MicroTechniX Michail.Yarochkin&microtechnix.com 2014-10-13
Ziad Sawalha Rackspace Hosting ziad.sawalha&rackspace.com 2011-08-15