Service Name and Transport Protocol Port Number Registry

Last Updated
2026-10-09
Expert(s)
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell,
and Michael Scharf
SCTP: Michael Tuexen
DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
[RFC 6335]
Note
Service names and port numbers are used to distinguish between different
services that run over transport protocols such as TCP, UDP, DCCP, and
SCTP.

Service names are assigned on a first-come, first-served process, as
documented in [RFC 6335].

Port numbers are assigned in various ways, based on three ranges: System
Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private
Ports (49152-65535); the different uses of these ranges are described in
[RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are 
assigned by the "IETF Review" or "IESG Approval" procedures described in 
[RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, 
the "IESG Approval" process, or the "Expert Review" process, as per 
[RFC 6335]. Dynamic Ports are not assigned.

The registration procedures for service names and port numbers are
described in [RFC 6335].

Assigned ports both System and User ports SHOULD NOT be used without
or prior to IANA registration.

************************************************************************
* PLEASE NOTE THE FOLLOWING:                                           *
*                                                                      *
* ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN             *
* ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK  *
* TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT   *
* IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE     *
* ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD          *
* CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF    *
* THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER          *
* REGISTERED OR NOT.                                                   *
************************************************************************

Request an Assignment
  [https://www.iana.org/protocols/apply]

Available Formats

CSV

XML

HTML

TXT
Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
prchat-server 4456 udp PR Chat Server
4461-4479 Unassigned
agtp-quic 4480 udp Agent Transfer Protocol over QUIC [Chris_Hood] [Chris_Hood] 2026-04-30
4481-4483 Unassigned
assyst-dr 4485 tcp Assyst Data Repository Service [Albert_Cester] [Albert_Cester] 2008-08-26
prex-tcp 4487 tcp Protocol for Remote Execution over TCP [Daniel_Ruppert] [Daniel_Ruppert] 2010-09-16
awacs-ice 4488 tcp Apple Wide Area Connectivity Service ICE Bootstrap [Rory_McGuire] [Rory_McGuire] 2010-09-24
awacs-ice 4488 udp Apple Wide Area Connectivity Service ICE Bootstrap [Rory_McGuire] [Rory_McGuire] 2010-09-24
4489-4499 Unassigned Known UNAUTHORIZED USE: Ports 4490 and 4491
ipsec-nat-t 4500 tcp IPsec NAT-Traversal 2022-09-15 [RFC 9329]
ipsec-nat-t 4500 udp IPsec NAT-Traversal 2017-07-07 [RFC 3948][RFC 7296]
4501 Unassigned [IANA] [IANA] De-registered 08 June 2001
a25-fap-fgw 4502 sctp A25 (FAP-FGW) [_3GPP_2] [Zhiming_Li] 2012-01-11
m-bus-oms 4503 udp M-Bus-OMS over UDP [OMS-Group_e._V.] [Ahmed_Kasttet] 2025-05-19
4504-4533 Unassigned
ehs-ssl 4536 tcp Event Heap Server SSL [Brad_Johanson] [Brad_Johanson] 2005-08
ehs-ssl 4536 udp Event Heap Server SSL [Brad_Johanson] [Brad_Johanson] 2005-08
swx-gate 4538 tcp Software Data Exchange Gateway [Julien_VALIENTE] [Julien_VALIENTE] 2006-05
swx-gate 4538 udp Software Data Exchange Gateway [Julien_VALIENTE] [Julien_VALIENTE] 2006-05
4539-4544 Unassigned
sf-lm 4546 tcp SF License Manager (Sentinel) [Thomas_Koell] [Thomas_Koell]
sf-lm 4546 udp SF License Manager (Sentinel) [Thomas_Koell] [Thomas_Koell]
lanner-lm 4547 tcp Lanner License Manager [Les_Enstone] [Les_Enstone]
lanner-lm 4547 udp Lanner License Manager [Les_Enstone] [Les_Enstone]
gds-adppiw-db 4550 tcp Perman I Interbase Server [Leo_Lesage] [Leo_Lesage] 2006-04
gds-adppiw-db 4550 udp Perman I Interbase Server [Leo_Lesage] [Leo_Lesage] 2006-04
ieee-mih 4551 tcp MIH Services [RFC 5677]
ieee-mih 4551 udp MIH Services [RFC 5677]
menandmice-mon 4552 tcp Men and Mice Monitoring [Carsten_Strotmann] [Carsten_Strotmann] 2009-05-20
menandmice-mon 4552 udp Men and Mice Monitoring [Carsten_Strotmann] [Carsten_Strotmann] 2009-05-20
dtn-bundle 4556 tcp DTN Bundle TCP CL Protocol [IESG] [IETF_Chair] 2021-02-22 [RFC 9174]
dtn-bundle 4556 udp DTN Bundle UDP CL Protocol 2006-11 2014-02-21 [RFC 7122]
dtn-bundle 4556 dccp DTN Bundle DCCP CL Protocol 2013-11-12 2014-02-21 [RFC 7122] 1685351985
4560-4562 Unassigned
amahi-anywhere 4563 tcp Amahi Anywhere [Amahi] [Carlos_Puchol] 2014-02-27
4564-4565 Unassigned
bmc-reporting 4568 tcp BMC Reporting [Portnoy_Boxman] [Portnoy_Boxman]
bmc-reporting 4568 udp BMC Reporting [Portnoy_Boxman] [Portnoy_Boxman]
iax 4569 tcp Inter-Asterisk eXchange [Benjamin_Kowarsch] [Benjamin_Kowarsch] [RFC 5456] Defined TXT keys:
auth plaintext | md5 | rsakeys
userid alphanumeric, additionally '_', '+', '-'
secret any printable ASCII characters
domain any DNS domain name or IP address
extension alphanumeric, additionally '*', '#', '_', '+', '-'
context alphanumeric, additionally '_', '+', '-'
trunk yes | no | 0 | 1
welcome alphanumeric, additionally '*', '#', '_', '+', '-'
voicemail alphanumeric, additionally '*', '#', '_', '+', '-'
reception alphanumeric, additionally '*', '#', '_', '+', '-'
echotest alphanumeric, additionally '*', '#', '_', '+', '-'
ivrtest alphanumeric, additionally '*', '#', '_', '+', '-'
All of these TXT record keys are optional, they may be omitted. Further keys may be added in the future.
iax 4569 udp Inter-Asterisk eXchange [Benjamin_Kowarsch] [Benjamin_Kowarsch] [RFC 5456] Defined TXT keys:
auth plaintext | md5 | rsakeys
userid alphanumeric, additionally '_', '+', '-'
secret any printable ASCII characters
domain any DNS domain name or IP address
extension alphanumeric, additionally '*', '#', '_', '+', '-'
context alphanumeric, additionally '_', '+', '-'
trunk yes | no | 0 | 1
welcome alphanumeric, additionally '*', '#', '_', '+', '-'
voicemail alphanumeric, additionally '*', '#', '_', '+', '-'
reception alphanumeric, additionally '*', '#', '_', '+', '-'
echotest alphanumeric, additionally '*', '#', '_', '+', '-'
ivrtest alphanumeric, additionally '*', '#', '_', '+', '-'
All of these TXT record keys are optional, they may be omitted. Further keys may be added in the future.
4571-4572 Unassigned
cardifftec-back 4573 tcp A port for communication between a server and client for a custom backup system [CardiffTec] [Benjamin_Misell] 2016-05-19
4574-4589 Unassigned
l3t-at-an 4591 tcp HRPD L3T (AT-AN) [Avi_Lior] [Avi_Lior] 2009-02-27
l3t-at-an 4591 udp HRPD L3T (AT-AN) [Avi_Lior] [Avi_Lior] 2009-02-27
hrpd-ith-at-an 4592 udp HRPD-ITH (AT-AN) [David_Ott] [David_Ott] 2008-06-05
ipt-anri-anri 4593 tcp IPT (ANRI-ANRI)
ipt-anri-anri 4593 udp IPT (ANRI-ANRI)
ias-session 4594 tcp IAS-Session (ANRI-ANRI)
ias-session 4594 udp IAS-Session (ANRI-ANRI)
ias-paging 4595 tcp IAS-Paging (ANRI-ANRI)
ias-paging 4595 udp IAS-Paging (ANRI-ANRI)
ias-neighbor 4596 tcp IAS-Neighbor (ANRI-ANRI) [David_Ott] [David_Ott] 2007-07-31
ias-neighbor 4596 udp IAS-Neighbor (ANRI-ANRI) [David_Ott] [David_Ott] 2007-07-31
a21-an-1xbs 4597 tcp A21 (AN-1xBS) [David_Ott] [David_Ott] 2006-02
a21-an-1xbs 4597 udp A21 (AN-1xBS) [David_Ott] [David_Ott] 2006-02
a16-an-an 4598 tcp A16 (AN-AN) [David_Ott] [David_Ott] 2005-12
a16-an-an 4598 udp A16 (AN-AN) [David_Ott] [David_Ott] 2005-12
a17-an-an 4599 tcp A17 (AN-AN) [David_Ott] [David_Ott] 2006-02
a17-an-an 4599 udp A17 (AN-AN) [David_Ott] [David_Ott] 2006-02
menandmice-upg 4603 tcp Men & Mice Upgrade Agent [Eggert_Thorlacius_2] [Eggert_Thorlacius_2] 2010-01-27
4607-4620 Unassigned
4622-4645 Unassigned
dots-signal 4646 tcp Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel Protocol. The service name is used to construct the SRV service names "_dots-signal._udp" and "_dots-signal._tcp" for discovering DOTS servers used to establish DOTS signal channel. [IESG] [IETF_Chair] 2020-01-16 2021-06-14 [RFC 8973][RFC 9132]
dots-signal 4646 udp Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel Protocol. The service name is used to construct the SRV service names "_dots-signal._udp" and "_dots-signal._tcp" for discovering DOTS servers used to establish DOTS signal channel. [IESG] [IETF_Chair] 2020-01-16 2021-06-14 [RFC 8973][RFC 9132]
4647-4657 Unassigned
playsta2-app 4658 tcp PlayStation2 App Port
playsta2-app 4658 udp PlayStation2 App Port
playsta2-lob 4659 tcp PlayStation2 Lobby Port [Noam_Rimon] [Noam_Rimon] 2004-12
playsta2-lob 4659 udp PlayStation2 Lobby Port [Noam_Rimon] [Noam_Rimon] 2004-12
eportcomm 4666 tcp E-Port Message Service
eportcomm 4666 udp E-Port Message Service
eportcommdata 4669 tcp E-Port Data Service [Robert_Shaffer] [Robert_Shaffer] 2006-02
eportcommdata 4669 udp E-Port Data Service [Robert_Shaffer] [Robert_Shaffer] 2006-02
appiq-mgmt 4674 tcp AppIQ Agent Management [Phil_Abercrombie] [Phil_Abercrombie] 2005-08
appiq-mgmt 4674 udp AppIQ Agent Management [Phil_Abercrombie] [Phil_Abercrombie] 2005-08
dhct-status 4675 tcp BIAP Device Status
dhct-status 4675 udp BIAP Device Status
dhct-alerts 4676 tcp BIAP Generic Alert [Louis_Slothouber] [Louis_Slothouber] 2005-08
dhct-alerts 4676 udp BIAP Generic Alert [Louis_Slothouber] [Louis_Slothouber] 2005-08
rfid-rp1 4684 tcp RFID Reader Protocol 1.0 [Michael_Mealling_2] [Michael_Mealling_2] 2005-08
rfid-rp1 4684 udp RFID Reader Protocol 1.0 [Michael_Mealling_2] [Michael_Mealling_2] 2005-08
msp-os 4686 tcp Manina Service Protocol [Markus_Nix] [Markus_Nix] 2005-08
msp-os 4686 udp Manina Service Protocol [Markus_Nix] [Markus_Nix] 2005-08
mobile-p2p 4688 tcp Mobile P2P Service [Hanz_Hager] [Hanz_Hager] 2008-12-04
mobile-p2p 4688 udp Mobile P2P Service [Hanz_Hager] [Hanz_Hager] 2008-12-04
4693-4699 Unassigned
netxms-agent 4700 tcp NetXMS Agent
netxms-agent 4700 udp NetXMS Agent
netxms-mgmt 4701 tcp NetXMS Management
netxms-mgmt 4701 udp NetXMS Management
netxms-sync 4702 tcp NetXMS Server Synchronization [Victor_Kirhenshtein] [Victor_Kirhenshtein] 2006-07
netxms-sync 4702 udp NetXMS Server Synchronization [Victor_Kirhenshtein] [Victor_Kirhenshtein] 2006-07
npqes-test 4703 tcp Network Performance Quality Evaluation System Test Service [Zhengli] [Zhengli] 2010-06-28
assuria-ins 4704 tcp Assuria Insider [Nick_Connor] [Nick_Connor] 2010-06-30
4705-4710 Unassigned
trinity-dist 4711 tcp Trinity Trust Network Node Communication [P3KI_GmbH] [Gregor_Jehle] 2017-01-12
trinity-dist 4711 udp Trinity Trust Network Node Communication [P3KI_GmbH] [Gregor_Jehle] 2017-01-12
trinity-dist 4711 sctp Trinity Trust Network Node Communication [P3KI_GmbH] [Gregor_Jehle] 2017-01-12
4712-4724 Unassigned
a26-fap-fgw 4726 udp A26 (FAP-FGW) [David_Ott] [David_Ott] 2010-10-15

Contact Information

ID Name Organization Contact URI Last Updated
[_3GPP_2] 3GPP2 mailto:lizhiming&huawei.com 2012-01-11
[Ahmed_Kasttet] Ahmed Kasttet OMS-Group e. V. (Open Metering System Group) mailto:ahmed.kasttet&oms-group.org 2025-05-19
[Albert_Cester] Albert Cester mailto:albert.cester&assyst-intl.com 2008-08-26
[Amahi] Amahi mailto:iana&amahi.org 2014-02-27
[Avi_Lior] Avi Lior mailto:avi&bridgewatersystems.com 2009-02-27
[Benjamin_Kowarsch] Benjamin Kowarsch mailto:benjamin&sunrise-tel.com 2004-11
[Benjamin_Misell] Benjamin Misell mailto:beninjam174&gmail.com 2016-05-19
[Brad_Johanson] Brad Johanson mailto:bradj&tidebreak.com 2005-08
[CardiffTec] CardiffTec mailto:beninjam174&gmail.com 2016-05-19
[Carlos_Puchol] Carlos Puchol Amahi mailto:iana&amahi.org 2014-02-27
[Carsten_Strotmann] Carsten Strotmann mailto:carsten.strotmann&menandmice.com 2009-05-20
[Chris_Hood] Chris Hood mailto:chris&nomotic.ai 2026-04-30
[Daniel_Ruppert] Daniel Ruppert mailto:daniel&kaffi.lu 2010-09-16
[David_Ott] David Ott mailto:dott&qualcomm.com 2010-10-15
[Eggert_Thorlacius_2] Eggert Thorlacius mailto:eggi&menandmice.com 2010-01-27
[Gregor_Jehle] Gregor Jehle mailto:hadez&p3ki.com 2017-01-12
[Hanz_Hager] Hanz Hager mailto:Hanz.Hager&comhem.se 2008-12-04
[IANA] IANA mailto:iana&iana.org
[IESG] IESG mailto:iesg&ietf.org
[IETF_Chair] IETF Chair IETF mailto:chair&ietf.org
[Julien_VALIENTE] Julien VALIENTE mailto:j.valiente&objectif-software.com 2006-05
[Leo_Lesage] Leo Lesage mailto:leo.lesage&adp.nl 2006-04
[Les_Enstone] Les Enstone mailto:lenstone&lanner.co.uk
[Louis_Slothouber] Louis Slothouber mailto:lpslot&biap.com 2005-08
[Markus_Nix] Markus Nix mailto:mnix&docuverse.de 2005-08
[Michael_Mealling_2] Michael Mealling mailto:michael&refactored-networks.com 2005-08
[Nick_Connor] Nick Connor mailto:nickc&assuria.com 2010-06-30
[Noam_Rimon] Noam Rimon mailto:noam.rimon&playstation.sony.com 2004-12
[OMS-Group_e._V.] OMS-Group e. V. (Open Metering System Group) mailto:office&oms-group.org 2025-05-19
[P3KI_GmbH] P3KI GmbH mailto:iana&p3ki.com 2017-01-12
[Phil_Abercrombie] Phil Abercrombie mailto:phil.abercrombie&appiq.com 2005-08
[Portnoy_Boxman] Portnoy Boxman mailto:portnoy_boxman&bmc.com 2005-01
[Robert_Shaffer] Robert Shaffer mailto:bob.shaffer&micmod.com 2006-02
[Rory_McGuire] Rory McGuire mailto:rlpm&apple.com 2010-09-24
[Thomas_Koell] Thomas Koell mailto:info&sf.com
[Victor_Kirhenshtein] Victor Kirhenshtein mailto:victor&opticom.lv 2006-07
[Zhengli] Zhengli mailto:std&iwncomm.com 2010-06-28
[Zhiming_Li] Zhiming Li 3GPP2 mailto:lizhiming&huawei.com 2012-01-11