Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 4198 | Unassigned | ||||||||||
| eims-admin | 4199 | tcp | EIMS ADMIN | Glenn Anderson | Glenn Anderson | ||||||
| eims-admin | 4199 | udp | EIMS ADMIN | Glenn Anderson | Glenn Anderson | ||||||
| d-data | 4301 | tcp | Diagnostic Data | ||||||||
| d-data | 4301 | udp | Diagnostic Data | ||||||||
| mirrtex | 4310 | tcp | Mir-RT exchange service | Sylvain Robert | Sylvain Robert | 2008-02-14 | |||||
| mirrtex | 4310 | udp | Mir-RT exchange service | Sylvain Robert | Sylvain Robert | 2008-02-14 | |||||
| p6ssmc | 4311 | tcp | P6R Secure Server Management Console | Jim Susoy | Jim Susoy | 2010-01-21 | |||||
| 4311 | udp | Reserved | |||||||||
| pscl-mgt | 4312 | tcp | Parascale Membership Manager | John Muth | John Muth | 2010-01-21 | |||||
| 4312 | udp | Reserved | |||||||||
| perrla | 4313 | tcp | PERRLA User Services | Cliff Batson | Cliff Batson | 2010-01-21 | |||||
| 4313 | udp | Reserved | |||||||||
| choiceview-agt | 4314 | tcp | ChoiceView Agent | Radish Systems | Richard A. Davis | 2013-03-28 | |||||
| 4314 | udp | Reserved | |||||||||
| 4315 | Unassigned | Unauthorized Use Known on port 4315 | |||||||||
| choiceview-clt | 4316 | tcp | ChoiceView Client | Radish Systems | Richard A. Davis | 2013-03-28 | |||||
| 4316 | udp | Reserved | |||||||||
| opentelemetry | 4317 | tcp | OpenTelemetry Protocol | OpenTelemetry | Morgan McLean | 2020-12-09 | |||||
| 4317 | udp | Reserved | |||||||||
| 4318 | Unassigned | ||||||||||
| skytale | 4319 | tcp | Sentyron SkyTale encrypted communication | Sentyron B.V. | Mark Revier | 2022-01-20 | 2025-10-30 | ||||
| skytale | 4319 | udp | Sentyron SkyTale encrypted communication | Sentyron B.V. | Mark Revier | 2022-01-20 | 2025-10-30 | ||||
| rwhois | 4321 | tcp | Remote Who Is | Mark Kosters | Mark Kosters | RFC 2167 | |||||
| rwhois | 4321 | udp | Remote Who Is | Mark Kosters | Mark Kosters | RFC 2167 | |||||
| 4324 | Reserved | 2015-05-12 | This entry is being removed on 2015-05-12. | ||||||||
| ktickets-rest | 4331 | tcp | ktickets REST API for event management and ticketing systems (embedded POS devices) | KeyTicket Solutions | MANG Ioan-Alexandru | 2014-04-04 | |||||
| 4331 | udp | Reserved | |||||||||
| netconf-ch-ssh | 4334 | tcp | NETCONF Call Home (SSH) | IESG | IETF Chair | 2016-01-12 | RFC 8071 | ||||
| netconf-ch-tls | 4335 | tcp | NETCONF Call Home (TLS) | IESG | IETF Chair | 2016-01-12 | RFC 8071 | ||||
| restconf-ch-tls | 4336 | tcp | RESTCONF Call Home (TLS) | IESG | IETF Chair | 2016-01-12 | RFC 8071 | ||||
| 4341 | tcp | Reserved | 2007-11-12 | 2018-11-30 | |||||||
| lisp-data | 4341 | udp | LISP Data Packets | IESG | IETF Chair | 2007-11-12 | 2021-02-17 | RFC 9300 | |||
| lisp-control | 4342 | udp | LISP Control Packets | IETF | IESG | 2007-05 | 2021-02-25 | RFC 9301 | |||
| plcy-net-svcs | 4351 | tcp | PLCY Net Services | J.J. Ekstrom | J.J. Ekstrom | ||||||
| plcy-net-svcs | 4351 | udp | PLCY Net Services | J.J. Ekstrom | J.J. Ekstrom | ||||||
| 4361 | tcp | Reserved | |||||||||
| nacnl | 4361 | udp | NavCom Discovery and Control Port | Yilei Jia | Yilei Jia | 2009-03-18 | |||||
| l2c-control | 4371 | tcp | LAN2CAN Control | Phil Tolson | Phil Tolson | 2008-07-07 | Modified: 21 January 2010 | ||||
| l2c-disc | 4371 | udp | LAN2CAN Discovery | Phil Tolson | Phil Tolson | 2010-01-21 | |||||
| l2c-data | 4372 | tcp | LAN2CAN Data | Phil Tolson | Phil Tolson | 2008-07-07 | Modified: 21 January 2010 | ||||
| apwi-imserver | 4391 | tcp | American Printware IMServer Protocol | Lech Lakomy | Lech Lakomy | 2009-02-12 | |||||
| 4391 | udp | Reserved | |||||||||
| ds-srvr | 4401 | tcp | ASIGRA Televaulting DS-System Service | ||||||||
| ds-srvr | 4401 | udp | ASIGRA Televaulting DS-System Service | ||||||||
| itwo-server | 4410 | tcp | RIB iTWO Application Server | Kristean Heisler | Kristean Heisler | 2009-12-16 | |||||
| 4410 | udp | Reserved | |||||||||
| found | 4411 | tcp | Found Messaging Protocol | Found Software, Inc. | John Mitchell | 2012-04-11 | Defined TXT keys: id, key | ||||
| 4411 | udp | Reserved | |||||||||
| 4412 | tcp | Reserved | |||||||||
| smallchat | 4412 | udp | SmallChat | Valentino_Giudice | Valentino_Giudice | 2015-08-18 | |||||
| vision-mon | 4413 | tcp | FORTÉ Vision Monitoring platform | FORTÉ | Rob Duram | 2015-09-18 | 2025-11-14 | ||||
| vision-mon-disc | 4413 | udp | FORTÉ Vision Monitoring platform | FORTÉ | Rob Duram | 2015-09-18 | 2025-11-14 | ||||
| updog | 4414 | tcp | Updog Monitoring and Status Framework | Egon Technologies, LLC | James Downs | 2015-10-05 | |||||
| 4414 | udp | Reserved | |||||||||
| brcd-vr-req | 4415 | tcp | Brocade Virtual Router Request | Brocade Communications Systems | Nick Carter | 2015-11-17 | |||||
| 4415 | udp | Reserved | |||||||||
| newmood-player | 4416 | tcp | Newmood Media Player | Creation Newmood Inc. | Bruno Frechette | 2015-11-18 | 2026-09-30 | ||||
| newmood-player | 4416 | udp | Newmood Media Player discovery | Creation Newmood Inc. | Bruno Frechette | 2015-11-18 | 2026-09-30 | ||||
| workflowdir | 4417 | tcp | Workflow Director Communication | WfDir | Brian Doyle | 2015-12-11 | |||||
| 4417 | udp | Reserved | |||||||||
| 4418 | tcp | Reserved | |||||||||
| axysbridge | 4418 | udp | AXYS communication protocol | Duran Audio B.V. | Gerald van Beuningen | 2016-03-14 | |||||
| cbp | 4419 | tcp | Colnod Binary Protocol | Colsys s.r.o. | Jiri Merth | 2016-03-23 | |||||
| 4419 | udp | Reserved | |||||||||
| scaleft | 4421 | tcp | Multi-Platform Remote Management for Cloud Infrastructure | ScaleFT, Inc | Paul Querna | 2016-04-07 | |||||
| 4421 | udp | Reserved | |||||||||
| wspipe | 4431 | tcp | adWISE Pipe | Heikki Ellilä | Heikki Ellilä | 2009-06-18 | |||||
| 4431 | udp | Reserved | |||||||||
| 4441 | tcp | Reserved | |||||||||
| netblox | 4441 | udp | Netblox Protocol | Brian S. Locke | Brian S. Locke | 2008-07-10 | |||||
| n1-fwp | 4446 | tcp | N1-FWP | ||||||||
| n1-fwp | 4446 | udp | N1-FWP | ||||||||
| n1-rmgmt | 4447 | tcp | N1-RMGMT | Lori Tassin | Lori Tassin | ||||||
| n1-rmgmt | 4447 | udp | N1-RMGMT | Lori Tassin | Lori Tassin | ||||||
| ctisystemmsg | 4451 | tcp | CTI System Msg | Control Technology Inc. | Clint Eskew | 2011-10-28 | |||||
| ctisystemmsg | 4451 | udp | CTI System Msg | Control Technology Inc. | Clint Eskew | 2011-10-28 | |||||
| ntske | 4460 | tcp | Network Time Security Key Establishment | IESG | IETF Chair | 2020-04-07 | RFC 8915 | ||||
| 4461-4479 | Unassigned | ||||||||||
| 4481-4483 | Unassigned | ||||||||||
| 4489-4499 | Unassigned | Known UNAUTHORIZED USE: Ports 4490 and 4491 | |||||||||
| 4501 | Unassigned | IANA | IANA | De-registered 08 June 2001 | |||||||
| ieee-mih | 4551 | tcp | MIH Services | RFC 5677 | |||||||
| ieee-mih | 4551 | udp | MIH Services | RFC 5677 | |||||||
| rsip | 4555 | tcp | RSIP Port | RFC 3103 | |||||||
| rsip | 4555 | udp | RSIP Port | RFC 3103 | |||||||
| dtn-bundle | 4556 | tcp | DTN Bundle TCP CL Protocol | IESG | IETF Chair | 2021-02-22 | RFC 9174 | ||||
| dtn-bundle | 4556 | udp | DTN Bundle UDP CL Protocol | 2006-11 | 2014-02-21 | RFC 7122 | |||||
| dtn-bundle | 4556 | dccp | DTN Bundle DCCP CL Protocol | 2013-11-12 | 2014-02-21 | RFC 7122 | 1685351985 | ||||
| 4571-4572 | Unassigned | ||||||||||
| l3t-at-an | 4591 | tcp | HRPD L3T (AT-AN) | Avi Lior | Avi Lior | 2009-02-27 | |||||
| l3t-at-an | 4591 | udp | HRPD L3T (AT-AN) | Avi Lior | Avi Lior | 2009-02-27 | |||||
| a21-an-1xbs | 4597 | tcp | A21 (AN-1xBS) | David Ott | David Ott | 2006-02 | |||||
| a21-an-1xbs | 4597 | udp | A21 (AN-1xBS) | David Ott | David Ott | 2006-02 | |||||
| a16-an-an | 4598 | tcp | A16 (AN-AN) | David Ott | David Ott | 2005-12 | |||||
| a16-an-an | 4598 | udp | A16 (AN-AN) | David Ott | David Ott | 2005-12 | |||||
| a17-an-an | 4599 | tcp | A17 (AN-AN) | David Ott | David Ott | 2006-02 | |||||
| a17-an-an | 4599 | udp | A17 (AN-AN) | David Ott | David Ott | 2006-02 | |||||
| piranha1 | 4600 | tcp | Piranha1 | ||||||||
| piranha1 | 4600 | udp | Piranha1 | ||||||||
| piranha2 | 4601 | tcp | Piranha2 | Primark Corporation | Primark Corporation |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Avi Lior | avi&bridgewatersystems.com | 2009-02-27 | |
| Brian Doyle | bd&wfdir.com | 2015-12-11 | |
| Brian S. Locke | blocke&zortlabs.com | 2008-07-10 | |
| Brocade Communications Systems | ncarter&brocade.com | 2015-11-17 | |
| Bruno Frechette | Creation Newmood Inc. | bruno&newmood.com | 2026-09-30 |
| Cliff Batson | cliff&perrla.com | 2010-01-21 | |
| Clint Eskew | Control Technology Inc. | ceskew&controltechnology.com | 2011-10-28 |
| Colsys s.r.o. | jiri.merth&colsys.cz | 2016-03-23 | |
| Control Technology Inc. | ceskew&controltechnology.com | 2011-10-28 | |
| Creation Newmood Inc. | it&newmood.com | 2026-09-30 | |
| David Ott | dott&qualcomm.com | 2010-10-15 | |
| Duran Audio B.V. | info&duran-audio.com | 2016-03-14 | |
| Egon Technologies, LLC | james.downs&egontech.com | 2015-10-05 | |
| FORTÉ | rob.duram&ourforte.com | 2025-10-30 | |
| Found Software, Inc. | john&foundapp.com | 2012-04-11 | |
| Gerald van Beuningen | gerald.van.beuningen&duran-audio.com | 2016-03-14 | |
| Glenn Anderson | glenn&qualcomm.co.nz | ||
| Heikki Ellilä | heikki.ellila&western.fi | 2009-06-18 | |
| IANA | iana&iana.org | ||
| IESG | iesg&ietf.org | ||
| IETF | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| J.J. Ekstrom | |||
| James Downs | james.downs&egontech.com | 2015-10-05 | |
| Jim Susoy | jim.susoy&p6r.com | 2010-01-21 | |
| Jiri Merth | jiri.merth&colsys.cz | 2016-03-23 | |
| John Mitchell | Found Software, Inc. | john&foundapp.com | 2012-04-11 |
| John Muth | muth¶scale.com | 2010-01-21 | |
| KeyTicket Solutions | amang&keyticket.eu | 2014-04-04 | |
| Kristean Heisler | Kristean.Heisler&rib-software.com | 2009-12-16 | |
| Lech Lakomy | llakomy&apwi.com | 2009-02-12 | |
| Lori Tassin | Ramsey&network-1.com | ||
| MANG Ioan-Alexandru | KeyTicket Solutions | amang&keyticket.eu | 2014-04-04 |
| Mark Kosters | markk&internic.net | ||
| Mark Revier | Sentyron B.V. | iana&sentyron.com | 2025-10-30 |
| Morgan McLean | OpenTelemetry | morgan_mclean&hotmail.com | 2020-12-09 |
| Nick Carter | ncarter&brocade.com | 2015-11-17 | |
| OpenTelemetry | cncf-opentelemetry-governance&lists.cncf.io | 2020-12-09 | |
| Paul Querna | paul.querna&scaleft.com | 2016-04-07 | |
| Phil Tolson | philtolson&eaton.com | 2010-01-21 | |
| Primark Corporation | joe.boone&primark.com | ||
| Radish Systems | rad&radishsystems.com | 2013-03-28 | |
| Richard A. Davis | Radish Systems | rad&radishsystems.com | 2013-03-28 |
| Rob Duram | rob.duram&ourforte.com | 2025-10-30 | |
| ScaleFT, Inc | notices&scaleft.com | 2016-04-07 | |
| Sentyron B.V. | iana&sentyron.com | 2025-10-30 | |
| Sylvain Robert | sylvain.robert&datadis.com | 2008-02-14 | |
| valentino.giudice&vallauri.edu | 2015-08-18 | ||
| WfDir | bd&wfdir.com | 2015-12-11 | |
| Yilei Jia | yjia&navcomtech.com | 2009-03-18 |