Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| apc-9950 | 9950 | udp | APC 9950 | American Power Conversion | American Power Conversion | ||||||
| apc-9951 | 9951 | tcp | APC 9951 | American Power Conversion | American Power Conversion | ||||||
| apc-9951 | 9951 | udp | APC 9951 | American Power Conversion | American Power Conversion | ||||||
| apc-9952 | 9952 | tcp | APC 9952 | American Power Conversion | American Power Conversion | ||||||
| apc-9952 | 9952 | udp | APC 9952 | American Power Conversion | American Power Conversion | ||||||
| acis | 9953 | tcp | 9953 | Thomas Guth | Thomas Guth | 2006-01 | |||||
| acis | 9953 | udp | 9953 | Thomas Guth | Thomas Guth | 2006-01 | |||||
| hinp | 9954 | tcp | HaloteC Instrument Network Protocol | HaloteC Instruments B.V. | Michel Stam | 2012-02-07 | |||||
| 9954 | udp | Reserved | |||||||||
| alljoyn-stm | 9955 | tcp | Contact Port for AllJoyn standard messaging | Qualcomm Innovation Center, Inc. | Craig Dowell | 2012-03-14 | |||||
| alljoyn-mcm | 9955 | udp | Contact Port for AllJoyn multiplexed constrained messaging | Qualcomm Innovation Center, Inc. | Craig Dowell | 2012-03-14 | |||||
| 9956 | tcp | Reserved | |||||||||
| alljoyn | 9956 | udp | Alljoyn Name Service | Qualcomm Innovation Center, Inc. | Craig Dowell | 2011-12-21 | |||||
| 9957-9965 | Unassigned | ||||||||||
| 9982-9985 | Unassigned | ||||||||||
| palace-4 | 9995 | tcp | Palace-4 | Douglas Crockford | Douglas Crockford | ||||||
| palace-4 | 9995 | udp | Palace-4 | Douglas Crockford | Douglas Crockford | ||||||
| palace-5 | 9996 | tcp | Palace-5 | Douglas Crockford | Douglas Crockford | ||||||
| palace-5 | 9996 | udp | Palace-5 | Douglas Crockford | Douglas Crockford | ||||||
| emcrmird | 10005 | tcp | EMC Replication Manager Server | Robert Boudrie | Robert Boudrie | 2008-06-09 | |||||
| 10005 | udp | Reserved | |||||||||
| zabbix-agent | 10050 | tcp | Zabbix Agent | Alexei Vladishev | Alexei Vladishev | 2006-02 | |||||
| zabbix-agent | 10050 | udp | Zabbix Agent | Alexei Vladishev | Alexei Vladishev | 2006-02 | |||||
| zabbix-trapper | 10051 | tcp | Zabbix Trapper | Alexei Vladishev | Alexei Vladishev | 2006-02 | |||||
| zabbix-trapper | 10051 | udp | Zabbix Trapper | Alexei Vladishev | Alexei Vladishev | 2006-02 | |||||
| 10052-10054 | Unassigned | ||||||||||
| qptlmd | 10055 | tcp | Quantapoint FLEXlm Licensing Service | Justin Vegso | Justin Vegso | 2010-07-01 | |||||
| 10055 | udp | Reserved | |||||||||
| 10056-10079 | Unassigned | ||||||||||
| 10105-10106 | Unassigned | ||||||||||
| netiq-endpt | 10115 | tcp | NetIQ Endpoint | Gary Weichinger | Gary Weichinger | ||||||
| netiq-endpt | 10115 | udp | NetIQ Endpoint | Gary Weichinger | Gary Weichinger | ||||||
| cimple | 10125 | tcp | HotLink CIMple REST API | HotLink Corporation | Richard Offer | 2014-12-18 | |||||
| 10125 | udp | Reserved | |||||||||
| 10130-10159 | Unassigned | ||||||||||
| snmptls | 10161 | tcp | SNMP-TLS | RFC 6353 | |||||||
| snmpdtls | 10161 | udp | SNMP-DTLS | RFC 6353 | |||||||
| snmptls-trap | 10162 | tcp | SNMP-Trap-TLS | RFC 6353 | |||||||
| snmpdtls-trap | 10162 | udp | SNMP-Trap-DTLS | RFC 6353 | |||||||
| 10202-10251 | Unassigned | ||||||||||
| apollo-relay | 10252 | tcp | Apollo Relay Port | Anthony Carrabino | Anthony Carrabino | 2003-08 | |||||
| apollo-relay | 10252 | udp | Apollo Relay Port | Anthony Carrabino | Anthony Carrabino | 2003-08 | |||||
| eapol-relay | 10253 | udp | Relay of EAPOL frames | Wi-SUN Alliance | Phil Beecher | 2015-06-26 | |||||
| 10253 | tcp | Reserved | |||||||||
| 10254-10259 | Unassigned | ||||||||||
| 10321 | tcp | Reserved | 2023-12-05 | De-Assigned on 2023-12-05. | |||||||
| 10500 | tcp | Reserved | |||||||||
| hip-nat-t | 10500 | udp | HIP NAT-Traversal | IESG | IETF Chair | 2020-08-12 | RFC 5770; RFC 9028 | ||||
| 10501-10539 | Unassigned | ||||||||||
| MOS-lower | 10540 | tcp | MOS Media Object Metadata Port | Eric Thorniley | Eric Thorniley | 2007-09-17 | |||||
| MOS-lower | 10540 | udp | MOS Media Object Metadata Port | Eric Thorniley | Eric Thorniley | 2007-09-17 | |||||
| MOS-upper | 10541 | tcp | MOS Running Order Port | Eric Thorniley | Eric Thorniley | 2007-09-17 | |||||
| MOS-upper | 10541 | udp | MOS Running Order Port | Eric Thorniley | Eric Thorniley | 2007-09-17 | |||||
| MOS-aux | 10542 | tcp | MOS Low Priority Port | Eric Thorniley | Eric Thorniley | 2007-09-17 | |||||
| MOS-aux | 10542 | udp | MOS Low Priority Port | Eric Thorniley | Eric Thorniley | 2007-09-17 | |||||
| MOS-soap | 10543 | tcp | MOS SOAP Default Port | Eric Thorniley | Eric Thorniley | 2007-09-17 | |||||
| MOS-soap | 10543 | udp | MOS SOAP Default Port | Eric Thorniley | Eric Thorniley | 2007-09-17 | |||||
| MOS-soap-opt | 10544 | tcp | MOS SOAP Optional Port | Eric Thorniley | Eric Thorniley | 2007-09-17 | |||||
| MOS-soap-opt | 10544 | udp | MOS SOAP Optional Port | Eric Thorniley | Eric Thorniley | 2007-09-17 | |||||
| 10545-10547 | Unassigned | ||||||||||
| serverdocs | 10548 | tcp | Apple Document Sharing Service | Apple Inc. | Jason Thorpe | 2015-09-29 | |||||
| 10548 | udp | Reserved | |||||||||
| 10549-10630 | Unassigned | ||||||||||
| lpdg | 10805 | tcp | LUCIA Pareja Data Group | Alvaro P. Dominguez | Alvaro P. Dominguez | 2006-02 | |||||
| lpdg | 10805 | udp | LUCIA Pareja Data Group | Alvaro P. Dominguez | Alvaro P. Dominguez | 2006-02 | |||||
| 10811-10859 | Unassigned | ||||||||||
| weave | 11095 | tcp | Nest device-to-device and device-to-service application protocol | Nest Labs, Inc. | Grant Erickson | 2014-01-16 | |||||
| weave | 11095 | udp | Nest device-to-device and device-to-service application protocol | Nest Labs, Inc. | Grant Erickson | 2014-01-16 | |||||
| netapp-icdata | 11105 | tcp | NetApp Intercluster Data | Craig Everhart | Craig Everhart | 2010-07-06 | |||||
| 11105 | udp | Reserved | |||||||||
| suncacao-websvc | 11165 | tcp | sun cacao web service access point | Nick Stephen | Nick Stephen | 2005-08 | |||||
| suncacao-websvc | 11165 | udp | sun cacao web service access point | Nick Stephen | Nick Stephen | 2005-08 | |||||
| t5-straton | 11173 | tcp | Straton Runtime Programing | COPALP | Jerome FOLLUT | 2012-03-01 | |||||
| oemcacao-websvc | 11175 | tcp | OEM cacao web service access point | David Sechrest | David Sechrest | 2010-09-22 | |||||
| 11175 | udp | Reserved | |||||||||
| xcompute | 11235 | tcp | numerical systems messaging | Xplicit Computing Inc | Graham J. Orr | 2020-10-16 | |||||
| 11235 | udp | Reserved | |||||||||
| xcompute | 11235 | sctp | numerical systems messaging | Xplicit Computing Inc | Graham J. Orr | 2020-10-16 | |||||
| 11435-11488 | Unassigned | Known UNAUTHORIZED USE: port 11488 | |||||||||
| 11490-11599 | Unassigned | ||||||||||
| 11724-11750 | Unassigned | ||||||||||
| intrepid-ssl | 11751 | tcp | Intrepid SSL | Robert Eden | Robert Eden | 2003-03 | |||||
| intrepid-ssl | 11751 | udp | Intrepid SSL | Robert Eden | Robert Eden | 2003-03 | |||||
| 11752-11795 | Unassigned | ||||||||||
| 11797-11875 | Unassigned | ||||||||||
| dbisamserver1 | 12005 | tcp | DBISAM Database Server - Regular | Tim Young | Tim Young | 2002-05 | |||||
| dbisamserver1 | 12005 | udp | DBISAM Database Server - Regular | Tim Young | Tim Young | 2002-05 | |||||
| italk | 12345 | tcp | Italk Chat System | Takayuki Ito | Takayuki Ito | ||||||
| italk | 12345 | udp | Italk Chat System | Takayuki Ito | Takayuki Ito | ||||||
| 12346-12545 | Unassigned | ||||||||||
| carb-repl-ctrl | 12546 | tcp | Carbonite Server Replication Control | Open Text Corporation | Tony Ponzo | 2022-10-07 | |||||
| 12546 | udp | Reserved | |||||||||
| 12547-12752 | Unassigned | ||||||||||
| tsaf | 12753 | tcp | tsaf port | Andreas Fehr | Andreas Fehr | ||||||
| tsaf | 12753 | udp | tsaf port | Andreas Fehr | Andreas Fehr | ||||||
| 12754-12864 | Unassigned | ||||||||||
| netperf | 12865 | tcp | control port for the netperf benchmark | netperf.org | Rick Jones | 2013-04-05 | |||||
| 12865 | udp | Reserved | |||||||||
| 12866-13159 | Unassigned | ||||||||||
| 13161-13215 | Unassigned | ||||||||||
| 13225-13399 | Unassigned |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Alexei Vladishev | alexei.vladishev&zabbix.com | 2006-02 | |
| Alvaro P. Dominguez | alpado&gmail.com | 2006-02 | |
| American Power Conversion | ports&apcc.com | 2002-02 | |
| Andreas Fehr | andreas&mrs.ch | ||
| Anthony Carrabino | anthonyc&vistasoftware.com | 2003-08 | |
| Apple Inc. | kazu&apple.com | 2015-09-29 | |
| COPALP | jf&copalp.com | 2012-03-01 | |
| Craig Dowell | Qualcomm Innovation Center, Inc. | cdowell&quicinc.com | 2011-12-21 |
| Craig Everhart | Craig.Everhart&netapp.com | 2010-07-06 | |
| David Sechrest | david.sechrest&oracle.com | 2010-09-22 | |
| Douglas Crockford | douglas&crockford.com | ||
| Eric Thorniley | eric&etcomms.co.uk | 2007-09-17 | |
| Gary Weichinger | gary.weichinger&netiq.com | ||
| Graham J. Orr | graham&xplicitcomputing.com | 2020-10-16 | |
| Grant Erickson | Nest Labs, Inc. | grant&nestlabs.com | 2014-01-16 |
| HaloteC Instruments B.V. | michel.stam&halotec.com | 2012-02-07 | |
| HotLink Corporation | roffer&hotlink.com | 2014-12-18 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Jason Thorpe | thorpej&apple.com | 2015-09-29 | |
| Jerome FOLLUT | COPALP | jf&copalp.com | 2012-03-01 |
| Justin Vegso | jvegso&quantapoint.com | 2010-07-01 | |
| Michel Stam | HaloteC Instruments B.V. | michel.stam&halotec.com | 2012-02-07 |
| Nest Labs, Inc. | grant&nestlabs.com | 2014-01-16 | |
| netperf.org | netperf-feedback&netperf.org | 2013-04-05 | |
| Nick Stephen | nick.stephen&sun.com | 2005-08 | |
| Open Text Corporation | tponzo&opentext.com | 2022-10-07 | |
| Phil Beecher | Wi-SUN Alliance | pbeecher&wi-sun.org | 2015-06-26 |
| Qualcomm Innovation Center, Inc. | cdowell&quicinc.com | 2011-12-21 | |
| Richard Offer | HotLink Corporation | roffer&hotlink.com | 2014-12-18 |
| Rick Jones | perfgeek&mac.com | 2013-04-05 | |
| Robert Boudrie | boudrie_rob&emc.com | 2008-06-09 | |
| Robert Eden | reden&sieglertech.com | 2003-03 | |
| Takayuki Ito | yuki&euc.jp | ||
| Thomas Guth | t.guth&zeiss.de | 2006-01 | |
| Tim Young | timyoung&elevatesoft.com | 2009-05-06 | |
| Tony Ponzo | Open Text Corporation | tponzo&opentext.com | 2022-10-07 |
| Wi-SUN Alliance | admin&wi-sun.org | 2015-06-26 | |
| Xplicit Computing Inc | info&xplicitcomputing.com | 2020-10-16 |