Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
tmophl7mts 20046 udp TMOP HL7 Message Transfer Service Tim Riley Tim Riley 2009-07-31
nfsrdma 20049 tcp Network File System (NFS) over RDMA 2017-09-05 RFC 8267
nfsrdma 20049 udp Network File System (NFS) over RDMA 2017-09-05 RFC 8267
nfsrdma 20049 sctp Network File System (NFS) over RDMA 2017-09-05 RFC 8267
20050-20056 Unassigned
20058-20166 Unassigned
tolfab 20167 tcp TOLfab Data Change Pierre Couderc Pierre Couderc 2006-03
tolfab 20167 udp TOLfab Data Change Pierre Couderc Pierre Couderc 2006-03
20168-20201 Unassigned
20481-20669 Unassigned
track 20670 tcp Track Michael Sweet Michael Sweet
track 20670 udp Track Michael Sweet Michael Sweet
20671-20809 Unassigned
21222-21336 Unassigned
netspeak-is 21846 tcp NetSpeak Corp. Directory Services Toby Hosterman Toby Hosterman
netspeak-is 21846 udp NetSpeak Corp. Directory Services Toby Hosterman Toby Hosterman
22006-22124 Unassigned
22126-22127 Unassigned
wnn6 22273 tcp wnn6 Yasunari Gon Yamasita Yasunari Gon Yamasita
wnn6 22273 udp wnn6 Yasunari Gon Yamasita Yasunari Gon Yamasita
22306-22332 Unassigned
22336-22342 Unassigned
22344-22346 Unassigned
22352-22536 Unassigned
22556-22762 Unassigned
talikaserver 22763 tcp Talika Main Server Laxman C. Marathe Laxman C. Marathe 2006-12
talikaserver 22763 udp Talika Main Server Laxman C. Marathe Laxman C. Marathe 2006-12
22764-22799 Unassigned
inovaport6 23005 tcp Inova LightLink Server Type 6 Chris Koeritz Chris Koeritz 2006-10
inovaport6 23005 udp Inova LightLink Server Type 6 Chris Koeritz Chris Koeritz 2006-10
23006-23052 Unassigned
aequus 23456 tcp Aequus Service James Anson James Anson 2009-02-12
23456 udp Reserved
areaguard-neo 23546 tcp AreaGuard Neo - WebServer SODATSW spol. s r.o. Roman Štěpánek 2012-05-31
23546 udp Reserved
med-net-svc 24006 tcp med-net-svc Juergen Fischbach Juergen Fischbach
med-net-svc 24006 udp med-net-svc Juergen Fischbach Juergen Fischbach
intel-rci 24386 tcp Intel RCI

IANA assigned this well-formed service name as a replacement for "intel_rci".
Mark Lewis Mark Lewis
intel_rci 24386 tcp Intel RCI Mark Lewis Mark Lewis This entry is an alias to "intel-rci". This entry is now historic, not usable for use with many common service discovery mechanisms.
intel-rci 24386 udp Intel RCI

IANA assigned this well-formed service name as a replacement for "intel_rci".
Mark Lewis Mark Lewis
intel_rci 24386 udp Intel RCI Mark Lewis Mark Lewis This entry is an alias to "intel-rci". This entry is now historic, not usable for use with many common service discovery mechanisms.
24387-24464 Unassigned
tonidods 24465 tcp Tonido Domain Server Madhan Kanagavel Madhan Kanagavel 2008-07-18
tonidods 24465 udp Tonido Domain Server Madhan Kanagavel Madhan Kanagavel 2008-07-18
24466-24553 Unassigned
24555-24576 Unassigned
24578-24600 Unassigned
udpstp 24601 udp UDP-based IP-Layer Capacity and Performance Measurement protocol IESG IETF Chair 2025-09-26 RFC 9946
24601 tcp Reserved
24602-24665 Unassigned
sdtvwcam 24666 tcp Service used by SmarDTV to communicate between a CAM and a second screen application SmarDTV Vincent Demortier 2015-03-04
24666 udp Reserved
24667-24675 Unassigned
canditv 24676 tcp Canditv Message Service Gary Aston Gary Aston 2009-03-10
canditv 24676 udp Canditv Message Service Gary Aston Gary Aston 2009-03-10
flashfiler 24677 tcp FlashFiler Ben Oram Ben Oram
flashfiler 24677 udp FlashFiler Ben Oram Ben Oram
proactivate 24678 tcp Turbopower Proactivate Ben Oram Ben Oram
proactivate 24678 udp Turbopower Proactivate Ben Oram Ben Oram
24679 Unassigned
tcc-http 24680 tcp TCC User HTTP Service Brian Kennedy Brian Kennedy 2006-08
tcc-http 24680 udp TCC User HTTP Service Brian Kennedy Brian Kennedy 2006-08
24681-24726 Unassigned
icl-twobase6 25005 tcp icl-twobase6 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase6 25005 udp icl-twobase6 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase7 25006 tcp icl-twobase7 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase7 25006 udp icl-twobase7 J. A. (Tony) Sever J. A. (Tony) Sever
sauterdongle 25576 tcp Sauter Dongle Christian Brecht Christian Brecht 2010-12-15
25576 udp Reserved
25577-25603 Unassigned
idtp 25604 tcp Identifier Tracing Protocol Huang Neng-geng Huang Neng-geng 2011-08-09
25604 udp Reserved
25605-25792 Unassigned
25956-25999 Unassigned
quake 26000 tcp quake Yasunari Gon Yamasita Yasunari Gon Yamasita
quake 26000 udp quake Yasunari Gon Yamasita Yasunari Gon Yamasita
26001-26132 Unassigned
scscp 26133 tcp Symbolic Computation Software Composability Protocol Alexander Konovalov Alexander Konovalov 2007-11-27
scscp 26133 udp Symbolic Computation Software Composability Protocol Alexander Konovalov Alexander Konovalov 2007-11-27
26134-26207 Unassigned
wnn6-ds 26208 tcp wnn6-ds Yasunari Gon Yamasita Yasunari Gon Yamasita
wnn6-ds 26208 udp wnn6-ds Yasunari Gon Yamasita Yasunari Gon Yamasita
26209-26256 Unassigned
cockroach 26257 tcp CockroachDB Cockroach Labs, Inc. Ben_Darnell 2015-09-29
26257 udp Reserved
26258-26259 Unassigned
ezproxy 26260 tcp eZproxy Albert C. Yang Albert C. Yang
ezproxy 26260 udp eZproxy Albert C. Yang Albert C. Yang
ezmeeting 26261 tcp eZmeeting Albert C. Yang Albert C. Yang
ezmeeting 26261 udp eZmeeting Albert C. Yang Albert C. Yang
k3software-svr 26262 tcp K3 Software-Server Jim Baldridge Jim Baldridge
k3software-svr 26262 udp K3 Software-Server Jim Baldridge Jim Baldridge
k3software-cli 26263 tcp K3 Software-Client Jim Baldridge Jim Baldridge
k3software-cli 26263 udp K3 Software-Client Jim Baldridge Jim Baldridge
26264 De-registered 2006-04-06
26265-26485 Unassigned
exoline-tcp 26486 tcp EXOline-TCP AB Regin Simon Jönsson 2008-12-24 2018-09-13
exoline-udp 26486 udp EXOline-UDP AB Regin Simon Jönsson 2008-12-24 2018-09-13
exoconfig 26487 tcp EXOconfig Urban Fosseus Urban Fosseus 2008-12-24
exoconfig 26487 udp EXOconfig Urban Fosseus Urban Fosseus 2008-12-24
26488 Unassigned

Contact Information

Name Organization Contact URI Last Updated
AB Regin urban.fosseus&regin.se 2018-09-13
Albert C. Yang albert.yang&ezmeeting.com 2002-03
Alexander Konovalov konovalov&member.ams.org 2007-11-27
ben&cockroachlabs.com 2015-09-29
Ben Oram beno&turbopower.com
Brian Kennedy BrianK&targetedconvergence.com 2006-08
Chris Koeritz portmanager&inovasolutions.com 2006-10
Christian Brecht Christian.Brecht&sauter-gmbh.de 2010-12-15
Cockroach Labs, Inc. iana-contact&cockroachlabs.com 2015-09-29
Gary Aston Gary.Aston&datadrivenlogistics.com 2009-03-10
Huang Neng-geng huangng&ngweb.org
nghuang&ieee.org
2011-08-09
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
J. A. (Tony) Sever J.A.Sever&bra0119.wins.icl.co.uk
James Anson janson&bigpond.com 2009-02-12
Jim Baldridge jimb&rpower.com
Juergen Fischbach juergen.fischbach&philips.com
Laxman C. Marathe lcmarathe&thomsonpress.com 2006-12
Madhan Kanagavel madhan&codelathe.com 2008-07-18
Mark Lewis mark.h.lewis&intel.com
Michael Sweet msweet&ctr.nawcad.navy.mil
Pierre Couderc pcouderc&tol.fr 2006-03
Roman Štěpánek SODATSW spol. s r.o. roman.stepanek&sodatsw.cz 2012-05-31
Simon Jönsson AB Regin simon.jonsson&regin.se 2018-09-13
SmarDTV vincent.demortier&smardtv.com 2015-03-04
SODATSW spol. s r.o. info&sodatsw.cz 2012-05-31
Tim Riley rileyt&saic.com 2009-07-31
Toby Hosterman root&netspeak.com
Urban Fosseus urban.fosseus&regin.se 2008-12-24
Vincent Demortier SmarDTV vincent.demortier&smardtv.com 2015-03-04
Yasunari Gon Yamasita yamasita&omronsoft.co.jp