Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
47810-47999 Unassigned
48006-48047 Unassigned
48051-48127 Unassigned
48557-48618 Unassigned
mihcs MIH Command Services RFC 5679
mihes MIH Event Services RFC 5679
mihis MIH Information Services RFC 5679
netconf-beep NETCONF over BEEP RFC 4744; RFC 9900
netconfsoapbeep NETCONF for SOAP over BEEP RFC 4743; RFC 9900
netconfsoaphttp NETCONF for SOAP over HTTPS RFC 4743; RFC 9900
7ksonar tcp Teledyne Marine 7k Sonar Protocol Teledyne Marine Anders Brandt 2023-10-03 Defined TXT keys: None
7ksonar udp Teledyne Marine 7k Sonar Protocol Teledyne Marine Anders Brandt 2023-10-03 Defined TXT keys: None
brski-reg-cmp tcp Bootstrapping Remote Secure Key Infrastructure registrar with CMP capabilities according to the Lightweight CMP Profile (LCMPP) RFC 9483 IESG IETF Chair 2024-09-23 RFC 9733 Defined TXT keys: None
caldav tcp Calendaring Extensions to WebDAV (CalDAV) - non-TLS IESG IETF Chair 2012-02-17 RFC 6764 This is an extension of the http service. Defined TXT keys: path=<context path>
caldavs tcp Calendaring Extensions to WebDAV (CalDAV) - over TLS IESG IETF Chair 2012-02-17 RFC 6764 This is an extension of the https service. Defined TXT keys: path=<context path>
core-rd tcp Resource Directory accessed using CoAP over TCP IESG IETF Chair 2021-03-16 RFC 9176 Defined TXT keys: None
core-rd udp Resource Directory accessed using CoAP IESG IETF Chair 2021-03-16 RFC 9176 Defined TXT keys: None
core-rd-tls tcp Resource Directory accessed using CoAP over TLS IESG IETF Chair 2021-03-16 2022-04-14 RFC 9176 Defined TXT keys: None
core-rd-dtls udp Resource Directory accessed using CoAP over DTLS IESG IETF Chair 2021-03-16 RFC 9176 Defined TXT keys: None
dccp-ping dccp ping/traceroute using DCCP Samuel Jero Samuel Jero 2012-11-14 1885957735 Defined TXT keys: None
dns-push-tls tcp DNS Push Notification Service Type IESG IETF Chair 2019-11-25 RFC 8765, Section 6.1 Defined TXT Keys: None
dots-call-home tcp DOTS Signal Channel Call Home Protocol. The service name is used to construct the SRV service names "_dots-call-home._udp" and "_dots-call-home._tcp" for discovering Call Home DOTS clients used to establish DOTS signal channel call home. IESG IETF Chair 2020-11-19 RFC 8973 Defined TXT keys: None
dots-call-home udp DOTS Signal Channel Call Home Protocol. The service name is used to construct the SRV service names "_dots-call-home._udp" and "_dots-call-home._tcp" for discovering Call Home DOTS clients used to establish DOTS signal channel call home. IESG IETF Chair 2020-11-19 RFC 8973 Defined TXT keys: None
dots-data tcp DOTS Data Channel Protocol. The service name is used to construct the SRV service name "_dots-data._tcp" for discovering DOTS servers used to establish DOTS data channel. IESG IETF Chair 2020-11-19 RFC 8973 Defined TXT keys: None
est tcp Enrollment Over Secure Transport Jack Visoky Jack Visoky 2017-10-06 RFC 7030. Defined TXT keys: None
fix Financial Information Exchange (FIX) Protocol Joakim Johansson Joakim Johansson Defined TXT keys: Currently valid enumerated values: FIX Session Protocol Versions (SESSIONVERSION): 1.1 FIX Application Protocol Versions (APPLICATIONVERSION): 2.7, 3.0, 4.0, 4.1, 4.2, 4.3, 4.4, 5.0 Possible TXT records defined and their values (replace uppercase text with enumerations from the list above): txtvers=1 fix=APPLICATIONVERSION fix supported=APPLICATIONVERSION[,APPLICATIONVERSION, ... ,APPLICATIONVERSION] fixt=SESSIONVERSION
help HELP command RFC 1078 TCP Port Service Multiplexer (TCPMUX)
hpr-bldlnx HP Remote Build System for Linux-based Systems Jeffrey J. Walls Jeffrey J. Walls Defined TXT keys: rh73, rhel3, rhel4, deb31, suse102
hpr-toollnx HP Remote System that houses compilers and tools for Linux-based Systems Jeffrey J. Walls Jeffrey J. Walls Defined TXT keys: rh73, rhel3, rhel4, deb31, suse102
hpr-tstlnx HP Remote Test System for Linux-based Systems Jeffrey J. Walls Jeffrey J. Walls Defined TXT keys: rh73, rhel3, rhel4, deb31, suse102
jnx-kcsync tcp jollys keychain cloud sync protocol Patrick Stein Patrick Stein 2011-10-24 Defined TXT keys: hash=<40hex characters> salt=<40hex characters> uuid=<40hex characters> Example: hash=5e7580598c0d7064d4fc79faaeb42585e1a675f8 salt=f0164cb3a0c3d7efe75abea8fda86d2d56c8dda9 uuid=db61dc092922252e45bbb264f59147138c7fd5fa
msrps tcp MSRP protocol over TLS 2014-04-25 RFC 4976 Defined TXT keys:
presence Peer-to-peer messaging / Link-Local Messaging XMPP Registrar XMPP Registrar Defined TXT keys: See http://www.xmpp.org/registrar/linklocal.html Note: Registration updated May 2007. Was formerly listed as "iChat AV" (Apple's IM client for Mac OS X) with TXT keys: txtvers, port.p2pj, phsh, vc, 1st, AIM, msg, status, last When first shipped in Mac OS X 10.2, iChat's peer-to-peer messaging protocol was created to solve the problem of serverless messaging between peers on the same link. However, there is nothing inherent in the protocol that limits it to being only link-local; it was simply an artifact of iChat in Mac OS X 10.2 using link-local Multicast DNS to discover peers. With the advent of Wide-Area DNS-SD, it is also possible to use iChat's peer-to-peer messaging between machines on different links.
radiusdtls udp Authentication, Accounting, and Dynamic Authorization via the RADIUS protocol. This service name is used to construct the SRV service label "_radiusdtls" for discovery of RADIUS/DTLS servers. IESG IETF Chair 2015-03-23 2015-10-06 RFC 7585 Defined TXT keys: None
radiustls tcp Authentication, Accounting, and Dynamic Authorization via the RADIUS protocol. This service name is used to construct the SRV service label "_radiustls" for discovery of RADIUS/TLS servers. IESG IETF Chair 2015-03-23 2015-10-06 RFC 7585 Defined TXT keys: None
spx-hmp tcp SpinetiX HMP SpinetiX S.A. Diego Santa Cruz 2011-10-18 Defined TXT keys: txtvers=1 cport= the port for the content HTTP server (secondary HTTP server used for content publishing) mode= the mode in which the HMP device is currently operating, one of "normal", "safe" or "recovery" serial= serial number of the HMP device firmware= firmware version string (e.g., 2.1.0-0.1.7844) model= model string (e.g., HMP100)
sztp tcp This service name is used to construct the SRV service label "_sztp" for discovering SZTP bootstrap servers. IESG IETF Chair 2019-01-17 RFC 8572 This protocol uses HTTPS as a substrate.
timezone tcp Time Zone Data Distribution Service - non-TLS IESG IETF Chair 2015-08-03 RFC 7808 This is an extension of the http service. Defined TXT keys: path=<context path> (as per Section 6 of RFC 6763).
timezones tcp Time Zone Data Distribution Service - over TLS IESG IETF Chair 2015-08-03 RFC 7808 This is an extension of the https service. Defined TXT keys: path=<context path> (as per Section 6 of RFC 6763).
wot tcp W3C WoT Thing Description or Directory W3C Web of Things Working Group Kazuyuki Ashimura 2022-11-22 2022-12-15

Defined TXT keys:

td: Absolute pathname of the Thing Description of the Thing or Thing Description of the Thing Description Directory.

type: Type of the Thing Description, i.e. "Thing" or "Directory". If omitted, the type is assumed to be Thing.

scheme: Scheme part of URL. One of the following values can be specified, with the standard registered URI interpretations RFC 7595: http (HTTP over TCP),https (HTTP over TLS/TCP), coap+tcp (CoAP over TCP), or coaps+tcp (CoAP over TLS/TCP). If omitted, the scheme is assumed to be http.

wot udp W3C WoT Thing Description or Directory W3C Web of Things Working Group Kazuyuki Ashimura 2022-11-22 2022-12-15

Defined TXT keys:

td: Absolute pathname of the Thing Description of the Thing or Thing Description of the Thing Description Directory.

type: Type of the Thing Description, i.e. "Thing" or "Directory". If omitted, the type is assumed to be Thing.

scheme: Scheme part of URL. One of the following values can be specified, with the standard registered URI interpretations RFC 7595: coap (CoAP over UDP), coaps CoAP over DTLS/UDP. If omitted, the scheme is assumed to be coap.

x510 tcp Security service to protocols ITU-T Study Group 17 Erik Andersen 2019-08-13 Defined TXT keys: None

Contact Information

Name Organization Contact URI Last Updated
Anders Brandt Teledyne Marine Anders.Brandt&Teledyne.com 2023-10-03
Diego Santa Cruz SpinetiX S.A. Diego.SantaCruz&spinetix.com 2011-10-18
Erik Andersen era&x500.eu 2019-08-13
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
ITU-T Study Group 17 era&x500.eu 2019-08-13
Jack Visoky jmvisoky&ra.rockwell.com 2017-10-06
Jeffrey J. Walls jeff.walls&hp.com
Joakim Johansson joakim.johansson&tbricks.com
Kazuyuki Ashimura ashimura&w3.org 2022-11-22
Patrick Stein Patrick.Stein&jinx.eu 2011-10-24
Samuel Jero sj323707&ohio.edu 2012-11-14
SpinetiX S.A. Diego.SantaCruz&spinetix.com 2011-10-18
Teledyne Marine info&teledynemarine.com 2023-10-03
W3C Web of Things Working Group team-wot&w3.org 2022-11-22
XMPP Registrar registrar&xmpp.org